Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema con la actualización online + Audio (solucionado)
  #1  
Antiguo 08-abr-2013, 01:51
Avatar de algosuntos
algosuntos algosuntos está desconectado
Habitual
 
Fecha de Ingreso: 27-octubre-2010
Versión: 42.2
Mensajes: 166
Agradecimientos: 36
Agradecido 9 Veces en 8 Mensajes
Poder de Credibilidad: 7
algosuntos está en el buen camino
Problema con la actualización online + Audio (solucionado)

Buenas a todos, el tema es que quiero actualizar (online) mi versión de 12.1 a 12.3, siguiendo los pasos que se indican en acá http://es.opensuse.org/SDB:Actualiza...tribuci%C3%B3n. Lo que hice fue reemplazar los repositorios 12.1 por los 12.3 e iniciar la actualización con el comando "zypper dup --download "in-advance" " y a partir de ahí me salen un montón de problemas:

Cita:
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita libgstreamer-0_10-0-32bit-0.10.36-11.5.x86_64
Problema: no hay nada que proporcione libcap.so.2 y que lo necesita libpulse0-32bit-3.0-1.6.1.x86_64
Problema: no hay nada que proporcione yast2-proxy y que lo necesita yast2-installation-2.23.13-1.4.3.noarch
Problema: no hay nada que proporcione libtheoradec.so.1 y que lo necesita libavcodec54-1.0.5-1.3.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita vlc-noX-2.0.5-102.26.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita k3b-2.0.2-15.31.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita libmpg123-0-1.15.3-1.1.i586
Problema: no hay nada que proporcione libdvdread.so.4 y que lo necesita gstreamer-0_10-plugins-ugly-0.10.19-10.16.i586
Problema: no hay nada que proporcione libcurl.so.4 y que lo necesita amarok-2.7.0-14.43.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita gstreamer-0_10-plugins-bad-0.10.23-19.20.i586
Problema: no hay nada que proporcione libbz2.so.1 y que lo necesita libstrigi0-0.7.8-3.3.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita libgstreamer-0_10-0-0.10.36-11.5.i586
Problema: no hay nada que proporcione libm.so.6(GLIBC_2.15) y que lo necesita libvlccore5-2.0.5-102.26.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita libxine2-1.2.2-83.2.i586
Problema: no hay nada que proporcione libSDL-1.2.so.0 y que lo necesita libavdevice54-1.0.5-1.3.i586
Problema: no hay nada que proporcione libm.so.6(GLIBC_2.15) y que lo necesita vlc-2.0.5-102.26.i586
Problema: no hay nada que proporcione libpng15.so.15 y que lo necesita libquicktime0-1.2.4-61.1.i586
Problema: no hay nada que proporcione libm.so.6(GLIBC_2.15) y que lo necesita libxine2-codecs-1.2.2-83.2.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita libmjpegutils-2_0-0-2.0.0-52.1.i586
Problema: no hay nada que proporcione libtag.so.1 y que lo necesita k3b-codecs-2.0.2-15.31.i586
Problema: no hay nada que proporcione libtinfo.so.5 y que lo necesita lame-3.99.5-1002.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita MPlayer-1.1+35127-2.20.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita libavformat52-0.7.15-1.4.i586
Problema: no hay nada que proporcione libjack.so.0 y que lo necesita gstreamer-0_10-plugins-good-0.10.31-11.18.i586
Problema: no hay nada que proporcione libm.so.6(GLIBC_2.15) y que lo necesita libx264-129-0.129svn20130224-2.1.i586
Problema: no hay nada que proporcione libm.so.6(GLIBC_2.15) y que lo necesita vlc-qt-2.0.5-102.26.i586
Problema: no hay nada que proporcione libtheoradec.so.1 y que lo necesita libavcodec52-0.7.15-1.4.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita mplayer2-20121128-1.4.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita mjpegtools-2.0.0-52.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita strigi-0.7.8-3.3.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15)(64bit) y que lo necesita libavformat52-0.7.15-1.4.x86_64
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.17)(64bit) y que lo necesita libavdevice54-1.0.5-1.3.x86_64
Problema: no hay nada que proporcione libgavl.so.1 y que lo necesita libgmerlin_gtk0-1.2.0-1.19.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita sox-14.4.0-38.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita libgmerlin0-1.2.0-1.19.i586
Problema: no hay nada que proporcione ksym(defaultaram_ops_charp) = 35b6b772 y que lo necesita nvidia-gfxG02-kmp-default-304.88_k3.7.10_1.1-24.1.x86_64
Problema: no hay nada que proporcione ksym(desktoparam_ops_charp) = 35b6b772 y que lo necesita nvidia-gfxG02-kmp-desktop-304.88_k3.7.10_1.1-24.1.x86_64
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita mozilla-nspr-4.9.6-1.4.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita dhcp-client-4.2.5.P1-0.2.4.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita dhcp-4.2.5.P1-0.2.4.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita bind-libs-9.9.2P2-2.3.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita zsh-5.0.2-2.5.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita sysconfig-0.80.5-1.5.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.17) y que lo necesita libxslt1-1.1.28-3.4.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita krb5-32bit-1.10.2-10.5.1.x86_64
Problema: no hay nada que proporcione libidn.so.11 y que lo necesita dnsmasq-2.65-2.5.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.17) y que lo necesita udev-195-13.14.1.i586
Problema: no hay nada que proporcione libcap.so.2 y que lo necesita systemd-195-13.14.1.i586
Problema: no hay nada que proporcione libgnome-keyring.so.0 y que lo necesita evolution-data-server-3.6.3-1.5.1.i586
Problema: no hay nada que proporcione liby2.so.3 y que lo necesita yast2-storage-2.23.9-1.4.1.i586
Problema: no hay nada que proporcione liblzma.so.5 y que lo necesita libMagickCore5-6.7.8.8-4.5.1.i586
Problema: no hay nada que proporcione yui_backend y que lo necesita yast2-2.23.23-1.4.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita sudo-1.8.6p3-3.5.1.i586
Problema: no hay nada que proporcione libbz2.so.1 y que lo necesita perl-5.16.2-2.5.1.i586
Problema: no hay nada que proporcione libcap.so.2 y que lo necesita libpulse0-3.0-1.6.1.i586
Problema: no hay nada que proporcione libkdecore.so.5 y que lo necesita kdebase4-workspace-branding-openSUSE-12.3-10.11.3.i586
Problema: no hay nada que proporcione libqt4-x11 >= 4.8.1 y que lo necesita kdebase4-runtime-branding-openSUSE-12.3-10.11.3.i586
Problema: no hay nada que proporcione libkdecore.so.5 y que lo necesita kdebase4-openSUSE-12.3-10.11.3.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita systemtap-runtime-2.0-2.4.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita systemtap-2.0-2.4.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita krb5-1.10.2-10.5.1.i586
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15)(64bit) y que lo necesita libxml2-2-2.9.0-2.5.1.x86_64
Problema: evolution-data-server-lang-3.6.3-1.5.1.noarch requiere evolution-data-server = 3.6.3, pero este requisito no puede cumplirse
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita MozillaFirefox-19.0.2-1.4.1.i586
Problema: no hay nada que proporcione libmozjs185-1_0 y que lo necesita polkit-default-privs-12.3-6.11.1.noarch
Problema: no hay nada que proporcione libm.so.6(GLIBC_2.15)(64bit) y que lo necesita libpulse0-3.0-1.6.1.x86_64
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.17)(64bit) y que lo necesita libudev-mini1-195-13.14.1.x86_64
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.16)(64bit) y que lo necesita systemd-195-13.14.1.x86_64
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15)(64bit) y que lo necesita libxml2-2-2.9.0-2.5.1.x86_64
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15)(64bit) y que lo necesita bind-libs-9.9.2P2-2.3.1.x86_64
Problema: no hay nada que proporcione libvpx.so.1()(64bit) y que lo necesita libavcodec54-1.0.5-1.3.x86_64
Problema: no hay nada que proporcione libvpx.so.1()(64bit) y que lo necesita libavcodec52-0.7.15-1.4.x86_64
Problema: no hay nada que proporcione libvpx.so.1()(64bit) y que lo necesita libavcodec52-0.7.15-1.4.x86_64
Problema: no hay nada que proporcione yui_backend y que lo necesita yast2-2.23.23-1.4.1.x86_64
Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15)(64bit) y que lo necesita vlc-noX-2.0.5-102.26.x86_64

Problema: no hay nada que proporcione libc.so.6(GLIBC_2.15) y que lo necesita libgstreamer-0_10-0-32bit-0.10.36-11.5.x86_64
Solución 1: mantener el antiguo libgstreamer-0_10-0-32bit-0.10.36-11.3.x86_64
Solución 2: romper libgstreamer-0_10-0-32bit-0.10.36-11.5.x86_64 ignorando algunas de sus dependencias
Lo hice todo por terminal sin Tmux ni GNU screen. Seguro que algo hice mal porque nunca hice una actualización.
Cualquier ayuda será bienvenida.

Última edición por algosuntos; 10-abr-2013 a las 03:20
Responder Citando
  #2  
Antiguo 08-abr-2013, 02:32
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.528
Agradecimientos: 1.911
Agradecido 1.402 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola algosuntos:

Te había leido en el post de :http://www.forosuse.org/forosuse/showthread.php?t=29654.

Por un problema similar ,no se si te sera de ayuda pero creo que en las dos situaciones creo que es la opcion 1
Casi siempre te mantiene la antigua o te hace un downgrade o te baja la versión una vez que tengas todo instalado ya puedes darle un zypper dump y que te revise de nuevo (lo mas seguro que te corrige los problemas) .
Puede que te saliera eso por que en ese momento no estaba disponible y para no romper las dependencias te da a elegir.
En el post que te leí te dan unos consejos pero también hay algunos tútoriales que hacen mención sobre las actualizaciones .
La segunda opción yo casi nunca la elijo prefiero mantener la actual o cambiar de proveedor así me suele pasar con aplicaciones que en suse no me funcionan correctamente como yo quiero (con sus codecs correctos ) y en cambio las de packman con una versión inferior van bien.(en packman elijo la versión de k3b de ellos por que me instala los codecs adicionales y en multimedia lo mismo).
Pero mi respuesta es de novato mejor espera que alguien mas te de una solución y puedas hacerlo con mas seguridad.
Saludos cordiales
Mira cuando termines las actualizaciones desde yast en instalar programas ,si lo que tienes instalado te aparece de un un color distinto (de un tutorial de D.R. creo que dice que si sale en rojo es que no cumple con las dependencias o es incorrecta la versión , si esta en azul es que hay actualización y en negro es normal ) cuando a mi me paso esto ejecute el zypper dum y me lo dejo bastante afinado y se quitaron casi todos los problemas.
También puedes usar Apper ,pero a mi si me encuentra algún problema no me deja actualizar ,entonces ejecuto desde yast actualización en linea (hay me saldrá que elija las opciones como a ti te sale y una vez resuelta ,como no me esta actualizando bien desde ahí me vuelvo a Apper y termino la actualización sin problemas).
Yo aun estoy con la 12.2 con kernel cambiado y con kde 4.10.2.
Saludos y suerte

Última edición por mikrios; 08-abr-2013 a las 02:53 Razón: yast
Responder Citando
  #3  
Antiguo 08-abr-2013, 03:29
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.654
Agradecimientos: 73
Agradecido 402 Veces en 314 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Cita:
Iniciado por mikrios Ver Mensaje
si sale en rojo es que no cumple con las dependencias o es incorrecta la versión
No se , creo que es por que no hay ningun repo que haga referencia a ese archivo o versión del mismo.

es decir, si tienes la versión 5 de un programa por que lo instalaste desde un .rpm y la versión de los repos es la 4 te sale rojo, y si en los repos no existe ese archivo también lo pone rojo, como que ese paquete esta cojo.

saludos.
__________________
Subir fotos: http://subefotos.com/
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a LUKE10 Por Este Mensaje:
mikrios (08-abr-2013)
  #4  
Antiguo 08-abr-2013, 03:30
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Cita:
Iniciado por algosuntos Ver Mensaje
Buenas a todos, el tema es que quiero actualizar (online) mi versión de 12.1 a 12.3, siguiendo los pasos que se indican en acá http://es.opensuse.org/SDB:Actualiza...tribuci%C3%B3n.
Si el párrafo

Cita:
El punto de partida válido es la última publicación de openSUSE con todas las actualizaciones aplicadas. Esto no incluye repositorios arbitrarios del openSUSE Build Service que hayas podido añadir. Recomendamos que deshabilites todos los repositorios del OBS primero, que hagas la actualización, y que los vuelvas a habilitar después. Los pasos siguientes muestran cómo hacer esta actualización antes de actualizar a la siguiente versión.
quiere decir lo que creo, el proceso no está pensado para saltar más de una versión. Si así fuera, tendrías que actualizar de 12.1 a 12.2 y luego de 12.2 a 12.3. En ese caso no sé si merecería la pena porque puede que termines descargando tanto software como si bajaras el DVD.

Un saludo.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jcsl Por Este Mensaje:
mikrios (08-abr-2013)
  #5  
Antiguo 08-abr-2013, 04:21
Avatar de algosuntos
algosuntos algosuntos está desconectado
Habitual
 
Fecha de Ingreso: 27-octubre-2010
Versión: 42.2
Mensajes: 166
Agradecimientos: 36
Agradecido 9 Veces en 8 Mensajes
Poder de Credibilidad: 7
algosuntos está en el buen camino
Gracias a todos por las respuestas. jcsl creo que no es un problema de versiones ya que te indica que si estás utilizando la versión de 12.1 o anterior, hay que agregar el repositorio http://download.opensuse.org/update/12.3-non-oss/, por lo que se da a entender que se puede saltear versiones, en principio, sin problemas.
Con zypper dup sucede lo mismo y no puedo continuar con la actualización.
Mi duda está en el hecho que eliminé todos los repositorios que tenía de la versión 12.1 y los reemplacé por los 12.3 y ahí pude haber cometido un error y por eso aparecen todos esos problemas.
Voy a revisar si cometí algún error o a alguien le pasó algo parecido. Cualquier novedad la informo.
Saludos!
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a algosuntos Por Este Mensaje:
mikrios (08-abr-2013)
  #6  
Antiguo 10-abr-2013, 01:26
Avatar de algosuntos
algosuntos algosuntos está desconectado
Habitual
 
Fecha de Ingreso: 27-octubre-2010
Versión: 42.2
Mensajes: 166
Agradecimientos: 36
Agradecido 9 Veces en 8 Mensajes
Poder de Credibilidad: 7
algosuntos está en el buen camino
Logré solucionar el problema. Me había olvidado de poner dos repositorios: oss y non oss. Luego todo salio perfecto. Recomiendo hacer la actualización con zypper dup in advance, ya que si hay un error como me pasó a mi se trabaría todo y ahy que hacer una instalación completa.
El problema es que no poseo sonido ni en los reproductores de audio, ni de video ni videos online. Verifiqué que funcione kmix y el sonido en hdmi, también tengo los codecs y repositorios instalados de acá http://opensuse-community.org/Restricted_formats/12.3 y probé con mmcheck para ver si faltaba algún paquete pero tengo todo instalado ya que sólo hice una actualización.
Si a alguien le pasó o sabe algo, que me de una mano.
Responder Citando
  #7  
Antiguo 10-abr-2013, 03:19
Avatar de algosuntos
algosuntos algosuntos está desconectado
Habitual
 
Fecha de Ingreso: 27-octubre-2010
Versión: 42.2
Mensajes: 166
Agradecimientos: 36
Agradecido 9 Veces en 8 Mensajes
Poder de Credibilidad: 7
algosuntos está en el buen camino
Al fin solucioné el problema que no era de codecs sino que en el mezclador de kmix tuve que agregar el canal que dice "front" que estaba sin volumen y por eso no se escuchaba ningún audio.

Saludos!
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a algosuntos Por Este Mensaje:
arag (10-abr-2013)
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Problema luego de actualizacion en OpenSuse 11.4 martin_nt Instalación y Actualizaciones 8 10-may-2011 18:15
Aurora Engine 1.4 para Gtk problema larva_pro Escritorios: KDE, Gnome, otros... 0 24-jul-2008 22:29
Problema con actualizacion Error de Packagekit NismoSYS Software 3 07-jul-2008 08:51
Problema con SATA en inicio de kernel en SUSE 10.2 Celula32 Software 2 16-dic-2006 21:11
problema en la actualizacion chaparro2001 Software 1 03-mar-2005 20:13



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 16:20.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba