Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Control Temperatura GPU Nvidia
  #1  
Antiguo 31-mar-2013, 20:42
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.654
Agradecimientos: 73
Agradecido 402 Veces en 314 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Control Temperatura GPU Nvidia

Hola geekos ¡¡¡.

bueno hoy os traigo un tema que llevo mucho tiempo mirando y no encuentro nada, y creo que estaría bien ver como solucionarlo entre todos.

el tema que traigo hoy es el control de nuestra refrigeración.

buscando por internet, he encontrado utilidades como nvclock, o usar los sensores con un script o el mismo controlador de nvidia con una característica deshabilitada, " Coolbits ".

bueno el nvclock lleva unos 4 años sin mantenerse, con lo que muchas tarjetas desde esa fecha( la mía incluida, gforce 257gtx ) esta fuera de su alcance.
http://www.linuxhardware.org/nvclock/

el uso de los sensores con el script es muy peligroso si no se tiene un conocimiento bastante amplio en ello, prácticamente dicen q puedes quemar la placa base u cpu.
http://draxus.org/weblog/2005/10/22/...ores-en-linux/

y por ultimo el q estoy detras de el, el " Coolbits ", una utilidad de nuestro propio controlador nvidia.

el problema para poder usarlo lo tengo que viene deshabilitado de fabrica, y en el manual dice que tengo que activar la funcion en el xorg.conf.

la cosa es q yo no tengo ese archivo y no se donde poner este parámetro necesario para activarlo.
Código:
Opción "Coolbits" "1"
pero el manual dice que lo ponga en xorg.conf. y no lo tengo.
la salida de la configuración x es esta con este comando.
Código:
ls -al /etc/X11/xorg.conf*
y esta es la salida
Código:
linux-3bn4:~ # ls -al /etc/X11/xorg.conf*
-rw-r--r-- 1 root root  874 Mar 14 04:13 /etc/X11/xorg.conf.install

/etc/X11/xorg.conf.d:
total 36
drwxr-xr-x  2 root root 4096 Mar 14 05:51 .
drwxr-xr-x 11 root root 4096 Mar 14 11:07 ..
-rw-r--r--  1 root root   61 Mar  1 22:51 05-glamor.conf
-rw-r--r--  1 root root 1099 Feb 21 11:07 10-evdev.conf
-rw-r--r--  1 root root 3640 Jan 27 14:09 11-mouse.conf
-rw-r--r--  1 root root 1918 Feb  4 21:49 50-synaptics.conf
-rw-r--r--  1 root root  115 Jan 28 09:19 50-vmmouse.conf
-rw-r--r--  1 root root  835 Jan 28 09:19 50-wacom.conf
-rw-r--r--  1 root root  107 Mar 14 05:51 90-keytable.conf
asi que ahora estoy sin saber donde mirar para activar el "Coolbits".

haber si sabéis donde poder activar o sabéis de otros programas o utilidades para poder controlar la refrigeración, por que en mi caso con 75ºc mi gráfica sigue estando al 40% de velocidad, cuando es variable, y quisiera poner varias velocidades a según q temperaturas para poder proteger la gpu.

un saludo y espero no haberos liado mucho con este tocho post.
__________________
Subir fotos: http://subefotos.com/
Responder Citando
  #2  
Antiguo 01-abr-2013, 04:59
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.535
Agradecimientos: 1.913
Agradecido 1.408 Veces en 1.179 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola Luke10:

En los repositorios tienes AsusFan que es una utilidad para controlar los ventiladores de nvidia.

Saludos cordiales
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
Germanlokura (07-oct-2014)
  #3  
Antiguo 01-abr-2013, 05:17
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.654
Agradecimientos: 73
Agradecido 402 Veces en 314 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Cita:
Iniciado por mikrios Ver Mensaje
Hola Luke10:

En los repositorios tienes AsusFan que es una utilidad para controlar los ventiladores de nvidia.

Saludos cordiales
hola, gracias por responder, si lo tenia instalado, pero nunca he sabido como funciona.

haber si podemos darle luz a estos programas y saber como manejarlos, o quien sabe hasta podría ver alguien que pudiese crear una aplicación grafica basándose en uno o varios a la vez de los mismos..

un saludo y gracias .
__________________
Subir fotos: http://subefotos.com/
Responder Citando
  #4  
Antiguo 02-abr-2013, 01:25
Viewsonic Viewsonic está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2011
Versión: 12.3
Mensajes: 7
Agradecimientos: 6
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
Viewsonic está en el buen camino
Hola, mira esto a ver si te sirve https://wiki.archlinux.org/index.php...spa%C3%B1ol%29

S2s.
Responder Citando
  #5  
Antiguo 02-abr-2013, 02:11
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Cita:
Iniciado por LUKE10 Ver Mensaje
y por ultimo el q estoy detras de el, el " Coolbits ", una utilidad de nuestro propio controlador nvidia.

el problema para poder usarlo lo tengo que viene deshabilitado de fabrica, y en el manual dice que tengo que activar la funcion en el xorg.conf.

la cosa es q yo no tengo ese archivo y no se donde poner este parámetro necesario para activarlo.
Código:
Opción "Coolbits" "1"
pero el manual dice que lo ponga en xorg.conf. y no lo tengo.
Ya no hace falta xorg.conf, durante el arranque se usa el controlador de NVIDIA si se encuentra, y si no se usa nouveau. Pero si quieres añadir opciones usa /etc/X11/xorg.conf.d/50-device.conf. En él descomenta las líneas Section "Device", Identifier "Default Device" y EndSection. La opción la añades en cualquier lugar entre Section "Device" y EndSection. Ah, no olvides que es Option xxx no Opción xxx (sé que lo sabes, pero cualquiera tiene un mal día, XD).

Cita:
Iniciado por LUKE10 Ver Mensaje
haber si sabéis donde poder activar o sabéis de otros programas o utilidades para poder controlar la refrigeración, por que en mi caso con 75ºc mi gráfica sigue estando al 40% de velocidad, cuando es variable, y quisiera poner varias velocidades a según q temperaturas para poder proteger la gpu.
¿Esa temperatura es en reposo, dándole un uso normal al ordenador o jugando? Porque si no es jugando es exagerada. Quizás tenga el ventilador muy sucio y/o la pasta térmica del disipador esté ya inservible. Tendrás un ventilador metiendo y otro sacando aire de la caja del ordenador, ¿no? La GTX 650 que tengo está a 30º y ni después de jugar sube a esos 75º que dices (claro que es muy maja, ni necesita alimentación extra, solo la del slot PCI-E).

Un saludo.
Responder Citando
  #6  
Antiguo 02-abr-2013, 02:45
Viewsonic Viewsonic está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2011
Versión: 12.3
Mensajes: 7
Agradecimientos: 6
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
Viewsonic está en el buen camino
Pues he hecho eso que dices y aun poniéndole "Coolbits" "1" no me sale nada, incluso he probado a añadirle el NoLogo a ver si salia la pantalla de Nvidia y nones.

Mi gráfica es una Nvidia Gtx 460 y Placa base Asrock 970 Extreme 3.

S2s.
Responder Citando
  #7  
Antiguo 02-abr-2013, 03:09
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Cita:
Iniciado por Viewsonic Ver Mensaje
Pues he hecho eso que dices y aun poniéndole "Coolbits" "1" no me sale nada, incluso he probado a añadirle el NoLogo a ver si salia la pantalla de Nvidia y nones.

Mi gráfica es una Nvidia Gtx 460 y Placa base Asrock 970 Extreme 3.

S2s.
El archivo de configuración /etc/X11/xorg.conf.d/50-device.conf:

Cita:
# Having multiple "Device" sections is known to be problematic. Make
# sure you don't have in use another one laying around e.g. in another
# xorg.conf.d file or even a generic xorg.conf file. More details can
# be found in https://bugs.freedesktop.org/show_bug.cgi?id=32430.
#
Section "Device"
Identifier "Default Device"
#
# #Driver "radeon"
#
# ## Required magic for radeon/radeonhd drivers; output name
# ## (here: "DVI-0") can be figured out via 'xrandr -q'
# #Option "monitor-DVI-0" "Default Monitor"
#
Option "Coolbits" "5"
EndSection
En la imagen adjunta se pueden ver unos nuevos ajustes disponibles (Enable GPU Fan Settings) para modificar la velocidad del ventilador. El logo se activa con Option "NoLogo" "false" (o 0 (cero) en vez de false). Por defecto debería estar activa pero yo no lo veo aparecer, así que o han cambiado el valor por defecto o no se muestra por otro motivo.

Un saludo.
Imágenes Adjuntas
Tipo de Archivo: png nvidia-settings_thermal-settings.png (80,0 KB (Kilobytes), 127 visitas)
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jcsl Por Este Mensaje:
Viewsonic (02-abr-2013)
  #8  
Antiguo 02-abr-2013, 03:21
Viewsonic Viewsonic está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2011
Versión: 12.3
Mensajes: 7
Agradecimientos: 6
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
Viewsonic está en el buen camino
Bueno, acabo de cambiarlo a ver como queda.

Gracias.

S2s.

Edito:

¡¡¡¡¡¡¡¡¡¡Perfecto!!!!!!!!!, ya se muestra la pestaña de overcloking del ventilador de la grafica.

Lo dicho, muchísimas gracias.

Última edición por Viewsonic; 02-abr-2013 a las 03:27
Responder Citando
  #9  
Antiguo 02-abr-2013, 03:27
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.654
Agradecimientos: 73
Agradecido 402 Veces en 314 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Cita:
Iniciado por jcsl Ver Mensaje
Hola.



Ya no hace falta xorg.conf, durante el arranque se usa el controlador de NVIDIA si se encuentra, y si no se usa nouveau. Pero si quieres añadir opciones usa /etc/X11/xorg.conf.d/50-device.conf. En él descomenta las líneas Section "Device", Identifier "Default Device" y EndSection. La opción la añades en cualquier lugar entre Section "Device" y EndSection. Ah, no olvides que es Option xxx no Opción xxx (sé que lo sabes, pero cualquiera tiene un mal día, XD).
Hola jcsl
la cosa es q busque el 50-device.conf y no se encuentra como puedes ver en mi 1º post.
lo que hice es crear el Xorg.conf con este comando como root.
Código:
Xorg -configure
me dio error, pero lo puse para probar y el pc arranco bien, este es mi Xorg.conf. generado y le añadí el
Opción "Coolbits" "4"
Código:
Section "ServerLayout"
    Identifier     "X.org Configured"
    Screen      0  "Screen0" 0 0
    Screen      1  "Screen1" RightOf "Screen0"
    Screen      2  "Screen2" RightOf "Screen1"
    Screen      3  "Screen3" RightOf "Screen2"
    InputDevice    "Mouse0" "CorePointer"
    InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
    ModulePath   "/usr/lib64/xorg/modules/updates"
    ModulePath   "/usr/lib64/xorg/modules"
    FontPath     "/usr/share/fonts/misc:unscaled"
    FontPath     "/usr/share/fonts/Type1/"
    FontPath     "/usr/share/fonts/100dpi:unscaled"
    FontPath     "/usr/share/fonts/75dpi:unscaled"
    FontPath     "/usr/share/fonts/ghostscript/"
    FontPath     "/usr/share/fonts/cyrillic:unscaled"
    FontPath     "/usr/share/fonts/misc/sgi:unscaled"
    FontPath     "/usr/share/fonts/truetype/"
    FontPath     "built-ins"
EndSection

Section "Module"
    Load  "glx"
    Load  "glx"
EndSection

Section "InputDevice"
    Identifier  "Keyboard0"
    Driver      "kbd"
EndSection

Section "InputDevice"
    Identifier  "Mouse0"
    Driver      "mouse"
    Option        "Protocol" "auto"
    Option        "Device" "/dev/input/mice"
    Option        "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
    Identifier   "Monitor0"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor1"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor2"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Monitor"
    Identifier   "Monitor3"
    VendorName   "Monitor Vendor"
    ModelName    "Monitor Model"
EndSection

Section "Device"
    Identifier  "Card0"
    Driver      "nvidia"
    Option "Coolbits" "4" 
    BusID       "PCI:4:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "SWcursor"               # [<bool>]
        #Option     "kmsdev"                 # <str>
        #Option     "ShadowFB"               # [<bool>]
    Identifier  "Card1"
    Driver      "modesetting"
    BusID       "PCI:4:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"               # [<bool>]
        #Option     "Rotate"                 # <str>
        #Option     "fbdev"                  # <str>
        #Option     "debug"                  # [<bool>]
    Identifier  "Card2"
    Driver      "fbdev"
    BusID       "PCI:4:0:0"
EndSection

Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "ShadowFB"               # [<bool>]
        #Option     "DefaultRefresh"         # [<bool>]
        #Option     "ModeSetClearScreen"     # [<bool>]
    Identifier  "Card3"
    Driver      "vesa"
    BusID       "PCI:4:0:0"
EndSection

Section "Screen"
    Identifier "Screen0"
    Device     "Card0"
    Monitor    "Monitor0"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device     "Card1"
    Monitor    "Monitor1"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen2"
    Device     "Card2"
    Monitor    "Monitor2"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen3"
    Device     "Card3"
    Monitor    "Monitor3"
    SubSection "Display"
        Viewport   0 0
        Depth     1
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     4
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     8
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     15
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     16
    EndSubSection
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
hay alguna forma de generar el 50-device.conf? ya que si esta versión de suse no usa el Xorg.conf ya que no se usa sax, pues me quedaría mas tranquilo.

Cita:
Iniciado por jcsl Ver Mensaje
¿Esa temperatura es en reposo, dándole un uso normal al ordenador o jugando? Porque si no es jugando es exagerada. Quizás tenga el ventilador muy sucio y/o la pasta térmica del disipador esté ya inservible. Tendrás un ventilador metiendo y otro sacando aire de la caja del ordenador, ¿no? La GTX 650 que tengo está a 30º y ni después de jugar sube a esos 75º que dices (claro que es muy maja, ni necesita alimentación extra, solo la del slot PCI-E).

Un saludo.
la temperatura en reposo es de unos 52ºc, y 75 es jugando al world of warcraft bajo wine.
cada 6 meses le paso el compresor a los disipadores y en la ultima limpieza le cambie la pasta térmica a la cpu y a la gpu.
la super torre q uso es de aluminio thermaltake muy bien refrigerada.
mi gráfica es una geforce 275gtx con alimentación extra con 2 conexiones pci-e, si, si 2 conectores pci-e .

la cosa es que de la forma usada el ventilador no es auto ajustable lo deje al 65% del ventilador con buenos resultados al jugar unos 60ºc.
pero el ventilador no baja si el pc esta en reposo, y lo que intento es q se ajuste a varios % según ciertas temperaturas.

bueno eso es todo hasta ahora q he podido sacar, haber si hay otra forma de poder poner varias temperaturas con varios %.

un saludo.
__________________
Subir fotos: http://subefotos.com/
Responder Citando
  #10  
Antiguo 02-abr-2013, 03:36
Viewsonic Viewsonic está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2011
Versión: 12.3
Mensajes: 7
Agradecimientos: 6
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
Viewsonic está en el buen camino
Luke, perdona la pregunta, ¿tienes ventiladores metiendo y sacando aire en tu torre?, lo digo porque mi gráfica esta al 40% de revoluciones y a 37º en reposo.

Otra cosa, ¿com es que te sale la temperatura de la placa base?.

Saludos.
Responder Citando
Respuesta

Marcadores

Etiquetas
grafica, nvidia, temperatura grafica, ventilacion de la grafica


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
T. wifi ovislink en OpenSuse 11.2 atami Hardware 1 14-nov-2009 18:34
wireless en opensuse 10.2 rub Hardware 5 27-abr-2009 06:08
Tarjeta de video korn_head Hardware 5 03-may-2007 20:24
Nvidia, intel, héroes, demonios y otras yerbas en el mundo linuxero RGB El Contubernio 5 06-mar-2007 18:56
Linux Desktop multiples rock General OpenSUSE 20 03-dic-2006 20:02



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 13:09.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba