Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Downgrade de gcc47 a gcc446
  #1  
Antiguo 22-feb-2013, 09:56
Avatar de deboh_at
deboh_at deboh_at está desconectado
Aforado
 
Fecha de Ingreso: 20-febrero-2013
Versión: Todas
Mensajes: 22
Agradecimientos: 12
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
deboh_at está en el buen camino
Downgrade de gcc47 a gcc446

Hola,

Pregunto aqui porque no he visto nada que me sirva por internet ni en el buscador.

Tengo un cliente, que tiene instalado OpenSuSE 12.2 , el cual le instala el gcc47. No le vale y quiere hacer un downgrade a gcc446 porque necesita usarlo con Matlab R2012b.

No encuentro nada al respecto de compatibilidad. Creo que no hay compatibilidad a esa versión del gcc, o si?

Otra cosa, gcc es lo mismo que cpp?

Gracias!
Responder Citando
  #2  
Antiguo 22-feb-2013, 10:26
Avatar de sieg84
sieg84 sieg84 está desconectado
Miembro Junior
 
Fecha de Ingreso: 18-diciembre-2009
Ubicación: México
Versión: Tumbleweed
Mensajes: 478
Agradecimientos: 38
Agradecido 91 Veces en 80 Mensajes
Poder de Credibilidad: 8
sieg84 está en el buen camino
creo que tendras que conseguir una distro que use esa version, openSUSE 11.2 usa gcc 4.4.1 (no tiene soporte).
o con debian 6 usa gcc 4.4.5
__________________
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a sieg84 Por Este Mensaje:
deboh_at (24-jun-2013)
  #3  
Antiguo 22-feb-2013, 14:36
XisEme XisEme está desconectado
Miembro Senior
 
Fecha de Ingreso: 08-septiembre-2005
Ubicación: ±43º21'N8º22'W
Versión: Tumbleweed[x64]
Mensajes: 1.232
Agradecimientos: 22
Agradecido 301 Veces en 258 Mensajes
Poder de Credibilidad: 14
XisEme está en el buen camino
Buscando en el buscador de paquetes ... ... y a probaaar ...
__________________
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a XisEme Por Este Mensaje:
deboh_at (24-jun-2013)
  #4  
Antiguo 22-feb-2013, 20:35
Avatar de VampirD
VampirD VampirD está desconectado
Miembro Senior
 
Fecha de Ingreso: 28-diciembre-2010
Ubicación: Frente al teclado
Versión: Leap 42.1
Mensajes: 827
Agradecimientos: 5
Agradecido 177 Veces en 144 Mensajes
Poder de Credibilidad: 7
VampirD está en el buen camino
Enviar un mensaje por ICQ a VampirD Enviar un mensaje por MSN a VampirD
haciendo un downgrade del gcc seguro hace un downgrade de las librerias del sistema, y no va a funcionar
__________________
VampirD

Microsoft Windows is like air conditioning
Stops working when you open a window.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a VampirD Por Este Mensaje:
deboh_at (24-jun-2013)
  #5  
Antiguo 22-feb-2013, 23:09
Avatar de zchronos
zchronos zchronos está desconectado
Miembro Senior
 
Fecha de Ingreso: 06-noviembre-2007
Ubicación: Chiclayo - Perú
Versión: 13.1
Mensajes: 822
Agradecimientos: 16
Agradecido 63 Veces en 49 Mensajes
Poder de Credibilidad: 10
zchronos está en el buen camino
Enviar un mensaje por MSN a zchronos
Cita:
Iniciado por deboh_at Ver Mensaje
Otra cosa, gcc es lo mismo que cpp?
Son consas MUY DIFERENTES. El GCC es un compilador, mientras que el cpp es la extensión del archivo cuando programas en C++

Tal y como dijo VampirD, habría que hacer un downgrade de varias librerías.

Es decir, la mayoría de paquetes ya son binarios, así que no necesitas compilarlos, PERO si deseas compilar, con un kernel moderno, librerías modernas, etc, etc. Pues tendrías que cambiar todas éstas a la versión anterior, lo cual es una pérdida de tiempo.

Si quieres usar una versión anterior del GCC, mejor busca una versión anterior de OpenSUSE u otra Distro.
__________________

"No existen los problemas, tan solo soluciones"
Linux user #460594
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a zchronos Por Este Mensaje:
deboh_at (24-jun-2013)
  #6  
Antiguo 25-feb-2013, 10:14
Avatar de deboh_at
deboh_at deboh_at está desconectado
Aforado
 
Fecha de Ingreso: 20-febrero-2013
Versión: Todas
Mensajes: 22
Agradecimientos: 12
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
deboh_at está en el buen camino
Hola,
Gracias a Tod@s! Por más que miro , sigo sin ver que exista compatibilidad del gcc44 con OpenSuSE 12.2 ¿Podría forzarse? Intuyo que puede ser problemático ¿no? Es que el Matlab que necesitan usar solo es compatible con esa versión del gcc. Proponer cambiar la versión del sistema operativo, no creo que les haga nada de gracia...Pero El Matlab R2011b usa el gcc 4.3.x y por lo que veo en el buscador de paquetes, existe un gcc43 para OpenSuSE 12.2 ¿Lo veis como una solución factible? ¿Alguien ha utilizadoel gcc 4.3 en OpenSuSE 12.2?
Responder Citando
  #7  
Antiguo 25-feb-2013, 10:38
Avatar de sieg84
sieg84 sieg84 está desconectado
Miembro Junior
 
Fecha de Ingreso: 18-diciembre-2009
Ubicación: México
Versión: Tumbleweed
Mensajes: 478
Agradecimientos: 38
Agradecido 91 Veces en 80 Mensajes
Poder de Credibilidad: 8
sieg84 está en el buen camino
tal vez esto te sirva de referencia:
http://www.linuxforums.org/forum/red...-compiler.html
__________________
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a sieg84 Por Este Mensaje:
deboh_at (24-jun-2013)
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Mi experiencia con openSUSE 11.4 y mi downgrade a 11.3 NestorAcevedo El Contubernio 2 15-jun-2011 09:07
Downgrade de Samba GeekPy Internet, Redes y Wireless 0 12-ago-2010 15:04
Downgrade kde 4.4 a 4.3 [SOLUCIONADO] gechdell Software 5 22-abr-2010 10:19
Downgrade Kernel canalla General OpenSUSE 4 17-jul-2008 08:41
Downgrade de xorg de 7.2 a 7.1 carpeta General OpenSUSE 2 18-jul-2007 22:04



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 03:42.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba