Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

cuidado con zypper rm --clean-deps
  #1  
Antiguo 28-ene-2013, 18:10
nslookup nslookup está desconectado
Aforado
 
Fecha de Ingreso: 27-enero-2013
Ubicación: En una galaxia muy muy lejana...
Versión: 12.2
Mensajes: 8
Agradecimientos: 5
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
nslookup está en el buen camino
cuidado con zypper rm --clean-deps

Hola compañeros, soy nuevo en opensuse. El caso es que después de instalar el sistema (versión 12.2) Me disponía a instalar los drivers de nvidia.
Mi portátil utiliza la tecnología optimus de nvidia. En fin, obviamente, después de lanzar lsmod para ver qué drivers había cargado el kernel, veo lo típico, el de intel y además el nouveau.
Quería eliminar el driver de nouveau, pero no sabía cómo se llamaba el paquete a desinstalar. Nada, echo un ojo al manual de zypper, le echo otro ojo al manual de rpm (tengo experiencia con distribuciones basadas en debian, pero no conozco opensuse ni el sistema de paquetes rpm).

Total que lanzo:
Código:
$ sudo rpm -q -a | grep nouveau
Y me escupe esto pantalla:
xorg-x11-driver-video-nouveau-0.0.16_20120321_ab7291d-3.5.1.x86_64
libdrm_nouveau1-2.4.33-2.3.2.x86_64
Y pienso..... ó, que bien, sólo dos paquetes a desinstalar, ahora voy a echarle otro ojo al manual de zypper para ver si hay algo parecido a apt-get autoremove....... Y me encuentro con la opción --clean-deps del comando remove de zypper.... ¡Esto pinta genial! (me digo a mí mismo...)

Total que lanzo:
Código:
$ sudo zypper rm --clean-deps xorg-x11-driver-video-nouveau-0.0.16_20120321_ab7291d-3.5.1.x86_64 libdrm_nouveau1-2.4.33-2.3.2.x86_64
Atentos a lo que me escupe por pantalla porque no tiene desperdicio:
Cita:
ali3n@linux-d1a0:~-$ rpm -q -a | grep nouveau
xorg-x11-driver-video-nouveau-0.0.16_20120321_ab7291d-3.5.1.x86_64
libdrm_nouveau1-2.4.33-2.3.2.x86_64
ali3n@linux-d1a0:~-$ sudo zypper rm --clean-deps xorg-x11-driver-video-nouveau-0.0.16_20120321_ab7291d-3.5.1.x86_64 libdrm_nouveau1-2.4.33-2.3.2.x86_64
root's password:
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
Resolviendo dependencias...

Los siguientes paquetes van a ser ELIMINADOS:
accountsservice aisleriot alacarte alsa-plugins-pulse aqbanking
aqbanking-lang at-spi2-atk-common at-spi2-atk-gtk2 at-spi2-atk-gtk3
at-spi2-core banshee banshee-backend-engine-gstreamer banshee-backend-io-gio
banshee-backend-platform-gnome banshee-backend-platform-unix banshee-core
banshee-dmp banshee-dmp-apple-devices banshee-dmp-mtp
banshee-extensions-default baobab bluez bogofilter brasero brasero-nautilus
brltty brltty-driver-at-spi2 brltty-driver-brlapi brltty-driver-espeak
brltty-driver-speech-dispatcher brltty-driver-xwindow bug-buddy
canberra-gtk-play caribou caribou-gtk2-module caribou-gtk3-module
caribou-gtk-module-common cdrdao cdrkit-cdrtools-compat cheese dbus-sharp
dbus-sharp-glib dhcp dhcp-client DirectFB-Mesa dnsmasq
dynamic-wallpaper-branding-openSUSE empathy eog espeak evince evolution
evolution-data-server evolution-mono-plugins evolution-python-plugins
evolution-webcal farstream-data file-roller flash-player-gnome fortune
fribidi gbrainy gbrainy-lang gcalctool gconf-sharp2 gdata-sharp gdb gdm
gdm-branding-openSUSE gdmflexiserver gedit geoclue geoclue-recommended gimp
gimp-branding-openSUSE gimp-help gimp-help-browser gimp-help-es gimp-lang
gimp-plugins-python gio-sharp gjs gkeyfile-sharp glamor glchess glib-sharp2
gnokii gnome-applets gnome-applets-lang gnome-bluetooth
gnome-bluetooth-plugin-phone-manager gnome-bluetooth-plugins-geoclue
gnome-contacts gnome-control-center gnome-control-center-branding-openSUSE
gnome-control-center-user-faces gnome-dictionary gnome-disk-utility
gnome-documents gnome-font-viewer gnome-games-recommended gnome-games-support
gnome-js-common gnome-menus gnome-menus-branding-openSUSE gnome-nettool
gnome-online-accounts gnome-packagekit gnome-panel gnome-panel-applet-tracker
gnome-panel-branding-openSUSE gnome-phone-manager gnome-power-manager
gnome-pty-helper gnome-screensaver gnome-screenshot gnome-session
gnome-session-core gnome-session-default-session
gnome-session-fallback-session gnome-settings-daemon gnome-shell
gnome-shell-browser-plugin gnome-shell-extension-alternative-status-menu
gnome-shell-extensions-common gnome-shell-search-provider-documents
gnome-sudoku gnome-system-monitor gnome-terminal gnome-themes-accessibility
gnome-tweak-tool gnome-user-docs gnome-user-share gnome-version
gnome-video-effects gnome-web-photo gnomine gnucash gnucash-docs gnucash-lang
goffice-lang gpgme grilo-plugins grilo-plugin-tracker grilo-plugin-upnp
grilo-plugin-youtube gsf-office-thumbnailer gsl gstreamer-0_10-libnice
gstreamer-0_10-plugin-gstclutter gstreamer-0_10-plugins-bad
gstreamer-0_10-plugins-farstream gstreamer-0_10-plugins-good
gstreamer-0_10-utils gstreamer-utils gtk2-engine-hcengine gtk-sharp2
gtk-sharp-beans gtkspell-lang gtk-vnc-lang gucharmap gudev-sharp guile
guile-modules-2_0 gutenprint gwenhywfar-lang hplip hplip-sane iagno icedax
inkscape inkscape-extensions-extra inkscape-extensions-gimp inkscape-lang
input-utils libaccountsservice0 libass4 libatkmm-1_6-1 libatspi0
libavahi-gobject0 libavahi-ui-gtk3-0 libbrasero-burn3-1 libbrasero-media3-1
libbrasero-utils3-1 libbrlapi0_5 libcacard0 libcairomm-1_0-1 libcamel-1_2-33
libcaribou0 libcdaudio libcelt0-2 libcelt051-0 libchamplain-0_12-0 libcheese3
libcheese-common libcheese-gtk21 libclutter-1_0-0 libclutter-gst-1_0-0
libclutter-gtk-1_0-0 libcogl9 libcogl-pango0 libcryptui0 libcryptui-data
libcue1 libdbi0 libdc1394-22 libdirac_encoder0 libdiscid0 libdjvulibre21
libdotconf0 libdrm_nouveau1 libdvdnav4 libdvdread4 libebackend-1_2-2
libebook-1_2-13 libecal-1_2-11 libedata-book-1_2-13 libedata-cal-1_2-15
libedataserver-1_2-16 libedataserverui-3_0-1 libEMF1 libenca0 libepc-1_0-2
libevdocument3-4 libevview3-3 libexempi3 libexiv2-12 libfarstream-0_1-0
libfftw3-3 libfolks25 libfolks-eds25 libfolks-libsocialweb25
libfolks-telepathy25 libfprint0 libgadu3 libgc1 libgdata13 libgdict-1_0-6
libgdiplus0 libgdmgreeter1 libgdmsimplegreeter1 libgee2 libgeocode-glib0
libgexiv2-1 libgiomm-2_4-1 libgjs0 libglibmm-2_4-1 libgme0 libgmime-2_6-0
libgnome-bluetooth10 libgnome-desktop-3-2 libgnomekbd libgnome-menu-3-0
libgnomesu libgnomesu0 libgoa-1_0-0 libgoa-backend-1_0-0 libgoffice-0_10-9
libgoffice-0_8-8 libgpgme11 libgrilo-0_1-0 libgrlnet-0_1-0 libgsf-1-114
libgsm1 libgssdp-1_0-3 libgstbasecamerabinsrc-0_10-23 libgstbasevideo-0_10-23
libgstcodecparsers-0_10-23 libgstphotography-0_10-23
libgstsignalprocessor-0_10-23 libgstvdp-0_10-23 libgtkhtml-4_0-0
libgtkhtml-editor-4_0-0 libgtkmm-2_4-1 libgtkmm-3_0-1 libgtksourceview-3_0-0
libgtkspell0 libgtk-vnc-2_0-0 libgtop-2_0-7 libgucharmap_2_90-7
libguile-2_0-22 libgupnp-1_0-4 libgupnp-av-1_0-2 libgupnp-igd-1_0-4
libgvnc-1_0-0 libgweather-3-0 libgweather-data libgwengui-gtk2-0
libgwenhywfar60 libgwenhywfar60-plugins libgxps2 libical0 libieee1284
libiptcdata libiptcdata0 libjack0 libjson-glib-1_0-0 libktoblzcheck1
liblirc_client0 liblouis2 liblrdf2 libMagick++5 libmemphis-0_2-0
libminiupnpc8 libmission-control-plugins0 libmms0 libmodplug1 libmono-2_0-1
libmozjs185-1_0 libmpcdec5 libmusicbrainz3-6 libmusicbrainz4 libmx-1_0-2
libmysqlclient18 libnautilus-extension1 libnice10 libnl3-200 libnl-config
libnm-glib4 libnm-glib-vpn1 libnm-gtk0 libnm-util2 libnotify-tools liboauth0
libofa0 libofx libofx5 libopenal1-soft libosinfo libosinfo-1_0-0
libpanel-applet-4-0 libpangomm-1_4-1 libpcsclite1 libpeas-1_0-0
libpeas-gtk-1_0-0 libpeas-loader-gjs libpeas-loader-python
libpeas-loader-seed libphonon4 libpkcs11-helper1 libplotter2 libportaudio2
libproxy1-networkmanager libpst4 libpulse-mainloop-glib0 libpurple
libpurple-branding-openSUSE libpurple-tcl libqt4 libqt4-sql libqt4-sql-mysql
libqt4-x11 libQtWebKit4 libquvi7 libquvi-scripts libraptor2-0 libraw1394-11
libraw2 librcc0 librcd0 libreoffice-filters-optional libreoffice-gnome
libreoffice-impress libreoffice-impress-extensions librest0 libsamplerate0
libseed-gtk3-0 libsexy libsigc-2_0-0 libsilc-1_1-2 libsilcclient-1_1-3
libsocialweb libsocialweb0 libsocialweb-branding-openSUSE
libsocialweb-client2 libsocks0 libsofia-sip-ua0 libsofia-sip-ua-glib3
libSoundTouch0 libspandsp2 libspectre1 libspeechd2 libspeexdsp1
libspice-client-glib-2_0-1 libspice-client-gtk-3_0-1 libsushi-1_0-0 libtag1
libtag_c0 libtelepathy-farstream2 libtelepathy-glib0 libtelepathy-logger2
libtimidity-0_1-0 libtotem-plparser17 libtotem-plparser-mini17
libtracker-common-0_14-0 libtracker-extract-0_14-0 libtracker-miner-0_14-0
libtracker-sparql-0_14-0 libunique-3_0-0 libunistring0 libusbredirhost1
libusbredirparser0 libv4l libv4l1-0 libv4l2-0 libv4lconvert0 libva1 libvdpau1
libvpx0 libvte2_90-9 libwacom2 libwacom-data libwavpack1 libwebkitgtk-1_0-0
libwebkitgtk-3_0-0 libwnck-3-0 libXevie1 libxklavier16 libxml++-2_6-2
libyelp0 libzvbi0 liferea lightsoff lirc lirc-remotes mahjongg
media-player-info Mesa Mesa-demo-x Mesa-libGL1 Mesa-libGLU1 metacity
mobile-broadband-provider-info ModemManager mono-addins mono-core mono-data
mono-data-sqlite mono-web mono-zeroconf mono-zeroconf-provider-avahi
mousetweaks mutter nautilus nautilus-evince nautilus-extension-seahorse
nautilus-extension-tracker-tags nautilus-file-roller nautilus-open-terminal
nautilus-sendto nautilus-sendto-plugin-empathy
nautilus-sendto-plugin-evolution nautilus-sendto-plugin-upnp nautilus-totem
NetworkManager NetworkManager-gnome NetworkManager-openvpn
NetworkManager-openvpn-gnome NetworkManager-pptp NetworkManager-pptp-gnome
NetworkManager-vpnc NetworkManager-vpnc-gnome notify-sharp obexd obexd-client
openal-soft opensp openvpn orca patterns-openSUSE-gnome
patterns-openSUSE-gnome_admin patterns-openSUSE-gnome_basis
patterns-openSUSE-gnome_basis_opt patterns-openSUSE-gnome_games
patterns-openSUSE-gnome_imaging patterns-openSUSE-gnome_imaging_opt
patterns-openSUSE-gnome_internet patterns-openSUSE-gnome_laptop
patterns-openSUSE-gnome_multimedia patterns-openSUSE-gnome_multimedia_opt
patterns-openSUSE-gnome_office patterns-openSUSE-gnome_office_opt
patterns-openSUSE-gnome_utilities patterns-openSUSE-gnome_yast
patterns-openSUSE-sw_management_gnome pcsc-lite perl-Crypt-SSLeay
perl-Date-Manip perl-Finance-Quote perl-HTML-Element-Extended
perl-HTML-TableExtract perl-HTML-TokeParser-Simple perl-Sub-Override
perl-Sub-Uplevel perl-Test-Exception perl-YAML-Syck phalanx
phonon-backend-gstreamer-0_10 pkcs11-helper polkit-gnome pstoedit pulseaudio
pulseaudio-module-bluetooth pulseaudio-module-gconf pulseaudio-module-lirc
pulseaudio-module-x11 pulseaudio-module-zeroconf pulseaudio-utils
python-atspi python-beautifulsoup python-brlapi python-gstreamer-0_10
python-httplib2 python-louis python-lxml python-pyOpenSSL python-qt4
python-sip python-speechd python-xdg quadrapassel rdesktop rtkit samba
sane-backends sane-backends-autoconfig seahorse seahorse-daemon shotwell
silc-toolkit simple-scan slib smolt-gui speech-dispatcher
speech-dispatcher-module-espeak sushi sushi-lang swell-foop
system-config-printer t1lib taglib-sharp tango-icon-theme tcl
telepathy-gabble telepathy-haze telepathy-idle telepathy-logger
telepathy-mission-control telepathy-mission-control-plugin-goa
telepathy-rakia telepathy-salut tk tomboy tomboy-lang totem
totem-browser-plugin totem-browser-plugin-gmp totem-plugins tracker
tracker-gui tracker-miner-evolution tracker-miner-files tracker-miner-firefox
transmission-common transmission-gtk typelib-1_0-AccountsService-1_0
typelib-1_0-Atk-1_0 typelib-1_0-Atspi-2_0 typelib-1_0-Caribou-1_0
typelib-1_0-Clutter-1_0 typelib-1_0-ClutterGst-1_0 typelib-1_0-Cogl-1_0
typelib-1_0-CoglPango-1_0 typelib-1_0-EvinceDocument-3_0
typelib-1_0-EvinceView-3_0 typelib-1_0-Folks-0_6 typelib-1_0-Gck-1
typelib-1_0-Gcr-3 typelib-1_0-GData-0_0 typelib-1_0-GdkPixbuf-2_0
typelib-1_0-GdmGreeter-1_0 typelib-1_0-Gee-1_0 typelib-1_0-GjsDBus-1_0
typelib-1_0-GMenu-3_0 typelib-1_0-GnomeBluetooth-1_0 typelib-1_0-Goa-1_0
typelib-1_0-Gst-0_10 typelib-1_0-GstInterfaces-0_10 typelib-1_0-Gtk-2_0
typelib-1_0-Gtk-3_0 typelib-1_0-GtkClutter-1_0 typelib-1_0-GtkSource-3_0
typelib-1_0-JSCore-1_0 typelib-1_0-Json-1_0 typelib-1_0-NetworkManager-1_0
typelib-1_0-NMClient-1_0 typelib-1_0-Pango-1_0 typelib-1_0-Peas-1_0
typelib-1_0-PeasGtk-1_0 typelib-1_0-Polkit-1_0 typelib-1_0-Soup-2_4
typelib-1_0-Sushi-1_0 typelib-1_0-TelepathyGlib-0_12
typelib-1_0-TelepathyLogger-0_2 typelib-1_0-TotemPlParser-1_0
typelib-1_0-Tracker-0_14 typelib-1_0-UpowerGlib-1_0 typelib-1_0-WebKit-1_0
typelib-1_0-Wnck-3_0 typelib-1_0-Xkl-1_0 unoconv usb_modeswitch
usb_modeswitch-data vaapi-intel-driver vinagre vinagre-lang vino vpnc wodim
xbrlapi xchat xchat-perl xchat-python xchat-tcl xdg-user-dirs
xdg-user-dirs-gtk xf86-input-evdev xf86-input-joystick xf86-input-keyboard
xf86-input-mouse xf86-input-synaptics xf86-input-vmmouse xf86-input-void
xf86-input-wacom xf86-video-ark xf86-video-ast xf86-video-ati
xf86-video-chips xf86-video-cirrus xf86-video-dummy xf86-video-fbdev
xf86-video-geode xf86-video-glint xf86-video-i128 xf86-video-intel
xf86-video-mach64 xf86-video-mga xf86-video-neomagic xf86-video-newport
xf86-video-nv xf86-video-qxl xf86-video-r128 xf86-video-savage
xf86-video-siliconmotion xf86-video-sis xf86-video-tdfx xf86-video-tga
xf86-video-v4l xf86-video-vesa xf86-video-vmware xf86-video-voodoo
xorg-x11-driver-input xorg-x11-driver-video
xorg-x11-driver-video-intel-legacy xorg-x11-driver-video-nouveau
xorg-x11-driver-video-radeonhd xorg-x11-server xorg-x11-server-extra
r yast2-control-center-gnome yelp yudit zenity

673 paquetes a quitar.
Después de la operación, se liberarán 1,2 GiB.
¿Desea continuar? [s/n/?] (s): n

Pues eso, menos mal que soy de los que leen antes de dar el "si quiero" que si no....

Ahora en serio, he googleado por ahí, y no he encontrado otra herramienta en zypper para eliminar dependencias. Así pues.... No se si esto es un pedazo de bug de zypper o si es que soy un melón y he entendido lo que me ha dado la gana al leerme el manual.

Una cosa está clara: no puedo perder gnome-terminal por desinstalarme los drivers de nouveau, vamos, no me ha pasado nunca en ubuntu ni en debian, y no veo por qué debería pasarme aquí, así que debe haber algo mal. Bien en zypper a la hora de resolver dependencias, o bien porque yo haya hecho algo mal.

¿Alguien me puede dar un consejillo? Desde luego, si es un bug de zypper, lo pienso reportar, y con pantallazos y todo, que los tengo. Si quereis que los ponga, lo hago.

¿Qué opinais?

Última edición por nslookup; 28-ene-2013 a las 18:12
Responder Citando
  #2  
Antiguo 28-ene-2013, 18:54
Avatar de Defton
Defton Defton está desconectado
Miembro Senior
 
Fecha de Ingreso: 03-abril-2007
Ubicación: Mexico/SanLuisPotosi
Versión: 42.1
Mensajes: 858
Agradecimientos: 7
Agradecido 151 Veces en 95 Mensajes
Poder de Credibilidad: 11
Defton está en el buen camino
Enviar un mensaje por MSN a Defton Enviar un mensaje por Skype™ a Defton
¿intentaste desinstalarlo desde yast?
__________________
__________________________________________________

Mi Blog:
http://elblogdedarkspark.blogspot.mx/
Canales de Youtube:
http://www.youtube.com/user/DarkSpark2099
http://www.youtube.com/user/defton En des-uso
Responder Citando
  #3  
Antiguo 28-ene-2013, 19:43
XisEme XisEme está desconectado
Miembro Senior
 
Fecha de Ingreso: 08-septiembre-2005
Ubicación: ±43º21'N8º22'W
Versión: Tumbleweed[x64]
Mensajes: 1.232
Agradecimientos: 22
Agradecido 301 Veces en 258 Mensajes
Poder de Credibilidad: 14
XisEme está en el buen camino
Dudo mucho que sea un bug. Creo que la cuestión está en libdrm_nouveau1, debe ser una librería de la que dependen otros. En mi caso con Kde no quiere desinstalar tanto
Código:
SR522:~ # zypper rm --clean-deps libdrm_nouveau1-2.4.33-2.3.2.x86_64Loading repository data...
Reading installed packages...
Resolving package dependencies...

The following packages are going to be REMOVED:
  Mesa Mesa-libGL1 kdm libdrm_nouveau1 synaptiks xf86-input-evdev xf86-input-joystick xf86-input-keyboard 
  xf86-input-mouse xf86-input-synaptics xf86-input-vmmouse xf86-input-void xf86-input-wacom xf86-video-ark 
  xf86-video-ast xf86-video-ati xf86-video-chips xf86-video-cirrus xf86-video-dummy xf86-video-fbdev 
  xf86-video-geode xf86-video-glint xf86-video-i128 xf86-video-intel xf86-video-mach64 xf86-video-mga 
  xf86-video-neomagic xf86-video-newport xf86-video-nv xf86-video-qxl xf86-video-r128 xf86-video-savage 
  xf86-video-siliconmotion xf86-video-sis xf86-video-tdfx xf86-video-tga xf86-video-v4l xf86-video-vesa 
  xf86-video-vmware xf86-video-voodoo xorg-x11-driver-input xorg-x11-driver-video 
  xorg-x11-driver-video-intel-legacy xorg-x11-driver-video-radeonhd xorg-x11-server 

45 packages to remove.
After the operation, 89.9 MiB will be freed.
Continue? [y/n/?] (y): n
Vamos que con quitar el driver propiamente bastaría
Código:
SR522:~ # zypper rm --clean-deps xorg-x11-driver-video-nouveau
Loading repository data...
Reading installed packages...
Package 'xorg-x11-driver-video-nouveau' is not installed.
'xorg-x11-driver-video-nouveau' not found in package names. Trying capabilities.
No provider of 'xorg-x11-driver-video-nouveau' is installed.
Resolving package dependencies...

Nothing to do.
Existe también rpmorphan <=> deborpham. En mi caso para mantener limpio el sistema estoy satisfecho con bleachbit.

Se me olvidaba (aunque habrá quien discrepe ):
apt-get/aptitude mejor que dpkg. zypper mejor que rpm. Synaptic es bueno; el gestor de software de Yast es requetebueno (como Defton dice pruébalo)
__________________
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.

Última edición por XisEme; 28-ene-2013 a las 20:17
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a XisEme Por Este Mensaje:
nslookup (29-ene-2013)
  #4  
Antiguo 29-ene-2013, 01:48
nslookup nslookup está desconectado
Aforado
 
Fecha de Ingreso: 27-enero-2013
Ubicación: En una galaxia muy muy lejana...
Versión: 12.2
Mensajes: 8
Agradecimientos: 5
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
nslookup está en el buen camino
Pues me da a mí que sí que va a ser un bug....

Esto es lo que me dice Yast:

Responder Citando
  #5  
Antiguo 29-ene-2013, 02:28
XisEme XisEme está desconectado
Miembro Senior
 
Fecha de Ingreso: 08-septiembre-2005
Ubicación: ±43º21'N8º22'W
Versión: Tumbleweed[x64]
Mensajes: 1.232
Agradecimientos: 22
Agradecido 301 Veces en 258 Mensajes
Poder de Credibilidad: 14
XisEme está en el buen camino
Lo que indica, insisto. que no es un «bug» sino una «feature». Mal o bien, está diseñado así: Mesa_x64bits requiere libdrm_nouveau. Es por eso que las soluciones que yast propone (es bueno ¿eh?) son: cambiar arquitectura i586, mantener (lo inteligente) o romper.

Puedes buscar el paquete Mesa y ver sus dependencias
dep_mesa.png
__________________
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a XisEme Por Este Mensaje:
nslookup (29-ene-2013)
  #6  
Antiguo 29-ene-2013, 20:33
nslookup nslookup está desconectado
Aforado
 
Fecha de Ingreso: 27-enero-2013
Ubicación: En una galaxia muy muy lejana...
Versión: 12.2
Mensajes: 8
Agradecimientos: 5
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
nslookup está en el buen camino
Wow!!!!!
Tienes razón XisEme! no es un bug, es que está hecho así!. Y la verdad, me cuesta entender el porqué han basado el funcionamiento de tantas cosas en una librería de un driver de nvidia. Entonces, ¿Quien tenga una tarjeta ati tiene que tener instalada esa librería del driver de nouveau para tarjetas nvidia? No le veo mucho sentido, pero como bien demuestra tu pantallazo, parece ser así.


Muchas gracias a los dos por vuestras respuestas.

PD: parece que teníais razón. Yast es requetebueno

Última edición por nslookup; 29-ene-2013 a las 20:38
Responder Citando
  #7  
Antiguo 30-ene-2013, 02:22
XisEme XisEme está desconectado
Miembro Senior
 
Fecha de Ingreso: 08-septiembre-2005
Ubicación: ±43º21'N8º22'W
Versión: Tumbleweed[x64]
Mensajes: 1.232
Agradecimientos: 22
Agradecido 301 Veces en 258 Mensajes
Poder de Credibilidad: 14
XisEme está en el buen camino
Por si pareciera que es una particularidad de openSUSE: Mesa también necesita libdrm-nouveau [+ -radeon + -intel] en otros sistemas GNU/Linux (debian incluído )
__________________
Todo es mejorable, estamos dispuestos a mejorar. ¿Yo? ... poco a poco.
Nunca hay acritud en mis comentarios, si lo pareciera, seguro que me he expresado mal.
Responder Citando
  #8  
Antiguo 30-ene-2013, 04:21
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.220
Agradecimientos: 42
Agradecido 1.263 Veces en 931 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

Como veis, libdrm no tiene que ver con el driver gráfico. Simplemente es la librería del "Render Direct Manager", que, entre otras cosas, incluye la del driver nouveau, intel y radeon. Sería buena idea que en futuras versiones no incluyesen paquetes que no precisas, pero ya sabéis, se instalan todos y que cada computador escoja los justos

Si lo que quieres es desinstalar el driver, desinstala el paquete de xorg (es como en Debian )

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
  #9  
Antiguo 30-ene-2013, 20:32
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Lo que ocurre es que al ser openSUSE una distribución generalista los paquetes se compilan con todo lo que se pueda. Eso hace que aparezcan muchas dependencias, algunas que pueden llegar a sorprender (al menos a mí). Reduciendo el uso de patrones y paquetes de branding openSUSE parece que se pueden reducir también las dependencias. Muchas de ellas parecen venir de los paquetes recomendados para uno dado. Durante la instalación (y cuando termina) selecciono en YaST la opción Ignorar paquetes recomendados para los paquetes ya instalados además de Limpiar durante la eliminación de paquetes (cuidado con ésta por a las dependencias) y así me deja borrar mucha morralla que ni quiero ni necesito. De esta forma se puede hacer una instalación reducida. También compruebo el Resumen de la instalación antes de hacer nada no sea que se me haya ido la mano.

Un saludo.
Responder Citando
  #10  
Antiguo 31-ene-2013, 03:11
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.220
Agradecimientos: 42
Agradecido 1.263 Veces en 931 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Para eso es bueno plantearse qué instalar, claro que los usuarios de estas distros precisamente es una decisión que tendemos a delegar en la distribución, e incluso solemos acabar por tener muchas más cosas.

Los paquetes libdrm-* ocupan unos KiB: tampoco es por eso xd

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
Respuesta

Marcadores

Etiquetas
zypper


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Actualización zypper y yast2, y ahora zypper no funciona Bauglir Instalación y Actualizaciones 5 10-ene-2012 10:52
pantalla blanca tras actualizar con zypper. spiderman3000p General OpenSUSE 2 26-feb-2011 00:13
Manual zypper para 11.1 (Traducción al español) tranzorx FAQs, Manuales y Tutoriales 11 22-ene-2010 00:21
nuevo zypper sphinx General OpenSUSE 18 14-oct-2008 21:24
¿Update? ¿Upgrade? eltitu General OpenSUSE 5 08-oct-2008 16:25



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 17:35.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba