Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

No funciona correctamente sistema gestión de energía (KDE 4.9.3)
  #1  
Antiguo 10-nov-2012, 16:46
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Exclamation No funciona correctamente sistema gestión de energía (KDE 4.9.3)

Uso OpenSUSE 12.2 64 bits en un HP Pavilion dv5, con gráfica Nvidia GeForce 9200M GS, en el que nunca antes había tenido ningún problema con la gestión de la energía.

Hace unos días se actualizó KDE a su versión 4.9.3, y poco después lo hizo el driver propietario de Nvidia, cuya versión actual en uso es la 304.64.

Antes de que KDE se actualizara a la versión 4.9.3, la gestión de la energía funcionaba bien, se aplicaban bien los perfiles de energía, y podía subir y bajar el brillo de la pantalla con las teclas Fn+F7/F8. Al llegar la versión 4.9.3 extrañamente dejaron de funcionar las teclas Fn+F7/F8, pero al menos podía modificar el brillo moviendo la barra de brillo en Systemsettings > Gestión de energía > Ahorro de energía.
Pero desde que se actualizara el driver de Nvidia, los perfiles de energía no se aplican en ningún momento, por lo que entre otras cosas el brillo de la pantalla no se modifica al llegar a ciertos niveles de energía. Tampoco me permite modificarlo moviendo la barra de brillo en Systemsettings > Gestión de energía > Ahorro de energía, por lo que la única manera de modificar el brillo es cambiando manualmente los valores del fichero /sys/class/backlight/acpi_video0/brightness.

Me gustaría saber si alguien más está padeciendo estos problemas, y si se conoce alguna posible solución.

Gracias de antemano.

Última edición por VaryHeavy; 10-nov-2012 a las 16:53
Responder Citando
  #2  
Antiguo 10-nov-2012, 23:10
Avatar de sieg84
sieg84 sieg84 está desconectado
Miembro Junior
 
Fecha de Ingreso: 18-diciembre-2009
Ubicación: México
Versión: Tumbleweed
Mensajes: 478
Agradecimientos: 38
Agradecido 91 Veces en 80 Mensajes
Poder de Credibilidad: 8
sieg84 está en el buen camino
podria ser algo relacionado con el driver nvidia, actualice la lap de mi hermano a kde4.9.3 y funciona lo del brillo de pantalla (Fn+F5/F6), esa lap tiene video intel y el Kernel 3.6.6
__________________
Responder Citando
  #3  
Antiguo 10-nov-2012, 23:25
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Lo más seguro es que sea cosa del driver de Nvidia. ¿Esa lap con kernel 3.6.6 que citas, no es con OpenSUSE, no?
Responder Citando
  #4  
Antiguo 11-nov-2012, 00:03
Avatar de arag
arag arag está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 08-agosto-2010
Ubicación: Venezuela
Versión: Ultima estable con kde
Mensajes: 2.371
Agradecimientos: 204
Agradecido 380 Veces en 327 Mensajes
Poder de Credibilidad: 10
arag está en el buen camino
Enviar un mensaje por MSN a arag Enviar un mensaje por Skype™ a arag
bueno en este repo esta esa version del kernel para openSUSE http://download.opensuse.org/reposit...standard/i586/
__________________
Mi blog Entre inyecciones y tuxes

La observación es una virtud capital que debemos cultivar por encima de todo pues solo de ella se deriva el éxito en nuestras jugadas.
Responder Citando
  #5  
Antiguo 11-nov-2012, 01:22
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por arag Ver Mensaje
bueno en este repo esta esa version del kernel para openSUSE http://download.opensuse.org/reposit...standard/i586/
He agregado dicho repositorio para probar con la actualización del kernel, pero al intentarlo me da conflictos con los módulos de VirtualBox para el kernel. ¿No existen módulos de VirtualBox compatibles aún con ese kernel?
Responder Citando
  #6  
Antiguo 11-nov-2012, 10:52
Avatar de sieg84
sieg84 sieg84 está desconectado
Miembro Junior
 
Fecha de Ingreso: 18-diciembre-2009
Ubicación: México
Versión: Tumbleweed
Mensajes: 478
Agradecimientos: 38
Agradecido 91 Veces en 80 Mensajes
Poder de Credibilidad: 8
sieg84 está en el buen camino
Cita:
Iniciado por VaryHeavy Ver Mensaje
Lo más seguro es que sea cosa del driver de Nvidia. ¿Esa lap con kernel 3.6.6 que citas, no es con OpenSUSE, no?
así es, openSUSE 12.2, el kernel 3.6.6 del mismo repo que público @arag. para instalar el driver NVIDIA tendrías que hacerlo de la forma "the hard way" como lo dice la wiki de openSUSE, lo de virtualbox instalando desde el rpm de virtualbox.org (en el foro hay guías) y sería cada vez que sé actualice el kernel.
casi como usar tumbleweed.
__________________
Responder Citando
  #7  
Antiguo 11-nov-2012, 16:56
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
También uso una tarjeta inalámbrica Broadcom que usa un módulo para el actual kernel. ¿Quiere decir que si me dispusiera a instalar el kernel 3.6.6 también tendría que instalar dicho módulo por el "hard way"?
Responder Citando
  #8  
Antiguo 11-nov-2012, 17:16
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
He intentado una solución alternativa: usar el driver Nouveau.

He desinstalado el módulo de Nvidia y he activado Nouveau en /etc/X11/xorg.conf.d/50-device.conf.

Resultados: Ahora sí puedo modificar el brillo de la pantalla desde Systemsettings > Gestión de energía, aunque la combinación de teclas Fn+F7/F8 continúa sin funcionar.

Por un momento pensé que podía ser cosa de la distribución del teclado, así que la cambié de la genérica de 101 teclas, primero, a la genérica de 104 teclas, y después a la de 105, para por último dejarla en Hewlett-Packard | Hewlett-Packard Pavilion dv5, sin que ésto haya hecho que la dichosa combinación de teclas funcione.

Por otra parte, el sistema de gestión de energía sigue sin funcionar como debería hacerlo, por ejemplo, al desenchufar el equipo de la corriente eléctrica el monitor de batería me sigue indicando que el equipo está enchufado a la corriente alterna, por lo que no se aplica el perfil adecuado de batería.

EDITO: Según he podido comprobar en el rato de funcionamiento del driver Nouveau, al parecer se consume la batería más rápidamente que cuando se usa el driver propietario.

Conclusiones: Está claro que con el driver propietario de Nvidia pasaba algo para que no me permitiera hacer cambios gráficamente.
Pero respecto al tema de la combinación de teclas y el funcionamiento incorrecto del sistema de gestión de energía, sospecho que tal vez pueda ser cosa de la versión del kernel. ¿Podría ser?

Última edición por VaryHeavy; 11-nov-2012 a las 18:28
Responder Citando
  #9  
Antiguo 11-nov-2012, 20:07
Avatar de sieg84
sieg84 sieg84 está desconectado
Miembro Junior
 
Fecha de Ingreso: 18-diciembre-2009
Ubicación: México
Versión: Tumbleweed
Mensajes: 478
Agradecimientos: 38
Agradecido 91 Veces en 80 Mensajes
Poder de Credibilidad: 8
sieg84 está en el buen camino
podrias intentar con el driver anterior pero instalarlo desde el run de nvidia.com o usar el driver beta 310.XX
puedes actualizar el kernel al 3.4.18 desde http://download.opensuse.org/reposit...12.2/standard/ ese repo lo estoy usando en mi pc, no tendrias problemas con el driver nvidia porque estarias usando la misma version del kernel 3.4.XX que trae opensuse 12.2

te pasa lo mismo si creas otro usuario en opensuse?
__________________
Responder Citando
  #10  
Antiguo 11-nov-2012, 20:15
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por sieg84 Ver Mensaje
podrias intentar con el driver anterior pero instalarlo desde el run de nvidia.com o usar el driver beta 310.XX
puedes actualizar el kernel al 3.4.18 desde http://download.opensuse.org/reposit...12.2/standard/ ese repo lo estoy usando en mi pc, no tendrias problemas con el driver nvidia porque estarias usando la misma version del kernel 3.4.XX que trae opensuse 12.2

te pasa lo mismo si creas otro usuario en opensuse?
¿Tampoco tendría problemas con los módulos de VirtualBox ni de la inalámbrica Broadcom?
Responder Citando
Respuesta

Marcadores

Etiquetas
energia, kde, nvidia


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Software libre y GNU/Linux Jersoncito El Contubernio 1 26-jun-2012 05:06
"Micro-manual" de grub -bueno, ni eso karlggest FAQs, Manuales y Tutoriales 3 28-jul-2007 20:44
suse 10.1 y wmware antaramir Hardware 2 16-nov-2006 00:40
Sistema de actualización openSUSE 10.1 2ª Parte valentinux Instalación y Actualizaciones 0 24-sep-2006 20:41
La Seguridad Social adapta el sistema RED a Linux narkone Noticias 1 02-jun-2006 01:07



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 02:58.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba