Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problemas con Amarok
  #1  
Antiguo 16-may-2012, 13:33
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 8
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Exclamation Problemas con Amarok

Hoy, de buenas a primeras, al abrir Amarok me salta una ventanita con el siguiente mensaje:

La base de datos de amarok notificó los siguientes errores:
GREPME MySQLe query failed! (2000) on init
en la mayor parte de los casos usted necesitará solucionar estos errores antes de que Amarok se ejecute adecuadamente.


El programa se abre, pero no aparece la base de datos de mi colección local de música. Además, después de abrir el programa, parece que algunos procesos se cuelgan, entre ellos KRunner, y el sistema no parece volver a la normalidad hasta que mato el proceso de Amarok, que he de decir que tengo que matarlo a la fuerza porque en el primer intento se queda zombie y no se elimina el proceso.

Es la primera vez que me encuentro con este problema. ¿Alguien sabe qué puede estar pasando?
Responder Citando
  #2  
Antiguo 16-may-2012, 13:39
Avatar de manolobarea
manolobarea manolobarea está desconectado
Habitual
 
Fecha de Ingreso: 13-enero-2012
Ubicación: Jerez
Versión: 12.1
Mensajes: 261
Agradecimientos: 19
Agradecido 61 Veces en 47 Mensajes
Poder de Credibilidad: 7
manolobarea llegará a ser famoso muy pronto
Enviar un mensaje por Skype™ a manolobarea
Has actualizado mysql?
Responder Citando
  #3  
Antiguo 16-may-2012, 13:43
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 8
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
¿Recientemente dices? creo que sí, que hace pocos días llegó una actualización de MySQL, aunque el gestor de bases de datos de MySQL, que lo uso en mis estudios, me funciona correctamente.

Igualmente, he probado a volver a la versión anterior que tenía instalada del servidor MySQL (mysql-community-server) y el problema de Amarok persiste.

Última edición por VaryHeavy; 16-may-2012 a las 13:57
Responder Citando
  #4  
Antiguo 16-may-2012, 14:57
Avatar de victorhck
victorhck victorhck está desconectado
Moderador
 
Fecha de Ingreso: 08-abril-2010
Ubicación: /HOME
Versión: Tumbleweed y Leap + KDE
Mensajes: 3.636
Agradecimientos: 317
Agradecido 1.160 Veces en 754 Mensajes
Poder de Credibilidad: 12
victorhck está en el buen camino
Hola!
Aqui hablan de lo mismo: http://lists.opensuse.org/opensuse-e.../msg00037.html

Esres tu mismo??
Saludos.
__________________


Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
→ Mi blog sobre openSUSE, GNU/Linux, software libre ...y de todo un poco: Victorhck in the free world
→ Me puedes seguir en: Mastodon - diaspora* - GNUsocial
Responder Citando
  #5  
Antiguo 16-may-2012, 15:59
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 8
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por victorhck Ver Mensaje
Hola!
Aqui hablan de lo mismo: http://lists.opensuse.org/opensuse-e.../msg00037.html

Esres tu mismo??
Saludos.
Pues no, no soy yo. Si te fijas en la fecha del bug es de Agosto de 2011, es decir, de incluso antes de ser lanzada OpenSUSE 12.1, y yo he visto este problema hoy por primera vez.

Según dicen los comentarios finales aquí https://bugzilla.novell.com/show_bug.cgi?id=712749, volviendo a la versión 5.5.16 de mysql-community-server se resuelve el problema... y yo antes volví una versión atrás de este paquete, pero no puedo confirmar ahora mismo si se trataba de la 5.5.16. Lo comprobaré más tarde.

EDITADO

Efectivamente al volver a la versión 5.5.16 ya no aparece ese mensaje al abrir Amarok y puede ejecutarse correctamente, no obstante, además de volver a dicha versión en el paquete mysql-community-server, he tenido que hacerlo también con libmysqlclient18, libmysqlclient18-32bit, libmysqld18 y mysql-community-server-client.

Eso sí, no deja de parecerme extraño, porque ya llevaba varios días sin recibir actualizaciones (lo que indica que esos paquetes ya tendrían que estar en la última versión, que al parecer es la que provoca el conflicto) y hace escasos 4 días, incluso ayer mismo, estuve usando Amarok sin problemas... por lo que sospecho que la raíz del problema es otra.

Última edición por VaryHeavy; 16-may-2012 a las 16:44
Responder Citando
  #6  
Antiguo 16-may-2012, 17:44
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Y no te vale esto. Porque si sirve te mereces una colleja digital al ser el primer resultado en una búsqueda (y si no sirve me la doy yo por listo, XD).

Un saludo.
Responder Citando
  #7  
Antiguo 16-may-2012, 18:26
Avatar de manolobarea
manolobarea manolobarea está desconectado
Habitual
 
Fecha de Ingreso: 13-enero-2012
Ubicación: Jerez
Versión: 12.1
Mensajes: 261
Agradecimientos: 19
Agradecido 61 Veces en 47 Mensajes
Poder de Credibilidad: 7
manolobarea llegará a ser famoso muy pronto
Enviar un mensaje por Skype™ a manolobarea
El paquete mysql-community-server-client es el que da el problemas al actualizar. Deberás estar atento por si sale un patch. Es decir un archivo diff. De momento no hay otra solución.
Responder Citando
  #8  
Antiguo 16-may-2012, 19:23
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 8
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por jcsl Ver Mensaje
Hola.

Y no te vale esto. Porque si sirve te mereces una colleja digital al ser el primer resultado en una búsqueda (y si no sirve me la doy yo por listo, XD).

Un saludo.
El que comenta abajo casualmente es un usuario de OpenSUSE, y dice que a él no le funcionó.
A mí tampoco me ha funcionado, así que tiene usted mi permiso para darse su correspondiente colleja xD

Última edición por VaryHeavy; 16-may-2012 a las 19:30
Responder Citando
  #9  
Antiguo 16-may-2012, 19:38
Avatar de victorhck
victorhck victorhck está desconectado
Moderador
 
Fecha de Ingreso: 08-abril-2010
Ubicación: /HOME
Versión: Tumbleweed y Leap + KDE
Mensajes: 3.636
Agradecimientos: 317
Agradecido 1.160 Veces en 754 Mensajes
Poder de Credibilidad: 12
victorhck está en el buen camino
Cita:
Iniciado por VaryHeavy Ver Mensaje
A mí tampoco me ha funcionado, así que tiene usted mi permiso para darse su correspondiente colleja xD
Yo,yo,yo,yo,yo,yo me lo pido yo!!!!! XD

(perdón por el offtopic tonto!!)
__________________


Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
→ Mi blog sobre openSUSE, GNU/Linux, software libre ...y de todo un poco: Victorhck in the free world
→ Me puedes seguir en: Mastodon - diaspora* - GNUsocial
Responder Citando
  #10  
Antiguo 16-may-2012, 19:45
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 8
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Cita:
Iniciado por manolobarea Ver Mensaje
El paquete mysql-community-server-client es el que da el problemas al actualizar. Deberás estar atento por si sale un patch. Es decir un archivo diff. De momento no hay otra solución.
No es sólo el mysql-community-server-client, ya que desactualizando únicamente éste y dejando los demás en la última versión persiste el problema.
He hecho las pruebas en mi sobremesa, actualizando los mismos paquetes uno por uno, y en el momento en que Amarok falla es al actualizar el libmysqld18 a la versión 5.5.23. Amarok abre correctamente con todos los demás en la versión 5.5.23 si libmysqld18 está en la versión 5.5.16, apareciendo el fallo si éste se actualiza a la versión 5.5.23.
Pero insisto en la rareza del asunto, porque hasta ayer pude abrir Amarok sin problemas (en mi portátil, donde me he dado cuenta hoy) y esos paquetes estaban en la versión 5.5.23 que hoy dan tantos problemas, o debían estarlo, porque de ayer para hoy yo no he hecho actualizaciones.
Responder Citando
Respuesta

Marcadores

Etiquetas
amarok, errores, mysql


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
amarok no reproduce mp3 decks Software 8 01-dic-2009 00:42
Problemas con el Amarok en openSUSE 10.3 mythril General OpenSUSE 10 29-nov-2007 23:10
problemas de instalacion en Amarok en KDE Suse 10.2 joallego Software 1 28-may-2007 23:13
problemas con amarok atami Software 0 28-feb-2007 11:47
problemas con amarok rubfogcor Multimedia 17 17-ene-2007 20:48



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 01:31.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba