Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Ver Resultados de Encuesta: ¿Saben cuál es la compatibilidad de la ati HD 5670 con SUSE 11.4?
No hay problema, funciona muy bien el driver 0 0%
Tuve problemas al instalar el driver pero los he solucionado 0 0%
Aún no salgo del problema, no la he podido hace funcionarl al 100% 0 0%
Prefiero las Nvidia 0 0%
Encuesta de Elección Múltiple. Votantes: 0. No puedes votar en esta encuesta

Respuesta
 
Herramientas Desplegado

Problema con resolución de pantalla: driver Nvidia, SuSE 11.4 [Solucionado]
  #1  
Antiguo 01-jul-2011, 23:36
leontro leontro está desconectado
Aforado
 
Fecha de Ingreso: 01-julio-2011
Versión: 11.4
Mensajes: 39
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
leontro está en el buen camino
Problema con resolución de pantalla: driver Nvidia, SuSE 11.4 [Solucionado]

Soy nuevo en el foro, así que si cometo alguno en mi exposición espero una no tan mala respuesta por parte de la comunidad
Tengo instalado SuSE 11.4 de 64 bits con el kernel 2.6.37.1-1.2. Tengo instalada una tarjeta gráfica ASUS silent con el Chipset Nvidia Geforce 210 y finalmente una TV/monitor VIZIO con resolución de 1360x768.
Tengo los siguientes problemas:
1.-Con el driver Click Install NVIDIA 270.41.06 (http://es.opensuse.org/NVIDIA#Para_o...C_11.3.2C_11.2) no he podido ajustar la resolución correcta de mi monitor que automáticamente se ajusta a 1024x768 y ni en las Preferencias del Sistema ni en Nvidia X Server Settings se puede modificar
2.- No he podido instalar el driver propietario de NVidia correspondiente a mi chipset porque el kernel del driver no se puede compilar. El driver es el siguiente http://la.nvidia.com/object/linux-di...driver-la.html

Bien, desarrollaré el primer problema.
Para solucionarlo he hecho lo siguiente:
a) He generado el xorg.conf con el comando nvidia-xconfig pero lo único que hace es bajar aún más la resolución, en el caso de la primera propuesta y dejar la pantalla en azul en la segunda propuesta. Por esta razón lo que lo he renombrado para evitar que opere.
Les dejo mi archivo xorg.conf tal como lo he modificado:
Primera propuesta
----------------------------
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.06 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Mon Apr 18 15:14:00 PDT 2011


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "UseEdid" "False"
Option "MetaModes" "1360x768 +0+0"
SubSection "Display"
Depth 24
Modes "1360x768" "1024x768" "800x600"
EndSubSection
EndSection
------------------
Segunda propuesta de xorg.conf


# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 270.41.06 (buildmeister@swio-display-x86-rhel47-08.nvidia.com) Mon Apr 18 15:14:00 PDT 2011


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Unknown"
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 160.0
# 1360x768 @ 60.00 Hz (GTF) hsync: 47.70 kHz; pclk: 84.72 MHz
Modeline "1360x768_60.00" 84.72 1360 1424 1568 1776 768 769 772 795 -HSync +Vsync
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Option "metamodes" "1360x768 +0+0"
EndSubSection

EndSection
-------------------------

b) También he modificado los archivos que están dentro de la carpeta xorg.conf.d. De ellos el resultado es el siguiente. Si modifico 50-device.conf y 50-monitor no pasa nada, pero si modifico 50-screen no me inicia en modo gráfico sino en modo texto.

Los muestro

------------------
50-device.conf

Section "Device"
Identifier "Device0"
VendorName "NVIDIA Corporation"
BoardName "GeForce 210"
Driver "nvidia"
Option "UseEdidFreqs" "false"
#Driver "radeon"

## Required magic for radeon/radeonhd drivers; output name
## (here: "DVI-0") can be figured out via 'xrandr -q'
#Option "monitor-DVI-0" "Default Monitor"

EndSection

50-monitor

Section "Monitor"
Identifier "Monitor0"
VendorName "VIZIO"
ModelName "M260VA-mx"
HorizSync 28-85
VertRefresh 50-100

## If your monitor doesn't support DDC you may override the
## defaults here
#HorizSync 28-85
#VertRefresh 50-100

## Add your mode lines here, use e.g the cvt tool

EndSection

El archivo 50-screen

Section "Screen"
Identifier "Screen0"
Device "Device0"
## Doesn't help for radeon/radeonhd drivers; use magic in
## 50-device.conf instead
Monitor "Monitor0"
SubSection "Display"
modes "1360x768" "1024x768" "800x600" "720x400" "640x480"
EndSubSection

EndSection

c) también he intentado crear modelines de la siguiente manera:

# xrandr --output default --mode "1360x768_60"
xrandr: cannot find mode 1360x768_60

Pero no encuentra el mode
---------------------------------------------------------

2.- Con respecto al segundo problema esto es lo que me sale en el archivo de error al pasar al modo texto y teclear # sh ./NVIDIA-Linux-x86_64-256.53.run

nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Jun 30 20:47:18 2011
installer version: 256.53

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 256.53.
-> Running distribution scripts
executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.37.1-1.2-desktop/source'
-> Kernel output path: '/lib/modules/2.6.37.1-1.2-desktop/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Performing Xen check.
-> Cleaning kernel module build directory.
executing: 'cd ./kernel; make clean'...
-> Building kernel module:
executing: 'cd ./kernel; make module SYSSRC=/lib/modules/2.6.37.1-1.2-deskto
p/source SYSOUT=/lib/modules/2.6.37.1-1.2-desktop/build'...
NVIDIA: calling KBUILD...
make -C /lib/modules/2.6.37.1-1.2-desktop/build \
KBUILD_SRC=/usr/src/linux-2.6.37.1-1.2 \
KBUILD_EXTMOD="/tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel" -f /usr/sr
c/linux-2.6.37.1-1.2/Makefile \
modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/generated/autoconf.h or include/config/auto.conf are
missing.";\
echo " Run 'make oldconfig && make prepare' on kernel src to fix it.
"; \
echo; \
/bin/false)
mkdir -p /tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/.tmp_versions ; r
m -f /tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/.tmp_versions/*
make -f /usr/src/linux-2.6.37.1-1.2/scripts/Makefile.build obj=/tmp/selfgz61
66/NVIDIA-Linux-x86_64-256.53/kernel
cc -Wp,-MD,/tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/.nv.o.d -nos
tdinc -isystem /usr/lib64/gcc/x86_64-suse-linux/4.5/include -I/usr/src/linux
-2.6.37.1-1.2/arch/x86/include -Iinclude -I/usr/src/linux-2.6.37.1-1.2/incl
ude -include include/generated/autoconf.h -I/tmp/selfgz6166/NVIDIA-Linux-x
86_64-256.53/kernel -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trig
raphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration
-Wno-format-security -fno-delete-null-pointer-checks -O2 -m64 -mtune=generic
-mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -D
CONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -D
CONFIG_AS_FXSAVEQ=1 -pipe -Wno-sign-compare -mno-sse -mno-mmx -mno-sse2 -mno
-3dnow -Wframe-larger-than=2048 -fno-stack-protector -fomit-frame-pointer -f
asynchronous-unwind-tables -g -Wdeclaration-after-statement -Wno-pointer-sig
n -fno-strict-overflow -fconserve-stack -DCC_HAVE_ASM_GOTO -I/tmp/selfgz61
66/NVIDIA-Linux-x86_64-256.53/kernel -Wall -MD -Wsign-compare -Wno-cast-qual
-Wno-error -D__KERNEL__ -DMODULE -DNVRM -DNV_VERSION_STRING=\"256.53\" -mcmo
del=kernel -mno-red-zone -UDEBUG -U_DEBUG -DNDEBUG -DMODULE -D"KBUILD
_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(nv)" -D"KBUILD_MODNAME=KBUILD_STR
(nvidia)" -c -o /tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/.tmp_nv.o
/tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv.c
In file included from /usr/src/linux-2.6.37.1-1.2/include/linux/kernel.h:17:
0,
from /usr/src/linux-2.6.37.1-1.2/include/linux/sched.h:54,
from /usr/src/linux-2.6.37.1-1.2/include/linux/utsname.h:35
,
from /tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv-l
inux.h:27,
from /tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv.c
:13:
/usr/src/linux-2.6.37.1-1.2/include/linux/bitops.h: In function ‘hweight_l
ong’:
/usr/src/linux-2.6.37.1-1.2/include/linux/bitops.h:49:41: warning: signed an
d unsigned type in conditional expression
In file included from /usr/src/linux-2.6.37.1-1.2/arch/x86/include/asm/uacce
ss.h:573:0,
from /usr/src/linux-2.6.37.1-1.2/include/linux/poll.h:14,
from /tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv-l
inux.h:84,
from /tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv.c
:13:
/usr/src/linux-2.6.37.1-1.2/arch/x86/include/asm/uaccess_64.h: In function â
€˜copy_from_user’:
/usr/src/linux-2.6.37.1-1.2/arch/x86/include/asm/uaccess_64.h:54:6: warning:
comparison between signed and unsigned integer expressions
/tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv.c: At top level:
/tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv.c:426:5: error: unknown
field ‘ioctl’ specified in initializer
/tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv.c:426:5: warning: initi
alization from incompatible pointer type
make[4]: *** [/tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel/nv.o] Error
1
make[3]: *** [_module_/tmp/selfgz6166/NVIDIA-Linux-x86_64-256.53/kernel] Err
or 2
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
-------------------------------

De manera que ni puedo instalar el driver propietario para probar si funciona mejor, ni puedo tener la resolución correcta.

Última edición por leontro; 19-jul-2011 a las 23:18 Razón: Solucionado
Responder Citando
  #2  
Antiguo 02-jul-2011, 14:20
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.591
Agradecimientos: 570
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Bienvenido al foro, por favor, lee las normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar.... es como una guía para los novatos. Fíjate lo que dice resaltado la norma 5.

Cierro la encuesta porque es un problema que tienes.

Sobre tu problema:
1.- En la sección FAQs hay dos manuales de como configurar la resolución del monitor.
2.- Tienes que instalar el patrón Desarrollo base mas el kernel-source y el kernel devel de tu kernel instalado.

Como eres nuevo, preséntate en la sección de Presentaciones y, por favor, lee las normas.

__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Dusculpas
  #3  
Antiguo 02-jul-2011, 20:37
leontro leontro está desconectado
Aforado
 
Fecha de Ingreso: 01-julio-2011
Versión: 11.4
Mensajes: 39
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
leontro está en el buen camino
Dusculpas

Espero no causarle en el futuro más problemas; de los relacionados con las normas ¡por supuesto!
Con respecto a la norma 5 me disculpo si acaso la forma en que escribí pudo interpretarse de manera presionarte o exigente. Esa no fue mi intención; quise ser lo más neutral posible.
Por otra parte la próxima vez, según la norma 16, comprimiré los archivos que presente.
Finalmente, sólo quisiera saber cuál norma fue la que rompí al hacer la encuesta. Me gustaría saberlo para interpretar correctamente la norma.
¡Gracias por su ayuda! Haré lo que me ha recomendado.

Última edición por leontro; 02-jul-2011 a las 20:41
Responder Citando
  #4  
Antiguo 02-jul-2011, 20:50
Avatar de arag
arag arag está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 08-agosto-2010
Ubicación: Venezuela
Versión: Ultima estable con kde
Mensajes: 2.371
Agradecimientos: 204
Agradecido 380 Veces en 327 Mensajes
Poder de Credibilidad: 10
arag está en el buen camino
Enviar un mensaje por MSN a arag Enviar un mensaje por Skype™ a arag
no te regañando por infringir una norma solo que por ser nuevo te recomienda que leas las normas y te señala los errores mas comunes para que no los cometas, es su mensaje de bienvenida

En cuanto a la encuesta es por que no esta relacionada con tu problema si quieres hacerla mejor que sea en un tema aparte
Responder Citando
  #5  
Antiguo 05-jul-2011, 10:34
leontro leontro está desconectado
Aforado
 
Fecha de Ingreso: 01-julio-2011
Versión: 11.4
Mensajes: 39
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
leontro está en el buen camino
He dejado de modificar los archivos de la carpeta /etc/X11/xorg.conf.d/.
En su lugar he creado el archivo xorg.conf con nvidia-xconfig.
Noté que otro problema que tenía se solucionó. ¡Ya tengo sonido!
En Nvidia-settings ya me han salido varias resoluciones más además de la 1024x768. Por ejemplo: 1152x864, 1280x290, 1280x1024, etc...
Además de que en las nuevas varias resoluciones no aparece la que soporta mi tv/monitor, que es 1360x768, cuando quiero aplicar a través de Nvidia-settings una resolución mayor a 1024x768 la pantalla se vuelve azul y tengo que entrar al modo gráfico he indicar init 3. Luego borrar el archivo nvidia-xconfig.install que se genera y reiniciar el modo gráfico con init 5.
He querido editar el archivo xorg.conf para indicarle la resolución que quiero pero también la pantalla se pone azul.
Aquí el archivo conflictivo editado por mí para la resolución de mi preferencia y que deja la pantalla en azul.
Cita:
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.41.06 (abuild@nott) Tue Jun 14 17:31:11 UTC 2011

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: builtin, VertRefresh source: builtin
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-1"
HorizSync 30-61
VertRefresh 56-75
Option "DPMS"
EndSectionnvidia-xconfig

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 210"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1360x768_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection]
Cuando funciona el xorg.conf contiene lo siguiente en la parte conflictiva remarcada arriba:
Cita:
Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1024x768_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection
Con respecto a la instalaciòn del driver propietario me di cuenta de que sí tenía instalado lo que DiabloRojo me señaló. Se me ocurrió actualizar el kernel-source y todo lo que ello implicaba y el problema cambió. Ahora no es que no se pueda compilar el kernel del driver sino que no encuentra el kernel porque no esta configurado. Aquí el nuevo archivo:
Cita:
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Mon Jul 4 23:52:19 2011
installer version: 256.53

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : false
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
no cc version check : false
force tls : (not specified)
force compat32 tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
compat32 install chroot : (not specified)
compat32 install prefix : (not specified)
compat32 install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> Installing NVIDIA driver version 256.53.
-> Running distribution scripts
executing: '/usr/lib/nvidia/pre-install'...
-> done.
-> Performing CC sanity check with CC="/usr/bin/gcc-4.5".
-> Performing CC version check with CC="/usr/bin/gcc-4.5".
ERROR: The kernel header file '/usr/src/linux/include/linux/version.h' does not
exist. The most likely reason for this is that the kernel source files
in '/usr/src/linux' have not been configured.

ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
Creo que estoy mejor que antes porque al menos ya tengo sonido y me aparecen al menos como opciones más resoluciones, aunque no está la que quiero
y cualquiera sauperior a 1024x768 vuelve la pantalla azul. Espero que esta "nueva" información ayude a la exposiciòn de mi problema y ayude a que encuentre solución.

Última edición por leontro; 05-jul-2011 a las 10:38 Razón: Apliar información y corrección de erratas
Responder Citando
  #6  
Antiguo 05-jul-2011, 15:09
Avatar de arag
arag arag está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 08-agosto-2010
Ubicación: Venezuela
Versión: Ultima estable con kde
Mensajes: 2.371
Agradecimientos: 204
Agradecido 380 Veces en 327 Mensajes
Poder de Credibilidad: 10
arag está en el buen camino
Enviar un mensaje por MSN a arag Enviar un mensaje por Skype™ a arag
revisa estos link
http://www.forosuse.org/forosuse/arc...p/t-23743.html
http://en.opensuse.org/SDB:NVIDIA_the_hard_way
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a arag Por Este Mensaje:
leontro (05-jul-2011)
En busca de edid.bin
  #7  
Antiguo 05-jul-2011, 21:48
leontro leontro está desconectado
Aforado
 
Fecha de Ingreso: 01-julio-2011
Versión: 11.4
Mensajes: 39
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
leontro está en el buen camino
En busca de edid.bin

Gracias por responder arag.
Me has abierto nuevas perspectivas.
Ahora sé que necesito un archivo llamado edid.bin que pondré en xorg.conf.
Los programas que he visto que crean ese archivo se hacen en Windows con un programa llamado SoftMCCS así que por ahora creo que no lo podré hacer.
En linux hay un programa llamado read edid pero no lo he podido instalar porque dice que me falta libx86.h y aunque he buscado de dónde sale no lo he encontrado. Yo tengo instalado el libx86 pero dentro de sus archivos no hay alguno con el nombre que el programa necesita.
He visto que hay quienes han usado los edid.bin de monitores que no son los suyos y les ha funcionado. Así que creo que o buscaré uno de esos o instalaré Windows ( lo que realmente no quiero) o haré funcionar el read edid encontrando el libx86.h.
Muchas gracias. Ahora al menos sé qué hacer.
Responder Citando
  #8  
Antiguo 05-jul-2011, 22:59
Avatar de arag
arag arag está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 08-agosto-2010
Ubicación: Venezuela
Versión: Ultima estable con kde
Mensajes: 2.371
Agradecimientos: 204
Agradecido 380 Veces en 327 Mensajes
Poder de Credibilidad: 10
arag está en el buen camino
Enviar un mensaje por MSN a arag Enviar un mensaje por Skype™ a arag
la libreria libx86 esta en el repo standard http://software.opensuse.org/search?...3A11.4&lang=es seguro necesita la version devel de ese paquete
Responder Citando
  #9  
Antiguo 06-jul-2011, 02:38
leontro leontro está desconectado
Aforado
 
Fecha de Ingreso: 01-julio-2011
Versión: 11.4
Mensajes: 39
Agradecimientos: 1
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
leontro está en el buen camino
Ya casi, casi está listo.
Acabo de hacer lo que indica la siguiente página
Con un archivo edid.bin que descargué de esta otra
Por fin una resolución mayor a 1024x768 ¡funciona!
Ahora el problema es que tengo que editar el binario pero no sé nada de eso.
Tengo que poner la resolución a 1360x768 con Frecuencia horizontal 47.72 y Frecuencia Vertical 59.799
El edid.bin que tengo tiene contiene lo siguiente:
Cita:
#./parse-edid /home/yo/Descargas/edid.bin | grep 'Mode'
./parse-edid: parse-edid version 2.0.0
./parse-edid: EDID checksum passed.
ModelName "Nvidia Defaul"
Mode "1366x768" # vfreq 59.940Hz, hfreq 46.753kHz
EndMode
#/Descargas/read-edid-2.0.0>
¿Cómo podría editarlo? Las instrucciones de la página ya mencionada no me parecen inteligibles a mí, un amateur.
Responder Citando
  #10  
Antiguo 06-jul-2011, 02:43
Avatar de arag
arag arag está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 08-agosto-2010
Ubicación: Venezuela
Versión: Ultima estable con kde
Mensajes: 2.371
Agradecimientos: 204
Agradecido 380 Veces en 327 Mensajes
Poder de Credibilidad: 10
arag está en el buen camino
Enviar un mensaje por MSN a arag Enviar un mensaje por Skype™ a arag
que parte no entiendes exactamente? para editarlo dice que instales ghex

Última edición por arag; 06-jul-2011 a las 02:45
Responder Citando
Respuesta

Marcadores

Etiquetas
drivers, nvidia, resolucion de pantalla, suse 11.4


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Problema con driver nvidia 260.19.36 en la 11.4 nopersona Software 8 28-abr-2011 04:22
Problema con graficos Nvidia al instalar Suse 11.4 Gurka Instalación y Actualizaciones 8 16-abr-2011 03:47
wireless en opensuse 10.2 rub Hardware 5 27-abr-2009 06:08
problema para instalar un nuevo driver en Suse 10.0 fjacosta Instalación y Actualizaciones 0 05-nov-2007 20:01
driver de nvidia en Suse 10.1 turke Hardware 3 11-may-2006 03:37



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 03:20.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba