Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

No puedo montar dispositivos USB salvo si es como root
  #1  
Antiguo 17-jun-2011, 02:17
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Exclamation No puedo montar dispositivos USB salvo si es como root

Le había echado una ojeada a este tema, pero mi problema, al menos por ahora, no es con un dispositivo externo NTFS, sino con dispositivos de almacenamiento USB en FAT32.
Me he dado cuenta hace 3 días, y me ha pasado ya con dos pendrives USB distintos, y en ambos casos al intentar montarlos, en Dolphin me tira el siguiente mensaje:
Cita:
Se produjo un error mientras se accedía a <<VARYHEAVY>>, el sistema respondió:
org.freedesktop.UDisks.Error.Failed: Error mounting: mount exited with exit code 1: helper failed with:
mount: only root can mount /dev/sdb1 on /media/IOMEGA_HDD
Donde "VARYHEAVY" es el pendrive USB que intento montar, y que el sistema reconoce como sdb1. Lo que no entiendo es por qué intenta montarlo en el directorio /media/IOMEGA_HDD, que es el directorio en el que el sistema monta mi disco externo (IOMEGA_HDD es mi disco duro externo).

La única manera que tengo de montar los dispositivos USB es como root, y además en modo de solo lectura (para el resto de usuarios que no son root).
¿Es un bug del kernel al igual que en el caso de los dispositivos NTFS? ¿alguna idea de cómo podría arreglarlo?

Última edición por VaryHeavy; 17-jun-2011 a las 08:17
Responder Citando
  #2  
Antiguo 17-jun-2011, 10:34
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.585
Agradecimientos: 568
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Instala ntfs-config y ejecútalo activado todas las opciones.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #3  
Antiguo 17-jun-2011, 18:33
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Ya lo tenía instalado, y activada la escritura para todos los dispositivos internos y externos. Pero repito, mi problema no es con un dispositivo NTFS... ¿o es que ntfs-config también afecta a los sistemas de ficheros FAT?
Responder Citando
  #4  
Antiguo 17-jun-2011, 21:16
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.585
Agradecimientos: 568
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
No debería afectar. Has actualizado el repositorio Update porque hay una actualización o parche del paquete hal.

Danos la salida de los ficheros /etc/fstab , /etc/mtab y del comando dmesg | tail una vez insertado el dispositivo USB como usuario.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #5  
Antiguo 23-jun-2011, 19:18
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
/etc/fstab
varyheavy@linux-kxql:~> cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>

proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
usbfs /proc/bus/usb usbfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
/dev/disk/by-id/ata-WDC_WD3200BEVT-60ZCT0_WD-WXE608C54136-part6 / ext4 acl,user_xattr 1 1
/dev/sda3 /media/HP_RECOVERY ntfs-3g defaults,locale=POSIX 0 0
/dev/sdb1 /media/IOMEGA_HDD ntfs-3g defaults,locale=es_ES.UTF-8 0 0
/dev/sda1 /media/windows ntfs-3g defaults,locale=POSIX 0 0
/dev/disk/by-id/ata-WDC_WD3200BEVT-60ZCT0_WD-WXE608C54136-part5 swap swap defaults 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0

/etc/mtab
varyheavy@linux-kxql:~> cat /etc/mtab
rootfs / rootfs rw 0 0
devtmpfs /dev devtmpfs rw,relatime,size=1537208k,nr_inodes=384302,mode=75 5 0 0
tmpfs /dev/shm tmpfs rw,relatime 0 0
devpts /dev/pts devpts rw,relatime,gid=5,mode=620,ptmxmode=000 0 0
/dev/sda6 / ext4 rw,relatime,user_xattr,acl,barrier=1,data=ordered 0 0
proc /proc proc rw,relatime 0 0
sysfs /sys sysfs rw,relatime 0 0
debugfs /sys/kernel/debug debugfs rw,relatime 0 0
fusectl /sys/fs/fuse/connections fusectl rw,relatime 0 0
/dev/sda3 /media/HP_RECOVERY fuseblk rw,relatime,user_id=0,group_id=0,allow_other,blksi ze=4096 0 0
/dev/sda1 /media/windows fuseblk rw,relatime,user_id=0,group_id=0,allow_other,blksi ze=4096 0 0
securityfs /sys/kernel/security securityfs rw,relatime 0 0

dmesg | tail
varyheavy@linux-kxql:~> dmesg | tail
[ 484.384976] scsi 6:0:0:0: Direct-Access silicon-power 1100 PQ: 0 ANSI: 0 CCS
[ 484.385478] sd 6:0:0:0: Attached scsi generic sg2 type 0
[ 484.386599] sd 6:0:0:0: [sdb] 15851520 512-byte logical blocks: (8.11 GB/7.55 GiB)
[ 484.392195] sd 6:0:0:0: [sdb] Write Protect is off
[ 484.392205] sd 6:0:0:0: [sdb] Mode Sense: 43 00 00 00
[ 484.392212] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 484.395264] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 484.396271] sdb: sdb1
[ 484.398254] sd 6:0:0:0: [sdb] Assuming drive cache: write through
[ 484.398258] sd 6:0:0:0: [sdb] Attached SCSI removable disk

¿Podría ser el problema la presencia de IOMEGA_HDD en /etc/fstab como /dev/sdb1? porque cuando introduzco el USB lo reconoce también como /dev/sdb1...
Responder Citando
  #6  
Antiguo 24-jun-2011, 11:09
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.585
Agradecimientos: 568
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Normal lo que te ocurre, compara ambas lineas, la 1ª de /etc/fstab y la 2ª de dmesg | tail una vez insertado el pendrive

Cita:
/dev/sdb1 /media/IOMEGA_HDD ntfs-3g defaults,locale=es_ES.UTF-8 0 0
[ 484.396271] sdb: sdb1
Cada vez que insertes un pendrive FAT32 sin tener puesto el disco duro externo IOMEGA toma como dispositivo sdb1 el que esta definido en /etc/ftab como ntfs-3g

Para solucionar esto, tienes dos opciones dejar siempre puesto el disco duro externo IOMEGA o usar la asignación con uuid o identificador (id) del disco duro externo en /etc/fstab
ls -l /dev/disk/by-id

Mas información; http://crashbit.homelinux.com/node/1749
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Última edición por DiabloRojo; 24-jun-2011 a las 11:11
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Después de actualizar el KERNEL, no puedo montar los discos duros externos manelleon Hardware 13 10-may-2011 15:54
problema con root [SOLUCIONADO] ncw2233 General OpenSUSE 14 15-dic-2010 04:05
Desaparición de todos los repositorios: "[|] Repository has no alias defined." Prideone Software 4 23-jul-2010 17:17
No puedo abrir ningun archivo como root Lord_Scarl Software 4 11-feb-2010 22:43
Ayuda!!! Amule no se abren los puertos como Root. zsamer Software 8 15-sep-2005 20:48



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 01:02.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba