Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

opensuse no me deja instalar macchanger
  #1  
Antiguo 30-may-2011, 11:01
Avatar de lealesdibua
lealesdibua lealesdibua está desconectado
Aforado
 
Fecha de Ingreso: 17-noviembre-2010
Versión: 11.3 64bit amg
Mensajes: 64
Agradecimientos: 16
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 8
lealesdibua está en el buen camino
opensuse no me deja instalar macchanger

por rpm no medeja instalar lo ice manual pero da un error
que no se que hacer ¡¡se sale del directorio y por rpm no medeja instalar nada

Cita:
dvd@linux-aiyk:/tmp> ls
flashgot.w6a27t0a.default netx-native-33116 pulse-YpdjdVgydENO
hsperfdata_dvd netx-native-52516 suggestedName.tmp
hsperfdata_root netx-native-5687 tracker-dvd
icedteaplugin-dvd netx-native-63157 unique
keyring-V5m40S orbit-dvd virtual-dvd.7ZObxG
macchanger_1.5.0.orig.tar.gz orbit-gdm virtual-dvd.9eIzbt
netx-native-26166 pulse-QzUPUF4ekTvK virtual-dvd.g349YL
dvd@linux-aiyk:/tmp> su
Contraseña:
linux-aiyk:/tmp # ls
.esd-1000 netx-native-26166 suggestedName.tmp
.esd-107 netx-native-33116 tracker-dvd
flashgot.w6a27t0a.default netx-native-52516 unique
hsperfdata_dvd netx-native-5687 virtual-dvd.7ZObxG
hsperfdata_root netx-native-63157 virtual-dvd.9eIzbt
icedteaplugin-dvd orbit-dvd virtual-dvd.g349YL
.ICE-unix orbit-gdm .X0-lock
keyring-V5m40S pulse-QzUPUF4ekTvK .X11-unix
macchanger_1.5.0.orig.tar.gz pulse-YpdjdVgydENO
linux-aiyk:/tmp # tar xzvf macchanger_1.5.0.orig.tar.gz
macchanger-1.5.0/
macchanger-1.5.0/tools/
macchanger-1.5.0/tools/IEEE_OUI.py
macchanger-1.5.0/README
macchanger-1.5.0/configure.in
macchanger-1.5.0/aclocal.m4
macchanger-1.5.0/Makefile.am
macchanger-1.5.0/Makefile.in
macchanger-1.5.0/config.h.in
macchanger-1.5.0/configure
macchanger-1.5.0/AUTHORS
macchanger-1.5.0/COPYING
macchanger-1.5.0/ChangeLog
macchanger-1.5.0/INSTALL
macchanger-1.5.0/NEWS
macchanger-1.5.0/depcomp
macchanger-1.5.0/install-sh
macchanger-1.5.0/missing
macchanger-1.5.0/macchanger.1
macchanger-1.5.0/src/
macchanger-1.5.0/src/Makefile.am
macchanger-1.5.0/src/Makefile.in
macchanger-1.5.0/src/mac.h
macchanger-1.5.0/src/mac.c
macchanger-1.5.0/src/maclist.h
macchanger-1.5.0/src/maclist.c
macchanger-1.5.0/src/netinfo.h
macchanger-1.5.0/src/netinfo.c
macchanger-1.5.0/src/main.c
macchanger-1.5.0/data/
macchanger-1.5.0/data/Makefile.am
macchanger-1.5.0/data/Makefile.in
macchanger-1.5.0/data/OUI.list
macchanger-1.5.0/data/wireless.list
macchanger-1.5.0/doc/
macchanger-1.5.0/doc/Makefile.am
macchanger-1.5.0/doc/Makefile.in
macchanger-1.5.0/doc/stamp-vti
macchanger-1.5.0/doc/version.texi
macchanger-1.5.0/doc/mdate-sh
macchanger-1.5.0/doc/texinfo.tex
macchanger-1.5.0/doc/macchanger.texi
macchanger-1.5.0/doc/macchanger.info
linux-aiyk:/tmp # cd macchanger-1.5.0
linux-aiyk:/tmp/macchanger-1.5.0 # ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for a BSD-compatible install... /usr/bin/install -c
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking for style of include used by make... GNU
checking dependency style of gcc... gcc3
configure: creating ./config.status
config.status: creating Makefile
config.status: creating src/Makefile
config.status: creating data/Makefile
config.status: creating doc/Makefile
config.status: creating config.h
config.status: executing depfiles commands
linux-aiyk:/tmp/macchanger-1.5.0 # make install
Making install in src
make[1]: se ingresa al directorio `/tmp/macchanger-1.5.0/src'
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -DLISTDIR="\"/usr/local/share/macchanger\"" -g -O2 -MT mac.o -MD -MP -MF ".deps/mac.Tpo" -c -o mac.o mac.c; \
then mv -f ".deps/mac.Tpo" ".deps/mac.Po"; else rm -f ".deps/mac.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -DLISTDIR="\"/usr/local/share/macchanger\"" -g -O2 -MT maclist.o -MD -MP -MF ".deps/maclist.Tpo" -c -o maclist.o maclist.c; \
then mv -f ".deps/maclist.Tpo" ".deps/maclist.Po"; else rm -f ".deps/maclist.Tpo"; exit 1; fi
maclist.c: In function ‘mc_maclist_set_random_vendor’:
maclist.c:101:6: warning: overflow in implicit constant conversion
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -DLISTDIR="\"/usr/local/share/macchanger\"" -g -O2 -MT netinfo.o -MD -MP -MF ".deps/netinfo.Tpo" -c -o netinfo.o netinfo.c; \
then mv -f ".deps/netinfo.Tpo" ".deps/netinfo.Po"; else rm -f ".deps/netinfo.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -DLISTDIR="\"/usr/local/share/macchanger\"" -g -O2 -MT main.o -MD -MP -MF ".deps/main.Tpo" -c -o main.o main.c; \
then mv -f ".deps/main.Tpo" ".deps/main.Po"; else rm -f ".deps/main.Tpo"; exit 1; fi
gcc -g -O2 -o macchanger mac.o maclist.o netinfo.o main.o
make[2]: se ingresa al directorio `/tmp/macchanger-1.5.0/src'
test -z "/usr/local/bin" || mkdir -p -- . "/usr/local/bin"
/usr/bin/install -c 'macchanger' '/usr/local/bin/macchanger'
make[2]: No se hace nada para `install-data-am'.
make[2]: se sale del directorio `/tmp/macchanger-1.5.0/src'
make[1]: se sale del directorio `/tmp/macchanger-1.5.0/src'
Making install in data
make[1]: se ingresa al directorio `/tmp/macchanger-1.5.0/data'
make[2]: se ingresa al directorio `/tmp/macchanger-1.5.0/data'
make[2]: No se hace nada para `install-exec-am'.
test -z "/usr/local/share/macchanger" || mkdir -p -- . "/usr/local/share/macchanger"
/usr/bin/install -c -m 644 'OUI.list' '/usr/local/share/macchanger/OUI.list'
/usr/bin/install -c -m 644 'wireless.list' '/usr/local/share/macchanger/wireless.list'
make[2]: se sale del directorio `/tmp/macchanger-1.5.0/data'
make[1]: se sale del directorio `/tmp/macchanger-1.5.0/data'
Making install in doc
make[1]: se ingresa al directorio `/tmp/macchanger-1.5.0/doc'
make[2]: se ingresa al directorio `/tmp/macchanger-1.5.0/doc'
make[2]: No se hace nada para `install-exec-am'.
test -z "/usr/local/info" || mkdir -p -- . "/usr/local/info"
/usr/bin/install -c -m 644 './macchanger.info' '/usr/local/info/macchanger.info'
install-info --info-dir='/usr/local/info' '/usr/local/info/macchanger.info'
make[2]: se sale del directorio `/tmp/macchanger-1.5.0/doc'
make[1]: se sale del directorio `/tmp/macchanger-1.5.0/doc'
make[1]: se ingresa al directorio `/tmp/macchanger-1.5.0'
make[2]: se ingresa al directorio `/tmp/macchanger-1.5.0'
make[2]: No se hace nada para `install-exec-am'.
test -z "/usr/local/man/man1" || mkdir -p -- . "/usr/local/man/man1"
/usr/bin/install -c -m 644 './macchanger.1' '/usr/local/man/man1/macchanger.1'
make[2]: se sale del directorio `/tmp/macchanger-1.5.0'
make[1]: se sale del directorio `/tmp/macchanger-1.5.0'
linux-aiyk:/tmp/macchanger-1.5.0 #
y cuando pongo macchanger en la shell macchanger --help

Cita:
linux-aiyk:/tmp/macchanger-1.5.0 # macchanger --help
GNU MAC Changer
Usage: macchanger [options] device

-h, --help Print this help
-V, --version Print version and exit
-s, --show Print the MAC address and exit
-e, --endding Don't change the vendor bytes
-a, --another Set random vendor MAC of the same kind
-A Set random vendor MAC of any kind
-r, --random Set fully random MAC
-l, --list[=keyword] Print known vendors
-m, --mac=XX:XX:XX:XX:XX:XX Set the MAC XX:XX:XX:XX:XX:XX

Report bugs to alvaro@gnu.org
asi que no tengo ni idea de que hacer

Última edición por lealesdibua; 30-may-2011 a las 11:13
Responder Citando
  #2  
Antiguo 30-may-2011, 11:45
Avatar de davmont
davmont davmont está desconectado
Moderador
 
Fecha de Ingreso: 13-diciembre-2007
Ubicación: ~/
Versión: 12.3 x86_64
Mensajes: 2.871
Agradecimientos: 78
Agradecido 141 Veces en 125 Mensajes
Poder de Credibilidad: 12
davmont está en el buen camino
¿cuál es el problema? el programa se deja ejecutar (se ha compilado sin error por lo que veo) y te lo está diciendo muy claro...

Cita:
Usage: macchanger [options] device
...
-m, --mac=XX:XX:XX:XX:XX:XX Set the MAC XX:XX:XX:XX:XX:XX
sólo necesitas saber la mac que quieres ponerle, y el dispositivo al que se la quieres cambiar (/sbin/ifconfig te dirá las tarjetas conectadas).

un saludo
__________________
No atiendo consultas sobre Linux/openSUSE por privado, usad el foro que para algo está
Normas del foro, de lectura obligada


Responder Citando
  #3  
Antiguo 30-may-2011, 16:59
Avatar de lealesdibua
lealesdibua lealesdibua está desconectado
Aforado
 
Fecha de Ingreso: 17-noviembre-2010
Versión: 11.3 64bit amg
Mensajes: 64
Agradecimientos: 16
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 8
lealesdibua está en el buen camino
gracias davmont nose porque no me dejava reinicie y todo perfecto



una pregunta davmont porque no medeja meter paquetes rpm opensuse hasta ahora no e podido meter ninguno por ejemplo el docky
yo uso gnome 11.3 64bit

Última edición por lealesdibua; 30-may-2011 a las 17:07
Responder Citando
  #4  
Antiguo 30-may-2011, 21:43
Avatar de davmont
davmont davmont está desconectado
Moderador
 
Fecha de Ingreso: 13-diciembre-2007
Ubicación: ~/
Versión: 12.3 x86_64
Mensajes: 2.871
Agradecimientos: 78
Agradecido 141 Veces en 125 Mensajes
Poder de Credibilidad: 12
davmont está en el buen camino
el programa si que se instalaba bien, no entiendo por qué no te funcionaba...

lo más probable es que sea problema de dependencias... has usado zypper/YaST?

prueba a hacerlo desde allí, e inicia un tema nuevo para el "nuevo problema", para mantener el hilo limpio... para más señas da el error que te devuelve al intentar instalar.

un saludo
__________________
No atiendo consultas sobre Linux/openSUSE por privado, usad el foro que para algo está
Normas del foro, de lectura obligada


Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Instalar opensuse en una partición distinta a xp thesoori Instalación y Actualizaciones 9 19-feb-2010 17:16
problemas al instalar OpenSUSE 10.3 32bits en DVD Jack_Deckard Instalación y Actualizaciones 7 13-ene-2009 21:53
Anuncio oficial openSUSE 11.0 (español) elpreto Portal de ForoSUSE 66 18-ago-2008 17:48
No puedo instalar opensuse 11 del live cd soichirutk Instalación y Actualizaciones 4 15-ago-2008 04:45
Problemas con la actualización de OpenSuse 10.3 gery Instalación y Actualizaciones 18 28-oct-2007 18:43



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 08:31.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba