Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Instalando Drivers ATI 10.9 - No 3D [FATAL: Module fglrx not found] [SOLUCIONADO]
  #1  
Antiguo 05-oct-2010, 03:08
1antares1 1antares1 está desconectado
Excluido
 
Fecha de Ingreso: 19-septiembre-2010
Ubicación: ¡En 2 casas! [A veces estoy en la mía]
Versión: 11.3
Mensajes: 79
Agradecimientos: 7
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 0
1antares1 está en el buen camino
Enviar un mensaje por MSN a 1antares1
Lightbulb Instalando Drivers ATI 10.9 - No 3D [FATAL: Module fglrx not found] [SOLUCIONADO]

Que tal, de nuevo. Quise abrir éste tema para ver si alguien conoce más del tema y podría echarme una mano, sobre los nuevos Drivers ATI 10.9 para openSUSE 11.3 64 bits (ATI HD 4670).

Es que por un error (ya fue por mi) jeje! Eliminé casi todas las dependencias sin ver detalles en la instalación de un codec, que era de 32 bits y terminé elimando todo el KDE y openoffice jeje! Pero eso no hay problema, instalé de 0 el openSUSE, con mis configuraciones guardadas y el home.

Todo perfecto de nuevo (Ya aprendí de mi error por no notar las dependencias en una instalación) Ajá, el problema es que antes los Drivers del repositorio ATI, los tenía funcionando perfectamente pero eran los Drivers 10.6 (Según el Catalyst), pensando que eran los 10.9

Y la instalación fue perfecta, funcionando bien. Pero ésta vez empecé a instalar los 10.9, siguiendo paso a paso ésta guía, igual que los drivers anteriores.

Instalé los headers necesarios, los sources, los patch's, como decía tal la guía, pero al terminar de instalar todo, tengo el Catalyst 10.9 pero lo único que me falta es cargar el módulo FGLRX.

Es decir, tengo Controlador 2D, según en "Equipo" y el Controlador 3D (Que con los 10.6, me decía), no tengo.

No tengo controlador 3D, ya que al paso de la guía:

Código:
modprobe -v fglrx
Me sale:

Código:
FATAL: Module fglrx not found
Ya tengo en la "Blacklist" el "Radeon", todos los paso iban bien, hasta que me ocurrió ésto.

Me falta cargar éste módulo, no he consigo como o como hacer para que me instale el "Controlador 3D" pero para los Drivers nuevos 10.9

Creo que hay alguien con el mismo inconveniente por acá, pero no quise desviar el tema y creo que mi deber es abrir otro tema con mi inconveniente.

A ver quien ha probado los Drivers ATI 10.9 y puede decirme los pasos correctos. El driver del Repositorio de ATI están los módulos antiguos y ese Catalyst 10.6.

Espero su respuestas y cooperación con mi problema.
Responder Citando
  #2  
Antiguo 05-oct-2010, 10:12
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.591
Agradecimientos: 570
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Evidentemente, el mensaje dice que no se instalo y genero correctamente el modulo y por ende no le puede cargar. Cuando se hace la instalación se genera un archivo log, no se donde estará, prueba mirarlo.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #3  
Antiguo 05-oct-2010, 17:20
1antares1 1antares1 está desconectado
Excluido
 
Fecha de Ingreso: 19-septiembre-2010
Ubicación: ¡En 2 casas! [A veces estoy en la mía]
Versión: 11.3
Mensajes: 79
Agradecimientos: 7
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 0
1antares1 está en el buen camino
Enviar un mensaje por MSN a 1antares1
Thumbs up

Cita:
Iniciado por DiabloRojo Ver Mensaje
Evidentemente, el mensaje dice que no se instalo y genero correctamente el modulo y por ende no le puede cargar. Cuando se hace la instalación se genera un archivo log, no se donde estará, prueba mirarlo.
Efectivamente DiabloRojo, re-instalando el paquete .RPM, viendo el "Registro de Instalación", me generó ésto:

Cita:
p, li { white-space: pre-wrap; } Instalando fglrx64_7_5_0_SUSE113-8.771-1.x86_64.rpm (tamaño instalado 125,15 MB)
Salida adicional del rpm:
/usr/src/kernel-modules/fglrx /
make: Entering directory `/usr/src/linux-2.6.34.7-0.3-obj/x86_64/desktop'
make -C ../../../linux-2.6.34.7-0.3 O=/usr/src/linux-2.6.34.7-0.3-obj/x86_64/desktop/.
CC [M] /usr/src/kernel-modules/fglrx/kcl_ioctl.o
/usr/src/kernel-modules/fglrx/kcl_ioctl.c: In function ‘KCL_IOCTL_AllocUserSpace32’:
/usr/src/kernel-modules/fglrx/kcl_ioctl.c:196:5: error: implicit declaration of function ‘compat_alloc_user_space’
/usr/src/kernel-modules/fglrx/kcl_ioctl.c:196:5: warning: return makes pointer from integer without a cast
make[3]: *** [/usr/src/kernel-modules/fglrx/kcl_ioctl.o] Error 1
make[2]: *** [_module_/usr/src/kernel-modules/fglrx] Error 2
make[1]: *** [sub-make] Error 2
make: *** [all] Error 2
make: Leaving directory `/usr/src/linux-2.6.34.7-0.3-obj/x86_64/desktop'
******************************
Build of kernel module failed!
******************************
************************************************** ************
Building/installation of fglrx kernel module failed! Try again
by calling "/usr/bin/fglrx-kernel-build.sh" manually.
************************************************** ************
************************************************** ***********
Please read "/usr/share/doc/packages/fglrx/README.SuSE" for
configuration details when using SaX2.
************************************************** ***********

Si hago clic en "Registro Post-Instalación SuSEconfig":

Cita:
p, li { white-space: pre-wrap; } Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module glib2 only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.glib2...
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module ispell only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.ispell...
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module postfix only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.postfix...
No changes for /etc/postfix/master.cf
Setting up postfix local as MDA...
Setting SPAM protection to "off"...
No changes for /etc/postfix/main.cf
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module groff only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.groff...
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module words only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.words...
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module gtk2 only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.gtk2...
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module fonts only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.fonts...
Creating fonts.{scale,dir} files .........
/etc/fonts/suse-font-dirs.conf unchanged
/etc/fonts/suse-hinting.conf unchanged
/etc/fonts/suse-bitmaps.conf unchanged
Creating cache files for fontconfig ...........................
Creating 32bit cache files for fontconfig ...........................
generating java font setup
Warning: cannot find a sans serif Japanese font. Japanese in Java might not work.
Warning: cannot find a serif Japanese font. Japanese in Java might not work.
Warning: cannot find a sans serif simplified Chinese font. Simplified Chinese in Java might not work.
Warning: cannot find a serif simplified Chinese font. Simplified Chinese in Java might not work.
Warning: cannot find a sans serif traditional Chinese font. Traditional Chinese in Java might not work.
Warning: cannot find a serif traditional Chinese font. Traditional Chinese in Java might not work.
Warning: cannot find a sans serif Korean font. Korean in Java might not work.
Warning: cannot find a serif Korean font. Korean in Java might not work.
writing /usr/lib64/jvm/jre/lib/fontconfig.SuSE.properties
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module permissions only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.permissions...
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running module desktop-file-utils only
Reading /etc/sysconfig and updating the system...
Executing /sbin/conf.d/SuSEconfig.desktop-file-utils...
Error in file "/usr/share/applications/kde4/kfontview.desktop": "fonts/package" is an invalid MIME type ("fonts" is an unregistered media type)
Finished.
Starting SuSEconfig, the SuSE Configuration Tool...
Running in verbose mode.
Running in full featured mode.
Reading /etc/sysconfig and updating the system...
skipping modules
Finished.

No se, si haga falta instalar algunos paquetes adicionales antes para que compile o instale bien. Algunos lenguajes o librerias, ya que claramente dice que hubo error con el Kernel.

Espero tu respuesta con paciencia. Saludos!
Responder Citando
  #4  
Antiguo 05-oct-2010, 17:46
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.591
Agradecimientos: 570
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Necesitas los paquetes que indica en la pagina de ATI, mas el kernel-desktop-devel, kernel-source, etc...

Ademas, no has mirado el mensaje de :
Cita:
Building/installation of fglrx kernel module failed! Try again
by calling "/usr/bin/fglrx-kernel-build.sh" manually.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #5  
Antiguo 05-oct-2010, 19:58
1antares1 1antares1 está desconectado
Excluido
 
Fecha de Ingreso: 19-septiembre-2010
Ubicación: ¡En 2 casas! [A veces estoy en la mía]
Versión: 11.3
Mensajes: 79
Agradecimientos: 7
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 0
1antares1 está en el buen camino
Enviar un mensaje por MSN a 1antares1
Arrow

Cita:
Iniciado por DiabloRojo Ver Mensaje
Necesitas los paquetes que indica en la pagina de ATI, mas el kernel-desktop-devel, kernel-source, etc...

Ademas, no has mirado el mensaje de :
Todos los paquetes que dice la guía + otros parches + compiladores tanto de C como de C++ y Java.

Todos los Kernel's, con las mismas versiones, están instaladas en mi pc. No creo que haga falta algún paquete aparte.

Ya que se instaló el Catalyst, y tengo controlador 2D, más no 3D (FGLRX).

Lo que si me faltaría es como instalar manualmente el:

"fglrx-kernel-build.sh"

O como lo llamo, ya que tengo todos los kernel's necesarios, desktop, devel, source's, headers, etc. Bueno, los que decía la guía y en el Forum SuSE (Inglés), como algunos path's, patch's, librerias.

Espero tu respuesta. Gracias por tu ayuda!
Responder Citando
  #6  
Antiguo 05-oct-2010, 20:07
1antares1 1antares1 está desconectado
Excluido
 
Fecha de Ingreso: 19-septiembre-2010
Ubicación: ¡En 2 casas! [A veces estoy en la mía]
Versión: 11.3
Mensajes: 79
Agradecimientos: 7
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 0
1antares1 está en el buen camino
Enviar un mensaje por MSN a 1antares1
Arrow

Trato de instalarlo por Consola, de ésta manera y sale éste mensaje:

Cita:
linux-ufse:/usr/bin # sh fglrx-kernel-build.sh
/usr/src/kernel-modules/fglrx /usr/bin
make: se ingresa al directorio `/usr/src/linux-2.6.34.7-0.3-obj/x86_64/desktop'
make -C ../../../linux-2.6.34.7-0.3 O=/usr/src/linux-2.6.34.7-0.3-obj/x86_64/desktop/.
CC [M] /usr/src/kernel-modules/fglrx/kcl_ioctl.o
/usr/src/kernel-modules/fglrx/kcl_ioctl.c: In function ‘KCL_IOCTL_AllocUserSpace32’:
/usr/src/kernel-modules/fglrx/kcl_ioctl.c:196:5: error: implicit declaration of function ‘compat_alloc_user_space’
/usr/src/kernel-modules/fglrx/kcl_ioctl.c:196:5: warning: return makes pointer from integer without a cast
make[3]: *** [/usr/src/kernel-modules/fglrx/kcl_ioctl.o] Error 1
make[2]: *** [_module_/usr/src/kernel-modules/fglrx] Error 2
make[1]: *** [sub-make] Error 2
make: *** [all] Error 2
make: se sale del directorio `/usr/src/linux-2.6.34.7-0.3-obj/x86_64/desktop'

******************************
Build of kernel module failed!
******************************


Espero tu respuesta. Saludos1
Responder Citando
  #7  
Antiguo 05-oct-2010, 20:59
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.591
Agradecimientos: 570
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por 1antares1 Ver Mensaje
Espero tu respuesta. Saludos1
Apañado estas si esperas por mi parte una solución, como si ser "experto" tuviera todas las soluciones, mis conocimientos son muy limitados pero, a menos, se buscar.

Buscando por el error, he dado con una solución en el foro donde el compañero sapienslinux sabe pescar por su cuenta, hay mas por Internet:
http://www.forosuse.org/forosuse/showthread.php?t=24821

Cuando te surge un problema, busca el error en el foro o por Internet porque antes que a ti siempre le ha ocurrido alguien el mismo problema y casi seguro que habrá una solución.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #8  
Antiguo 05-oct-2010, 21:08
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Primer resultado al hacer una búsqueda de /usr/src/kernel-modules/fglrx/kcl_ioctl.c:196:5: error: implicit declaration of function ‘compat_alloc_user_space’:

http://www.kwokinator.com/blog/20100...-linux-kernels

Creo que eso puede resolver tu problema.

Un saludo.

Última edición por jcsl; 05-oct-2010 a las 21:10 Razón: Ampliar.
Responder Citando
  #9  
Antiguo 05-oct-2010, 21:26
1antares1 1antares1 está desconectado
Excluido
 
Fecha de Ingreso: 19-septiembre-2010
Ubicación: ¡En 2 casas! [A veces estoy en la mía]
Versión: 11.3
Mensajes: 79
Agradecimientos: 7
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 0
1antares1 está en el buen camino
Enviar un mensaje por MSN a 1antares1
Thumbs up

Cita:
Iniciado por DiabloRojo Ver Mensaje
Apañado estas si esperas por mi parte una solución, como si ser "experto" tuviera todas las soluciones, mis conocimientos son muy limitados pero, a menos, se buscar.

Buscando por el error, he dado con una solución en el foro donde el compañero sapienslinux sabe pescar por su cuenta, hay mas por Internet:
http://www.forosuse.org/forosuse/showthread.php?t=24821

Cuando te surge un problema, busca el error en el foro o por Internet porque antes que a ti siempre le ha ocurrido alguien el mismo problema y casi seguro que habrá una solución.
Bueno DiabloRojo, gracias por la solución y el tema que mandaste. Ya lo guardé para tenerlo en mi carpeta de soluciones.

Pués, igual buscando información (En inglés y alemán), estaba en un tema tan fácil, en el mismo que recomendé anteriormente a alguien (Acá en FOROSuse):

http://lizards.opensuse.org/2010/07/...rs-under-11-3/

Resulta que sólo instalando el nuevo Script, lo baje y lo instalé como el run de ATI y listo! No se que habrá hecho, pero me instaló el .rpm y sin error alguno.

Reinicio y veo que tengo Aceleración 3D Algo habrá hecho, pero lo ejecutó muy bueno en la consola, perfecto y completo. Detecta la versión para mi PC.

Lo dejo como solución para un futuro problema semejante.

Gracias DiabloRojo por la paciencia y ayuda

Saludos! [SOLUCIONADO]
Responder Citando
  #10  
Antiguo 06-oct-2010, 11:07
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.591
Agradecimientos: 570
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por 1antares1 Ver Mensaje
Saludos! [SOLUCIONADO]
¿Cual es la solución?.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Respuesta

Marcadores

Etiquetas
ati drivers modulo fglrx


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Xorg 7.2 no soporta 2 tarjetas graficas [SOLUCIONADO] spokkazo Software 43 30-oct-2008 12:29
Desktop de Open Suse 10.3 solo usa 2/3 de mi pantalla galessandro Hardware 4 13-mar-2008 16:03
XGL error al activarlo Fabricio Guzzo Escritorios: KDE, Gnome, otros... 5 21-sep-2007 11:08
lento pero muy lento al arrancar xakalito General OpenSUSE 7 04-may-2007 22:54
firefox dmickey General OpenSUSE 6 27-sep-2006 18:57



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 03:27.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba