Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

GRUB - El retorno
  #1  
Antiguo 20-ago-2010, 23:09
xcv xcv está desconectado
Aforado
 
Fecha de Ingreso: 03-julio-2010
Ubicación: /dev/null
Versión: 11.2
Mensajes: 32
Agradecimientos: 4
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
xcv está en el buen camino
GRUB - El retorno

Hola a todos de nuevo, mis problemas con el grub reaparecen.

La ultima vez me paso algo parecido y lo medio-arregle de pura suerte (probe combinaciones a lo loco en "arrancar desde ... "). En realidad no lo arreglé del todo porque seguia fallando, sacaba 4 errores distintos aleatoriamente, otras funcionaba, es decir, reiniciaba hasta que arrancaba. Estos son los errores que me sacaba:

1.)Error 18: Selected cylinder exceeds maximum supported by BIOS
Eso era despues de seleccionar del menu.

2.)Error 18: Selected cylinder exceeds maximum supported by BIOS
Tambien antes de cargar el menu, despues pone modo consola (GRUB>)

3.)(hd0,5)/boot/message: file not found
Antes del arranque del menu, despues sacaba la consola del grub

4.)Consola del grub directamente
Ni cargaba el menu ni nada, simplemente arrancaba la consola del grub

Esto era porque instale el ubuntu 10.04 (aprovecho para recordar mi firma xD) y me puso el grub2 pasando totalmente de que le dijera que NO lo instalara (no me gusta el grub2, dificil de configurar y feo). Entonces hice el tonto con el yast hasta que conseguí borrar el grub2 del ubuntu del mapa, el problema fue que no se instalo bien el grub1 o me cargue el MBR (creo que le di a reescribir MBR), no lo se, como digo arriba lo medio-arregle de pura suerte.

Bueno, despues de esta introduccion, decir que lo de reiniciar hasta que funciona se me ha acabado, lo he intentado durante media hora (sin parar) y siempre me daba algun error, asi que he metido el DVD y he hecho lo mismo que la ultima vez, probar combinaciones a lo loco, pero ninguna me ha funcionado, asi que ya no se que hacer, el grub solo arranca su modo consola (ya he desarrollado cierto odio hacia ella ¬¬) y lo unico que puedo arrancar ahora mismo es el "Reparar el sistema" y el "Modo rescate" del DVD de opensuse y la version live del CD de ubuntu.

Asi estan mis particiones:
sda: 300GB
sda1: Windows FAT 75GB
sda2: Extended: 225
sda5: Swap 3GB
sda6: root (OpenSUSE 11.2) ext4 22GB
sda7: home (OpenSUSE 11.2) ext4 50GB
sda8: root (Ubuntu 10.04) ext4 24GB
sda9: home (Ubuntu 10.04) ext4 50GB

Si necesitais mas informacion solo teneis que pedirla y decir como puedo obtenerla

Ya tengo el OpenSUSE muy bien apañado asi que la solucion "reinstalacion" deberia estar despues de arreglarlo a martillazos/patadas/puenting sin cuerda

Gracias, a ver si zanjo de una vez el tema de mi grub, ya me esta empezando a hartar.

PD: Ya he intentado los pasos que dicen varios tutoriales sin exito, incluido instalar el grub tal cual propone el instalador del DVD (tampoco funciona poniendo MBR)



EDIT
He conseguido que al menos muestre el menu alguna vez, estoy como antes, pero ahora ha surgido un error nuevo:
5.)(hd0,5)/boot/message: read error
Antes del menu, inmediatamente pone la consola del grub.

De momento no he conseguido que arranque (reiniciando y volviendolo a intentar), ahora esta con "boot from root partition"

Última edición por xcv; 21-ago-2010 a las 02:00
Responder Citando
  #2  
Antiguo 21-ago-2010, 01:08
Avatar de xisco
xisco xisco está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 23-marzo-2006
Ubicación: Sector Horchata
Versión: La ultima estable
Mensajes: 1.685
Agradecimientos: 29
Agradecido 157 Veces en 129 Mensajes
Poder de Credibilidad: 13
xisco está en el buen camino
hola
prueba a arrancar con algun medio que permita msdos y pon fdisk /mbr, esto borraria el mbr. Tambien podrias intentar reinstalar el windows que se suele cargar el mbr y despues de alguna de estas opciones instala el grub otra vez reparando con el dvd de suse.
De todas formas me da que eldisco es muy grande para tu bios, que capacidad tiene?? Yntu ordenador cuanto tiempo tiene?'

Salu2
Responder Citando
  #3  
Antiguo 21-ago-2010, 01:58
xcv xcv está desconectado
Aforado
 
Fecha de Ingreso: 03-julio-2010
Ubicación: /dev/null
Versión: 11.2
Mensajes: 32
Agradecimientos: 4
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
xcv está en el buen camino
El disco es de 300 GB, he añadido el tamaño de cada particion en el primer post.

Si, el ordenador ya tiene sus añitos (no se cuantos) pero aunque no es del todo nuevo, esta bastante "actualizado" en cuanto a hardware, incluso hace no tanto se estropeo la placa base y hubo que cambiarsela. Lo unico que se de la bios es que puede arrancar usb 2.0 pero no por defecto solo manualmente con F11 durante el arranque, acabo de ver que tiene los drivers en la configuracion, asi que debe de poder y por tanto tampoco es tan antigua. Por defecto solo se le puede configurar floppy, hd o cd/dvd

Todo habia ido bien hasta que el ubuntu metio el grub2 y tuve que hacer todo tipo de guarradas para sacarlo de ahi o al menos dejarlo K.O.

Entonces meto el disquete del XP y con el ms-dos pongo fdisk /mbr? No me manejo demasiado con el ms-dos y los disquetes xD

EDIT: He hecho algunas pruebas que he visto por google en la consola de grub:
GRUB>root (hd0,5)
File system is ext2fs.... / O Error 18, es decir volver a meter root (hd0,5) hasta que sale lo "bueno"
GRUB>setup (hd0)
Checking.......... / Igual, tengo que meter setup (hd0) hasta que lo acaba sin sacar ningun Error 18
GRUB>reboot

El ordenador se enciende...
Igual que antes!

EDIT2: Ahora no se por que pero hace lo mismo con todos los "boot from...", igual que antes, varia entre esos fallos y al final en boot from extended partition despues de varios resets ha arrancado el GRUB y el OpenSUSE, pero necesito ayuda porque hasta que no sepa como arreglar esto el uptime va a estar creciendo no pienso apagar ni loco he estado toda la mañana reiniciando para que se encendiera O_O. Alguna solucion para poder apagar tranquilo sabiendo que podre arrancar despues? Arrancando a la fuerza con el DVD de instalacion da un error raro de que no encuentra ext4.ko y se queda bloqueado con las luces del teclado parpadeando...

Última edición por xcv; 21-ago-2010 a las 15:26 Razón: Nuevas pruebas
Responder Citando
  #4  
Antiguo 22-ago-2010, 00:33
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.211
Agradecimientos: 42
Agradecido 1.261 Veces en 929 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Yo, por viejas costumbres:

1. DVD instalación OpenSUSE
2. Reparación
3. Creo que es "personalizada" o algo así, donde te dice que ya sabes tu problema y eso.
4. Grub
5. En la segunda pestaña, selecciono "no instalar cargador de arranque".
6. Después vuelvo a seleccionar "Grub"
7. Instalar Grub en MBR (ver nota) y en la partición raíz de OpenSUSE si quieres.
/. Proponer configuración en la otra pestaña, o modifícala a tu gusto.
8. Reiniciar

nota: IMHO, creo más fácil administrar un sistema con un grub en el MBR.

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
  #5  
Antiguo 22-ago-2010, 02:29
xcv xcv está desconectado
Aforado
 
Fecha de Ingreso: 03-julio-2010
Ubicación: /dev/null
Versión: 11.2
Mensajes: 32
Agradecimientos: 4
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
xcv está en el buen camino
Cita:
Iniciado por karlggest Ver Mensaje
Yo, por viejas costumbres:

1. DVD instalación OpenSUSE
2. Reparación
3. Creo que es "personalizada" o algo así, donde te dice que ya sabes tu problema y eso.
4. Grub
5. En la segunda pestaña, selecciono "no instalar cargador de arranque".
6. Después vuelvo a seleccionar "Grub"
7. Instalar Grub en MBR (ver nota) y en la partición raíz de OpenSUSE si quieres.
/. Proponer configuración en la otra pestaña, o modifícala a tu gusto.
8. Reiniciar

nota: IMHO, creo más fácil administrar un sistema con un grub en el MBR.

Salud!!
En la 5 le doy a aceptar verdad? Es decir, instalar gestor de arranque->no instalar->aceptar, y despues lo mismo pero seleccionando grub en MBR...

Que hace exactamente el paso 5? Hay que poner alguna opcion tipo arrancar de MBR, extended, etc? Que hace exactamente?

Gracias, solo es que necesito estar casi seguro porque ahora que lo tengo encendido con lo que me ha costado, tengo que tener cierta seguridad de arreglarlo y poderlo volver a encender...

EDIT: Acabo de hacer lo que dices y me he quedado igual, sigue como antes


EDIT2: Arreglado actualizando la BIOS, ahora necesito saber como arrancar el ubuntu 10.04 con esta version, splash 1280x1024 incluido

Última edición por xcv; 24-ago-2010 a las 11:09
Responder Citando
  #6  
Antiguo 31-ago-2010, 00:13
Avatar de eduararley
eduararley eduararley está desconectado
Miembro Senior
 
Fecha de Ingreso: 21-abril-2007
Ubicación: Medellín, Colombia
Versión: 11.0 x86 GNOME
Mensajes: 1.193
Agradecimientos: 29
Agradecido 48 Veces en 43 Mensajes
Poder de Credibilidad: 12
eduararley está en el buen camino
Enviar un mensaje por Yahoo  a eduararley
Me imagino que sabes que GRUB no soporta EXT4, solo GRUB2. También me imagino que, dado que pretendes arrancar Ubuntu con GRUB, tomaste la precaución de utilizar EXT3 o inferior para tu carpeta /boot en ese sistema, ya que por defecto usa EXT4 en instalaciones nuevas
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Reinstalar el cargador de arranque GRUB sanjui Instalación y Actualizaciones 42 08-feb-2016 23:25
Configuración Grub para triple arranque trykenter General OpenSUSE 13 20-ago-2009 20:29
Suse 11.1 me mata el grub nestoriano Software 3 23-feb-2009 04:32
"Micro-manual" de grub -bueno, ni eso karlggest FAQs, Manuales y Tutoriales 3 28-jul-2007 20:44
Imposible configurar GRUB durante instalación de SUSE Maal656 Instalación y Actualizaciones 6 05-jul-2007 07:17



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 11:24.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba