Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

error con glib al instalar screem
  #1  
Antiguo 19-jun-2010, 05:49
Avatar de Victor90
Victor90 Victor90 está desconectado
Aforado
 
Fecha de Ingreso: 02-junio-2010
Versión: 11.2 (x86_64)
Mensajes: 11
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
Victor90 está en el buen camino
Question error con glib al instalar screem

Hola a todos, espero y puedan ayudarme un poco con esto, esto de compilar se me dificulta un poco ya que no estoy familiarizado con linux asi que este es el problema:

Estoy tratando de instalar el editor screem, pero este no esta en los repositorios asi que decidi hacerlo todo como se hace antes.

Bueno al momento de darle configure me arroja que me falta glib2.5.6 o una version mejor, la busco tambien en los repositorios pero no esta actualizado, asi que tambien decido hacerlo a la antigua, pero al momento de darle configure
me sale una lista enorme de warnings y errores

no se si alguien tenga alguna sugerencia o me pueda guiar para poder actualizar glib para poder instalar screem

gracias

[EDITO]
Les pongo los primeros warnings y errores que me da, ya que es muy grande la lista pero a ver si se puede entender mejor mi problema:

ay.Tpo -c garray.c -fPIC -DPIC -o .libs/garray.o
garray.c: In function 'IA__g_array_sized_new':
garray.c:84: warning: dereferencing type-punned pointer will break strict-aliasing rules
garray.c:91: warning: dereferencing type-punned pointer will break strict-aliasing rules
garray.c: In function 'IA__g_array_free':
garray.c:125: warning: dereferencing type-punned pointer will break strict-aliasing rules
garray.c:127: warning: dereferencing type-punned pointer will break strict-aliasing rules
garray.c: In function 'IA__g_ptr_array_sized_new':
garray.c:391: warning: dereferencing type-punned pointer will break strict-aliasing rules
garray.c:398: warning: dereferencing type-punned pointer will break strict-aliasing rules
garray.c: In function 'IA__g_ptr_array_free':
garray.c:426: warning: dereferencing type-punned pointer will break strict-aliasing rules
garray.c:428: warning: dereferencing type-punned pointer will break strict-aliasing rules
garray.c: At top level:
galias.h:22: error: 'g_allocator_free' aliased to undefined symbol 'IA__g_allocator_free'
galias.h:26: error: 'g_allocator_new' aliased to undefined symbol 'IA__g_allocator_new'
galias.h:78: error: 'g_ascii_digit_value' aliased to undefined symbol 'IA__g_ascii_digit_value'
galias.h:82: error: 'g_ascii_dtostr' aliased to undefined symbol 'IA__g_ascii_dtostr'
galias.h:86: error: 'g_ascii_formatd' aliased to undefined symbol 'IA__g_ascii_formatd'
galias.h:90: error: 'g_ascii_strcasecmp' aliased to undefined symbol 'IA__g_ascii_strcasecmp'
galias.h:94: error: 'g_ascii_strdown' aliased to undefined symbol 'IA__g_ascii_strdown'
galias.h:98: error: 'g_ascii_strncasecmp' aliased to undefined symbol 'IA__g_ascii_strncasecmp'
galias.h:102: error: 'g_ascii_strtod' aliased to undefined symbol 'IA__g_ascii_strtod'


Última edición por Victor90; 20-jun-2010 a las 04:49
Responder Citando
  #2  
Antiguo 20-jun-2010, 09:32
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.481
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
En su día intente instalar ese editor de HTML para probarlo pero desistí por lo requisitos que pedía: las librerías de Gnome que no tenia instalado. Sobre el paquete glib mira si puedes instalar sus glib*-devel correspodientes. Mira con "zypper se -s glib"

Tienes otras alternativas libres que hace el mismo trabajo que Screem: Geany, BlueFish, Quanta +, Anjuta, etc.... y sin contar los basados en Java que funciona en Windows y Linux.

PD: Los mensajes de salida lo podías comprimirlos y adjuntarlo porque de esa manera nadie lo mira.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Última edición por DiabloRojo; 20-jun-2010 a las 09:41
Responder Citando
Adjunto la lista
  #3  
Antiguo 22-jun-2010, 00:30
Avatar de Victor90
Victor90 Victor90 está desconectado
Aforado
 
Fecha de Ingreso: 02-junio-2010
Versión: 11.2 (x86_64)
Mensajes: 11
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
Victor90 está en el buen camino
Adjunto la lista

Gracias diablo rojo pero el screem me pide la version 2.5.6 de glib, pero en ningun repositorio viene actualizado, solo viene una version anterior, no sabras de algun repositorio que lo tenga actualizado o probare otro editor =P

aqui la lista de errores que tengo
lista.odt
Responder Citando
  #4  
Antiguo 22-jun-2010, 09:12
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.481
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Ni idea como no sea el glib2. Prueba instalar el rpm de screem que es para Fedora, Red Hat y CentOS en openSUSE satisfaciendo las dependencias.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Última edición por DiabloRojo; 22-jun-2010 a las 09:14
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Manual - Instalar canon IP1800 AfaChile Hardware 2 22-may-2011 09:24
¿Cómo instalar screem (editor html)? Alienator Software 2 08-dic-2009 01:13
Conflictos al intentar instalar KDE 4.1 en Opensuse 11.0 [SOLUCIONADO] McGiver Escritorios: KDE, Gnome, otros... 13 03-ago-2008 02:09
Problemas con la actualización de OpenSuse 10.3 gery Instalación y Actualizaciones 18 28-oct-2007 17:43
dudas para actualizar kernel fox2099 Software 14 01-may-2007 22:53



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 08:12.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba