Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Técnica > Internet, Redes y Wireless


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema con configuración de apache con glpi y koha?
  #1  
Antiguo 02-jun-2010, 23:54
debrob debrob está desconectado
Aforado
 
Fecha de Ingreso: 30-diciembre-2009
Ubicación: Mexico
Versión: 11.2
Mensajes: 1
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
debrob está en el buen camino
Enviar un mensaje por MSN a debrob
Question Problema con configuración de apache con glpi y koha?

Hola a todos.. tengo ya algo de tiempo en esto de linux y también un poco menos visitando este foro, y de decir que encontrado respuesta algunas de mis problemas, pero esta vez tengo uno y por mas que busco la solución no doy con ella .

Mi problema es el siguiente, tengo instalado un servidor web con servicios (mas bien programas) como GLPI, phpMyAdmin y KOHA (Sistema para automatización de bibliotecas), y el problema que tengo:

*Al momento de instalar KOHA el sistema phpMyAdmin no puede ser accesado desde la intranet mas que del equipo local (este no es problema en si, ya que solo utilizo para hacer respaldos de la BD GLPI), bueno de momento tengo acceso GLPI y KOHA desde la intranet, pero tengo un problemita para sacar unos reportes de GLPI que antes de instalar KOHA si podía hacer .
*Después edite el archivo de glpi.conf que se encuentra en /etc/apache2/conf.d dejandolo asi:

Alias /glpi /usr/share/glpi

<Directory /usr/share/glpi>
Options None
AllowOverride Limit Options FileInfo

php_value memory_limit 64M

Order Deny,Allow
Allow from all
</Directory>

<Directory /usr/share/glpi/install>

# 15" should be enough for migration in most case
php_value max_execution_time 900
php_value memory_limit 128M

</Directory>

<Directory /usr/share/glpi/config>
Order Allow,Deny
Deny from all
</Directory>

<Directory /usr/share/glpi/locales>
Order Allow,Deny
Deny from all
</Directory>

<Directory /usr/share/glpi/install/mysql>
Order Allow,Deny
Deny from all
</Directory>

<Directory /usr/share/glpi/scripts>
Order Allow,Deny
Deny from all
</Directory>

# some people prefer a simple URL like http://glpi.example.com
<VirtualHost *:80>
DocumentRoot /usr/share/glpi
# ServerName glpi.example.com
</VirtualHost>


Con lo cual resolví mi problema de reportes con GLPI , pero a hora ya no pude acceder a la pagina de KOHA bueno mas bien al servicio de OPAC que se encuentra en el puerto 80, ya que la pagina de administración que se encuentra en el puerto 8080 si tengo acceso desde la intranet.

Aqui esta la configuración del archivo koha-httpd.conf que se encuentra en /etc/apache2/vhosts.d :

# Koha Apache Configuration Directives

NameVirtualHost *:80
Listen 8080

#OPAC
<VirtualHost _default_:80>
ServerAdmin webmaster@linux-ydn0
DocumentRoot /usr/share/koha/opac/htdocs
ServerName opac.linux-ydn0
# ServerAlias opac.10.11.8.38
ScriptAlias /cgi-bin/koha/ "/usr/share/koha/opac/cgi-bin/opac/"
ScriptAlias /index.html "/usr/share/koha/opac/cgi-bin/opac/opac-main.pl"
ScriptAlias /opac-search.pl "/usr/share/koha/opac/cgi-bin/opac/search"
ScriptAlias /search "/usr/share/koha/opac/cgi-bin/opac/search"
ErrorLog /var/log/koha/koha-opac-error_log
# TransferLog /var/log/koha/koha-opac-access_log
SetEnv KOHA_CONF "/etc/koha/koha-conf.xml"
SetEnv PERL5LIB "/usr/share/koha/lib"

# Repeat this virtualhost stanza changing the following environment vars to
# create multiple OPAC interfaces with custom css and/or search limits:
# SetEnv OPAC_CSS_OVERRIDE mystyle.css
# SetEnv OPAC_SEARCH_LIMIT branch:CODE
# SetEnv OPAC_LIMIT_OVERRIDE 1

Options +FollowSymLinks

ErrorDocument 400 /cgi-bin/koha/errors/400.pl
ErrorDocument 401 /cgi-bin/koha/errors/401.pl
ErrorDocument 403 /cgi-bin/koha/errors/403.pl
ErrorDocument 404 /cgi-bin/koha/errors/404.pl
ErrorDocument 500 /cgi-bin/koha/errors/500.pl

# Rewrite Rules
RewriteEngine On

# Uncomment to turn on rewrite logging
# RewriteLog /var/log/koha/koha-opac-rewrite.log
# RewriteLogLevel 1
RewriteCond %{QUERY_STRING} (.*?)(?:[A-Za-z0-9_-]+)=&(.*)
RewriteRule (.+) $1?%1%2 [N,R,NE]

RewriteRule ^/bib/([^\/]*)/?$ /cgi-bin/koha/opac-detail\.pl?bib=$1 [PT]
RewriteRule ^/isbn/([^\/]*)/?$ /search?q=isbn:$1 [PT]
RewriteRule ^/issn/([^\/]*)/?$ /search?q=issn:$1 [PT]
</VirtualHost>

## Intranet
<VirtualHost *:8080>
ServerAdmin webmaster@linux-ydn0
DocumentRoot /usr/share/koha/intranet/htdocs
ServerName linux-ydn0:8080
# ServerAlias intranet.mydomain.com
ScriptAlias /cgi-bin/koha/ "/usr/share/koha/intranet/cgi-bin/"
ScriptAlias /index.html "/usr/share/koha/intranet/cgi-bin/mainpage.pl"
ScriptAlias /search "/usr/share/koha/intranet/cgi-bin/search.pl"
ErrorLog /var/log/koha/koha-error_log
# TransferLog /var/log/koha/koha-access_log
SetEnv KOHA_CONF "/etc/koha/koha-conf.xml"
SetEnv PERL5LIB "/usr/share/koha/lib"
Options +FollowSymLinks

ErrorDocument 400 /cgi-bin/koha/errors/400.pl
ErrorDocument 401 /cgi-bin/koha/errors/401.pl
ErrorDocument 403 /cgi-bin/koha/errors/403.pl
ErrorDocument 404 /cgi-bin/koha/errors/404.pl
ErrorDocument 500 /cgi-bin/koha/errors/500.pl

RewriteEngine On
# Uncomment to turn on rewrite logging
# RewriteLog /var/log/koha/koha-intranet-rewrite.log
# RewriteLogLevel 1

RewriteCond %{QUERY_STRING} (.*?)(?:[A-Za-z0-9_-]+)=&(.*)
RewriteRule (.+) $1?%1%2 [N,R,NE]
RewriteRule ^/bib/([^\/]*)/?$ /cgi-bin/koha/detail\.pl?bib=$1 [PT]
RewriteRule ^/isbn/([^\/]*)/?$ /search?q=isbn:$1 [PT]
RewriteRule ^/issn/([^\/]*)/?$ /search?q=issn:$1 [PT]
</VirtualHost>

<Directory /usr/share/koha>
Order allow,deny
Allow from all
</Directory>

Así que de momento tuve que poner en "#" la configuración del virtualhost del archivo
glpi.conf y quedarme sin función de reportes.

Ese es mi problema, agradecería mucho de su ayuda.
__________________
Por una sociedad sin censuras de acceso a la información.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Manual para configurar un Servidor FTP con Vsftpd gabrielkfr FAQs, Manuales y Tutoriales 33 09-jun-2014 22:47
Configuración de Apache de Forma Gráfica Mazinger Z Hardware 0 29-jun-2008 04:21
Problema con Apache CGSHBL Internet, Redes y Wireless 12 03-oct-2007 16:11
Problema con mi Servidor Apache cejodrake Internet, Redes y Wireless 23 21-sep-2006 19:08
apache/ no me funk :S linuxero Software 3 19-jul-2006 19:51



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 22:03.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba