Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Escritorios: KDE, Gnome, otros...


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Error nombre repositorio y consiguiente bloqueo de todos los repositorios
  #1  
Antiguo 18-mar-2010, 12:47
newbie009 newbie009 está desconectado
Aforado
 
Fecha de Ingreso: 16-marzo-2010
Versión: openSUSE 11.2.2
Mensajes: 5
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
newbie009 está en el buen camino
Exclamation Error nombre repositorio y consiguiente bloqueo de todos los repositorios

Un saludo a la comunidad de openSUSE.

He instalado hace poco openSUSE 11.2 sin problemas. He ido añadiendo los repositorios con YaST y he hecho un error con el nombre de un repositorio de Gnome Contrib. El nombre lo copié de la página web de los repositorios Gnome y no me di cuenta de que habia dos símbolos entre dos de las palabras del título. Cuando traté de actualizar me dió este mensaje de error:

ERROR /etc/zypp/repos.d/Gnome_Contrib_openSUSE_ 11.2
Icon-repos Line3 is missing "=" sign

y me indica que busque ayuda en zypper.

Como resultado el YaST no funciona ya que cada vez que trato de hacer algo con los repoositorios aparece ese error y ademas la lista de repositorios ha desaparecido de la pantalla de YaST.

He intentado borrar este repositorio desde una Terminal con

zypper rr

y también desactivarlo pero me volvió a dar el mismo error en ambos casos.

Luego intenté cambiar el nombre del fichero donde esta almacenado ese repositorio (para eliminar los símbolos del título que bloquean todo) pero no lo logré con gedit como root porque curiosamente me permitia cambiar el contenido del fichero pero no su titulo. La opción "rename" aparece desactivada en todos los intentos que he hecho.

Gracias por adelantado por la ayuda que podáis darme.

Última edición por newbie009; 18-mar-2010 a las 13:00 Razón: Corregir título
Responder Citando
  #2  
Antiguo 18-mar-2010, 14:01
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.585
Agradecimientos: 568
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Porque no lo borras como superusuario root: rm /etc/zypp/repos.d/Gnome_Contrib_openSUSE_ 11.2.repo

Si no es ese el nombre correcto, entra en la carpeta /etc/zypp/repos.d y borralo a mano.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
newbie009 (18-mar-2010)
Si pero ¿cómo se borra a mano un fichero si se necesita ser superusuario para ello?
  #3  
Antiguo 18-mar-2010, 15:05
newbie009 newbie009 está desconectado
Aforado
 
Fecha de Ingreso: 16-marzo-2010
Versión: openSUSE 11.2.2
Mensajes: 5
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
newbie009 está en el buen camino
Smile Si pero ¿cómo se borra a mano un fichero si se necesita ser superusuario para ello?

Muchas gracias por la respuesta.:
Lo primero ya lo intenté pero sin resultado.
Intentaré lo segundo pero ayer cuando intenté cambiar al menos el nombre del archivo (es hay donde hay los iconos que crean todo el problema) no pude ni usando gedit como root ni entrando terminal mc. Perdón por adelantado porque quizas sea algo simple pero dado mi carácter de novato pues no lo consigo.
Responder Citando
  #4  
Antiguo 19-mar-2010, 10:47
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.585
Agradecimientos: 568
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
A lo mejor esta pillado, es decir, que se esta ejecutando y por eso no te deja borrarlo. Para borrarlo
cd /etc/zypp/repos.d/
sudo rm -f "Nombre del fichero completo.repo"


Para matar un proceso como superusuario:
top
sudo kill -9 nº_del_proceso

La ejecución del comando sudo requiere introducir la contraseña del superusuario root.
Mas informacion: http://mundogeek.net/archivos/2004/0...ndows-y-linux/
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
newbie009 (28-mar-2010)
El problema lo tengo en el nombre del fichero
  #5  
Antiguo 19-mar-2010, 11:04
newbie009 newbie009 está desconectado
Aforado
 
Fecha de Ingreso: 16-marzo-2010
Versión: openSUSE 11.2.2
Mensajes: 5
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
newbie009 está en el buen camino
Question El problema lo tengo en el nombre del fichero

Muchas gracias de nuevo por las sugerencias paqra resolver este bug.

No me ha funcionado porque el problema lo tengo en el nombre del fichero que tiene dos iconos (como dije es el producto de haber copiado el titulo de la pagina web y luego ha traducido algo que habia alli como dos iconos que aparecen -por ejemplo al abrir el fichero con gedit- como dos rectangulos entre dos palabras del titulo).
Cuando pongo el nombre del fichero sin estos iconos lo que obtengo es esto:

linux-w5l1:~ # zypper mr /etc/zypp/repos.d/GNOME:_Contrib_openSUSE_11.2.repoUnexpected exception.
/etc/zypp/repos.d/GNOME:_Contrib_openSUSE_11.2

Icon_.repo: Line 3 is missing '=' sign
Please file a bug report about this.
See http://en.opensuse.org/Zypper/Troubleshooting for instructions.

Pienso aue lo mejor sería poder borrar el fichero entero y luego volver a introducir el repositorio, pero como dije, no sé como hacerlo.

Gracias por adelantado de la posible ayuda que puedas darme.
Responder Citando
  #6  
Antiguo 19-mar-2010, 11:22
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.585
Agradecimientos: 568
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
ls -al
Y copias el nombre completo del repo que quieres borrar y lo pones entre comillas
O usa el tabulador para completar el nombre según lo vas escribiendo.

Suerte y adiós.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Solucionado pero....
  #7  
Antiguo 28-mar-2010, 16:22
newbie009 newbie009 está desconectado
Aforado
 
Fecha de Ingreso: 16-marzo-2010
Versión: openSUSE 11.2.2
Mensajes: 5
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
newbie009 está en el buen camino
Cool Solucionado pero....

Solucionado pero a las bravas. Es decir reinstalando openSUSE. En las soluciones propuestas consistían siempre en poner el nombre del fichero. Como este nombre contenía icnonos pues no sabía como escribirlos en la terminal y me daba error. Lo de autocompletar con Tab tampoco funcionó pues el nombre del fichero no lo había escrito antes.

Por si le sirve a alguien que no cometa el error que yo hice de copiar el nombre del repositorio de la página web con sus iconos (no me di cuenta de esto). que utilice como nombre del repositorio sólo lo permitido en el nombre de los ficheros.

También intenté borrar el fichero entrando con el Live CD pero no me dejo porque me indicaba que no tenía los derechos suficientes.

Gracias por las respuestas ya que me han permitido aprender mas sobre openSUSE
Responder Citando
Respuesta

Marcadores

Etiquetas
repositorios, yast, zypper


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Repositorios suse 11.2 kintaro Software 14 18-abr-2010 00:22
Manual zypper para 11.1 (Traducción al español) tranzorx FAQs, Manuales y Tutoriales 11 22-ene-2010 00:21
plasma en kde4.1 no arranca ÆPEDRAZA Software 18 27-sep-2008 01:13
Todos los servidores de repositorios han desaparecido de repente amungar Escritorios: KDE, Gnome, otros... 13 15-ene-2008 19:10
dvd con todos los repositorios juliandojal Instalación y Actualizaciones 2 05-jun-2007 13:30



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 08:43.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba