Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Supuestamente no existe la libreria, pero si, ayuda¡¡¡ libstdc++.so.6
  #1  
Antiguo 30-ene-2010, 01:41
mrkarateka10 mrkarateka10 está desconectado
Aforado
 
Fecha de Ingreso: 30-enero-2010
Versión: 11.1
Mensajes: 4
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
mrkarateka10 está en el buen camino
Exclamation Supuestamente no existe la libreria, pero si, ayuda¡¡¡ libstdc++.so.6

Amigos tengo opensuse 11.1, todo iba bien hasta q decidi instalar guest y con ello gcc, y otras cosas q no recuerdo, despues de eso, reinicie mi pc y sorpresa, no abre ni el nautilus, ni mplayer, y el mas importante yast2(no funciona zypper), sin el no puedo instalar nada¡¡¡¡. Aqui esta el error q me aparece cuando intento abrir yast2

/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/liby2util.so.4)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libblocxx.so.6)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by /usr/lib/YaST2/plugin/libpy2gtk.so.2)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/YaST2/plugin/libpy2gtk.so.2)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libblocxx.so.6)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libyui.so.3)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by /usr/lib/libzypp.so.523)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libzypp.so.523)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/liby2util.so.4)
/usr/lib/YaST2/plugin/libpy2gtk.so.2: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libboost_signals.so.1.36.0)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.10' not found (required by /usr/lib/libycp.so.3)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/liby2.so.2)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libycpvalues.so.3)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/liby2util.so.4)
/usr/lib/YaST2/bin/y2base: /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/libblocxx.so.6)
Gtk-Message: Failed to load module "gnomebreakpad": /lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found (required by /usr/lib/bug-buddy/libbreakpad.so.0)


aclaro que la libreria esta en /lib y en /usr/lib..
ayuda no se q hacer
debo reinstalar todo???
Responder Citando
  #2  
Antiguo 30-ene-2010, 08:43
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Castellón
Versión: Tumbleweed+Kde
Mensajes: 3.369
Agradecimientos: 325
Agradecido 482 Veces en 399 Mensajes
Poder de Credibilidad: 13
jesusx está en el buen camino
Podrias reparar el sistema con el dvd
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
  #3  
Antiguo 30-ene-2010, 09:23
RedDwarf RedDwarf está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 11-mayo-2006
Versión: openSUSE 12.1
Mensajes: 1.531
Agradecimientos: 0
Agradecido 29 Veces en 26 Mensajes
Poder de Credibilidad: 13
RedDwarf está en el buen camino
Al menos en openSUSE 11.2 libstdc++ está en /usr/lib, no en /lib. Así que es bien posible que aun tengas la versión buena en /usr/lib y el único problema es que el sistema usa la primera que encuentra y busca antes en /lib.
Si es el caso simplemente borra la versión en /lib y solucionado.
Si la versión del sistema está jodida reinstálala con "rpm -i libstdc++<loquesea>.rpm", que está programado en C y no necesita de esa librería como zypper.

En cualquier caso, supongo que en la 11.1 libstdc++ también está en /usr/lib. Así que para haber acabado con una versión en /lib o has compilado a mano o has instalado un RPM que no era de openSUSE (encontrado en alguna web buscadora de RPMs?).
a) RPMs instala de Packman, de los repositorios oficiales, de http://download.opensuse.org/repositories/ y como mucho algún programa concreto tipo Skype. **NO** instales el primer RPM que encuentres, que usemos el mismo formato no significa que un RPM de Fedora o Mandriva vaya a funcionar correctamente en openSUSE. Y si vas a hacerlo, que sea con programas y no con librerías... y si vas a hacerlo con librerías que no sea con la segunda librería más básica del sistema!!!
Si quieres un buscador de RPMs usa sólo los específicos de openSUSE (y que sean exactamente para tu versión): http://packages.opensuse-community.org/ o http://software.opensuse.org/search
b) Compila sólo si es necesario. Si quieres un programa que no está en RPM para openSUSE... pide a algún empaquetador que lo cree y lo incluya en http://download.opensuse.org/repositories/

Usa sólo RPMs para tu versión de openSUSE y estas cosas no pasarán.


P.D. en ningún momento te está diciendo que no existe la librería, sólo que es una versión demasiado vieja.

Última edición por RedDwarf; 30-ene-2010 a las 09:25
Responder Citando
  #4  
Antiguo 30-ene-2010, 16:27
mrkarateka10 mrkarateka10 está desconectado
Aforado
 
Fecha de Ingreso: 30-enero-2010
Versión: 11.1
Mensajes: 4
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
mrkarateka10 está en el buen camino
mi querido amigo RED, me has salvado la patria¡¡¡¡, muchas gracias, lo que hice fue borrar la libreria de /lib, y puse un enlace a la de /usr/lib, y Eureka, funciono
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Multiples cuestiones sobre opensuse por un usuario de ubuntu dudoso100 General OpenSUSE 18 27-ene-2009 21:16
Problemas con la actualización de OpenSuse 10.3 gery Instalación y Actualizaciones 18 28-oct-2007 17:43



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 22:16.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba