Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

[solucionado] Opensuse 11.2 no detecta dispotivos usb
  #1  
Antiguo 13-nov-2009, 23:51
Avatar de oscarpoio
oscarpoio oscarpoio está desconectado
Miembro Junior
 
Fecha de Ingreso: 25-noviembre-2006
Versión: 11.2
Mensajes: 544
Agradecimientos: 0
Agradecido 18 Veces en 12 Mensajes
Poder de Credibilidad: 11
oscarpoio está en el buen camino
[solucionado] Opensuse 11.2 no detecta dispotivos usb

Solucionado actualizando al kernel 2.6.31.12-0.1.1



Saludos

He instalado opensuse 11.2 tanto en un pc de sobremesa como en un netbook (medion akoya mini E1210), en ambos funcionaba sin problema la versión 11.1.

En el caso del pc sobremesa todo va como la seda y funciona correcatamente, sin embargo en el caso del netbook, detectando pefectamente todo incluida wiffi y webcam, ha aparecido un extraño problema, no monta los dispositivos usb.

El proceso de instalación en este caso lo he hecho conectando un lector CD/DVD por USB, y ha ido sin problemas, sin embargo tras la instalación no detecta ningún dispositivo USB que se conecte.

Como no sé si se trata de un bug, o de un fallo mío, lo planteo aquí para ver si a alguien le suena lo que está pasando antes de plantearlo como bug.

Actualizado
- Parece no detectar los dispositivos usb conectados, ya que al hacer un lsusb muestra todos como "linux Foundation ....", vamos en ningún caso el dispositivo que se ha conectado.

- Obviamente al intenetar montar a "mano el dispositivo usb". el mensaje que se devuelve es "el dispostivio especial /dev/sdb1 no existe" (ya que no lo detecta obviamente)


Alguien tiene una idea, de que puede estar sucediendo??

lsusb
Cita:
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 5986:0141 Acer, Inc
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
dmesg | grep -i usb
Cita:
[ 0.336150] usbcore: registered new interface driver usbfs
[ 0.336156] usbcore: registered new interface driver hub
[ 0.336182] usbcore: registered new device driver usb
[ 0.912837] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 0.913374] ehci_hcd 0000:00:1d.7: new USB bus registered, assigned bus number 1
[ 0.927028] ehci_hcd 0000:00:1d.7: USB 2.0 started, EHCI 1.00
[ 0.927109] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[ 0.927119] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 0.927129] usb usb1: Product: EHCI Host Controller
[ 0.927136] usb usb1: Manufacturer: Linux 2.6.31.5-0.1-desktop ehci_hcd
[ 0.927145] usb usb1: SerialNumber: 0000:00:1d.7
[ 0.927426] usb usb1: configuration #1 chosen from 1 choice
[ 0.927520] hub 1-0:1.0: USB hub found
[ 0.927754] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 0.927821] uhci_hcd: USB Universal Host Controller Interface driver
[ 0.928110] uhci_hcd 0000:00:1d.0: new USB bus registered, assigned bus number 2
[ 0.928252] usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
[ 0.928267] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 0.928278] usb usb2: Product: UHCI Host Controller
[ 0.928286] usb usb2: Manufacturer: Linux 2.6.31.5-0.1-desktop uhci_hcd
[ 0.928294] usb usb2: SerialNumber: 0000:00:1d.0
[ 0.928529] usb usb2: configuration #1 chosen from 1 choice
[ 0.928628] hub 2-0:1.0: USB hub found
[ 0.928946] uhci_hcd 0000:00:1d.1: new USB bus registered, assigned bus number 3
[ 0.929126] usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
[ 0.929136] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 0.929145] usb usb3: Product: UHCI Host Controller
[ 0.929153] usb usb3: Manufacturer: Linux 2.6.31.5-0.1-desktop uhci_hcd
[ 0.929161] usb usb3: SerialNumber: 0000:00:1d.1
[ 0.929392] usb usb3: configuration #1 chosen from 1 choice
[ 0.929492] hub 3-0:1.0: USB hub found
[ 0.929829] uhci_hcd 0000:00:1d.2: new USB bus registered, assigned bus number 4
[ 0.929983] usb usb4: New USB device found, idVendor=1d6b, idProduct=0001
[ 0.929993] usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 0.930024] usb usb4: Product: UHCI Host Controller
[ 0.930032] usb usb4: Manufacturer: Linux 2.6.31.5-0.1-desktop uhci_hcd
[ 0.930040] usb usb4: SerialNumber: 0000:00:1d.2
[ 0.930264] usb usb4: configuration #1 chosen from 1 choice
[ 0.930363] hub 4-0:1.0: USB hub found
[ 0.931108] uhci_hcd 0000:00:1d.3: new USB bus registered, assigned bus number 5
[ 0.931276] usb usb5: New USB device found, idVendor=1d6b, idProduct=0001
[ 0.931286] usb usb5: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[ 0.931296] usb usb5: Product: UHCI Host Controller
[ 0.931303] usb usb5: Manufacturer: Linux 2.6.31.5-0.1-desktop uhci_hcd
[ 0.931312] usb usb5: SerialNumber: 0000:00:1d.3
[ 0.931564] usb usb5: configuration #1 chosen from 1 choice
[ 0.931660] hub 5-0:1.0: USB hub found
[ 0.931866] Initializing USB Mass Storage driver...
[ 0.932052] usbcore: registered new interface driver usb-storage
[ 0.932063] USB Mass Storage support registered.
[ 0.932210] usbcore: registered new interface driver libusual
[ 0.932257] usbcore: registered new interface driver ums-alauda
[ 0.932307] usbcore: registered new interface driver ums-cypress
[ 0.932354] usbcore: registered new interface driver ums-datafab
[ 0.932397] usbcore: registered new interface driver ums-freecom
[ 0.932443] usbcore: registered new interface driver ums-isd200
[ 0.932493] usbcore: registered new interface driver ums-jumpshot
[ 0.932537] usbcore: registered new interface driver ums-karma
[ 0.932582] usbcore: registered new interface driver ums-onetouch
[ 0.932633] usbcore: registered new interface driver ums-sddr09
[ 0.932680] usbcore: registered new interface driver ums-sddr55
[ 0.932725] usbcore: registered new interface driver ums-usbat
[ 0.954321] usbcore: registered new interface driver hiddev
[ 0.954377] usbcore: registered new interface driver usbhid
[ 0.954387] usbhid: v2.6:USB HID core driver
[ 1.319043] usb 1-5: new high speed USB device using ehci_hcd and address 2
[ 1.633813] usb 1-5: New USB device found, idVendor=5986, idProduct=0141
[ 1.633824] usb 1-5: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[ 1.633834] usb 1-5: Product: BisonCam, NB Pro
[ 1.634076] usb 1-5: configuration #1 chosen from 1 choice
[ 1.770036] usb 1-6: new high speed USB device using ehci_hcd and address 3
[ 1.896051] usb 1-6: New USB device found, idVendor=0bda, idProduct=0158
[ 1.896063] usb 1-6: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1.896074] usb 1-6: Product: USB2.0-CRW
[ 1.896081] usb 1-6: Manufacturer: Generic
[ 1.896088] usb 1-6: SerialNumber: 20071114173400000
[ 1.896337] usb 1-6: configuration #1 chosen from 1 choice
[ 1.904642] scsi4 : SCSI emulation for USB Mass Storage devices
[ 1.906313] usb-storage: device found at 3
[ 1.906324] usb-storage: waiting for device to settle before scanning
[ 2.910327] usb-storage: device scan complete
[ 7.209498] input: BisonCam, NB Pro as /devices/pci0000:00/0000:00:1d.7/usb1/1-5/1-5:1.0/input/input7
[ 7.209731] usbcore: registered new interface driver uvcvideo
[ 7.209748] USB Video Class driver (v0.1.0)
[ 18.381541] hub 1-0:1.0: Cannot enable port 6. Maybe the USB cable is bad?
[ 18.381707] hub 1-0:1.0: Cannot enable port 6. Maybe the USB cable is bad?
[ 18.381872] hub 1-0:1.0: Cannot enable port 6. Maybe the USB cable is bad?
[ 18.382072] hub 1-0:1.0: Cannot enable port 6. Maybe the USB cable is bad?
__________________
Opensuse 12.1 en imac 21,5 (abril 2011) - triple boot (¿como hacerlo?... manual AQUÍ)

Última edición por oscarpoio; 08-feb-2010 a las 19:16
Responder Citando
  #2  
Antiguo 14-nov-2009, 00:15
Avatar de oscarpoio
oscarpoio oscarpoio está desconectado
Miembro Junior
 
Fecha de Ingreso: 25-noviembre-2006
Versión: 11.2
Mensajes: 544
Agradecimientos: 0
Agradecido 18 Veces en 12 Mensajes
Poder de Credibilidad: 11
oscarpoio está en el buen camino
Sigo investigando, gracias a lo publicando en este foro y "aprendiendo" (que siempre se agradece), resulta que parece ser que no tengo cargados los módulos USB, ver para creer jaja

Al ejecutar "lsmod | grep usb", el resultado es "nada" con lo cual ahí podría estar el fallo, voy a ver que módulos y como cargarlos .

¿alguna idea de por donden pueden ir los tiros?
__________________
Opensuse 12.1 en imac 21,5 (abril 2011) - triple boot (¿como hacerlo?... manual AQUÍ)

Última edición por oscarpoio; 14-nov-2009 a las 03:41
Responder Citando
  #3  
Antiguo 14-nov-2009, 08:45
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.470
Agradecimientos: 563
Agradecido 2.415 Veces en 1.626 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Los modulos depende de la motherboard en mi caso son usbcore, hci_usb, ehci_hcd y uhci_hcd
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #4  
Antiguo 14-nov-2009, 10:37
Avatar de oscarpoio
oscarpoio oscarpoio está desconectado
Miembro Junior
 
Fecha de Ingreso: 25-noviembre-2006
Versión: 11.2
Mensajes: 544
Agradecimientos: 0
Agradecido 18 Veces en 12 Mensajes
Poder de Credibilidad: 11
oscarpoio está en el buen camino
Gracias, probaré con esos, supongo que para cargarlos hay que usar modprobe pero ¿para que los cargue al inicio del sistema que archivo habría que editar?

Por cierto en el pc de sobremesa sólo me sale con el lsmod | grep usb el módulo usblp (supongo que el de impresión) pero ninguno de los que te aparecen a ti jeje

Voy a ir probando a ver que sale, gracias por la información.
__________________
Opensuse 12.1 en imac 21,5 (abril 2011) - triple boot (¿como hacerlo?... manual AQUÍ)
Responder Citando
  #5  
Antiguo 14-nov-2009, 12:50
Avatar de oscarpoio
oscarpoio oscarpoio está desconectado
Miembro Junior
 
Fecha de Ingreso: 25-noviembre-2006
Versión: 11.2
Mensajes: 544
Agradecimientos: 0
Agradecido 18 Veces en 12 Mensajes
Poder de Credibilidad: 11
oscarpoio está en el buen camino
Cuando pensaba que estaba solucionado, tras una instalación si los detectaba, nuevamente al reinicar sigue sin funcionar y sin cargar los módulos.
__________________
Opensuse 12.1 en imac 21,5 (abril 2011) - triple boot (¿como hacerlo?... manual AQUÍ)

Última edición por oscarpoio; 14-nov-2009 a las 14:15
Responder Citando
  #6  
Antiguo 14-nov-2009, 17:26
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.470
Agradecimientos: 563
Agradecido 2.415 Veces en 1.626 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Mira los mensajes del kernel.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #7  
Antiguo 14-nov-2009, 18:14
Avatar de oscarpoio
oscarpoio oscarpoio está desconectado
Miembro Junior
 
Fecha de Ingreso: 25-noviembre-2006
Versión: 11.2
Mensajes: 544
Agradecimientos: 0
Agradecido 18 Veces en 12 Mensajes
Poder de Credibilidad: 11
oscarpoio está en el buen camino
Durante el arranque del sistema aparece

Cita:
FATAL ahci module not found
Haciendo un dmseg he "rescatado" estas líneas de error, que tal vez tengan que ver

Cita:

hub 1-0:1.0. cannont reset port 6 (err= -108)
....
hub 1-0:1.0: cannot enable port 6. Maybe the USB cable is bad?
dmseg completo
mensajes_dmseg.tar.gz


Curiosamente tras la instalación, antes de reiniciar el equipo detecta pefectamente todos los dispositivos usb.
__________________
Opensuse 12.1 en imac 21,5 (abril 2011) - triple boot (¿como hacerlo?... manual AQUÍ)

Última edición por oscarpoio; 14-nov-2009 a las 18:27
Responder Citando
  #8  
Antiguo 15-nov-2009, 13:02
Avatar de oscarpoio
oscarpoio oscarpoio está desconectado
Miembro Junior
 
Fecha de Ingreso: 25-noviembre-2006
Versión: 11.2
Mensajes: 544
Agradecimientos: 0
Agradecido 18 Veces en 12 Mensajes
Poder de Credibilidad: 11
oscarpoio está en el buen camino
Ahora que bugzilla ha vuelto, lo he reportado a ver si descubrimos la causa de la misteriosa desparición de los USB ejeje


No se si lo habré explicado bien, pero alguna vez tiene que ser la primera que se usa bugzilla


https://bugzilla.novell.com/show_bug.cgi?id=555623
__________________
Opensuse 12.1 en imac 21,5 (abril 2011) - triple boot (¿como hacerlo?... manual AQUÍ)

Última edición por oscarpoio; 15-nov-2009 a las 13:10
Responder Citando
  #9  
Antiguo 15-nov-2009, 16:00
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.470
Agradecimientos: 563
Agradecido 2.415 Veces en 1.626 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Podias haber dado la salida de "lsmod | grep -i usb" y "dmesg | grep -i usb" como archivos adjuntos en formato txt
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #10  
Antiguo 15-nov-2009, 17:10
Avatar de oscarpoio
oscarpoio oscarpoio está desconectado
Miembro Junior
 
Fecha de Ingreso: 25-noviembre-2006
Versión: 11.2
Mensajes: 544
Agradecimientos: 0
Agradecido 18 Veces en 12 Mensajes
Poder de Credibilidad: 11
oscarpoio está en el buen camino
Incluí el dmseg, supongo que lo planteas (desconozco como funcionan casi todos los comandos de este tipo) es sólo sacar los datos relativos al usb de los mensajes del kernel ¿no?

Con respecto a lsmod | grep -i usb no me da ningún dato de salida. Lo indicaré también en bugzilla supongo que todo dato que se añada será útil.

Por cierto que ahora los usb funcionan aleatoriamente, en ocasiones tras el arranque funciona y otras no funciona, así que supongo que algo estará provocando este funcionamiento anómalo. Lo indicaré también en bugzilla.

dmesg_grep_usb.txt
__________________
Opensuse 12.1 en imac 21,5 (abril 2011) - triple boot (¿como hacerlo?... manual AQUÍ)

Última edición por oscarpoio; 15-nov-2009 a las 21:21
Responder Citando
Respuesta

Marcadores

Etiquetas
deteccion, usb


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
openSUSE 11.2 será liberado el 12 de Noviembre GNW Noticias 0 25-abr-2009 03:55
Calendario del openSuSE 11.2 Dux Noticias 10 14-ene-2009 23:35
Planes para openSUSE 11.2 RGB Noticias 6 19-dic-2008 12:00
Anuncio oficial openSUSE 11.0 (español) elpreto Portal de ForoSUSE 66 18-ago-2008 16:48
Guía de Instalación de OpenSuSE 10.3 DiabloRojo Instalación y Actualizaciones 5 11-feb-2008 10:41



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 15:12.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba