Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Instalacion openSUSE 11, problema con particiones
  #1  
Antiguo 26-sep-2008, 05:31
carlos-cv-907 carlos-cv-907 está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2007
Versión: 10.3
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
carlos-cv-907 está en el buen camino
Instalacion openSUSE 11, problema con particiones

Tengo instalado ubuntu en la partición /dev/sda5.

Intenté instalar openSUSE 11 en la partición siguiente /dev/sda6.

Sin embargo el sistema de instalación de SUSE me indica que está ocupada y que no la puedo utilizar.

Le di formato con SystemRescue (un disco vivo) que extrañamente la designó como /dev/sda9.

Aunque pude instalar openSUSE luego de esa operación se me desconfiguró el Grub y sólo puedo ingresar a WinXP y a Ubuntu. El grub ya lo reparé y rearmé con las herramientas gráficas de openSUSE. Sin embargo sigue sin funcionar y no puedo ingresar a openSUSE de manera normal (sólo con SuperGrub Disk o con el disco de instalación de la distro). Supongo que es un problema de interpretación de las particiones.

Como alternativa se me ocurre editar el fstab (en modo gráfico con gparted no puedo demontar las particiones) en Ubuntu (preguntaré en el foro respectivo).

Mi pregunta en este foro es si alguien conoce algún truco para evitar ese problema. La partición no está ocupada, no tiene archivos, siemplemente Ubuntu la montó de manera automática. O bien si es un bug del proceso de instalación de openSUSE 11.

Lo que pienso es instalar de nuevo, pero antes debo encontrar la manera para que openSUSE no lea esa partición como ocupada.

Antes tuve conviviendo en una misma computadora Linux Mint (derivado de Ubuntu, instalado primero) y openSUSE 10.3 y no tuve ese problema al instalar.

Las particiones que tengo son:

dev/sda1 * 1 3947 31704246 7 HPFS/NTFS (aquí tengo WinXP)
/dev/sda2 3948 25875 176136628+ 7 HPFS/NTFS (Mis documentos de WinXP)
/dev/sda3 25876 30401 36355095 f W95 Ext'd (LBA)
/dev/sda5 25876 26895 8193118+ 83 Linux (aquí tengo Ubuntu)
/dev/sda6 26896 27813 7373803+ 83 Linux (aquí instalé openSUSE)
/dev/sda7 27814 28731 7373803+ 83 Linux (aquí pensaba instalar Mandriva)
/dev/sda8 28732 28865 1076323+ 82 Linux swap / Solaris
/dev/sda9 28866 30401 12337888+ 83 Linux (partición para compartir archivos)

Lo curioso es que en Ubuntu esas particiones no me aparecen en el fstab, sólo en modo gráfico. El fstab de Ubuntu sólo dice lo siguiente (esto lo consultaré en http://www.ubuntu-es.org/)

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# /dev/sda5
UUID=6b935816-fa82-4edb-8361-a63aeebe29d3 / ext3 relatime,errors=remount-ro 0 1
/dev/sda8 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0
Responder Citando
mi experiencia
  #2  
Antiguo 26-sep-2008, 05:45
Avatar de chiquimouse
chiquimouse chiquimouse está desconectado
Habitual
 
Fecha de Ingreso: 21-diciembre-2006
Ubicación: Bogotá colombia
Versión: 11 X86_64
Mensajes: 212
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 11
chiquimouse está en el buen camino
Enviar un mensaje por MSN a chiquimouse
mi experiencia

Hola , bueno te cuento mi experiencia siempre que instale ubuntu y luego opensuse, no podia instalar opensuse porque me decia que no se podia particionar el disco, otra de las cosas que me gusta de opensuse es que si puedo seleccionar como partionarre el disco el tipo de partcion y demas, claro que ubuntu tmabien pero no me es tan expplicito y claro como opensuse.

la solucion fue instalar ubuntu y seleccionar todas las particiones como logicas (nose si esto este mal pero siempre me funciono) y al momento de instalar opensuse ya me dejaba crear extendida y particionar para seguir con la instalacion, el grub me mostraba windows, ubuntu y mi opensuse sin problemas

espero te sirve mi experiencia y solución

suerte
__________________
chiquilinux Blog tutoriales opensuse 11
Responder Citando
  #3  
Antiguo 26-sep-2008, 08:19
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.478
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Algun error aparecera a intentar entrar en openSUSE 11.0 y en que punto
ocurre.

¿Que grub estas utilizando el de Ubuntu o openSUSE?, esto es muy importante dejarlo claro, si no sabes cual es el que carga, apunta los nombres de las opciones que aparece.

Y adjunta el menu.lst de Ubuntu y openSUSE.

Todo esto que te estoy preguntado lo he explicado mil veces en el foro: busca por "grub opensuse ubuntu"
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #4  
Antiguo 26-sep-2008, 18:54
carlos-cv-907 carlos-cv-907 está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2007
Versión: 10.3
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
carlos-cv-907 está en el buen camino
Las particiones son lógicas y las realizo de previo antes de instalar.

El Grub que estoy utilizando es el de openSUSE, pero me aparece sin la imagen de fondo, sólo en formato de texto. Con ese Grub solo puedo ingresar a Windows y a Ubuntu. El de Ubuntu me aparece cuando le doy click a la opción para ingresar a Ubuntu.

Otra opción sería editar el grub de Ubuntu, para integrar opensuse (pero no se si funciona sin la imagen) y restaurar el de Ubuntu con SuperGrubDisk.

Eso lo he hecho antes desde Win2 con Notepad++ y viendo las particiones de Linux con Explore2fs.

Mi duda es si no hay un problema de interpretación de los datos del Grub y la partición, porque está en sda5, pero cuando le di formato con System Rescue, que uso para crear las particiones o modificarlas, la convirtió en sda9. Pero al instalar con OpenSUSE me aparecía como sda5.

Voy a revisar con el buscador "grub opensuse ubuntu" pero me temo que este sea un problema diferente, porqué el instalador de openSUSE no me dejaba usar la partición sda5 con el mensaje que estaba ocupada (no tenía datos ni nada ahí), solo estaba montada en Ubuntu. Antes con OS 10.3 no tuve este problema.

Última edición por carlos-cv-907; 26-sep-2008 a las 18:58
Responder Citando
  #5  
Antiguo 26-sep-2008, 19:04
carlos-cv-907 carlos-cv-907 está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2007
Versión: 10.3
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
carlos-cv-907 está en el buen camino
Si no funciona reparar el grub, voy a desmontar esa partición en Ubuntu e instalo de nuevo openSUSE.
En el foro Ubuntu-es.org me informan que puedo desmontar así:
Ejecuta en una consola:
sudo umount /dev/sda5
Esto no afecta a ninguna otra partición
Responder Citando
  #6  
Antiguo 26-sep-2008, 19:58
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.478
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Desde Ubuntu, ejecuta "sudo fdisk -l" y danos su salida, monta la particion de OpenSUSE "mount /dev/sda5 /mnt/opensuse", ojo crea antes la carpeta /mnt/opensuse para darnos los archivos de openSUSE /mnt/opensuse/boot/grub/menu.lst y /mnt/opensuse/etc/fstab

Sin datos, pocos te puede ayudarte ya que no somos adivinos.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #7  
Antiguo 27-sep-2008, 08:28
carlos-cv-907 carlos-cv-907 está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2007
Versión: 10.3
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
carlos-cv-907 está en el buen camino
De momento puedo decir que corriendo el disco de instalación de openSUSE y las opciones para recuperar el sistema ingresé a la reparación del Grub.
Me di cuenta que había un error en el párametro devfs=mount,dall resume=/dev/sda9 splash=silent showopts. Lo cambié por devfs=mount,dall resume=/dev/sda6 splash=silent showopts y pude ingresar a openSUSE, además se configuró el Grub en modo gráfico.
Sin embargo solo me aparecía openSUSE y no los otros sistemas operativos.
Ingresé a openSUSE y en la opción para configurar el cargador de arranque hice dos pruebas:
- Con proponer una nueva configuración me aparecen los otros sistemas operativos y me queda el Grub bien en modo gráfico pero sólo puedo ingresar a openSUSE, no a Ubuntu ni a Windows.
- Con proponer y fusionar con los grub existentes vuelvo de nuevo a un Grub en modo de texto que solo me permite ingresar a Ubuntu y Windows, pero no a openSUSE.

La configuración actual del GRUB (con el cambio mencionado) es

# Modified by YaST2. Last modification on vie sep 26 23:01:12 CST 2008
default 3
timeout 8
gfxmenu


###Don't change this comment - YaST2 identifier: Original name: linux###

title openSUSE 11.0
kernel devfs=mount,dall splash=silent showopts

###Don't change this comment - YaST2 identifier: Original name: Ubuntu 8.04.1, kernel 2.6.24-19-generic (/dev/sda5)###
title Ubuntu 8.04.1, kernel 2.6.24-19-generic (/dev/sda5)
root (hd0,4)
configfile /boot/grub/menu.lst
configfile /boot/grub/menu.lst


###Don't change this comment - YaST2 identifier: Original name: openSUSE 11.0 (/dev/sda6)###

title openSUSE 11.0 (/dev/sda6)
root (hd0,5)
configfile /boot/grub/menu.lst
configfile /boot/grub/menu.lst

###Don't change this comment - YaST2 identifier: Original name: windows 1###
title windows 1
rootnoverify (hd0)
chainloader (hd0,0)+1


###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Modo seguro -- openSUSE 11.0
kernel showopts ide=nodma apm=off acpi=off noresume nosmp noapic maxcpus=0 edd=off x11failsafe

###Don't change this comment - YaST2 identifier: Original name: Kernel-2.6.25.5-1.1-pae###
title Kernel-2.6.25.5-1.1-pae
kernel devfs=mount,dall splash=silent showopts

Nota: estoy pensando en instalar de nuevo escogiendo KDE 3.5 pues KDE4, aunque es un escritorio muy estético, presenta problemas de estabilidad. Y no sé si eso influye en las opciones para configurar el Grub.
Responder Citando
  #8  
Antiguo 27-sep-2008, 15:29
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.478
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por DiabloRojo
Desde Ubuntu, ejecuta "sudo fdisk -l" y danos su salida
Estoy esperando esto.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #9  
Antiguo 27-sep-2008, 18:38
carlos-cv-907 carlos-cv-907 está desconectado
Aforado
 
Fecha de Ingreso: 05-septiembre-2007
Versión: 10.3
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
carlos-cv-907 está en el buen camino
Ya lo había puesto en el primer post, pero respito

sudo fdisk -l
[sudo] password for carloscv:

Disco /dev/sda: 250.0 GB, 250059350016 bytes
255 cabezas, 63 sectores/pista, 30401 cilindros
Unidades = cilindros de 16065 * 512 = 8225280 bytes
Identificador de disco: 0x1fbf1fbe

Disposit. Inicio Comienzo Fin Bloques Id Sistema
/dev/sda1 * 1 3947 31704246 7 HPFS/NTFS
/dev/sda2 3948 25875 176136628+ 7 HPFS/NTFS
/dev/sda3 25876 30401 36355095 f W95 Ext'd (LBA)
/dev/sda5 25876 26895 8193118+ 83 Linux
/dev/sda6 26896 27813 7373803+ 83 Linux
/dev/sda7 27814 28731 7373803+ 83 Linux
/dev/sda8 28732 28865 1076323+ 82 Linux swap / Solaris
/dev/sda9 28866 30401 12337888+ 83 Linux

La partición sda6 corresponde a openSUSE.

Al intentar ingresar a SUSE vía Grub de este me sale el mensaje:
Error 1: Filename must be either an absolute patname or blocklist
Responder Citando
  #10  
Antiguo 27-sep-2008, 22:37
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.478
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por carlos-cv-907
title openSUSE 11.0

title Ubuntu 8.04.1, kernel 2.6.24-19-generic (/dev/sda5)

title openSUSE 11.0 (/dev/sda6)

title windows 1

title Modo seguro -- openSUSE 11.0

title Kernel-2.6.25.5-1.1-pae
Tienes una configuración y opciones muy raras, dime de las opciones cuales puedes entrar y cuales no.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Convocatoria para la comunidad Opensuse obelich General OpenSUSE 8 24-oct-2008 23:47
Anuncio oficial openSUSE 11.0 (español) elpreto Portal de ForoSUSE 66 18-ago-2008 16:48
Problema en instalación Opensuse 10.2 ptrvio Instalación y Actualizaciones 8 03-abr-2007 20:45
Problema con servidor de instalación y drivers de red GoLiaZ Instalación y Actualizaciones 0 15-sep-2006 09:02
Problema con opensuse 10 (x86 y x64) kaiseryeahhh Instalación y Actualizaciones 19 01-abr-2006 11:51



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 04:47.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba