Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Instalando Nvidia en openSUSE 11.0 [SOLUCIONADO]
  #1  
Antiguo 09-jul-2008, 22:40
Avatar de ronaldfer
ronaldfer ronaldfer está desconectado
Aforado
 
Fecha de Ingreso: 01-mayo-2007
Ubicación: Santa Cruz de la Sierra
Versión: 11.4
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
ronaldfer está en el buen camino
Instalando Nvidia en openSUSE 11.0 [SOLUCIONADO]

Hola a todos.

Bueno, decirles que me estoy cambiando a opensuse 11 para uso personal y la instalacion fue sin problemas. Lo instale con el live CD con kde 4. Luego de esto realize la actualizacion del sistema (estaba un beta de firefox 3) y todo bien.

Desde el principio me sale la imagen del monitor desfasada hacia la derecha (mi tarjeta es nvidia fx 5200), lo cual es un problema que lo solucione facilmente instalando el driver de nvidia en opensuse 10.3. Ahora para la 11 realizo el mismo proceso de instalacion del driver y para mi sorpresa no funciona.

Nunca me funciono el 1-click-install, por eso lo que siempre hago es:
+ añadir el repositorio de nvidia.
+ seleccionar e instalar los paquetes x11-video-nvidiaG01 y nvidia-gfxG01-kmp-default (en la 11 se seleccionan automaticamente).
+ luego cierro sesion y entro en modo consola. Como root ejecuto sax2 -r
+ Acepto la configuracion, reinicio y listo.

En la 11 hice esto y al parecer estaba bien, salio el logo de nvidia y me aparece la pantalla de logueo, luego inicio sesion y cuando carga se sale y me vota nuevamente a la pantalla de logueo. No puedo iniciar sesion en modo grafico de ninguna forma y para ningun usuario (incluso root). Ahora lo que yo pienso es que el driver esta instalado correctamente, pero hay algun problema con kde4 porque es ahi donde falla.

Lo volvi a intentar, pero en vez de aceptar la configuracion, le doy "cambiar configuracion" y este me lleva a la interfaz del sax2, no cambio nada y le doy aceptar y luego probar (test). Deberia aparecerme una pantalla donde hay unas flechas para mover y redimensionar (lo cual nunca entendi por que lo ponen si no se puede hacer nada ), pero esta pantalla no me aparece, parece que esta cargando y luego me vota a la interfaz del sax2.

He visto que muchas personas tienen este problema en opensuse 11 y no lo tenian en la 10.3 y que lo solucionaron compilando. Bueno pero para mi el driver esta instalado correctamente y no quisiera descargar e instalar el kernel-source, gcc, make, cuando puede ser un simple problema de configuracion. Lo raro es que yo segui el procedimiento que esta descrito en la pagina oficial de opensuse, y si lo pusieron es por que funciona.

Bueno espero puedan ayudarme.

pdta: una vez instalado el driver, cuando ejecuto startx desde consola, me sale esto:

*
*******************************************
X.Org X Server 1.4.0.90
Release Date: 5 September 2007
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux linux-yobc 2.6.25.9-0.2-default #1 SMP 2008-06-28 00:00:07 +0200 i686
Build Date: 16 June 2008 03:12:42PM

Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Jul 9 14:56:16 2008
(==) Using config file: "/etc/X11/xorg.conf"
(II) Module "ramdac" already built-in
(EE) NVIDIA OpenGL Driver requires CPUs with SSE to run.

The current CPU does not support SSE.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
> Ignoring extra symbols
Errors from xkbcomp are not fatal to the X server
Could not init font path element /usr/share/fonts/TTF/, removing from list!
Could not init font path element /usr/share/fonts/OTF, removing from list!
Could not init font path element /usr/share/fonts/Type1/, removing from list!
Could not init font path element /usr/share/fonts/100dpi:unscaled, removing from list!
/etc/X11/xim: Checking whether an input method should be started.
/etc/X11/xim: user environment variable LANG=POSIX
/etc/X11/xim: user environment variable LC_CTYPE=es_ES.UTF-8
sourcing /etc/sysconfig/language to get the value of INPUT_METHOD
INPUT_METHOD is not set or empty (no user selected input method).
Trying to start a default input method for the locale es_ES.UTF-8 ...
There is no default input method for the current locale.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Duplicate shape name ""
> Using last definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
> Warning: Multiple doodads named ""
> Using first definition
Errors from xkbcomp are not fatal to the X server
Warning: Type "ONE_LEVEL" has 1 levels, but <RALT> has 2 symbols
Ignoring extra symbols
Warning: No symbols defined for <SYRQ> (keycode 92)
Warning: No symbols defined for <II5D> (keycode 93)
Warning: No symbols defined for <II65> (keycode 101)
Warning: No symbols defined for <BRK> (keycode 114)
Warning: No symbols defined for <FK13> (keycode 118)
Warning: No symbols defined for <FK14> (keycode 119)
Warning: No symbols defined for <FK15> (keycode 120)
Warning: No symbols defined for <FK16> (keycode 121)
Warning: No symbols defined for <FK17> (keycode 122)
Warning: No symbols defined for <KPDC> (keycode 123)
Warning: No symbols defined for <XFER> (keycode 129)
Warning: No symbols defined for <I02> (keycode 130)
Warning: No symbols defined for <NFER> (keycode 131)
Warning: No symbols defined for <I04> (keycode 132)
Warning: No symbols defined for <AE13> (keycode 133)
Warning: No symbols defined for <I06> (keycode 134)
Warning: No symbols defined for <I07> (keycode 135)
Warning: No symbols defined for <I08> (keycode 136)
Warning: No symbols defined for <I09> (keycode 137)
Warning: No symbols defined for <I0A> (keycode 138)
Warning: No symbols defined for <I0B> (keycode 139)
Warning: No symbols defined for <I0C> (keycode 140)
Warning: No symbols defined for <I0D> (keycode 141)
Warning: No symbols defined for <I0E> (keycode 142)
Warning: No symbols defined for <I0F> (keycode 143)
Warning: No symbols defined for <I10> (keycode 144)
Warning: No symbols defined for <I11> (keycode 145)
Warning: No symbols defined for <I12> (keycode 146)
Warning: No symbols defined for <I13> (keycode 147)
Warning: No symbols defined for <I14> (keycode 148)
Warning: No symbols defined for <I15> (keycode 149)
Warning: No symbols defined for <I16> (keycode 150)
Warning: No symbols defined for <I17> (keycode 151)
Warning: No symbols defined for <I18> (keycode 152)
Warning: No symbols defined for <I19> (keycode 153)
Warning: No symbols defined for <I1A> (keycode 154)
Warning: No symbols defined for <I1B> (keycode 155)
Warning: No symbols defined for <K59> (keycode 157)
Warning: No symbols defined for <I1E> (keycode 158)
Warning: No symbols defined for <I1F> (keycode 159)
Warning: No symbols defined for <I20> (keycode 160)
Warning: No symbols defined for <I21> (keycode 161)
Warning: No symbols defined for <I22> (keycode 162)
Warning: No symbols defined for <I23> (keycode 163)
Warning: No symbols defined for <I24> (keycode 164)
Warning: No symbols defined for <I25> (keycode 165)
Warning: No symbols defined for <I26> (keycode 166)
Warning: No symbols defined for <I27> (keycode 167)
Warning: No symbols defined for <I28> (keycode 168)
Warning: No symbols defined for <I29> (keycode 169)
Warning: No symbols defined for <K5A> (keycode 170)
Warning: No symbols defined for <I2B> (keycode 171)
Warning: No symbols defined for <I2C> (keycode 172)
Warning: No symbols defined for <I2D> (keycode 173)
Warning: No symbols defined for <I2E> (keycode 174)
Warning: No symbols defined for <I2F> (keycode 175)
Warning: No symbols defined for <I30> (keycode 176)
Warning: No symbols defined for <I31> (keycode 177)
Warning: No symbols defined for <I32> (keycode 178)
Warning: No symbols defined for <I33> (keycode 179)
Warning: No symbols defined for <I34> (keycode 180)
Warning: No symbols defined for <K5B> (keycode 181)
Warning: No symbols defined for <K5D> (keycode 182)
Warning: No symbols defined for <K5E> (keycode 183)
Warning: No symbols defined for <K5F> (keycode 184)
Warning: No symbols defined for <I39> (keycode 185)
Warning: No symbols defined for <I3A> (keycode 186)
Warning: No symbols defined for <I3B> (keycode 187)
Warning: No symbols defined for <I3C> (keycode 188)
Warning: No symbols defined for <K62> (keycode 189)
Warning: No symbols defined for <K63> (keycode 190)
Warning: No symbols defined for <K64> (keycode 191)
Warning: No symbols defined for <K65> (keycode 192)
Warning: No symbols defined for <K66> (keycode 193)
Warning: No symbols defined for <I42> (keycode 194)
Warning: No symbols defined for <I43> (keycode 195)
Warning: No symbols defined for <I44> (keycode 196)
Warning: No symbols defined for <I45> (keycode 197)
Warning: No symbols defined for <K67> (keycode 198)
Warning: No symbols defined for <K68> (keycode 199)
Warning: No symbols defined for <K69> (keycode 200)
Warning: No symbols defined for <K6A> (keycode 201)
Warning: No symbols defined for <I4A> (keycode 202)
Warning: No symbols defined for <K6B> (keycode 203)
Warning: No symbols defined for <K6C> (keycode 204)
Warning: No symbols defined for <K6D> (keycode 205)
Warning: No symbols defined for <K6E> (keycode 206)
Warning: No symbols defined for <K6F> (keycode 207)
Warning: No symbols defined for <HKTG> (keycode 208)
Warning: No symbols defined for <KANA> (keycode 209)
Warning: No symbols defined for <EISU> (keycode 210)
Warning: No symbols defined for <AB11> (keycode 211)
Warning: No symbols defined for <I54> (keycode 212)
Warning: No symbols defined for <I55> (keycode 213)
Warning: No symbols defined for <I5A> (keycode 218)
Warning: No symbols defined for <K74> (keycode 219)
Warning: No symbols defined for <K75> (keycode 220)
Warning: No symbols defined for <K76> (keycode 221)
Warning: No symbols defined for <I5E> (keycode 222)
Warning: No symbols defined for <I5F> (keycode 223)
Warning: No symbols defined for <I60> (keycode 224)
Warning: No symbols defined for <I61> (keycode 225)
Warning: No symbols defined for <I62> (keycode 226)
Warning: No symbols defined for <I63> (keycode 227)
Warning: No symbols defined for <I64> (keycode 228)
Warning: No symbols defined for <I65> (keycode 229)
Warning: No symbols defined for <I66> (keycode 230)
Warning: No symbols defined for <I67> (keycode 231)
Warning: No symbols defined for <I68> (keycode 232)
Warning: No symbols defined for <I69> (keycode 233)
Warning: No symbols defined for <I6A> (keycode 234)
Warning: No symbols defined for <I6B> (keycode 235)
Warning: No symbols defined for <I6C> (keycode 236)
Warning: No symbols defined for <I6D> (keycode 237)
Warning: No symbols defined for <I6E> (keycode 238)
Warning: No symbols defined for <I6F> (keycode 239)
Warning: No symbols defined for <I70> (keycode 240)
Warning: No symbols defined for <I71> (keycode 241)
Warning: No symbols defined for <I72> (keycode 242)
Warning: No symbols defined for <I73> (keycode 243)
Warning: No symbols defined for <I74> (keycode 244)
Warning: No symbols defined for <I75> (keycode 245)
Warning: No symbols defined for <I76> (keycode 246)
Warning: No symbols defined for <I77> (keycode 247)
Warning: No symbols defined for <I78> (keycode 248)
Warning: No symbols defined for <I79> (keycode 249)
Warning: No symbols defined for <I7A> (keycode 250)
Warning: No symbols defined for <I7B> (keycode 251)
Warning: No symbols defined for <I7C> (keycode 252)
Warning: No symbols defined for <I7D> (keycode 253)
Warning: No symbols defined for <I7E> (keycode 254)
Warning: No symbols defined for <I7F> (keycode 255)
startkde: Starting up...
kbuildsycoca4 running...
NVIDIA OpenGL Driver requires CPUs with SSE to run.

The current CPU does not support SSE.
startkde: Shutting down...
klauncher: Exiting on signal 1
startkde: Running shutdown scripts...
startkde: Done.

waiting for X server to shut down
__________________
La libertad es un derecho, tu obligación es usarla en algo útil.

Última edición por ronaldfer; 11-jul-2008 a las 20:29
Responder Citando
  #2  
Antiguo 10-jul-2008, 02:32
Avatar de JoeTux
JoeTux JoeTux está desconectado
Habitual
 
Fecha de Ingreso: 19-febrero-2008
Ubicación: Santiago - Chile
Versión: 12.1 Kernel 3.1.0 KDE 4.8
Mensajes: 151
Agradecimientos: 17
Agradecido 22 Veces en 14 Mensajes
Poder de Credibilidad: 7
JoeTux está en el buen camino
Lightbulb

Encontre esto en la pagina de opensuse, puede que sea la solucion


Problem with some AGP graphics boards

Using AGP graphics boards with some motherboards you may need to manually add [Option "NvAGP" "2"] as shown below. This was the case with a Gigabyte GA-K8NS AMD64 motherboard and AGP Nvidia FX5200 graphics board. Without this command X failed to start.

Section "Device"

BoardName "GeForce FX 5200 (0x0322)"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
VendorName "NVidia"
Option "NvAGP" "2"

EndSection
Responder Citando
  #3  
Antiguo 10-jul-2008, 05:50
Avatar de ronaldfer
ronaldfer ronaldfer está desconectado
Aforado
 
Fecha de Ingreso: 01-mayo-2007
Ubicación: Santa Cruz de la Sierra
Versión: 11.4
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
ronaldfer está en el buen camino
Hola de nuevo.

Gracias JoeTux por responder, si eso lo leí justo despues de escribir este post y en ese momento lo intenté y no cambia nada, sigue el mismo problema.

Luego me fui por el camino facil (supuestamente), instale el kernel-source, gcc, make. Descargue el driver de la pagina de nvidia (173.14.09) y lo instale siguiendo este HOWTO:

http://www.suse.de/~sndirsch/nvidia-...ler-HOWTO.html

Reinicio la compu y ...(lo que esperaba) exactamente el mismo problema.

La verdad no seria muy urgente instalar el driver si no fuera porque hay como 1 cm de la pantalla desfazada que no puedo ver. Es solo por eso... ya que no me interesa instalar efectos de escritorios ni nada de eso.

Seguire buscando, cualquier ayuda es bienvenida.
Saludos...

pdta: Vaya que esto me esta dando pelea
__________________
La libertad es un derecho, tu obligación es usarla en algo útil.
Responder Citando
  #4  
Antiguo 10-jul-2008, 08:35
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 13.996
Agradecimientos: 335
Agradecido 1.183 Veces en 764 Mensajes
Poder de Credibilidad: 10
DiabloRojo está en el buen camino
Cita:
Iniciado por ronaldfer
(EE) NVIDIA OpenGL Driver requires CPUs with SSE to run.

The current CPU does not support SSE.
Este es el fallo y suerte en la búsqueda de la solución, ya nos contaras... NVIDIA OpenGL Driver requires CPUs with SSE to run
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   SubirImagenes    SendSpace       TextSnip  Cl1p
Responder Citando
  #5  
Antiguo 11-jul-2008, 16:48
Avatar de ronaldfer
ronaldfer ronaldfer está desconectado
Aforado
 
Fecha de Ingreso: 01-mayo-2007
Ubicación: Santa Cruz de la Sierra
Versión: 11.4
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
ronaldfer está en el buen camino
Hola.

He estado leyendo sobre SSE ( es un conjunto de instrucciones y registros) por que no tenia idea de que se trataba y efectivamente mi procesador Athlon no soporta esta tecnologia. Los de AMD recien la introdujeron con el Athlon XP (la sucesora de athlon ).

Al parecer, los nuevos driver de nvidia hacen uso de esta tecnologia y pues a nosotros nos dejaron de lado. Aceptar que tengo hardware antiguo, y hasta que me compre un nuevo procesador, voy a tener que instalar una version antigua del driver. Yo creo que con eso se soluciona ¿verdad?.

No estoy seguro desde que version empezaron con esto, asi que me descargue 2 versiones del driver: 171.06.01 y 100.14.19. Ahora mi problema esta en que me da error al compilar (en ambas). Me fijo el log /var/log/nvidia-installer.log y este en una parte me dice:
********************************************
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it
."; \
********************************************

Efectivamente, en la direccion /usr/src/linux-2.6.25.9-0.2/include/linux/ no se encuentran los archivos autoconf.h, ni auto.conf. Asi que hago lo que me dice, ejecuto como root make oldconfig && make prepare. Me vuelvo a fijar en la direccion y solo me crea el archivo autoconf.h, pero el archivo auto.conf no. ¿deberia ser asi?. La cosa que al intentar volver a instalar el driver me sale el mismo error y me vota el mismo log.

Bueno aqui me quede, no se me ocurre nada mas. ¿Voy bien o hice algo mal?. Instale por si acaso el kernel-syms. Otra cosa en yast me fijo las versiones y el kernel-default y el kernel-source estan con la 2.6.25.9-0.2, pero el linux-kernel-headers esta con la 2.6.25-8.1 y no hay otra version para instalar o actualizar.

Espero algunas sugerencias, saludos...

Pdta: mi nvidia-installer.log es este:
*
************************************
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Thu Jul 10 23:46:46 2008

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
precompiled interfaces : true
no ncurses color : false
query latest version : false
OpenGL header files : true
no questions : true
silent : false
no recursion : false
no backup : false
kernel module only : false
sanity : false
add this kernel : false
no runlevel check : false
no network : false
no ABI note : false
no RPMs : false
no kernel module : false
force SELinux : default
no X server check : false
force tls : (not specified)
X install prefix : (not specified)
X library install path : (not specified)
X module install path : (not specified)
OpenGL install prefix : (not specified)
OpenGL install libdir : (not specified)
utility install prefix : (not specified)
utility install libdir : (not specified)
doc install prefix : (not specified)
kernel name : (not specified)
kernel include path : (not specified)
kernel source path : (not specified)
kernel output path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp mirror : ftp://download.nvidia.com
RPM file list : (not specified)

Using: nvidia-installer ncurses user interface
-> License accepted.
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: Yes)
-> No matching precompiled kernel interface was found on the NVIDIA ftp site;
this means that the installer will need to compile a kernel interface for
your kernel.
-> Performing CC sanity check with CC="cc".
-> Performing CC version check with CC="cc".
-> Kernel source path: '/lib/modules/2.6.25.9-0.2-default/source'
-> Kernel output path: '/lib/modules/2.6.25.9-0.2-default/build'
-> Performing rivafb check.
-> Performing nvidiafb check.
-> Performing Xen check.
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.25.9-0.2-de
fault/source SYSOUT=/lib/modules/2.6.25.9-0.2-default/build'...
NVIDIA: calling KBUILD...
make CC=cc KBUILD_OUTPUT=/lib/modules/2.6.25.9-0.2-default/build KBUILD_VERB
OSE=1 -C /lib/modules/2.6.25.9-0.2-default/source SUBDIRS=/tmp/selfgz17813/N
VIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv modules
make -C /lib/modules/2.6.25.9-0.2-default/build \
KBUILD_SRC=/usr/src/linux-2.6.25.9-0.2 \
KBUILD_EXTMOD="/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv"
-f /usr/src/linux-2.6.25.9-0.2/Makefile \
modules
test -e include/linux/autoconf.h -a -e include/config/auto.conf || ( \
echo; \
echo " ERROR: Kernel configuration is invalid."; \
echo " include/linux/autoconf.h or include/config/auto.conf are mis
sing."; \
echo " Run 'make oldconfig && make prepare' on kernel src to fix it
."; \
echo; \
/bin/false)
mkdir -p /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/.tmp_ve
rsions ; rm -f /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/.
tmp_versions/*
make -f /usr/src/linux-2.6.25.9-0.2/scripts/Makefile.build obj=/tmp/selfgz17
813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv
cc -Wp,-MD,/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/.nv
.o.d -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.3/include -D__KERNEL
__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.25.9-0.2/include -include inclu
de/linux/autoconf.h -I/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/
src/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing
-fno-common -Werror-implicit-function-declaration -Os -fno-stack-protector -
m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-stack-boundary=
2 -march=i586 -mtune=generic -ffreestanding -DCONFIG_AS_CFI=1 -DCONFIG_AS_CF
I_SIGNAL_FRAME=1 -pipe -Wno-sign-compare -mno-sse -mno-mmx -mno-sse2 -mno-3d
now -I/usr/src/linux-2.6.25.9-0.2/include/asm-x86/mach-generic -Iinclude/asm
-x86/mach-generic -I/usr/src/linux-2.6.25.9-0.2/include/asm-x86/mach-default
-Iinclude/asm-x86/mach-default -fno-omit-frame-pointer -fno-optimize-sibling
-calls -fasynchronous-unwind-tables -Wdeclaration-after-
statement -Wno-pointer-sign -I/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-p
kg1/usr/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subsc
ripts -Wparentheses -Wpointer-arith -Wno-multichar -Werror -MD -Wsign-compar
e -Wno-cast-qual -Wno-error -D__KERNEL__ -DMODULE -DNVRM -DNV_VERSION_STRING
=\"171.06.01\" -UDEBUG -U_DEBUG -DNDEBUG -DMODULE -D"KBUILD_STR(s)=#s" -D"KB
UILD_BASENAME=KBUILD_STR(nv)" -D"KBUILD_MODNAME=KBUILD_STR(nvidia)" -c -o /
tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/.tmp_nv.o /tmp/se
lfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/nv.c
In file included from /usr/src/linux-2.6.25.9-0.2/include/linux/list.h:8,
from /usr/src/linux-2.6.25.9-0.2/include/linux/preempt.h:11
,
from /usr/src/linux-2.6.25.9-0.2/include/linux/spinlock.h:4
9,
from /usr/src/linux-2.6.25.9-0.2/include/linux/seqlock.h:29
,
from /usr/src/linux-2.6.25.9-0.2/include/linux/time.h:8,
from /usr/src/linux-2.6.25.9-0.2/include/linux/timex.h:57,
from /usr/src/linux-2.6.25.9-0.2/include/linux/sched.h:54,
from /usr/src/linux-2.6.25.9-0.2/include/linux/utsname.h:35
,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-linux.h:19,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv.c:14:
/usr/src/linux-2.6.25.9-0.2/include/linux/prefetch.h: In function ‘prefetc
h_range’:
/usr/src/linux-2.6.25.9-0.2/include/linux/prefetch.h:57: warning: pointer of
type ‘void *’ used in arithmetic
In file included from include2/asm/dma-mapping_32.h:5,
from include2/asm/dma-mapping.h:2,
from /usr/src/linux-2.6.25.9-0.2/include/linux/dma-mapping.
h:52,
from /usr/src/linux-2.6.25.9-0.2/include/asm-generic/pci-dm
a-compat.h:7,
from include2/asm/pci.h:90,
from /usr/src/linux-2.6.25.9-0.2/include/linux/pci.h:948,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-linux.h:86,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv.c:14:
/usr/src/linux-2.6.25.9-0.2/include/linux/scatterlist.h: In function ‘sg_v
irt’:
/usr/src/linux-2.6.25.9-0.2/include/linux/scatterlist.h:199: warning: pointe
r of type ‘void *’ used in arithmetic
In file included from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-linux.h:109,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv.c:14:
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h: In function ‘zero_use
r_segments’:
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:134: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:134: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:134: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:134: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:137: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:137: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:137: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:137: warning: pointer of
type ‘void *’ used in arithmetic
cc -Wp,-MD,/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/.nv
-vm.o.d -nostdinc -isystem /usr/lib/gcc/i586-suse-linux/4.3/include -D__KER
NEL__ -Iinclude -Iinclude2 -I/usr/src/linux-2.6.25.9-0.2/include -include in
clude/linux/autoconf.h -I/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/u
sr/src/nv -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-alias
ing -fno-common -Werror-implicit-function-declaration -Os -fno-stack-protect
or -m32 -msoft-float -mregparm=3 -freg-struct-return -mpreferred-s
tack-boundary=2 -march=i586 -mtune=generic -ffreestanding -DCONFIG_AS_CFI=1
-DCONFIG_AS_CFI_SIGNAL_FRAME=1 -pipe -Wno-sign-compare -mno-sse -mno-mmx -mn
o-sse2 -mno-3dnow -I/usr/src/linux-2.6.25.9-0.2/include/asm-x86/mach-generic
-Iinclude/asm-x86/mach-generic -I/usr/src/linux-2.6.25.9-0.2/include/asm-x86
/mach-default -Iinclude/asm-x86/mach-default -fno-omit-frame-pointer -fno-op
timize-sibling-calls -fasynchronous-unwind-tables -Wdeclaration-after-statem
ent -Wno-pointer-sign -I/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/us
r/src/nv -Wall -Wimplicit -Wreturn-type -Wswitch -Wformat -Wchar-subscripts
-Wparentheses -Wpointer-arith -Wno-multichar -Werror -MD -Wsign-compare -Wno
-cast-qual -Wno-error -D__KERNEL__ -DMODULE -DNVRM -DNV_VERSION_STRING=\"171
.06.01\" -UDEBUG -U_DEBUG -DNDEBUG -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_B
ASENAME=KBUILD_STR(nv_vm)" -D"KBUILD_MODNAME=KBUILD_STR(nvidia)" -c -o /tmp
/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/.tmp_nv-vm.o /tmp/se
lfgz17813/NVIDIA-Linux-x86-171.06.0
1-pkg1/usr/src/nv/nv-vm.c
In file included from /usr/src/linux-2.6.25.9-0.2/include/linux/list.h:8,
from /usr/src/linux-2.6.25.9-0.2/include/linux/preempt.h:11
,
from /usr/src/linux-2.6.25.9-0.2/include/linux/spinlock.h:4
9,
from /usr/src/linux-2.6.25.9-0.2/include/linux/seqlock.h:29
,
from /usr/src/linux-2.6.25.9-0.2/include/linux/time.h:8,
from /usr/src/linux-2.6.25.9-0.2/include/linux/timex.h:57,
from /usr/src/linux-2.6.25.9-0.2/include/linux/sched.h:54,
from /usr/src/linux-2.6.25.9-0.2/include/linux/utsname.h:35
,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-linux.h:19,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-vm.c:14:
/usr/src/linux-2.6.25.9-0.2/include/linux/prefetch.h: In function ‘prefetc
h_range’:
/usr/src/linux-2.6.25.9-0.2/include/linux/prefetch.h:57: warning: pointer of
type ‘void *’ used in arithmetic
In file included from include2/asm/dma-mapping_32.h:5,
from include2/asm/dma-mapping.h:2,
from /usr/src/linux-2.6.25.9-0.2/include/linux/dma-mapping.
h:52,
from /usr/src/linux-2.6.25.9-0.2/include/asm-generic/pci-dm
a-compat.h:7,
from include2/asm/pci.h:90,
from /usr/src/linux-2.6.25.9-0.2/include/linux/pci.h:948,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-linux.h:86,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-vm.c:14:
/usr/src/linux-2.6.25.9-0.2/include/linux/scatterlist.h: In function ‘sg_v
irt’:
/usr/src/linux-2.6.25.9-0.2/include/linux/scatterlist.h:199: warning: pointe
r of type ‘void *’ used in arithmetic
In file included from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-linux.h:109,
from /tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv/nv-vm.c:14:
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h: In function ‘zero_use
r_segments’:
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:134: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:134: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:134: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:134: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:137: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:137: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:137: warning: pointer of
type ‘void *’ used in arithmetic
/usr/src/linux-2.6.25.9-0.2/include/linux/highmem.h:137: warning: pointer of
type ‘void *’ used in arithmetic
/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/nv-vm.c: In func
tion ‘nv_set_page_attrib_uncached’:
/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/nv-vm.c:64: warn
ing: ‘change_page_attr’ is deprecated (declared at include2/asm/cacheflu
sh.h:27)
/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/nv-vm.c: In func
tion ‘nv_set_page_attrib_cached’:
/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/nv-vm.c:79: warn
ing: ‘change_page_attr’ is deprecated (declared at include2/asm/cacheflu
sh.h:27)
/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/nv-vm.c: In func
tion ‘nv_flush_caches’:
/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/nv-vm.c:364: err
or: implicit declaration of function ‘global_flush_tlb’
make[4]: *** [/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/src/nv/nv
-vm.o] Error 1
make[3]: *** [_module_/tmp/selfgz17813/NVIDIA-Linux-x86-171.06.01-pkg1/usr/s
rc/nv] Error 2
make[2]: *** [sub-make] Error 2
NVIDIA: left KBUILD.
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
__________________
La libertad es un derecho, tu obligación es usarla en algo útil.
Responder Citando
  #6  
Antiguo 11-jul-2008, 17:03
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 13.996
Agradecimientos: 335
Agradecido 1.183 Veces en 764 Mensajes
Poder de Credibilidad: 10
DiabloRojo está en el buen camino
Para el kernel 2.6.25 como tiene openSUSE 11.0 hay que parchearlo según el driver que descargues, busca un post mio sobre una pregunta de nvidia, es reciente.

PD: Aqui lo tienes: http://www.forosuse.org/forosuse/sho...ghlight=nvidia
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   SubirImagenes    SendSpace       TextSnip  Cl1p
Responder Citando
Solucion!!!
  #7  
Antiguo 11-jul-2008, 18:57
Avatar de ronaldfer
ronaldfer ronaldfer está desconectado
Aforado
 
Fecha de Ingreso: 01-mayo-2007
Ubicación: Santa Cruz de la Sierra
Versión: 11.4
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
ronaldfer está en el buen camino
Solucion!!!

Gracias amigos ya esta solucionado.

No sabia que tenia que parchear el driver (versiones anteriores a 173.08) para kernel 2.6.25. Bravo DiabloRojo. Lo menos que puedo hacer es elaborar un pequeño resumen de la solucion para aquellos que tengan este mismo problema.

BREVE RESUMEN
==================

Si han leido este post desde el comienzo se daran cuenta que yo no podia instalar versiones recientes del driver nvidia (173.08 en adelante) por que estos utilizaban nuevas tecnologias (SSE) que mi procesador no soportaba. Asi que para los que tengan hardware nuevo es recomendable que utilizen paquetes precompilados para su version de opensuse en este caso opensuse 11, ya sea por 1-click-install o por repositorios.

En caso de que les ocurra lo mismo que a mi, yo lo solucioné:

1).- Primero asegurate de tener instalado los paquetes:
kernel-source, gcc y make
y ademas aplicar las actualizaciones del sistema, por si acaso.

2).- Luego deben descargar una version anterior del driver nvidia, yo lo hice con la version 169.07 y esta es su direccion de la pagina de nvidia:
http://us.download.nvidia.com/XFree8...69.07-pkg1.run

Informacion del driver
http://www.nvidia.com/object/linux_d...32_169.07.html

3).- Si intentas instalar el driver te saldra un error de compilacion. Esto se debe a que esta version del driver no puede ser instalada en un kernel 2.6.25 sin antes aplicarle un parche. En esta direccion describen como aplicarle el parche:
http://www.nvnews.net/vbulletin/showthread.php?t=110088

Yo descargué y utilizé el parche NVIDIA_kernel-169.12-2286310.diff.txt que se encuentra en esa direccion.

4).- Inicia en modo consola (init 3) y asegurate que no tengas el xserver corriendo.
Aplica el parche asi:
#sh /ruta/donde/pusiste/NVIDIA-Linux-x86-169.07-pkg1.run \
--apply-patch /ruta/donde/pusiste/NVIDIA_kernel-169.12-2286310.diff.txt

5).- Por ultimo ejecuta el instalador parcheado para compilar e instalar el driver:
#sh NVIDIA-Linux-x86-169.07-pkg1-custom.run

Listo!!
Cuando reinicies tendras tu driver funcionando.

Agradecimientos a los que me ayudaron a solucionar este problema.
Saludos...
__________________
La libertad es un derecho, tu obligación es usarla en algo útil.

Última edición por ronaldfer; 14-jul-2008 a las 00:59
Responder Citando
Otro caso diferente con solución (de chorra)
  #8  
Antiguo 16-jul-2008, 01:29
migtei migtei está desconectado
Miembro Junior
 
Fecha de Ingreso: 23-julio-2006
Ubicación: Mallorca
Mensajes: 387
Agradecimientos: 1
Agradecido 5 Veces en 4 Mensajes
Poder de Credibilidad: 9
migtei está en el buen camino
Otro caso diferente con solución (de chorra)

Enhorabuena por tu éxito. Yo he tenido problemas con el driver nvidia propietario instalado con yast en suse 11, en concreto los paquetes:
nvidia-gfxG01-kmp-pae...
x11-video-nvidiaG0...

Por si ayuda a alguien, pego lo que me ha ocurrido y lo que he hecho.
Tras instalar los dos paquetes mencionados del repositorio nvidia y ejecutar como root el comando: sax2 -r -m 0=nvidia el servidor X muere y me devuelve a una consola de texto sin poder acceder a sax2 para conseguir un entorno gráfico con otro driver.
Conseguir (recuperar) un escritorio usando drivers genéricos (nv o vesa).
Si quieres tener escritorio gráfico (sin driver nvidia), ejecuta como root en una consola virtual (CTRL + alt + F2 por ejemplo, pon root y luego la contraseña de este) estos pasos:
Código:
init 3                            #=> paso a nivel de ejecución en consola (runlevel 3).
sax2 -r -m 0=vesa                 #=> el que siempre funciona.
O alternativamente:
Código:
sax2 -r -m 0=nv                   => el driver nv para nvidia de código abierto bueno pero espartano.
Dices a sax aceptar, y acto seguido inicias el nivel de ejecución 5 que es el nivel con sistema gráfico poniendo el comando:
Código:
init 5
Ya arranca el escritorio, pelado pero utilizable, ya no estarás atado a una consola y puedes arrancar yast y sax2 para hacer pruebas, o buscar soluciones con un navegador.
Ahora copia como root el archivo xorg.conf que funciona bien (el que acabas de configurar con vesa o nv), para poder hacer pruebas y luego poder volver a salvo al escritorio gráfico. Como root:
Código:
cp /etc/X11/xorg.conf    /etc/X11/xorg.conf-bueno_con_vesa
Ahora haz todas las pruebas y perrerías que quieras, cuando quieras volver a tener el escritorio gráfico pelado que funciona, solo tienes que copiar el archivo /etc/X11/xorg.conf-bueno_con_vesa de nuevo a /etc/X11/xorg.conf sin tener que pasar por sax2, como root haz:
Código:
cp /etc/X11/xorg.conf-bueno_con_vesa    /etc/X11/xorg.conf
Luego vuelves a ejecutar como root en la consola (recuerda que no tienes entorno gráfico):
Código:
init 3
init 5
Para que re-arranque el escritorio usando el archivo xorg.conf con driver nv o vesa (genéricos).
Con esto queda resuelto el problema de poder arrancar un entorno gráfico.
Mis problemas
De acuerdo al enlace "supported product list" del último driver versión 173.14.09 :
http://www.nvidia.com/object/IO_18897.html
Confirmo que mi tarjeta está soportada, en mi trasto:
Código:
/sbin/lspci
...
01:00.0 VGA compatible controller: nVidia Corporation NV44A [GeForce 6200] (rev a1)
...
Miro el código de fabricante y dispositivo como número (el que utiliza lspci para buscar en su base de datos):
Código:
/sbin/lspci -n
...
01:00.0 0300: 10de:0221 (rev a1)
...
De la web http://www.nvidia.com/object/IO_18897.html :
Supported Products List
GeForce Products:
...
GeForce 6200 0x0221
Cuando intento cargar el módulo como root a mano me escupe a la cara:
Código:
modprobe -v nvidia
insmod /lib/modules/2.6.25.9-0.2-pae/weak-updates/nvidia.ko NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=33 NVreg_DeviceFileMode=0660
FATAL: Error inserting nvidia (/lib/modules/2.6.25.9-0.2-pae/weak-updates/nvidia.ko): No such device
Que quiere decir que no encuentra ningún dispositivo (device) correspondiente, el driver instalado (con yast) no los ha creado.
Si busco en el directorio /dev no encuentro el dispositivo:
Código:
ls -l /dev/nvid*              ##no sale nada
En caso de estar bien instalado debiera salir:
Código:
/dev/nvidia0
/dev/nvidiactl
Tampoco aparece el directorio /proc/driver/nvidia donde el sistema escribe y lee datos del hardware nvidia configurado. Debiera salir de estar correcto y sanote algo como:
Código:
ls -l /proc/driver/nvidia
total 0
dr-xr-xr-x 2 root root 0 jul 15 23:02 agp
dr-xr-xr-x 2 root root 0 jul 16 00:36 cards
-r--r--r-- 1 root root 0 jul 16 00:36 registry
-r--r--r-- 1 root root 0 jul 16 00:36 version
dr-xr-xr-x 2 root root 0 jul 16 00:36 warnings
Busco errores en los log de Xorg, que son los archivos de los últimos arranques del servidor gráfico (/var/log/Xorg.0.log, /var/log/Xorg.0.log.old, /var/log/Xorg.99.log, y /var/log/Xorg.99.log.old), uno a uno con el comando:
Código:
cd /var/log
egrep '^\((EE|WW)\)'  Xorg.1.log
(EE) NVIDIA(0): Failed to load the NVIDIA kernel module!
(EE) NVIDIA(0):  *** Aborting ***
(EE) Screen(s) found, but none have a usable configuration.
Que significa: busca e imprime en consola las líneas que comiencen por EE (error) o WW (warning).
Muere sin dar nada de info, incluso si le pido ser verboso.
La solución
Cambios en la BIOS, "boot parameters" especiales al arrancar, tropecientas pruebas y "reboot", no se crean los "devices" para nvidia.
¡A la mierda los paquetes de yast y a compilar el driver!
Elimina los paquetes instalados con yast como root con:
Código:
rpm -e --nodeps  nvidia-gfxG01-kmp-pae
rpm -e --nodeps  x11-video-nvidiaG01
Instala con yast los paquetes: kernel-source-2.6.25.9-0.2 que son las fuentes del kernel que tengo, gcc y make
Para saber el kernel que tienes usa el comando: uname -a
Ahora descarga el driver compilable de (la versión última en vigor) en:
http://www.nvidia.com/object/linux_d...173.14.09.html
Su nombre sería del tipo:
NVIDIA-Linux-x86-173.14.09-pkg1.run
Seguidamente tienes que salir y matar el entorno gráfico para poder compilarlo con:
Pulsa ctrl + alt + F1
Logueate como root y pon su contraseña. El "prompt" ahora debiera ser una cuadradilla # . Vas al directorio donde está el paquete compilable:
Código:
cd   /directorio/donde/descargaste/NVIDIA-Linux-x86-173.14.09-pkg1.run
init 3              #esto mata el servidor gráfico
sh   NVIDIA-Linux-x86-173.14.09-pkg1.run  -q    #esto comienza la compilación
Aceptas la licencia, ok, ok, ok, y cuando termina ejecutas por fín:
Código:
sax2 -r -m 0=nvidia
Te arranca una prueba, la aceptas en caso satisfactorio y ya puedes arrancar el entorno gráfico con:
Código:
init 5
Epílogo
Siempre he usado el paquete compilable de nvidia excepto esta vez que me he dejado llevar por la curiosidad y he salido escaldado con los paquetes para yast especiales para suse 11. No sé porqué no se crearon los dispositivos nvidia, que era el problema que no permitía cargar el módulo nvidia.ko . Pues eso, que a veces tres minutos compilando son menos trabajo que todos los click clack automágicos.
Suerte...

Última edición por migtei; 29-ago-2008 a las 11:52
Responder Citando
  #9  
Antiguo 16-jul-2008, 08:44
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 13.996
Agradecimientos: 335
Agradecido 1.183 Veces en 764 Mensajes
Poder de Credibilidad: 10
DiabloRojo está en el buen camino
Buen aporte migtei, me sigues sorprendiendo tus conocimientos.

Para los demás aforados, ruego que leais también este otro Tema para tarjetas Nvidia viejas:
Nvidia "Old Legacy" y OpenSUSE 11.0 [SOLUCIONADO]

Y sobre todo para openSUSE 11.0 o que utiliceis el kernel 2.6.25, ver este sobre parches:
Using NVIDIA Linux graphics drivers with Linux 2.6.25

[EDITADO] Acaba de salir las nuevas versiones Nvidia "Old Legacy" con soporte al kernel > 2.6.25 que lleva openSUSE 11.0
71.86.06
96.43.07
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   SubirImagenes    SendSpace       TextSnip  Cl1p

Última edición por DiabloRojo; 19-jul-2008 a las 21:19
Responder Citando
  #10  
Antiguo 19-jul-2008, 23:23
Avatar de ronaldfer
ronaldfer ronaldfer está desconectado
Aforado
 
Fecha de Ingreso: 01-mayo-2007
Ubicación: Santa Cruz de la Sierra
Versión: 11.4
Mensajes: 32
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
ronaldfer está en el buen camino
Solo una cosa quisiera añadir.

Si bien la version 169 del driver nvidia compila, instala y funciona sin problemas, no podras habilitar la aceleracion por hardware, aunque glxinfo te diga que esta habilitado.

Esto se necesita para algunos juegos y para los efectos de escritorio (eso creo) y no se habilita por el mismo problema que tenia antes... SSE. Una version anterior del driver que no depende de SSE es la 100.14.19. Instalalo y podras ejecutar tus juegos y habilitar efectos de escritorio (ojo... me refiero para los que tengan procesador incompatible con SSE).

El parche de la version 100.14.19 para kernel 2.6.25 lo estoy poniendo como archivo adjunto (comprimido). Se le aplica el parche de la misma manera y se ejecuta igual.

Si te da algun error de compilación (como me ocurrió), puede ser que no encuentre la ruta al codigo fuente del kernel. Entonces lo que haces es indicarselo al instalador asi:
Código:
#sh instalador --kernel-source-path=LARUTA
donde "LARUTA" en mi caso era: /usr/src/linux-2.6.25.9-0.2

Lo probe en Zenwalk con kernel 2.6.25 y todo funciona ok, aunque estoy teniendo problemas para opensuse 11... no quiere compilar. Al parecer se debe a que en mi sistema el kernel-source y el linux-kernel-headers tienen versiones distintas, pero ese es otro cuento .

Saludos...
Archivos Adjuntos
Tipo de Archivo: gz NVIDIA-x86-100.14.19-kernel-2.6.25-compat.diff.txt.tar.gz (6,7 KB (Kilobytes), 4 visitas)
__________________
La libertad es un derecho, tu obligación es usarla en algo útil.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Review de openSUSE 11.0 y comparativa con Ubuntu. Dux El Contubernio 54 20-feb-2010 13:30
Introducción: Primeros pasos en Linux. Open Suse y Foro Suse. Afrodita FAQs, Manuales y Tutoriales 7 11-mar-2009 00:37
Anuncio oficial openSUSE 11.0 (español) elpreto Portal de ForoSUSE 66 18-ago-2008 16:48
Calendarios de Distros. Afrodita La cafetería 0 06-feb-2008 16:52
Tarjeta de video korn_head Hardware 5 03-may-2007 19:24



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 21:52.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba