Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

openSuse no inicia, he cambiado la tabla de particiones [SOLUCIONADO]
  #1  
Antiguo 30-ago-2007, 21:46
Avatar de jncruces
jncruces jncruces está desconectado
Miembro Junior
 
Fecha de Ingreso: 03-agosto-2007
Ubicación: Sevilla (España)
Versión: openSUSE Leap 42.1
Mensajes: 455
Agradecimientos: 33
Agradecido 102 Veces en 85 Mensajes
Poder de Credibilidad: 11
jncruces está en el buen camino
openSuse no inicia, he cambiado la tabla de particiones [SOLUCIONADO]

Hola,

Voy ha plantear un problema que por supuesto ya estoy buscando, y he buscado bastante, pero sinceramente, no se ni como buscarlo, incluso no sabía en qué sección ponerlo en el foro.

Problema: He instalado el wifislax en mi ordenador (como si hubiese sido otro digo yo), primero me fui al windows y modifiqué la tabla de particiones de la siguiente forma:

Estado Inicial:
*particion primaria (20GB) para windows (ntfs)
*particion extendida (100) :
- particion (80 GB) como almacen (ntfs)
- particion (19 GB) para opensuse (ext3)
- particion (1GB) como swap (swap)

Estado final:
*particion primaria (20GB) para windows (ntfs)
*particion extendida (100) :
- particion (75 GB) como almacen (ntfs) (redimensionada)
- particion (5 GB) para wifislax
- particion (19 GB) para opensuse
- particion (1GB) como swap

(Todas las cifras son más o menos, tengo un disco de 120 GB)

Tras instalar el wifislax creia que todo estaba correcto, windows corria, wifislax corria, y por ultimo openSuse, kk.

Iniciando el opensuse el sistema se queda parando indicando un error como el que sigue:
kernel panic ... VFS: bloq error (0,0) ...

(Siento no poner el error correctamente, la proxima vez que inicie edito y lo pongo correcto, pero creo que se entiende de qué va)

Yo entiendo que como antes el opensuse era /dev/sda6 y ahora ese /dev/sda6 es el wifislax (por haberlo puesto antes en la tabla de particiones) el opensuse ha pasado ha ser /dev/sda7, realmente el sistema no puede arrancar porque no sabe donde estan los ficheros (supongo que intenta iniciar wifislax, porque corresponde con las rutas que el tenia antes).

No se como arreglar esto, tal vez sea sencillo, modificando algun ficherito en el openSuse que le haga saber que ahora tiene que buscar las cosas en /dev/sda7 pero no tengo ni idea de cual puede ser.


Gracias por adelantado, y sino lo soluciono, que no creo que sea un caso unico pero no se si alguien lo habra solucionado sin formatear todo, jj
__________________
En ocasiones, se pueden ajustar los tipos para permitir la operación.
Responder Citando
  #2  
Antiguo 30-ago-2007, 21:51
Avatar de arlick
arlick arlick está desconectado
Habitual
 
Fecha de Ingreso: 17-agosto-2006
Ubicación: At the computer
Versión: 10.2
Mensajes: 204
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
arlick está en el buen camino
usas grub?

si es asi copia aca el fichero /etc/grub/menu.lst

si no es asi yo no te podría ayudar mucho
__________________
Responder Citando
  #3  
Antiguo 30-ago-2007, 21:56
Avatar de jncruces
jncruces jncruces está desconectado
Miembro Junior
 
Fecha de Ingreso: 03-agosto-2007
Ubicación: Sevilla (España)
Versión: openSUSE Leap 42.1
Mensajes: 455
Agradecimientos: 33
Agradecido 102 Veces en 85 Mensajes
Poder de Credibilidad: 11
jncruces está en el buen camino
Si uso grub, salvo que antes tenia el grub del openSuse y ahora tengo un grub que me ha puesto el wifislax, voy ha intentar copiar el fichero ese (del cual ya hace mencion el wifislax en su manual de instalacion) desde el wifislax al openSuse (creo que es eso lo que me dices), pero no es problema del grub, ya te digo que el grub actual sabe que tengo el openSuse, pero cuando le doy a iniciar es el unico que no inicia.
__________________
En ocasiones, se pueden ajustar los tipos para permitir la operación.
Responder Citando
  #4  
Antiguo 30-ago-2007, 22:01
Avatar de jncruces
jncruces jncruces está desconectado
Miembro Junior
 
Fecha de Ingreso: 03-agosto-2007
Ubicación: Sevilla (España)
Versión: openSUSE Leap 42.1
Mensajes: 455
Agradecimientos: 33
Agradecido 102 Veces en 85 Mensajes
Poder de Credibilidad: 11
jncruces está en el buen camino
Estoy buscando el archivo menu.lst pero no se encuentra en /etc/grub/menu.lst parece que se encuentra en /boot/grub/menu.lst espero no equivocarme y gracias por tu excepcional rapidez,

...

No ha funcionado se sigue quedando donde antes, ahora pongo el mensaje de error completo:

VFS: Cannot open root device "sda7" or unknown -block(0,0)
Please append a correct "root=" boot option
Kernel panic -not syncing: VFS: Unable to mount root fs on unknown -block(0,0)
__________________
En ocasiones, se pueden ajustar los tipos para permitir la operación.

Última edición por jncruces; 30-ago-2007 a las 22:13
Responder Citando
  #5  
Antiguo 30-ago-2007, 23:29
Avatar de darkskimmer
darkskimmer darkskimmer está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 07-julio-2006
Ubicación: Málaga...por poco tiempo!!
Versión: 11.1
Mensajes: 2.151
Agradecimientos: 0
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 14
darkskimmer está en el buen camino
Prueba reparar la tabla de particiones. Hay muchas aplicaciones (Partition Magic es la única que conozco) aunque tambien tenemos Gpart y TestDi. Lo que explica en este link:

http://blogdrake.net/node/2882

Saludos y suerte! Estas cosas son jodidillas
__________________

How-to VirtualBox <~ Guía sobre VirtualBox
Responder Citando
  #6  
Antiguo 31-ago-2007, 01:00
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.221
Agradecimientos: 42
Agradecido 1.264 Veces en 932 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Si tú no lo cambias, a la nueva partición se le asignará el siguiente número, es decir, openSuSE no cambia de partición (sda6) ...

Si no te ha funcionado lo de reparar, postea el archivo de menú del grub que uses ...

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
  #7  
Antiguo 31-ago-2007, 10:24
Avatar de jncruces
jncruces jncruces está desconectado
Miembro Junior
 
Fecha de Ingreso: 03-agosto-2007
Ubicación: Sevilla (España)
Versión: openSUSE Leap 42.1
Mensajes: 455
Agradecimientos: 33
Agradecido 102 Veces en 85 Mensajes
Poder de Credibilidad: 11
jncruces está en el buen camino
Hoy mismo en cuanto llegue a mi casa después del trabajo me pondre ha probar esos dos programitas.

Por la tarde además también posteare el archivo menu.lst pero no es problema de ese archivo ni del grub, incluso el mismo opensuse hace 6 o 7 pasitos de incio.

Analizando el problema llego a la conclusion de que el problema ha sido del partition magic (ha creado la nueva particion pero no ha enlazado bien la siguiente en el disco, es decir la particion sda7 existe pero tiene un comienzo confuso a mi entender), ya he probado con el mismo partition magic al analizar pero falla (el partition magic peta como programa de windows que es) y hoy probare el nuevo partition magic que me he bajado también.
También decir que desde el wifislax puedo acceder a esa particion, es decir los datos están ahi, todo esta ahi, creo que los primeros inodes son los que estan dañados.



Pero la vida sigue, los discos se formatean y se vuelven a formatear, he lanzado el tema por intentar resolverlo para aprender más, tanto yo como vosotros, siempre se que puedo volver ha meter el dvd del opensuse y volver ha instalar!!! Esto es un consejo para todo el mundo (la gente se asusta por estos problemas y no tienen por qué).
__________________
En ocasiones, se pueden ajustar los tipos para permitir la operación.

Última edición por jncruces; 31-ago-2007 a las 10:28
Responder Citando
  #8  
Antiguo 31-ago-2007, 12:11
Avatar de darkskimmer
darkskimmer darkskimmer está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 07-julio-2006
Ubicación: Málaga...por poco tiempo!!
Versión: 11.1
Mensajes: 2.151
Agradecimientos: 0
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 14
darkskimmer está en el buen camino
De todos modos tenemos muchas alternativas amigo! Tenemos el SysRescue para salvar esos datos en caso de que no puedas solucionarlo.

Existen tambien CD's como el utilisimo Hirens Boot CD que tienen programas para arreglar el MBR y la tabla de particiones asi como el Partition Magic, que también arregla el MBR y la tabla de particiones.


Saludos!
__________________

How-to VirtualBox <~ Guía sobre VirtualBox
Responder Citando
  #9  
Antiguo 31-ago-2007, 12:35
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.595
Agradecimientos: 571
Agradecido 2.476 Veces en 1.674 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Si no has redimensionado la particion de OpenSuse no deberias tener problemas con la tabla de particiones sino con el grub de wifislax y, tambien, con OpenSuse si ha cambiado el numero de la particion, para eso tienes que editar el fstab de OpenSuse en la linea donde se define el punto de montaje de la particion root, esa linea donde aparece '/'.

Unos datos necesarios son el "fdisk -l" y el contenido de /boot/grub/menu.lst de wifislax suponiendo que se utilice ese grub. Tambien el contenido de fstab de OpenSuse.

Os cuento por experiencia mia que se puede mover el contenido de una particion que contenga un SO GNU/Linux a otra particion, aunque sea a otro disco duro, y que funcione. El truco es editar el fichero fstab de la particion movida y editar el menu.lst del grub a utilizar para que apunte a la nueva particion. Ojo, con el nuevo concepto de etiquetas de Hal en fstab, las cosas cambian.

EDITADO: En el foro he explicado varias veces esta tematica.
Si fuera un problema de inodes de OpenSuse con fsck desde wifislax lo puedes arreglar.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Última edición por DiabloRojo; 31-ago-2007 a las 12:55
Responder Citando
  #10  
Antiguo 31-ago-2007, 13:34
Avatar de jncruces
jncruces jncruces está desconectado
Miembro Junior
 
Fecha de Ingreso: 03-agosto-2007
Ubicación: Sevilla (España)
Versión: openSUSE Leap 42.1
Mensajes: 455
Agradecimientos: 33
Agradecido 102 Veces en 85 Mensajes
Poder de Credibilidad: 11
jncruces está en el buen camino
El grub esta perfecto, ya lo vereis hoy cuando postee el menu.lst, el problema tiene que estar en el propio opensuse, mirare eso del fstab y lo del fsck.

Se me esta acumulando el trabajo, jj
estoy deseando salir del trabajo para empezar con el opensuse.
__________________
En ocasiones, se pueden ajustar los tipos para permitir la operación.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
¿porque ubuntu es mas popular q suse? goundzchecky El Contubernio 161 16-ago-2012 16:01
ya instaler OpenSUSE pero no inicia graficos jclaurian Instalación y Actualizaciones 4 31-ago-2007 05:23
Duda de particiones y discos duros [SOLUCIONADO] Defton Hardware 19 19-ago-2007 04:28
No veo particiones windows es opensuse 10.2 ersolan Hardware 4 23-may-2007 02:23
Instalar lo que falta en la version opensuse y ver los archivos en otras particiones kiedis Instalación y Actualizaciones 2 13-feb-2006 23:25



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 11:07.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba