Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

problemas configuracion tarjeta sonido
  #1  
Antiguo 28-mar-2007, 15:49
signatus signatus está desconectado
Aforado
 
Fecha de Ingreso: 28-marzo-2007
Versión: 10.2
Mensajes: 4
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
signatus está en el buen camino
problemas configuracion tarjeta sonido

Acabo de instalar suse 10.2 en mi nuevo pc sobremesa. Todo ha funcionado bien menos la configuracion de la tarjeta sonido integrada en la placa AM2NF6G-VSTA. La tarjeta de sonido es una Realtek ALC888 7.1.

He entrado en yast-hardware -sonido y pone nVidia sin configurar,pulsar editar para configurar ,elijo configuracion rapida y entonces dice:

Error durante instalacion nvidia corporation( la q escoje predeterminada,la realtek en question no esta en la lista). El modulo del kernel snd-hda-intel para el soporte de sonido no puede ser cargado.Esto puede ser debido a unos parametros incorrectos,inclusive e/s o IRQ no validas.

Al margen izdo aconseja pasar las opciones al modulo ALSA si el problema persiste.

Alguien me dice por donde y como solucionar el problema. Llevo trastendo linux un tiempo pero como simple usuario. He leido en el foro q se trata d configurar con alsaconf pero no se como hacerlo.
gracias
Responder Citando
  #2  
Antiguo 28-mar-2007, 19:37
Avatar de Livesey
Livesey Livesey está desconectado
Habitual
 
Fecha de Ingreso: 26-agosto-2005
Ubicación: El renacimiento que mira al sur
Mensajes: 317
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 13
Livesey está en el buen camino
Bajate las fuentes de Alsa y las descomprimes en una carpeta. Abre la consola en la carpeta donde hayas extraido las fuentes y escribe:
./configure --with-card=hda-intel
a continuación:
make
Logueate como ROOT:
su
y por último:
make install

PD.: Instala las fuentes del kernel y los compiladores si no lo has hecho antes.
Responder Citando
  #3  
Antiguo 29-mar-2007, 11:30
signatus signatus está desconectado
Aforado
 
Fecha de Ingreso: 28-marzo-2007
Versión: 10.2
Mensajes: 4
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
signatus está en el buen camino
Hola,gracias por la ayuda.

He probado hacer lo que sugieres y ocurre esto:

davidllop@linux-david:~/alsa-driver-1.0.13> ./configure --with-card=hda-intel
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
davidllop@linux-david:~/alsa-driver-1.0.13>


Supongo falta compilador. Como y de donde lo instalo?

Perdona mi ignorancia.

Gracias
Responder Citando
  #4  
Antiguo 29-mar-2007, 14:15
Regnum
Invitado
 
Mensajes: n/a
Buenas.

Bueno, no soy un experto en esto (soy, digamos, un mierdecilla xD), pero si no me equivoco, vas al Yast, Instalar nuevo software y buscas el gcc, el cc.. todo lo que ponia ahi. Y los instalas

Suerte :P
Responder Citando
  #5  
Antiguo 29-mar-2007, 16:27
signatus signatus está desconectado
Aforado
 
Fecha de Ingreso: 28-marzo-2007
Versión: 10.2
Mensajes: 4
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
signatus está en el buen camino
Ya he instalado compiladores i fuentes kernel,pero cuando hago el paso final como usuario root make install al final aparece esto:

make[2]: se sale del directorio `/home/davidllop/alsa-driver-1.0.13/pcmcia/vx'
make[1]: se sale del directorio `/home/davidllop/alsa-driver-1.0.13/pcmcia'
/sbin/depmod -a 2.6.18.8-0.1-default
if [ -L /usr/include/sound ]; then \
rm -f /usr/include/sound; \
ln -sf /home/davidllop/alsa-driver-1.0.13/include/sound /usr/include/sound; \
else \
rm -rf /usr/include/sound; \
install -d -m 755 -g root -o root /usr/include/sound; \
for f in include/sound/*.h; do \
install -m 644 -g root -o root $f /usr/include/sound; \
done \
fi
cat WARNING

WARNING!!! The mixer channels for the ALSA driver are muted by default!!!
************************************************** ************************
You would use some ALSA or OSS mixer to set the appropriate volume.

linux-david:/home/davidllop/alsa-driver-1.0.13 #
Responder Citando
  #6  
Antiguo 29-mar-2007, 17:24
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.478
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
No hay ningún error, es un aviso (warning).
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #7  
Antiguo 29-mar-2007, 17:29
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.175
Agradecimientos: 40
Agradecido 1.238 Veces en 910 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
El mensaje parece indicar que no tienes configurado el volumen del mezclador de la tarjeta de sonido. Toma nota del, por si luego te plantea problemas. Significaría que el volumen del sonido está apagado por defecto. En el mezclador que uses, tendrías que activarlo.

Saludos!!

Última edición por karlggest; 29-mar-2007 a las 17:32
Responder Citando
  #8  
Antiguo 29-mar-2007, 18:39
Avatar de Livesey
Livesey Livesey está desconectado
Habitual
 
Fecha de Ingreso: 26-agosto-2005
Ubicación: El renacimiento que mira al sur
Mensajes: 317
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 13
Livesey está en el buen camino
Eso significa que los volúmenes estan a cero por defecto. Puedes usar alsamixer en la consola; o kmix en la barra de tareas para subirlos.
Responder Citando
  #9  
Antiguo 30-mar-2007, 13:31
signatus signatus está desconectado
Aforado
 
Fecha de Ingreso: 28-marzo-2007
Versión: 10.2
Mensajes: 4
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
signatus está en el buen camino
Sigo sin sonido.

Volumen kmix activado ,alsamixer tambien.

Que mas puedo hacer?
Responder Citando
  #10  
Antiguo 30-mar-2007, 19:44
Avatar de Livesey
Livesey Livesey está desconectado
Habitual
 
Fecha de Ingreso: 26-agosto-2005
Ubicación: El renacimiento que mira al sur
Mensajes: 317
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 13
Livesey está en el buen camino
Asegurate que tu usuario pertenece al grupo audio. Inicia la sesión como root para verificar si hay sonido.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Problemas con la tarjeta de sonido en SLED 10 PiTeR Hardware 0 28-mar-2007 10:22
Problemas con mi tarjeta de Sonido Agente Zeth Hardware 1 28-feb-2006 20:53
Problemas con la tarjeta de sonido Raiden Hardware 4 05-sep-2005 16:23
problemas con la tarjeta de sonido c-media susepanda2005 Hardware 3 30-mar-2005 17:35
Problemas con la tarjeta de Sonido druidas Hardware 17 19-ago-2004 16:55



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 21:41.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba