Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Compatibilidad Apache (Tomcat, Httpd) Java (J2SDK, J2EESDK), PHP, JSP, MOODLE
  #1  
Antiguo 02-feb-2007, 21:21
joseluisbz joseluisbz está desconectado
Habitual
 
Fecha de Ingreso: 20-diciembre-2006
Versión: 10.1
Mensajes: 210
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 11
joseluisbz está en el buen camino
Compatibilidad Apache (Tomcat, Httpd) Java (J2SDK, J2EESDK), PHP, JSP, MOODLE

Cordial Saludo:

Quisiera crear aplicaciones de Java y correrlas en una intranet
Para lo cual:
Baje las versiones de SDK de Java,
J2SDK y J2EESDK Puedo instalar las dos en SuSE 10.1, cuales son diferencias funcionales, o la otra es si J2EESDK contiene a J2SDK.
A diferencia del J2RE que es el que permite ejecutar la aplicación de Java del lado del cliente.

Los Servidores
Podrìa utilizarla con Apache HTTPD y TOMCAT
Estuve viendo estas pàginas para poder integrar pero estoy bastante enrredado.

JAVA
http://www.milmazz.com/archivos/2005...ava-en-ubuntu/
http://espaciolinux.com/postt10109.html
http://java.sun.com/j2ee/1.4/docs/
http://docs.sun.com/app/docs/doc/819-4710
http://docs.sun.com/app/docs/doc/819-4712
http://docs.sun.com/app/docs/doc/819-4711
http://java.sun.com/j2ee/1.4/docs/relnotes/install.html
http://java.sun.com/j2se/1.4.2/docs/index.html
http://www.lykkenborg.no/blog/java/2...nux-howto.html

TOMCAT
http://lists.opensuse.org/opensuse-e.../msg01279.html
http://mundogeek.net/archivos/2006/0...mcat-en-linux/
http://www.manycomics.com/blog/entrada/?id=20070117
http://www.novell.com/products/linux...x/tomcat5.html


Integrado de Novell
http://www.novell.com/coolsolutions/appnote/17572.html
http://support.novell.com/cgi-bin/se...i?10083618.htm
__________________
José Luis Bernal Zambrano
Electronics Engineer

Última edición por joseluisbz; 14-feb-2007 a las 01:53
Responder Citando
  #2  
Antiguo 02-feb-2007, 21:45
Avatar de ramso
ramso ramso está desconectado
Miembro Junior
 
Fecha de Ingreso: 05-mayo-2006
Versión: 11.1
Mensajes: 465
Agradecimientos: 1
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 12
ramso está en el buen camino
Enviar un mensaje por MSN a ramso Enviar un mensaje por Yahoo  a ramso
El j2sdk o java es el lenguaje en si y se puede usar standalone o como applet.
El j2eesdk es el Java 2 enterprise edition o las extensiones para desarrollo de aplicaciones web.
Si quieres usar tomcat u otro servidor de apliaciones necesitas los dos, el java para compilar y el j2ee para ejecutar, ya las traen en la instalación.
Lo mejor es que lo instales desde los repositorios de addons para 10.1 esta tanto el tomcat como el java. Y para programar y probarte te recomiendo eclipse con el wdt.
Responder Citando
J2re, J2sdk, J2eesdk
  #3  
Antiguo 02-feb-2007, 22:24
joseluisbz joseluisbz está desconectado
Habitual
 
Fecha de Ingreso: 20-diciembre-2006
Versión: 10.1
Mensajes: 210
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 11
joseluisbz está en el buen camino
J2re, J2sdk, J2eesdk

J2RE, es el que habitualmente necesita el Cliente.


Pero dentro de la transacciòn Cliente-Servidor

J2SDK podrìa no ejecutarse en un Servidor?, o solo me permite desarrollar, compilar?
J2EESDK para realizar mis aplicaciones para trabajar en el lado del servidor?
Necesariamente los dos entonces?
o por lo menos puedo instalar los dos sin problemas de compatibilidad?

En el caso del Editor, pienso utilizar WideStudio

Gracias
__________________
José Luis Bernal Zambrano
Electronics Engineer
Responder Citando
  #4  
Antiguo 02-feb-2007, 23:30
Avatar de ramso
ramso ramso está desconectado
Miembro Junior
 
Fecha de Ingreso: 05-mayo-2006
Versión: 11.1
Mensajes: 465
Agradecimientos: 1
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 12
ramso está en el buen camino
Enviar un mensaje por MSN a ramso Enviar un mensaje por Yahoo  a ramso
Creo que tienes un pequeño jaleo.

Si desarrollas una aplicacion j2ee el cliente es un navegador.
El servidor es un "Servidor de aplicaciones" como Tomcat. Para ejecutar tomcat necesitas el jre instalado en el servidor.
Para compilar necesitas el j2sdk y las librerias de j2ee, que estan en tomcat.
Para editar necesitas un editor, que permita tratar java, jsp o jsf, configurar servidor. Es interesante que uses algun framework para MVC como struct, spring o JSF. Y para el acceso a los datos un motor de persistencia como hibernate o JDO. Por eso te recomende eclipse que te permite todo esto en base a plugins.

hecha una hojeada a esto:
http://tomcat.apache.org/
http://struts.apache.org/
http://myfaces.apache.org/
http://www.eclipse.org
http://www.jpox.org/
http://www.hibernate.org/
En esta pagina tienes bastantes tutoriales del uso de todo esto http://java.programacion.com/

Para todo esto tienes paquetes en los repositorios de SuSe deberias de instalar los java-1_5_0-sun-devel y el tomcat55. Esta en http://software.opensuse.org/download/Java:/tomcat55/ y aqui http://software.opensuse.org/download/Java:/addon/
Responder Citando
  #5  
Antiguo 03-feb-2007, 01:37
joseluisbz joseluisbz está desconectado
Habitual
 
Fecha de Ingreso: 20-diciembre-2006
Versión: 10.1
Mensajes: 210
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 11
joseluisbz está en el buen camino
Gracias por tu respuesta:
Estuve revisando estos Link's por encima para ver la diferencia entre
las tecnologías:

JVM (Java Virtual Machine)
JRE (Java Runtime Environment)
JDK (Java Development Kit)
SDK (Standard Development Kit)
J2SE (Java 2 Standard Edition)
J2EE (Java 2 Enterprise Edition)

Para aclarar un poco las tecnologías
http://www.desarrolloweb.com/faq/283.php
http://foros.laneros.com/showthread.php?threadid=8327
http://www.osmosislatina.com/java/componentes.htm

Cómo podría aplicarse una instalación similar en SUSE como esta?
http://mundogeek.net/archivos/2006/0...mcat-en-linux/
http://www.sargue.net/fitxers/diarioTomcat5Debian.html
Código PHP:
http://www.google.com.co/search?hl=es&client=firefox-a&channel=s&rls=org.mozilla%3Aen-GB%3Aofficial&q=Tomcat+J2EE+Suse+Install&btnG=B%C3%BAsqueda&meta=lr%3Dlang_es%7Clang_en 
Ahora bien será necesario utilizar Tomcat, aún instalando J2EE?

Estaré revisando las páginas que me comentas...

Nuevamente gracias..
__________________
José Luis Bernal Zambrano
Electronics Engineer

Última edición por joseluisbz; 03-feb-2007 a las 01:43
Responder Citando
  #6  
Antiguo 03-feb-2007, 11:49
Avatar de ramso
ramso ramso está desconectado
Miembro Junior
 
Fecha de Ingreso: 05-mayo-2006
Versión: 11.1
Mensajes: 465
Agradecimientos: 1
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 12
ramso está en el buen camino
Enviar un mensaje por MSN a ramso Enviar un mensaje por Yahoo  a ramso
El j2ee no es un servidor en si mismo, normalmente con el j2ee 5 vendra glassfisn que es el servidor de sun para esta especificación. Realmente el j2ee es el servlet.jar y el jasper.jar . Que los servidores de aplicaciones ya traen, ademas de otras que son necesarias para otras especificaciones. Hay multitud de ellos, divididos en dos familias, servidores j2ee con soporte de ejb (jboss, geronimo, etc..) y solo de servlets (Tomcat, glasfish, jetty, etc...)
Personalmente prefiero tomcat, ya que hasta j2ee 5 ha sido la especificación por defecto. Es mucho mejor usar un servidor que el j2ee.
Instalar todo esto en suse es bastante simple. Primero tienes que tener los repositorios instalados, el de suse el de addons y el que te comente del java.
Luego desde yast,rug, smart o el gestor de paquetes que uses instalas los paquetes siguientes:
java-1_5_0-sun, java-1_5_0-sun-devel, java-1_5_0-sun-jdbc, java-1_5_0-sun-plugin, tomcat55, tomcat55-admin-webapps, apache2 y apache2-mod_jk
Los ejemplos son los paquetes tomcat55-webapps

Ademas esto instalara un gran cantidad de paquetes como dependencias. Cuanto esto este instalado, activas desde yast el arraque automatico de apache y tomcat. y todo en funcionamiento, para acceder a tomcat http://localhost:8080 en /admin tienes el administrador y en /manger/html el gestor de apliaciones. Añade un usuario en /etc/tomcat55/tomcat-users.xml con los roles admin y manager y podras usarlas.
Responder Citando
  #7  
Antiguo 03-feb-2007, 17:24
joseluisbz joseluisbz está desconectado
Habitual
 
Fecha de Ingreso: 20-diciembre-2006
Versión: 10.1
Mensajes: 210
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 11
joseluisbz está en el buen camino
Bueno Ramso, yo bajè los siguientes archivos:

php-5.2.0.tar.gz
httpd-2.2.4.tar.gz
mysql-5.o.27.tar.gz
apache-tomcat-6.0.8.tar.gz

En cuanto a Java(No son los más recientes, pero son los últimos de sus respectivos lanzamientos, ya están las versiones 6):
j2eesdk-1_4_03-linux-ml.bin
j2sdk-1_4_2_13-linux-i586.bin

Ahora, realmente estoy evitando utilizar los gestores de paquetes para repositorios (como yast o smart), sino que desde el repositorio trato de descargarlos manualmente, debido a que a veces me toca hacer la misma operaciòn en otros equipos y saber exactamente cuales necesito. Son todos los que necesito los que describes en
Cita:
java-1_5_0-sun, java-1_5_0-sun-devel, java-1_5_0-sun-jdbc, java-1_5_0-sun-plugin, tomcat55, tomcat55-admin-webapps, apache2 y apache2-mod_jk
Los ejemplos son los paquetes tomcat55-webapps
Al tratar de instalar estos paquetes tendré que tener en cuenta las dependencias.
Me gusta a la manera manual.

Gracias,
__________________
José Luis Bernal Zambrano
Electronics Engineer

Última edición por joseluisbz; 06-feb-2007 a las 23:07
Responder Citando
  #8  
Antiguo 03-feb-2007, 21:15
Avatar de ramso
ramso ramso está desconectado
Miembro Junior
 
Fecha de Ingreso: 05-mayo-2006
Versión: 11.1
Mensajes: 465
Agradecimientos: 1
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 12
ramso está en el buen camino
Enviar un mensaje por MSN a ramso Enviar un mensaje por Yahoo  a ramso
Pues vas a tener que descargar probablemente todos los paquetes del repositorio de java addons, el tomcat 55 necesita java 5. El tomcat 6 es beta así que mejor no lo uses de momento.
Responder Citando
  #9  
Antiguo 03-feb-2007, 23:24
joseluisbz joseluisbz está desconectado
Habitual
 
Fecha de Ingreso: 20-diciembre-2006
Versión: 10.1
Mensajes: 210
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 11
joseluisbz está en el buen camino
Bien Ramso

Al intentar hacer la instalación me di cuenta de la compatibilidad, pero con:
apache-tomcat-5.5.20-compat.tar.gz creo que si puedo utilizar apache-tomcat-5.5.20.tar.gz
Y las demàs herramientas:

apache-tomcat-5.5.20-admin.tar.gz
apache-tomcat-5.5.20-deployer.tar.gz
apache-tomcat-5.5.20-embed.tar.gz

Ahora la pregunta en que parte la cadena entra Tomcat para la instalaciòn, leyendo veo que primero tengo que disponer de la instalación de Java
Entonces sería
1) J2SE
2) J2EE
3) Apache-Tomcat (Aunque realmente no entendì como se instala), sabes cómo hacerlo?

Pero estos al parecer son parches
Apache-Tomcat-compat
http://forum.java.sun.com/thread.jspa?threadID=604294&messageID=3263818
Apache-Tomcat-admin
Apache-Tomcat-deployer (Solo descomprimir)
Apache-Tomcat-Embed

De todas formas ya los tengo, es mejor que SOSObre y no que FAFAlte.

http://www.coreservlets.com/Apache-Tomcat-Tutorial/#
Ejemplo para otro OS.
http://www.opennms.org/index.php/Deb....5_install_log
http://johnturner.com/howto/apache2-...rh9-howto.html
http://www.linux-sxs.org/internet_serving/c140.html
http://www.sitepoint.com/article/jsp...rt-guide-linux

http://www.warpstock.net/wse2006/dow...tation_V04.pdf
http://landau.dsic.upv.es/pbs/Jakarta%20Tomcat%205.pdf
http://wiki.media-style.com/display/...user+interface
http://www.cccp-project.org/docs.html
http://lists.centos.org/pipermail/ce...ry/058729.html




Gracias,
__________________
José Luis Bernal Zambrano
Electronics Engineer

Última edición por joseluisbz; 06-feb-2007 a las 23:47
Responder Citando
  #10  
Antiguo 04-feb-2007, 11:25
Avatar de ramso
ramso ramso está desconectado
Miembro Junior
 
Fecha de Ingreso: 05-mayo-2006
Versión: 11.1
Mensajes: 465
Agradecimientos: 1
Agradecido 4 Veces en 4 Mensajes
Poder de Credibilidad: 12
ramso está en el buen camino
Enviar un mensaje por MSN a ramso Enviar un mensaje por Yahoo  a ramso
El orden de instalación es correcto, pero no necesitas instalar j2ee ya que tomcat lo trae por defecto. Para instalar solo debes de descomprimir el tar.gz. Normalmente en /srv/www. Para arrancar en el directorio bin tendras un script de arraque que es catalina.sh.
Admin y deployer son interesantes, ya que la primera aplicación te permite configurar bastantes parametros del servidor, para empezar esta bien y la segunda te permite gestionar e instalar las aplicaciones.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
firefox sin sonido xuo Software 9 28-sep-2006 19:51
Firefox y KDE keogh Escritorios: KDE, Gnome, otros... 8 11-sep-2006 20:20
diferencias entre paquetes apache y el httpd, cual instalo? zsamer Software 2 27-oct-2005 21:25
Compatibilidad java 32 y 64 bits RGB Software 1 08-jun-2005 17:19
Ejecución remota de código en Java Web Start chuzo Internet, Redes y Wireless 0 21-mar-2005 23:16



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 02:55.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba