Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problemas con la tarjeta de Sonido
  #1  
Antiguo 19-ago-2004, 00:33
druidas
Invitado
 
Mensajes: n/a
Problemas con la tarjeta de Sonido

HOola¡¡
Bueno, me he dado cuenta de que no puedo escuchar nada bajo linux: ni los cd's, ni peliculas, ni mp3... vamos, nada.

He ido a Yast Control Center/Sonido y en configuración de sonido, me dice que el modelo de la tarjeta es: VT8233/A/8235 AC97 y en estado, me dice que ejecutando.

Exactamente no sé donde mirar qué tarjeta de sonido tengo, viene integrada en la placa base (eso creo), y ésta es: ASUS A7V8X-X y según tengo por ahi, el sonido se corresponde con SoundMAX Integrated Digital Audio.

En fin, desde windows no tengo problemas con el sonido. No sé si falta ponerle algun driver desde linux, si es que reconoce otra tarjeta, o lo qué... ¿alguna idea de qué debo hacer para que funcione en suse?
Responder Citando
  #2  
Antiguo 19-ago-2004, 00:54
Avatar de chuzo
chuzo chuzo está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-julio-2004
Ubicación: En un lugar de la mancha ...
Mensajes: 2.348
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 16
chuzo está en el buen camino
Hola

Ya se que puede parecer una tontería .. pero antes de mirar otras cosas has comprobado el volumen?? Yo tengo las opciones puestas así, puedes comprobar si lo tienes parecido, no vaya a ser algo de eso

__________________
La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
"No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"

Última edición por chuzo; 19-ago-2004 a las 00:58
Responder Citando
  #3  
Antiguo 19-ago-2004, 01:15
druidas
Invitado
 
Mensajes: n/a
HOola chuzo¡¡ Bueno, te cuento:

Sí, eso lo tengo igual que tú. Lo único que me cambia es que yo tengo una fila más, donde pone VIA DXS que está todo a 0.

También he mirado en el icono que sale al lado del relog, donde se controla el volumen, y tengo todo lo de mute desmarcado.

Si reproduzco un cd por ejemplo, me dice que el volumen está al 40%.

También he comprobado que esté todo bien cnchufado.
Responder Citando
  #4  
Antiguo 19-ago-2004, 01:29
Avatar de chuzo
chuzo chuzo está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-julio-2004
Ubicación: En un lugar de la mancha ...
Mensajes: 2.348
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 16
chuzo está en el buen camino
Bueno, pues una vez descartado eso vamos a probar otras cosas. Parece que esa tarjeta da algún tipo de problema, he encontrado una especie de "manual" para solucionar el problema del sonido ... lo puedes bajar aquí (espero que vaya bien el enlace, no lo puedo adjuntar porque es un poco más grande de lo permitido)

De todas formas el manual es un tanto "lioso", así que te pongo más o menos lo que tendrías que hacer:

Primero te bajas el siguiente fichero:

http://fresh.t-systems-sfr.com/linux...nux-v2x.tar.gz

Luego tendrías que ejecutar los siguientes comandos:

modprobe –r snd-pcm-oss
modprobe –r snd-seq-oss
modprobe –r snd-mixer-oss
modprobe –r snd-via82xx


Con eso eliminas los módulos (equivalente a los drivers) que se crearon en la instalación

Después descomprimes el fichero que te puse antes y ejecutas el fichero que lleva dentro:

tar zxvf oss398c-linux-v2x.tar.gz
./oss-install


Con eso te debe ejecutar un programa de instalación del nuevo "driver"

Una vez terminado te vas a la carpeta /usr/lib/oss y ejecutas:

./soundon

y según el manual con eso ya debería funcionar, a ver si hay suerte
__________________
La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
"No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"
Responder Citando
  #5  
Antiguo 19-ago-2004, 01:42
Avatar de riven
riven riven está desconectado
Administrador
 
Fecha de Ingreso: 16-julio-2004
Ubicación: /home/riven
Versión: 11.4
Mensajes: 895
Agradecimientos: 8
Agradecido 53 Veces en 21 Mensajes
Poder de Credibilidad: 10
riven está en el buen camino
¿Tampoco tienes sonido de eventos en kde? has probado a ver si tienes bien los modulos ALSA? mira a ver con el script alsaconf este lo has de ejecutar desde root; dinos si te ha dado algun problema.
__________________
Nunca olvido una cara pero con la suya voy a hacer una excepción.
Estos son mis principios. Si no le gustan tengo otros.

Responder Citando
  #6  
Antiguo 19-ago-2004, 01:55
druidas
Invitado
 
Mensajes: n/a
PUff... vaya, cuantas molestias, gracias de veras.

A ver, cuando ejecuto los comandos que me pones, los tres primeros parece que va bien, porque no se queja, en cambio el último me dice : snd-via82xx : Device or resource busy.

El fichero que me has puesto, lo he descargado en /home/esme/Programas, y es desde ahí donde lo he descomprimido (no sé si debería haberlo descomprimido en otro sitio, q eso no lo tengo nunca claro, ¿lo tendria que haber copiado en /usr y descomprimirlo desde allí?) En fin, que cuando voy a /usr/lib no hay nada que sea oss, con lo cual, no puedo ejecutar el ./soundon

Ayhss.. que paciencia conmigo, siento mi ignorancia
Responder Citando
  #7  
Antiguo 19-ago-2004, 01:59
druidas
Invitado
 
Mensajes: n/a
HOla riven¡¡
Los únicos sonidos que escucho desde linux, son dos pip pip cuando arranca (está en la pantalla negra esa del principio), y otro pip cuando lo apago. Por lo demás, nada más.

He ejecutado alsaconf, y me sale una pantallita azul donde dice que tengo instalada la tarjeta de sonido que he puesto antes... pero, una vez ahí ya no sé que hacer para ver si da o no problemas
Responder Citando
  #8  
Antiguo 19-ago-2004, 02:04
Avatar de chuzo
chuzo chuzo está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-julio-2004
Ubicación: En un lugar de la mancha ...
Mensajes: 2.348
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 16
chuzo está en el buen camino
En primer lugar no es ninguna molestia ayudarte, ya lo sabes

Cita:
Iniciado por druidas
(no sé si debería haberlo descomprimido en otro sitio, q eso no lo tengo nunca claro, ¿lo tendria que haber copiado en /usr y descomprimirlo desde allí?) En fin, que cuando voy a /usr/lib no hay nada que sea oss, con lo cual, no puedo ejecutar el ./soundon
A ver, el fichero lo puedes guardar donde quieras, eso da igual. Una vez lo descomprimes tienes que irte en la consola a esa carpeta y ejecutar ./oss-install, supongo que lo tendras en /home/esme/Programas/oss398c-linux-v2x. Pues te vas a la consola y pones:

cd /home/esme/Programas/oss398c-linux-v2x (para entrar en esa carpeta)
./oss-install (ejecutas el fichero oss-install)

y te debe aparecer una especie de instalador ... Una vez hagas eso ya sí deberías tener la carpeta oss y poder ejecutar el otro comando
__________________
La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
"No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"
Responder Citando
  #9  
Antiguo 19-ago-2004, 02:09
Avatar de chuzo
chuzo chuzo está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-julio-2004
Ubicación: En un lugar de la mancha ...
Mensajes: 2.348
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 16
chuzo está en el buen camino
Vaya .. y esto otro no lo había visto antes

Cita:
Iniciado por druidas
A ver, cuando ejecuto los comandos que me pones, los tres primeros parece que va bien, porque no se queja, en cambio el último me dice : snd-via82xx : Device or resource busy.
Ese mensaje indica que el dispositivo está ocupado, normalmente porque el módulo está siendo usado por otro módulo ... si ejecutas el comando lsmod te aparecen los módulos que tienes cargados en ese momento, y si están siendo usados por otro también te lo pone, lo puedes probar y a ver qué te sale
__________________
La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
"No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"
Responder Citando
  #10  
Antiguo 19-ago-2004, 02:27
druidas
Invitado
 
Mensajes: n/a
HOola¡¡ Bueno, te dejo lo que me ha salido. Supongo que tengo que buscarme otra versión más reciente, no? Bueno, ya seguiremos. Gracias otra vez¡¡

linux:/home/esme/Programas # ./oss-install
Checking for any previously installed sound drivers... You appear to have the th
e kernel level sound driver installed as a loadable
module. Unload it by executing rmmod sound and try installing OSS/Linux again.

If this error repeats again you probably have the sound driver being loaded
automagically by the kerneld daemon. In this case you should remove all sound.o
files from all subdirectories of /lib/modules in addition to executing
rmmod sound. After that you probably should reboot the system before trying to
install OSS again. Edit /etc/modules.conf and remove the 'alias sound ...'
line in case it exist and replace it by 'alias sound off'.

Also add a line containing 'alias char-major-14 off' to /etc/modules.conf.
Am I allowed to do these changes automatically for you (Y/N) ? y
Trying to disable the conflicting sound driver
/etc/modules.conf backed up to /etc/modules.conf.pre-oss
Unloading the existing sound driver
If your system freezes now, please reboot and disable the current driver manuall y.
Done.
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Can't connect to display: :0.0
Can't connect to display: :0.0
Can't connect to display: :0.0



* Open Sound System installation completed successfully *
Device configuration has been saved to /usr/lib/oss/devices.cfg
Execute /usr/lib/oss/soundconf if you want to change configuration.
Start the driver by using /usr/lib/oss/soundon command
See /usr/lib/oss/Readme for further instructions



*** Activating OSS and performing selftest ***


This Open Sound System copy is licensed for limited evaluation use only.
You can order the permanent OSS license using the 'Order permanent OSS license'
function of soundconf command. Alternatively use our ordering page at
http://www.opensound.com/order.html.


This OSS version expired: 06/2004
Please download the latest OSS version from http://www.opensound.com/download.cgi


Failed to activate the driver
Probably caused by a technical problem.
See /usr/lib/oss/soundon.log for more info.
Starting OSS failed
linux:/home/esme/Programas # cd /usr/lib/oss
linux:/usr/lib/oss # ./soundon
This Open Sound System copy is licensed for limited evaluation use only.
You can order the permanent OSS license using the 'Order permanent OSS license'
function of soundconf command. Alternatively use our ordering page at
http://www.opensound.com/order.html.


This OSS version expired: 06/2004
Please download the latest OSS version from http://www.opensound.com/download.cgi


Failed to activate the driver
Probably caused by a technical problem.
See /usr/lib/oss/soundon.log for more info.
linux:/usr/lib/oss #
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Traducción Tutorial Sonido en openSuse 11.0 tranzorx Hardware 7 02-mar-2012 05:59
Traducción de SDB:AudioTroubleshooting de openSUSE tranzorx Hardware 6 09-mar-2011 20:10
Sonido se me desconfigura. Tarjeta integrada Azalia. tranzorx General OpenSUSE 12 25-sep-2008 19:27
Problemas con la tarjeta de sonido Raiden Hardware 4 05-sep-2005 16:23
problemas con la tarjeta de sonido c-media susepanda2005 Hardware 3 30-mar-2005 17:35



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 18:19.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba