Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Sobre eliminar un repo [solucionado]
  #1  
Antiguo 04-mar-2017, 13:37
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 494
Agradecimientos: 180
Agradecido 112 Veces en 96 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Question Sobre eliminar un repo [solucionado]

Hola:

Uno de mis repos es:

http://download.opensuse.org/reposit...USE_Leap_42.2/

Lo tengo porque tiene un soft de grabación de vídeo para juegos openGL que usaba hace mucho. Ayer intenté usarlo de nuevo y veo que sigue topeando CPU en la grabación por lo que es inusable.

Como ya no lo uso (ya que hace mucho que uso Vokoscreen) y es un repo personal de los que se aconseja no tener salvo excepciones, me disponía a borrar ese repo. Pero antes me he puesto a mirar qué tenía instalado de ese repo y si habían equivalentes en los repos de siempre.

Mi única duda surge en que tengo instalados 2 paquetes que no sé si son necesarios o no (en caso de ser necesarios no los encuentro en repos oficiales + Packman). Esos 2 paquetes instalados del repo lemmy04 no los busqué yo, se instalaron ellos solos.

Los paquetes son:

intel-e1000e 3.3.5.3-3.9
intel-e1000e-kmp-default 3.3.5.3_k4.4.49_16-3.9

Veo que en ajustes de red aparece ese driver como usado por la tarjeta de red, así que no sé qué hacer con ese repo.

Código:
sudo dmesg | grep -e eth -e e1000
[    0.000000] BRK [0x023e1000, 0x023e1fff] PGTABLE
[    1.713511] e1000e: loading out-of-tree module taints kernel.
[    1.714004] e1000e: Intel(R) PRO/1000 Network Driver - 3.3.5.3-NAPI
[    1.714005] e1000e: Copyright(c) 1999 - 2016 Intel Corporation.
[    1.782058] e1000e 0000:00:1f.6: Interrupt Throttling Rate (ints/sec) set to dynamic conservative mode
[    2.050168] e1000e 0000:00:1f.6 0000:00:1f.6 (uninitialized): registered PHC clock
[    2.131782] e1000e 0000:00:1f.6 eth0: (PCI Express:2.5GT/s:Width x1) 38:d5:47:12:99:a6
[    2.131783] e1000e 0000:00:1f.6 eth0: Intel(R) PRO/1000 Network Connection
[    2.131937] e1000e 0000:00:1f.6 eth0: MAC: 12, PHY: 12, PBA No: FFFFFF-0FF
[    6.323624] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    9.139000] e1000e: eth0 NIC Link is Up 100 Mbps Full Duplex, Flow Control: None
[    9.139009] e1000e 0000:00:1f.6 eth0: 10/100 speed: disabling TSO
[    9.139073] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
Tras todo el sumario, pues eso. ¿Puedo borrar esos paquetes o me quedaré sin poder usar la tarjeta de red?

Tarjeta integrada en placa base Asus B150 Pro Gaming. CPU i5-6600K.
OpenSUSE Leap 42.2. Kernel 4.4..49-16. Plasma 5.8.3.

SOLUCIONADO: La solución ha sido poner el repo específico de Hardware (http://download.opensuse.org/reposit...USE_Leap_42.2/) y pillar los paquetes intel e1000e de ahí.


Saludos

Última edición por Krovikan; 05-mar-2017 a las 13:50 Razón: solucionado
Responder Citando
  #2  
Antiguo 04-mar-2017, 13:46
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.221
Agradecimientos: 42
Agradecido 1.264 Veces en 932 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

Al eliminar un repo simplemente borras la entrada de la base de datos con el software que contiene y el propio repo. No tiene que tener efecto sobre el software instalado.

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
  #3  
Antiguo 04-mar-2017, 14:03
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 494
Agradecimientos: 180
Agradecido 112 Veces en 96 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Cierto. No recordaba ese punto en el mensaje (ya que sí, ese dato lo sé pero ni lo recordé mencionar).

Me explicaré más.

Pretendía asegurarme que todos los paquetes (salvo los pertenecientes al programa GLC) ya estuvieran en OSS o Non-OSS.

Pero al no pertenecer esos 2 paquetes a ninguno de los repos nombrados (salvo al de lemmy04), ¿qué pasaría si borro los paquetes?

¿Me quedo sin red o el sistema por sí solo ya utilizará algún módulo de driver de red?
En caso de lo segundo, ¿ese driver de sistema será mejor o peor que ese intel-e1000e? Que recuerdo que yo no pedí que se instalara, fue él solito. Y supongo que si no hubiera tenido el repo lemmy04 no se habría instalado ya que no está en ningún otro repo.

Gracias @karlggest. Espero haberme explicado mejor esta vez. Sorry.


Saludos
Responder Citando
  #4  
Antiguo 04-mar-2017, 16:13
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.221
Agradecimientos: 42
Agradecido 1.264 Veces en 932 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

En los paquetes que tengas dudas, selecciona el paquete y ve abajo a la pestaña "versiones" (todo esto con YaST).

A partir de ahí, depende de qué sea, claro.

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
Los Siguientes 2 Usuarios Han Dado las Gracias a karlggest Por Este Mensaje:
Krovikan (04-mar-2017)
  #5  
Antiguo 04-mar-2017, 17:08
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 494
Agradecimientos: 180
Agradecido 112 Veces en 96 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Los paquetes con dudas (no los instalé a conciencia, lo hicieron ellos solos):




Si los marco para borrado no me piden borrar nada más ni hacen conflicto con nada (no los he borrado, sólo ver qué pasaba si los marcaba):



Lo que me preocupa de esos paquetes (que no tendría que tener si no fuera por ese repo externo que muy pocos tendrán) es la siguiente captura:


El nombre del único módulo que aparece en el combo es e1000e. No sé si me quedaré sin red o es que utilizará un módulo propio del kernel. No tengo ni idea.


Saludos
Responder Citando
  #6  
Antiguo 05-mar-2017, 10:47
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.595
Agradecimientos: 571
Agradecido 2.476 Veces en 1.674 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Si funciona, no los borres. Mira esto: https://software.opensuse.org/package/intel-e1000e

No obstante, mirando en mi carpeta de drivers de LAN de Intel, veo que lo tengo dentro de unas carpetas con esos drivers, eso quiere decir que ya viene incluido en el kernel y que tu has instalado la ultima version de ese driver como paquete. En mi caso utilizo Leap 42.1.

Ejecutando lsmod | grep -i e1000 no me sale ninguna linea de salida, eso quiere decir que no utilizo dicho driver

Código:
~> lsmod | grep -i e1000

~> ls -al /lib/modules/`uname -r`/kernel/drivers/net/ethernet/intel
total 72
drwxr-xr-x 1 root root   114 feb 25 18:20 .
drwxr-xr-x 1 root root   520 feb 25 18:20 ..
drwxr-xr-x 1 root root    16 feb 25 18:20 e1000
drwxr-xr-x 1 root root    18 feb 25 18:20 e1000e
-rw-r--r-- 1 root root 70506 feb 20 11:45 e100.ko
drwxr-xr-x 1 root root    16 feb 25 18:20 fm10k
drwxr-xr-x 1 root root    14 feb 25 18:20 i40e
drwxr-xr-x 1 root root    18 feb 25 18:20 i40evf
drwxr-xr-x 1 root root    12 feb 25 18:20 igb
drwxr-xr-x 1 root root    16 feb 25 18:20 igbvf
drwxr-xr-x 1 root root    14 feb 25 18:20 ixgb
drwxr-xr-x 1 root root    16 feb 25 18:20 ixgbe
drwxr-xr-x 1 root root    20 feb 25 18:20 ixgbevf
Si me das el identificador de la tarjeta de red (xxxx:yyyy) miro que drivers soporta.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p

Última edición por DiabloRojo; 05-mar-2017 a las 11:51
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Krovikan (05-mar-2017)
  #7  
Antiguo 05-mar-2017, 12:26
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 494
Agradecimientos: 180
Agradecido 112 Veces en 96 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
A mi me sale:

Código:
lsmod | grep -i e1000
e1000e                258048  0 
ptp                    20480  1 e1000e
Respecto al identificador supongo que será:

Código:
sudo lspci -nn | grep Ethernet
00:1f.6 Ethernet controller [0200]: Intel Corporation Ethernet Connection (2) I219-V [8086:15b8] (rev 31)

Saludos
Responder Citando
  #8  
Antiguo 05-mar-2017, 12:55
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.595
Agradecimientos: 571
Agradecido 2.476 Veces en 1.674 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Efectivamente, esa tarjeta [8086:15b8] utiliza el driver e1000e.

Tu mismo decides si quieres el driver del paquete intel-e1000e o el de que viene incluido en el kernel como en mi caso.

Otra alternativa seria que cambiaras ese repo particular al de hardware, según mi 1er. enlace.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Krovikan (05-mar-2017)
[solucionado]
  #9  
Antiguo 05-mar-2017, 13:44
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 494
Agradecimientos: 180
Agradecido 112 Veces en 96 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
[solucionado]

Muchas gracias D.R.

Ya he añadido el repo:

http://download.opensuse.org/reposit...USE_Leap_42.2/

que es específico de eso y que el único paquete que cojo de ahí es el intel e1000e.

El de GLC (lemmy04) que tenía mucha diversidad de paquetes aunque sólo usaba los de GLC y el intel e100e (éste último sin saberlo), ha pasado a mejor vida.


Saludos y paso a Solucinado esto
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Boton derecho sobre archivos y sistema colapsa temporalmente.... [solucionado] Mark0pX Software 1 28-oct-2012 19:31
Favor ayuda!!! Buscar carpetas y eliminar solo su contenido [solucionado] alyonidi General OpenSUSE 4 10-oct-2009 03:17
Duda sobre instalación [SOLUCIONADO] gery Instalación y Actualizaciones 2 06-feb-2009 23:57
Duda sobre actualizaciones en opensuse [SOLUCIONADO] blackstar Software 10 19-nov-2008 22:58
script simple para eliminar archivos [SOLUCIONADO] Juan Carlos Programación y Scripts 3 18-mar-2008 12:03



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 03:11.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba