Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Multimedia


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Videos a pantalla completa en Mplayer
  #1  
Antiguo 24-ago-2006, 22:31
Avatar de abahatar
abahatar abahatar está desconectado
Aforado
 
Fecha de Ingreso: 22-agosto-2006
Mensajes: 13
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
abahatar está en el buen camino
Exclamation Videos a pantalla completa en Mplayer

Hola foro, aprovecho este mensage para saludar a todos y para expresar una problemilla que tengo.

Hace poco que he pasado de Ubuntu a Suse 10.1 y me ha gustado el canvio, no lo niego, me costo un poco poner la wifi y el compiz pero es lo que tiene. Lo dicho, contento pero tambien me encuentro que no puedo ver peliculas a pantalla completa con el mplayer, y he porbado con los controladores que viene y he bajado de la pagina de mplayer tambien pero nada.... como mucho puedo ver el video bien pero no en pantalla completa.

Pos eso que un poco de ayudita no me vendria mal.

Gracias por adelantado y un saludo a todos.
Responder Citando
  #2  
Antiguo 24-ago-2006, 23:56
Avatar de rben1771
rben1771 rben1771 está desconectado
Miembro Junior
 
Fecha de Ingreso: 31-julio-2006
Mensajes: 611
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
rben1771 está en el buen camino
Le das al boton derecho del raton sobre la pantalla del video y del menú emergente que te saldra tienes que darle a Full Screen para poner el mplayer en pantalla completa
__________________
OpenSuSE:
Gnu/Linux for authentics human beings.
Responder Citando
  #3  
Antiguo 25-ago-2006, 01:38
Avatar de abahatar
abahatar abahatar está desconectado
Aforado
 
Fecha de Ingreso: 22-agosto-2006
Mensajes: 13
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
abahatar está en el buen camino
Cita:
Iniciado por rben1771
Le das al boton derecho del raton sobre la pantalla del video y del menú emergente que te saldra tienes que darle a Full Screen para poner el mplayer en pantalla completa

Jjejeje, gracias por lo evidente... no creas que lo he intentado, el problema esta en que aunque tenga la pantalla completa el video sigue ocupando el tamaño original, no se si me explico.
Responder Citando
  #4  
Antiguo 25-ago-2006, 02:05
RedDwarf RedDwarf está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 11-mayo-2006
Versión: openSUSE 12.1
Mensajes: 1.531
Agradecimientos: 0
Agradecido 29 Veces en 26 Mensajes
Poder de Credibilidad: 14
RedDwarf está en el buen camino
Sí, ahora te explicas. Copia los resultados de:
- mplayer -v <video>
- mplayer -vo xv -v <video> (con esto se ven a pantalla completa?)
- xvinfo
Y saber que gráfica/driver tienes también vendría bien.
En Ubuntu te funcionaba, no?

Mientras tanto puedes verlos a pantalla completa con: mplayer -zoom <video>, pero no es una buena forma de lograrlo.
Responder Citando
  #5  
Antiguo 25-ago-2006, 02:37
Avatar de abahatar
abahatar abahatar está desconectado
Aforado
 
Fecha de Ingreso: 22-agosto-2006
Mensajes: 13
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
abahatar está en el buen camino
Cita:
Iniciado por RedDwarf
Sí, ahora te explicas. Copia los resultados de:
- mplayer -v <video>
- mplayer -vo xv -v <video> (con esto se ven a pantalla completa?)
- xvinfo
Y saber que gráfica/driver tienes también vendría bien.
En Ubuntu te funcionaba, no?

Mientras tanto puedes verlos a pantalla completa con: mplayer -zoom <video>, pero no es una buena forma de lograrlo.

Gracias por responder y sobre todo tan rapido, he probado en terminal de ejecutar los comando que me distes y funciona per va lentisimo, tanto que colapsa, por otro lado aqui te dejo el resultado de xvinfo
X-Video Extension version 2.2
screen #0
Adaptor #0: "Xgl Generic Texture Video"
number of ports: 32
port base: 48
operations supported: PutImage
supported visuals:
depth 24, visualID 0x2c
depth 24, visualID 0x2d
depth 32, visualID 0x2e
depth 32, visualID 0x2f
no port attributes defined
maximum XvImage size: 2048 x 2048
Number of image formats: 3
id: 0x32595559 (YUY2)
guid: 59555932-0000-0010-8000-00aa00389b71
bits per pixel: 16
number of planes: 1
type: YUV (packed)
id: 0x32315659 (YV12)
guid: 59563132-0000-0010-8000-00aa00389b71
bits per pixel: 12
number of planes: 3
type: YUV (planar)
id: 0x0
guid: 03000000-0000-0010-8000-00aa00389b71
bits per pixel: 32
number of planes: 1
type: RGB (packed)
depth: 24
red, green, blue masks: 0xff0000, 0xff00, 0xff
enrique@Henrike:/windows/F/friks/bleach/Videos>

Tengo una grafica de 64 Mb con el chip nvidia, una cpu de 1200 y 512 de RAM.

Gracias otra vez.
Responder Citando
  #6  
Antiguo 25-ago-2006, 03:07
RedDwarf RedDwarf está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 11-mayo-2006
Versión: openSUSE 12.1
Mensajes: 1.531
Agradecimientos: 0
Agradecido 29 Veces en 26 Mensajes
Poder de Credibilidad: 14
RedDwarf está en el buen camino
Funciona con todos o solo con "-zoom" (que sí, es lento)?
Nunca he probado xgl (desactivandolo te funcionará), pero ese "Generic Texture Video" debería ser suficiente para tener pantalla completa.
Si solo funciona con el "-zoom" habrá que ver la salida de "mplayer -v".
Responder Citando
  #7  
Antiguo 25-ago-2006, 10:46
Avatar de abahatar
abahatar abahatar está desconectado
Aforado
 
Fecha de Ingreso: 22-agosto-2006
Mensajes: 13
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
abahatar está en el buen camino
Cita:
Iniciado por RedDwarf
Funciona con todos o solo con "-zoom" (que sí, es lento)?
Nunca he probado xgl (desactivandolo te funcionará), pero ese "Generic Texture Video" debería ser suficiente para tener pantalla completa.
Si solo funciona con el "-zoom" habrá que ver la salida de "mplayer -v".

He probado con -v pero aunque la pantalla es totalmente completa sigue llendo lento, también he probado por quitar el compiz.desktop de /home/usuario/.kde/Autostart para que no se autoinicie y he modificado el "displaymanager" para xv=fbo pero sigo con las mismas, lo raro es que en ubunu no tuve todas estas historias....

Seguiré buscando y si veo que no puedo pues desinstalare xgl y compiz y restaurare el displaymanager a su estado original.

Ahora hago una pequeña trampa y es que aprovecho el zoom del xgl para ver el video a "pantalla completa", por ahora es una solución.

Gracias otra vez por la ayuda.

Última edición por abahatar; 25-ago-2006 a las 13:02
Responder Citando
  #8  
Antiguo 26-ago-2006, 20:53
Avatar de abahatar
abahatar abahatar está desconectado
Aforado
 
Fecha de Ingreso: 22-agosto-2006
Mensajes: 13
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
abahatar está en el buen camino
Cita:
Iniciado por abahatar
He probado con -v pero aunque la pantalla es totalmente completa sigue llendo lento, también he probado por quitar el compiz.desktop de /home/usuario/.kde/Autostart para que no se autoinicie y he modificado el "displaymanager" para xv=fbo pero sigo con las mismas, lo raro es que en ubunu no tuve todas estas historias....

Seguiré buscando y si veo que no puedo pues desinstalare xgl y compiz y restaurare el displaymanager a su estado original.

Ahora hago una pequeña trampa y es que aprovecho el zoom del xgl para ver el video a "pantalla completa", por ahora es una solución.

Gracias otra vez por la ayuda.
He probado quitando el xgl y el compiz y vuelve a funcinar bien, lo raro es que cuando estava en X11/xv la pantalla era como si se estirase en todos los lados del cubo....
Bueno... esperare a una versión estable del XGL, por cierto en Gnome me pasaba lo mismo.

Un saludo a todos.
Responder Citando
  #9  
Antiguo 26-ago-2006, 21:40
Avatar de ShakaGoldSaint
ShakaGoldSaint ShakaGoldSaint está desconectado
Habitual
 
Fecha de Ingreso: 17-junio-2006
Ubicación: /home/eleazar
Versión: Ubuntu Fiesta Fawn!
Mensajes: 337
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 13
ShakaGoldSaint está en el buen camino
Enviar un mensaje por MSN a ShakaGoldSaint
Solo por saber, estas completamente seguro de que el responsable de tu percanse es el xvideo?, me refiero has probado otras aplicaciones para reproducir video?

Bueno, los gurus ya han posteado, aqui voy sho con un intento de solucion chimba

Juega con el /home/<Nombredeusuario>/.mplayer/config para ver que tal, googleando se consiguen archivos config para el mplayer bastante "pimped"

Aqui el mio, vilmente googleado (tiene muchas opciones como comentario #, porque no todas me daban mejoras en mi caso, y pues uno las deja ahi por pereza)

Código:
#General setup

#ao="alsa" #audio out
#mixer-channel="Master"
#srate=48000

really-quiet="1" #Very very little console output

vo="xv" #video out
zoom="1" #Allow sofware scaling if I use x11 for vo
#aid="1" #audio channel
sid="0" #subtitle set

#Display

double="yes" #double buffering(recommended for subtitles)
#monitoraspect="16:9" #I'm on a widescreen laptop so keeps 4:3 content from stretching
framedrop="0" # For slow machines
hardframedrop="0" #Make sure hard frame drop is off but can turn on easily now

# Set font encoding.
#subfont-encoding=unicode

# Set subtitle file encoding.
#unicode=yes
#utf8=yes

#subtitle code
#Truetype fonts rock! (sudo apt-get msttcorefonts)
font=/windows/WINDOWS/Fonts/trebucbd.ttf

ffactor="10" #black outline
sub-bg-alpha="0" #background color ala closed captions
sub-bg-color="0" #black to white
subfont-text-scale="3.4" #truetype font scaling
subfont-blur="1" #Slight blur

#This sets the postprocessing into overdrive using all possible spare cpu cycles to make the movie look better
#autoq=100
#vf=pp=de,hqdn3d


#subpos="90" #By default subtitles are too low
subalign="2"

#always keep mplayer on top
ontop="0"

#turns off xscreen saver...maybe
stop-xscreensaver="yes"

#Some extra stuff I am currently not using....
#Fix A/V sync problems on files with bad MP3 VBR audio
#mc="1"
#autosync="10"
#delay="0.5"
Si estas completamente seguro de que el problema es directamente con el xvideo sencillamente ignora este post xD

Saludos
__________________
(\__/) Este es Conejo.
(='.'=) Copia a Conejo en tu firma y
(")_(") ayudale en sus planes de dominacion mundial.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
No puedo instalar Mplayer moino Multimedia 3 16-ene-2007 06:47
Como escuchar la radio con suse 10.1 danielremix Multimedia 6 24-jun-2006 22:51
Radio en Firefox galois Software 10 17-abr-2006 18:39
mplayer error en libs galaxi2 Software 4 22-sep-2005 16:37
Programas a pantalla completa JuanJ Software 4 01-mar-2005 22:21



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 00:35.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba