Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Ayudaa con tarjeta de video ati radeon 9250
  #1  
Antiguo 29-jun-2006, 19:52
panchox
Invitado
 
Mensajes: n/a
Ayudaa con tarjeta de video ati radeon 9250

Hola a todos,,, soy novato en linux,,,

Tengo una placa madreAsrock P4i45GV con video on-board intel extreme graphics, y le agrege una ATI 9250 Gamer Edition, la cosa es que hace rato no podia instalar ninguna distribucion de linux porque me salia un error :
INIT: PANIC: segmentation violation at 0xffffe420! sleeping for 30 seconds. .

Estuve buscando y varios tenian el mismo problema,,, asi q decidi sacar la tarjeta para ver si pescaba linux,,, y lo pude instalar,,, lo malo es q única manera de bootear con SuSE 10.1 es ir al bios setup seleccionar como primary video card : internal VGA, desconectar el monitor de la tarjeta Ati, y conectarlo a la tarjeta de video on-board, y alli recien inicia SuSe,,, porque si conecto el monitor a la ATI,,, no se inicia porque me dice q espera a la otra tarjeta,,, Intel,,, estuve buscando en internet,, y igual decia algo de que se puede desactivar la agregando el modulo de intel a la lista negra (blacklist) de los módulos que se cargan al iniciar la distribución, pero no espedifica mas,,, espero ayuda porfa,,, quiero emigrar rapido de Windows....

Saludos

Última edición por panchox; 29-jun-2006 a las 19:58
Responder Citando
  #2  
Antiguo 09-jul-2006, 22:07
panchox
Invitado
 
Mensajes: n/a
Porfa,, llevo como 4 semanas usando SUSe,,, y nadie responde,,, estoy utilizando la tarjeta de video integrada,,, y quiero usar la mia,,,,
Responder Citando
  #3  
Antiguo 09-jul-2006, 22:20
Avatar de keops
keops keops está desconectado
Miembro Junior
 
Fecha de Ingreso: 19-diciembre-2005
Ubicación: Mallorca
Mensajes: 600
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
keops está en el buen camino
Hola,

Y la bios, ¿ no te deja desactivar la tarjeta que lleva integrada la placa ?

Salu2
__________________
SuSE 11.3 - KDE
The Time Of CHOICE, Time Of Freedom
Responder Citando
  #4  
Antiguo 10-ago-2006, 21:41
randu
Invitado
 
Mensajes: n/a
yo tambien tengo el mismo problema, ya encontraste una forma de solucionarlo
Responder Citando
  #5  
Antiguo 10-ago-2006, 22:31
milytres
Invitado
 
Mensajes: n/a
Cita:
Iniciado por keops
Hola,

Y la bios, ¿ no te deja desactivar la tarjeta que lleva integrada la placa ?

Salu2
Como te dice Keops o bien mira el manual de la placa a ver si tienes algun jamper para deshabilitar la tarjeta que va integrada en placa.

Por otra parte creo que se podría arrancar con las dos tarjetas instaladas, no se si Suse lo soporta pero no me extrañaría, en ese caso mira de conectar un monitor a cada salida de las tarjetas, es decir dos monitores, para así hacer configuraciones.

Saludos.
Responder Citando
  #6  
Antiguo 21-ago-2006, 01:36
randu
Invitado
 
Mensajes: n/a
ya encontre como solucionar el problema de compatibilidad de la mother board ASRock P4i45GV con tarjetas de video AGP
para mi caso particular una tarjeta ati radeon 9250 de 256M

cuando uno instala cualquier distribución de linux, se encuentra el siguiente mensaje
INIT! PANIC: Segmentation violation at 0xfffe420! sleeping for 30 seconds.

y no arranca por todos los medios posibles, lo que sucede es que la mother board no es 100% compatible como dice el fabricante con las tarjetas AGP, y cuando uno monta un sistema operativo como linux genera estos problemas.

una forma sencilla para solucionar esto es

1. en la bios cambiar el tipo de puerto de video al generico de la mother board, con esto instalamos nuestra distribución preferida luego de tenerlo instalado tenemos que hacer un blacklist de el modulo intelagp, para que nuestra tarjeta no se cuelgue cuando trate de arrancar. se hace añadiendo al fichero /etc/modprobe.conf.local lo siguiente:

# blacklist agp module
blacklist intel_agp

bueno a mi me funciono solo quitando este modulo, existen otros modulos que pueda que deban ser agregados si algo sale mal entonces probar a agregar otros modulos, para esto es solo mirar con lsmod | grep agp los modulos que estan corriendo.


2. luego de esto podemos proceder a instalar los driver de nuestra tarjeta de video (en mi caso una ati y para la distro suse 10.1) como aparece en muchos manuales de las tarjetas ati.
recordemos que debemos primero instalar
gcc, make, kernel-source, kernel-syms, kdeadmin3

luego pasamos a init 3 e instalamos el driver
chmod +x ./ati-driver-installer-8.24.8-x86.run --buildpkg SuSE/SUSE101-IA32 (esto puede variar dependiendo de la version del driver y de la distribucion que tengamos instalada)

luego instalamos el rpm que nos crea

rpm -ivh fglrx_........rpm

despues ejecutamos

ldconfig
.
.
.
aticonfig --initial --input=/etc/X11/xorg.conf
despues que tenemos instalado el driver procedemos a reiniciar el computador y cambiar nuevamente en la bios a agp, con esto iniciamos en linux normalmente,
si no nos carga el entorno grafico, entramos a sax2 y configuramos nuevamente nuestro monitor,

sax2 -r -m 0=fglrx

si por algun motivo no arranca o nos saca este error:
sax: ups lost card during probing... abort at /usr/share/sax/init.pl line 619
entonces ejecutamos esta linea

sax2 -c 1 -m 1=fglrx

y listo nuestra distribución tiene entorno grafico.
Responder Citando
  #7  
Antiguo 23-ago-2006, 20:17
obrero
Invitado
 
Mensajes: n/a
Cita:
Iniciado por milytres
Como te dice Keops o bien mira el manual de la placa a ver si tienes algun jamper para deshabilitar la tarjeta que va integrada en placa.

Por otra parte creo que se podría arrancar con las dos tarjetas instaladas, no se si Suse lo soporta pero no me extrañaría, en ese caso mira de conectar un monitor a cada salida de las tarjetas, es decir dos monitores, para así hacer configuraciones.

Saludos.

pero tengo una duda por k no se puede desabilitar el video integrado de la placa (atravez de la BIOS sin necesidad de jumpear) que por lo demas no es antigua peor bueno lo importante es que ya lo solucionaron
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
tarjeta de video jaimeaag Instalación y Actualizaciones 7 26-jul-2006 10:22
Problemas con la tarjeta de video Rock-Lee General OpenSUSE 2 13-jun-2006 20:28
CAMBIO DE TARJETA video willicl Hardware 15 25-abr-2006 00:40
Problema de arranque con tarjeta de video eNvidia fx5500 JK0 Hardware 5 14-ago-2005 01:12
Problema con tarjeta de video Elmer Hardware 1 09-jul-2005 01:58



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 05:39.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba