Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

raspberry pi3 b+ [Solucionado]
  #1  
Antiguo 05-jul-2018, 00:42
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 15.0
Mensajes: 901
Agradecimientos: 212
Agradecido 355 Veces en 243 Mensajes
Poder de Credibilidad: 14
soyasi está en el buen camino
raspberry pi3 b+ [Solucionado]

Me ha caído del cielo este juguetito, he conseguido instalar varias distros diferentes pero no opensuse, los manuales que encuentro son para la "raspberry pi 3" que en teoría debería de funcionar, pero parece ser que no.

Ya he probado de diferentes formas:

con la opción de victorhck de su blog y con la página oficial de opensuse

El mismo problema se plantea en el foro de raspberry

Alguna idea de por donde buscar ....

Pasos que he seguido segun la pagina de opensuse

1º bajo la iso 2º la quemo en un usb
Cita:
dd if=openSUSE-Leap-15.0-DVD-aarch64-Build124.1-Media.iso of=/dev/sdm bs=4M iflag=direct,fullblock oflag=direct
3º miro la MSD

Cita:
fdisk -l /dev/sde
Disco /dev/sde: 29,7 GiB, 31888244736 bytes, 62281728 sectores
Unidades: sectores de 1 * 512 = 512 bytes
Tamaño de sector (lógico/físico): 512 bytes / 512 bytes
Tamaño de E/S (mínimo/óptimo): 512 bytes / 512 bytes
Tipo de etiqueta de disco: dos
Identificador del disco: 0x324a75c8

Disposit. Inicio Comienzo Final Sectores Tamaño Id Tipo
/dev/sde1 8192 62281727 62273536 29,7G c W95 FAT32 (LBA)

Ver la velocidad de la tarjeta, en este caso 10,1 MB/s

dd if=/dev/sde of=suse bs=64k count=16k conv=fdatasync
16384+0 registros leídos
16384+0 registros escritos
1073741824 bytes (1,1 GB, 1,0 GiB) copied, 106,209 s, 10,1 MB/s
4º Genero la partición en vfat
Cita:
mkfs -t vfat /dev/sde1
5º Monto la partición
Cita:
mount /dev/sde1 /mnt
6º bajo el software
Cita:
zypper -n in raspberrypi-firmware raspberrypi-firmware-config raspberrypi-firmware-dt
7º lo copio a la tarjeta
Cita:
cp -a /boot/vc/* /mnt/
8º lo borro
Cita:
zypper -n rm raspberrypi-firmware raspberrypi-firmware-config raspberrypi-firmware-dt
9º creo directorio temporal
Cita:
mkdir tmp_uboot
10º Bajo sofware necesario u-boot
Cita:
wget http://download.opensuse.org/ports/a....1.aarch64.rpm -O tmp_uboot/u-boot-rpi3.aarch64.rpm
11º entro al directorio temporal
Cita:
cd tmp_uboot
12º
Cita:
rpm2cpio u-boot-rpi3.aarch64.rpm | cpio -id
genera por respuesta --> 1257 bloques

13º copio al directorio raiz de la tarjeta
Cita:
cp boot/vc/* /mnt/
14º salgo del directorio
Cita:
cd..
15º borro el directorio temporal
Cita:
rm -rf tmp_uboot
16º desmonto la tarjeta sd
Cita:
umount /mnt
15º Inserto la MSD y el usb en la Raspberry Pi 3 b+

16º Conecto a la pantalla via HDMI

17º conecto teclado y ratón.

18º Le doy corriente via adaptador micro USB

19º El Led rojo se queda encendido de forma permanente y el led verde enciende 1 seg y se apaga, el usb no parpadea.

La pantalla se queda congelada con la siguiente informacion:



Usando este método o el descrito por victorhck en su blog el resultado en pantalla es el mismo.


el archivo config.txt
Cita:

# Get more options/information on http://elinux.org/RPiconfig
# or on https://www.raspberrypi.org/document.../config-txt.md
#
# !!!!! This file will get overwritten by updates. Please use !!!!!
# !!!!! extraconfig.txt if you want to set additional !!!!!
# !!!!! configuration options or add dt overlays. !!!!!

# Our kernels are located on a Linux partition. Chainload U-Boot to load them.
kernel=u-boot.bin

# Use 32 MB for GPU for all RPis (Min 16 - Max 192 MB)
# We don't need that much memory reserved for it, because we drive most hardware
# from Linux, not the VPU OS
gpu_mem=32

# Turbo mode: 0 = enable dynamic freq/voltage - 1 = always max
force_turbo=0
# Start in turbo mode for 30 seconds or until cpufreq sets a frequency
initial_turbo=30

# DO NOT overvoltage manually to not void warranty!
over_voltage=0

# Fix mini UART input frequency, and setup/enable up the UART.
enable_uart=1

# Disable warning overlays as they don't work well together with linux's graphical output
avoid_warnings=1

# These are not applied automatically? Needed to use respective upstream drivers.
dtoverlay=vc4-kms-v3d
dtoverlay=dwc2

# This overlay fixes divergences between the RPi device tree and what
# upstream provides
dtoverlay=upstream-mmc
dtoverlay=upstream-aux-interrupt

[pi1]

# Max ARM freq (default 700 MHz)
arm_freq=840

# Max core (GPU) freq (default 250 MHz)
core_freq=375

# SDRAM freq (default 400)
sdram_freq=400


[pi3]

# Boot in AArch64 (64-bit) mode
arm_control=0x200

# Older kernels didn't support HDMI connection detection on the rpi3, so force
# HDMI to always plugged in there. This overlay is only effective on rpi3.
dtoverlay=rpi3-hdmi


[all]

# Allow user overrides of config options
include extraconfig.txt
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 15.0 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 12-jul-2018 a las 05:45
Responder Citando
  #2  
Antiguo 05-jul-2018, 10:18
Avatar de victorhck
victorhck victorhck está desconectado
Moderador
 
Fecha de Ingreso: 08-abril-2010
Ubicación: /HOME
Versión: Tumbleweed y Leap + KDE
Mensajes: 3.665
Agradecimientos: 326
Agradecido 1.182 Veces en 763 Mensajes
Poder de Credibilidad: 12
victorhck está en el buen camino
Hola!

Veo un montón de pasos!! no sé si todos son necesarios!

Veamos, copiamos la imagen a la tarjeta con:

Código:
xzcat openSUSE-Tumbleweed-ARM-JeOS-raspberrypi3.aarch64-2017.06.10-Build2.7.raw.xz | dd bs=4M of=/dev/sdb iflag=fullblock oflag=direct; sync
Mutandi, mutantis, cambia el nombre de la imagen .raw.xz a la que hayas descargado y cambia /dev/sdb por lo que sea en tu equipo donde hayas introducido la tarjeta para "quemarle" la imagen.

Simplemente con eso, metiendo la tarjeta en tu Rpi ya debería arrancar. Espera un poco en el primer arranque que creo recordar que tardaba un poco.

Conéctale un cable de red para conectarte via ssh (o un teclado y un monitor) después era necesario activar la wifi (en el tutorial venían los pasos)

Eso sería el proceso básico, después ya gracias a YaST todo lo demás (añadir usuario normal, configurar repos, asignar ip local fija, etc)

Debo decir que cambié openSUSE por Raspbian y me va mejor. openSUSE con el paso de los días empezaba a consumir mucha Swap y no supe el motivo!

* https://victorhckinthefreeworld.com/...archa-desde-0/
* https://victorhckinthefreeworld.com/...se-tumbleweed/
* https://victorhckinthefreeworld.com/...r-en-opensuse/
__________________


Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
→ Mi blog sobre openSUSE, GNU/Linux, software libre ...y de todo un poco: Victorhck in the free world
→ Me puedes seguir en: Mastodon - diaspora* - PixelFed
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a victorhck Por Este Mensaje:
soyasi (05-jul-2018)
  #3  
Antiguo 05-jul-2018, 10:25
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.949
Agradecimientos: 629
Agradecido 2.681 Veces en 1.826 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
@soyasi, haz caso a @victorhck que también tiene una RaspBerry y "presume" de ella en su blog. El mejor consejo: pasarte a Raspbian
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
soyasi (05-jul-2018)
  #4  
Antiguo 05-jul-2018, 10:38
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 15.0
Mensajes: 901
Agradecimientos: 212
Agradecido 355 Veces en 243 Mensajes
Poder de Credibilidad: 14
soyasi está en el buen camino
Gracias por la contestación!!

la tuya también es la raspberry pi3 b+ ??

yo las imágenes que he probado son las de este repo

creo que he probado la mayoría y no me han funcionado ..

efectivamente el método que pones también lo he usado, pero el resultado ha sido el mismo, con la única imagen que no lo he probado es con la de TW.

Esta tarde pruebo, por si me suena la campana.

Con raspbian, ubuntu mate, etc ha funcionado todo a la primera

__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 15.0 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 05-jul-2018 a las 11:02
Responder Citando
  #5  
Antiguo 05-jul-2018, 14:10
Avatar de victorhck
victorhck victorhck está desconectado
Moderador
 
Fecha de Ingreso: 08-abril-2010
Ubicación: /HOME
Versión: Tumbleweed y Leap + KDE
Mensajes: 3.665
Agradecimientos: 326
Agradecido 1.182 Veces en 763 Mensajes
Poder de Credibilidad: 12
victorhck está en el buen camino
no es B+
no sé si tiene que ver... Yo sólo probé Tumbleweed.

Gracias DR por el voto de confianza, aunque creo que excesivo!!

Quizás fui yo que no supe configurar algo...
__________________


Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
→ Mi blog sobre openSUSE, GNU/Linux, software libre ...y de todo un poco: Victorhck in the free world
→ Me puedes seguir en: Mastodon - diaspora* - PixelFed
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a victorhck Por Este Mensaje:
soyasi (05-jul-2018)
  #6  
Antiguo 05-jul-2018, 14:58
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 15.0
Mensajes: 901
Agradecimientos: 212
Agradecido 355 Veces en 243 Mensajes
Poder de Credibilidad: 14
soyasi está en el buen camino
la imagen se graba correctamente, pero me da el mismo problema:

Cita:
xzcat openSUSE-Tumbleweed-ARM-KDE-raspberrypi3.aarch64-2018.05.11-Build1.1.raw.xz | dd bs=4M of=/dev/sdk iflag=fullblock oflag=direct; sync
1168+1 registros leídos
1168+1 registros escritos
4902092800 bytes (4,9 GB, 4,6 GiB) copied, 609,529 s, 8,0 MB/s
Cita:
xzcat openSUSE-Leap15.0-ARM-KDE-raspberrypi3.aarch64-2018.07.02-Buildlp150.1.1.raw.xz | dd bs=4M of=/dev/sdk iflag=fullblock oflag=direct; sync
1092+0 registros leídos
1092+0 registros escritos
4580179968 bytes (4,6 GB, 4,3 GiB) copied, 569,794 s, 8,0 MB/s
Cita:
xzcat openSUSE-Leap15.0-ARM-JeOS-raspberrypi3.aarch64-2018.07.02-Buildlp150.1.1.raw.xz | dd bs=4M of=/dev/sdk iflag=fullblock oflag=direct; sync
457+1 registros leídos
457+1 registros escritos
1918894080 bytes (1,9 GB, 1,8 GiB) copied, 236,82 s, 8,1 MB/s
Parece ser que la b+ es la que todavía da problemas, por lo que leo en el foro ingles, solo que a ellos les ha arrancado y a mi no aún.

Creo que el primer problema es un Bug de U-boot.bin. Lista de correos

Cita:
Net: No ethernet found.
starting USB...
USB0: Core Release: 2.80a
scaning bus 0 for devices...
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 15.0 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 05-jul-2018 a las 16:29
Responder Citando
  #7  
Antiguo 05-jul-2018, 23:11
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.790
Agradecimientos: 2.019
Agradecido 1.513 Veces en 1.270 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola:

La 3, modelo b a secas, de rs, comprada en Lopacan.



las infos que vi son las de blog de victorhck y en la wiki "https://en.opensuse.org/openSUSE:OpenSUSE_on_your_ARM_board"


Por falta de tiempo, no he hecho casi nada; pensaba usar adaptador de tarjeta a usb, y de ahí image writter u otros.

Saludos cordiales.

"https://en.opensuse.org/openSUSE:OpenSUSE_on_your_ARM_board"
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
soyasi (07-jul-2018)
  #8  
Antiguo 07-jul-2018, 20:48
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 15.0
Mensajes: 901
Agradecimientos: 212
Agradecido 355 Veces en 243 Mensajes
Poder de Credibilidad: 14
soyasi está en el buen camino
LLevo varios días mirando por diferentes foros el problema y la única solución que he visto es instalarlo en una "raspberry pi 3 b" y después pasar la tarjeta a la "raspiberry pi 3 b+" de esa forma funciona prácticamente sin problemas.

Curioso el tema!!

Así que si por casualidad alguien tiene una imagen de la tarjeta sd y la comparte por Megasync estaría agradecido.

LLevo varios días usando raspbian (debian strech 9) y aunque esta bastante bien, no me termina de convencer.

Gráciasss!!

Si alguien encuentra la solución para instalar desde cero la b+ que avise....


Edito; @mikrios te dejo la carpeta comprimida en Megasync si me haces un favor: es la que cree para instalar en mi raspberry, solo necesitarías el usb con la iso. Si la descomprimes la copias directamente en la micro sd tuya y todos los archivos deberían de estar en raíz menos la carpeta overlays que se creara con su contenido. Métela en la raspi tuya y si funciona, ya se puede confirmar que es la b+ en la que abra que modificar algún parámetro.

A mi no me ha funcionado en la "b+" pero a ti te debería de funcionar en la "b" o eso creo.
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 15.0 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 08-jul-2018 a las 01:33
Responder Citando
  #9  
Antiguo 08-jul-2018, 03:23
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.790
Agradecimientos: 2.019
Agradecido 1.513 Veces en 1.270 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola:

Voy a intentarlo, eso si la encuentro.

Si veo que no tengo tiempo, busco todo el material y te la llevas .

Edito: voy a leer info, haber si puedo hacerlo, de todas formas, es un equipo, que por ahora no voy a usar, y otros, lo veo difícil por la parálisis y falta del sentido de la mano (ayer mismo, me cayo 2,5 metros de barrar de metal en dos dedos de la pierna derecha, si no es por que no siento nada
ya estaría bailando la jota, si veo que tengo problemas, pasas a recogerlo y queda para ti, lo puedes considerar un regalo, en mi caso aprenderé en otro momento y mejor por que ya tienen experiencia) .

Edito : "https://en.opensuse.org/HCL:Raspberry_Pi3" (15.0,42.3 y TW)

Saludos cordiales.

Última edición por mikrios; 08-jul-2018 a las 16:12 Razón: añadir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
soyasi (08-jul-2018)
  #10  
Antiguo 09-jul-2018, 23:42
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 15.0
Mensajes: 901
Agradecimientos: 212
Agradecido 355 Veces en 243 Mensajes
Poder de Credibilidad: 14
soyasi está en el buen camino
El tema lo re resuelto de la forma menos creativa que se puedan imaginar

Después de haber probado con varias distros que no usan el u-boot.bin y todas se instalaban a la primera, estaba convencido de que ese era el motivo. He leído con el traductor de google en ingles, alemán y todo lo que he pillado y todo indicaba que era un problema con los periféricos, así que incluso llegue a compilar el u-boot del github, después de leerme otros tantos foros y no se cuantas cosas más, ya que nunca lo había hecho...

Hasta que se me encendió una neurona y se me ocurrió hacer lo contrario de lo que hacía, desconecté todos los periférico usb, solo dejé el hdmi y el cable de red. y mi sorpresa es que arrancó todo a la perfección, cuando llegó a la pagina de introducir el usuario y contraseña, conecté el teclado y el ratón y siguió arrancando la distribución como nada.

Acabo de probar la de kde que es excesivamente pesada, después de haber probado LXDE en raspbian, voy a probar con XFCE y si no con LXQT que es una mezcla entre LXDE y Razor-qt, que tampoco he probado nunca.

Algo tan sencillo y que me haya dado dar tantas vueltas ...


Edito: El problema se repite, si se hace un reinicio con el teclado y el ratón conectado, se queda congelado igual que en la foto que he puesto. Si se reinicia sin teclado y ratón, lo hace normalmente. Hay que tenerlo en cuenta.
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 15.0 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 10-jul-2018 a las 01:21
Responder Citando
Los Siguientes 3 Usuarios Han Dado las Gracias a soyasi Por Este Mensaje:
DiabloRojo (10-jul-2018), mikrios (10-jul-2018), victorhck (11-jul-2018)
Respuesta

Marcadores

Etiquetas
raspberry pi


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Montar partición en Raspberry Pi [SOLUCIONADO] victorhck Portátiles y otros Dispositivos 7 12-ene-2018 19:30
openSUSE Tumbleweed en Raspberry Pi victorhck Portátiles y otros Dispositivos 4 07-dic-2017 03:36
Servidor casero con raspberry pi o similar? J_VM La cafetería 11 28-jun-2017 21:52
Revistas españolas sobre electrónica, PIC, Arduino y Raspberry Pi Meta El Contubernio 1 11-dic-2013 10:51



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 03:38.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba