Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema con Nvidia, pantalla en negro.
  #1  
Antiguo 04-jun-2018, 15:55
Avatar de susenoob
susenoob susenoob está desconectado
Aforado
 
Fecha de Ingreso: 15-noviembre-2016
Versión: 42.1
Mensajes: 18
Agradecimientos: 3
Agradecido 2 Veces en 1 Mensaje
Poder de Credibilidad: 0
susenoob está en el buen camino
Problema con Nvidia, pantalla en negro.

Buenas, desde hace un tiempo me está surgiendo un problema y me gustaría saber si a más gente también le sucede.

A veces cuando arranco el ordenador, en lugar de aparecer SDDM aparece la pantalla en negro con el cursor del ratón, si lo dejo así, en un rato arranca SDDM, luego inicio sesión y también tarda muchísimo más de lo normal en arrancar KDE, y una vez arrancado el entorno, va como lagueado, muy lento.

Lo extraño de ésto es que solo me sucede muy de vez en cuando, si cuando me sucede reinicio el pc, vuelve todo a la normalidad arrancando rápido, por cierto también he notado que al apagar sucede algo similar a veces, se queda la pantalla en negro con el cursor del ratón y si lo dejo, al rato se apaga.

Como digo este comportamiento sucede muy eventualmente (cada dos dias o así) y es extremadamente molesto, mi hardware es el siguiente:

CPU: I7-3770 3.4GHz
RAM: 16GB
GPU: Nvidia GTX 660 Ti (2GB)
SSD: 240 GB (uso el flag "discard" para el ssd en /etc/fstab)

Evidentemente uso el driver privativo de Nvidia, exactamente la versión "390.59" y utilizo la opción "Force Composition Pipeline" para evitar el tearing.

Muchas gracias.
Responder Citando
  #2  
Antiguo 04-jun-2018, 16:34
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 15
Mensajes: 721
Agradecimientos: 305
Agradecido 170 Veces en 146 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Prueba con uno de mis posts que hay en el foro sobre los drivers Nvidia. Siempre describo la instalación manual de los mismos y cuando y cómo volverlos a instalarlos tras una actualización de kernel o X.org.


También puedes probar la Release Oficial (396.24) en lugar de la rama de larga vida que es el driver que tienes, el 390.59.


https://devtalk.nvidia.com/default/t...iver-releases/





Saludos
Responder Citando
  #3  
Antiguo 04-jun-2018, 16:50
Avatar de susenoob
susenoob susenoob está desconectado
Aforado
 
Fecha de Ingreso: 15-noviembre-2016
Versión: 42.1
Mensajes: 18
Agradecimientos: 3
Agradecido 2 Veces en 1 Mensaje
Poder de Credibilidad: 0
susenoob está en el buen camino
Cita:
Iniciado por Krovikan Ver Mensaje
Prueba con uno de mis posts que hay en el foro sobre los drivers Nvidia. Siempre describo la instalación manual de los mismos y cuando y cómo volverlos a instalarlos tras una actualización de kernel o X.org.


También puedes probar la Release Oficial (396.24) en lugar de la rama de larga vida que es el driver que tienes, el 390.59.


https://devtalk.nvidia.com/default/t...iver-releases/

Saludos
Gracias por tu respuesta.

Yo es que he instalado la versión del driver que viene en el repo comunitario de Nvidia, y no me gustaría instalar el driver manualmente con el .run, ya que eso lo saca completamente del sistema de empaquetado de opensuse 15.
Responder Citando
  #4  
Antiguo 04-jun-2018, 17:24
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.802
Agradecimientos: 2.024
Agradecido 1.518 Veces en 1.275 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola:

systemd-analyze blame, systemd-analyze critical-chain y systemd-analyze plot > /home/user/Documentos/arranque.svg , eso lo visualizas con firefox.

Después de actualizar el kernel, en el siguiente reinicio se ejecuta dentro de systemd purge-kernels, eso puede tardar un tiempo en borrar los antiguos kernel .

Quien se está moviendo en estos temas es @Krovikan, por lo que tiene mas experiencia,comprueba lo que te comenta y si falla, mira lo que te dije para que lo hagas en consola .

En este equipo, mas o menos andamos a la par, la única diferencia, puede ser la ram y que uso nouveau.

Código PHP:
francis@FRANK-Z87-D:~> inxi -xxxSMCGIz
System
:    HostFRANK-Z87-D Kernel4.16.13-3.gf670a16-default x86_64 bits64 compilergcc v7.3.1 
           Desktop
KDE Plasma 5.8.7 tkQt 5.6.2 dmsddm DistroopenSUSE Leap 42.3 
Machine
:   TypeDesktop SystemASUS productAll Series vN/A serial: <filter>                                                             
           
MoboASUSTeK modelZ87-DELUXE vRev 1.xx serial: <filterUEFIAmerican Megatrends v2103                                     
           date
08/15/2014                                                                                                                   
CPU
:       TopologyQuad Core modelIntel Core i7-4770S bits64 typeMT MCP archHaswell rev3                                          
           L2 cache
8192 KiB                                                                                                                 
           flags
lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips49603                                                             
           Speed
2098 MHz min/max800/3900 MHz Core speeds (MHz): 13492 23174 33533 43453 53487                                   
           6
3466 73508 83574                                                                                                            
Graphics
:  Card-1NVIDIA GK106 [GeForce GTX 660drivernouveau vkernel bus ID01:00.0 chip ID10de:11c0                                
           Display
x11 serverX.Org 1.18.3 drivernouveau unloadedfbdev,modesetting,nv,nvidia,vesa                                       
           tty
N/A                                                                                                                           
           OpenGL
rendererGallium 0.4 on NVE6 v4.3 Mesa 17.0.5 compat-v3.0 direct renderYes                                          
Info
:      Processes293 Uptime1h 00m Memory31.35 GiB used1.62 GiB (5.2%) Initsystemd v228                                         
           runlevel
5 targetgraphical.target Compilersgcc4.8.5 alt4.8 Shellbash v4.3.42                                          
           running in
konsole inxi3.0.09 
Saludos cordiales.

Última edición por mikrios; 04-jun-2018 a las 17:26 Razón: corregir
Responder Citando
  #5  
Antiguo 04-jun-2018, 18:49
Avatar de susenoob
susenoob susenoob está desconectado
Aforado
 
Fecha de Ingreso: 15-noviembre-2016
Versión: 42.1
Mensajes: 18
Agradecimientos: 3
Agradecido 2 Veces en 1 Mensaje
Poder de Credibilidad: 0
susenoob está en el buen camino
Cita:
Iniciado por mikrios Ver Mensaje
Hola:

systemd-analyze blame, systemd-analyze critical-chain y systemd-analyze plot > /home/user/Documentos/arranque.svg , eso lo visualizas con firefox.

Después de actualizar el kernel, en el siguiente reinicio se ejecuta dentro de systemd purge-kernels, eso puede tardar un tiempo en borrar los antiguos kernel .

Quien se está moviendo en estos temas es @Krovikan, por lo que tiene mas experiencia,comprueba lo que te comenta y si falla, mira lo que te dije para que lo hagas en consola .

En este equipo, mas o menos andamos a la par, la única diferencia, puede ser la ram y que uso nouveau.

Código PHP:
francis@FRANK-Z87-D:~> inxi -xxxSMCGIz
System
:    HostFRANK-Z87-D Kernel4.16.13-3.gf670a16-default x86_64 bits64 compilergcc v7.3.1 
           Desktop
KDE Plasma 5.8.7 tkQt 5.6.2 dmsddm DistroopenSUSE Leap 42.3 
Machine
:   TypeDesktop SystemASUS productAll Series vN/A serial: <filter>                                                             
           
MoboASUSTeK modelZ87-DELUXE vRev 1.xx serial: <filterUEFIAmerican Megatrends v2103                                     
           date
08/15/2014                                                                                                                   
CPU
:       TopologyQuad Core modelIntel Core i7-4770S bits64 typeMT MCP archHaswell rev3                                          
           L2 cache
8192 KiB                                                                                                                 
           flags
lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips49603                                                             
           Speed
2098 MHz min/max800/3900 MHz Core speeds (MHz): 13492 23174 33533 43453 53487                                   
           6
3466 73508 83574                                                                                                            
Graphics
:  Card-1NVIDIA GK106 [GeForce GTX 660drivernouveau vkernel bus ID01:00.0 chip ID10de:11c0                                
           Display
x11 serverX.Org 1.18.3 drivernouveau unloadedfbdev,modesetting,nv,nvidia,vesa                                       
           tty
N/A                                                                                                                           
           OpenGL
rendererGallium 0.4 on NVE6 v4.3 Mesa 17.0.5 compat-v3.0 direct renderYes                                          
Info
:      Processes293 Uptime1h 00m Memory31.35 GiB used1.62 GiB (5.2%) Initsystemd v228                                         
           runlevel
5 targetgraphical.target Compilersgcc4.8.5 alt4.8 Shellbash v4.3.42                                          
           running in
konsole inxi3.0.09 
Saludos cordiales.
Ok, cuando me vuelva a suceder lanzaré esos comandos, muchas gracias.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Kernel 4.11 no me reconoce los drivers NVIDIA Replicante Instalación y Actualizaciones 5 22-jun-2017 12:17
Problema con tarjeta gráfica NVIDIA pcadan Hardware 4 04-dic-2009 21:57
Problema Driver nVidia, kernel-source J4ckal General OpenSUSE 10 24-oct-2008 23:34
problema con hardware kernel19 Hardware 2 02-may-2008 23:01
Problema con el refresco de pantalla Lord Daeron Instalación y Actualizaciones 3 22-ago-2006 13:02



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 01:52.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba