Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problemas Instalar APT Suse 9.2
  #1  
Antiguo 28-abr-2005, 21:05
Visions
Invitado
 
Mensajes: n/a
Problemas Instalar APT Suse 9.2

Buenas a todos,
Mi distribución es una Suse 9.2 y me gustaria instalarme APT. Tras leer varias paginas te dicen que hay que bajarse los rpm de lua,apt-libs y apt,e instalarlos en ese orden. Para lua solo encuentro la version Suse 9.1,pero en principio no tiene por qué dar error no?
Mis dos problemas son:
1) Al instalar lua con rpm-Uhv,me dice:
"package lua-5.0.2-rb.suse091.1 is already installed. "
Le doy a buscar si está instalado con rpm -q lua-5.0.2-rb.suse091.1.i586.rpm y me dice:
"package lua-5.0.2-rb.suse091.1.i586.rpm is not installed"
En qué quedamos,lo tengo o no lo tengo? Cada uno dice una cosa!
2) Al instalar apt-libs... me dice:
error: Failed dependencies:
librpm-4.1.so is needed by apt-libs-0.5.15cnc7-0.suse092.rb0
librpmdb-4.1.so is needed by apt-libs-0.5.15cnc7-0.suse092.rb0
librpmio-4.1.so is needed by apt-libs-0.5.15cnc7-0.suse092.rb0
Y le doy a whereis librpm-4.1.so, librpmdb-4.1.so... y me contesta:
"librpmdb-4.1: /lib/librpmdb-4.1.so /usr/lib/librpmdb-4.1.so"
"librpm-4.1: /lib/librpm-4.1.so /usr/lib/librpm-4.1.so"
y sí,puse la ruta en ldconfig pero ni así. Es decir,me dice q es necesario unas librerias que tengo!!! Por qué puede ser eso??
Lo siento por extenderme,pero es que estoy desesperado... Muchas gracias de antemano.
Un saludo
Responder Citando
  #2  
Antiguo 28-abr-2005, 21:32
geeko
Invitado
 
Mensajes: n/a
mete todos en una carpeta y ejecútalo así:

rpm -Uhv *.rpm

de esta forma se instalarán en el orden correcto. Aquí tienes los paquetes para 9.2

ftp://ftp.gwdg.de/pub/linux/suse/apt...MS.suser-rbos/

y si se te pone tonto podrías hacerlo con:

rpm -Uhv --force *.rpm

de esta forma se instalarían "por cojones" pero no es seguro que te funcionen bies después
Responder Citando
Solo esto...
  #3  
Antiguo 29-abr-2005, 01:34
Goltnor
Invitado
 
Mensajes: n/a
Talking Solo esto...

Hola amigo para instalarte Apt solo pon en la consola como Root esto:

rpm --install -hv ftp://ftp.gwdg.de/pub/linux/misc/apt4rpm/9.2/apt{-libs,}-0.5.15cnc6-rb.suse092.6.i586.rpm


Espero que te sirva...

Responder Citando
  #4  
Antiguo 02-may-2005, 19:12
Visions
Invitado
 
Mensajes: n/a
Muchas gracias a los dos,de verdad,ahora lo pruebo y en cuanto tenga una respuesta(tanto si he podido como sino) os lo hago saber,da gusto obtener respuestas tan precisas y tan rapidas...
Un saludo.
Responder Citando
  #5  
Antiguo 02-may-2005, 20:28
Visions
Invitado
 
Mensajes: n/a
Bueno,como me temía,no ha habido manera
Tanto con la solución primera, como con la segunda que me dais, en ambos obtengo el mismo mensaje:

warning: apt-0.5.15cnc7-0.suse092.rb0.i586.rpm: V3 DSA signature: NOKEY, key ID8c9b4b0d
error: Failed dependencies:
librpm-4.1.so is needed by apt-0.5.15cnc7-0.suse092.rb0
librpmdb-4.1.so is needed by apt-0.5.15cnc7-0.suse092.rb0
librpmio-4.1.so is needed by apt-0.5.15cnc7-0.suse092.rb0
librpm-4.1.so is needed by apt-libs-0.5.15cnc7-0.suse092.rb0
librpmdb-4.1.so is needed by apt-libs-0.5.15cnc7-0.suse092.rb0
librpmio-4.1.so is needed by apt-libs-0.5.15cnc7-0.suse092.rb0
-------------------------------------------------------------------------------------
Como ya comenté,esas librerias las tengo,en /usr/lib y en /lib, y en la ruta del ldconfig... Hay alguna forma de obligarle a encontrarmelas? por qué con whereis me dice que sí que las tengo,pero luego el APT dice que nanai..
Responder Citando
rpm
  #6  
Antiguo 02-may-2005, 21:17
Goltnor
Invitado
 
Mensajes: n/a
Talking rpm

Todas esas dependencias las contiene el paquete: rpm que de seguro esta en los CD's de SuSE pero sino lo esta aqui lo tienes:

rpm-4.1.1-191.i586.rpm

Con eso se deberia solucionar el problema...Veo que dices que ya lo tienes instalado pero de todas maneras prueba a instalar este paquete y ves que ocurre

Espero que te sirva


Última edición por Goltnor; 02-may-2005 a las 21:24
Responder Citando
  #7  
Antiguo 02-may-2005, 23:22
Avatar de seshomaru
seshomaru seshomaru está desconectado
Aforado
 
Fecha de Ingreso: 09-febrero-2005
Ubicación: Buenos Aires
Mensajes: 46
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
seshomaru está en el buen camino
Enviar un mensaje por MSN a seshomaru
Talking

Caballeros aprobecho la movida para preguntar algo quizas obvio. Que es exactamente APT???. Es una copia del famoso apt-get de debian pero para rpm??? Convive bien con el sistema de parches de Suse??? Y YUM??? Cual es mejor? Algun problema conocido, alguna ventaja sobre la actualizacion???

Siempre he escuchado de estos sistemas pero nunca los he probado. De hecho lo que hago es agregar alguna fuentes nuevas al repositorio de Yast como Packman o Guru y santo remedio. Puedo bajar codecs y otros paquetes no soportados ofialmente pos suse. Sugerencias??????
Responder Citando
  #8  
Antiguo 03-may-2005, 20:28
Visions
Invitado
 
Mensajes: n/a
Cita:
Iniciado por goltnor
Todas esas dependencias las contiene el paquete: rpm que de seguro esta en los CD's de SuSE pero sino lo esta aqui lo tienes:

rpm-4.1.1-191.i586.rpm

Con eso se deberia solucionar el problema...Veo que dices que ya lo tienes instalado pero de todas maneras prueba a instalar este paquete y ves que ocurre

Espero que te sirva

Bueno,como me temia,no me dejó :S
Tras poner rpm -Uhv rpm-4.1.1-191.i586.rpm me dice:

error: Failed dependencies:
librpm-4.1.so()(64bit) is needed by (installed) net-snmp-5.1.2-3
librpm-4.1.so()(64bit) is needed by (installed) yast2-packagemanager-2.10.18-2
librpm-4.1.so()(64bit) is needed by (installed) kdebase3-Personal-9.2-7.1
librpm-4.1.so()(64bit) is needed by (installed) yast2-core-2.10.16-2.1
librpm-4.1.so()(64bit) is needed by (installed) deltarpm-1.0-4.2
librpmdb-4.1.so()(64bit) is needed by (installed) net-snmp-5.1.2-3
librpmdb-4.1.so()(64bit) is needed by (installed) yast2-packagemanager-2.10.18-2
librpmdb-4.1.so()(64bit) is needed by (installed) kdebase3-Personal-9.2-7.1
librpmdb-4.1.so()(64bit) is needed by (installed) yast2-core-2.10.16-2.1
librpmdb-4.1.so()(64bit) is needed by (installed) deltarpm-1.0-4.2
librpmio-4.1.so()(64bit) is needed by (installed) net-snmp-5.1.2-3
librpmio-4.1.so()(64bit) is needed by (installed) yast2-packagemanager-2.10.18-2
librpmio-4.1.so()(64bit) is needed by (installed) kdebase3-Personal-9.2-7.1
librpmio-4.1.so()(64bit) is needed by (installed) yast2-core-2.10.16-2.1
librpmio-4.1.so()(64bit) is needed by (installed) deltarpm-1.0-4.2
-----------------------------------------------------------------------------------------------
Cada vez que intenta algo da un error de dependencias. Que significa ese (installed) entre parentesis? Hay alguna manera de corregir ésto? Gracias de antemano...
Responder Citando
  #9  
Antiguo 08-may-2005, 13:41
Visions
Invitado
 
Mensajes: n/a
No es por ser pesado,pero necesito instalar el APT y no sé como solucionar lo de las dependencias,nadie mas ha tenido algun problema similar?? Gracias...
Responder Citando
  #10  
Antiguo 08-may-2005, 15:59
Avatar de chuzo
chuzo chuzo está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-julio-2004
Ubicación: En un lugar de la mancha ...
Mensajes: 2.348
Agradecimientos: 0
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 16
chuzo está en el buen camino
Cita:
Iniciado por Visions
1) Al instalar lua con rpm-Uhv,me dice:
"package lua-5.0.2-rb.suse091.1 is already installed. "
Le doy a buscar si está instalado con rpm -q lua-5.0.2-rb.suse091.1.i586.rpm y me dice:
"package lua-5.0.2-rb.suse091.1.i586.rpm is not installed"
En qué quedamos,lo tengo o no lo tengo? Cada uno dice una cosa!
Cuando quieras consultar si hay algún paquete instalado tienes que poner el nombre del paquete, no el nombre del fichero, es decir, en este caso sería:

rpm -q lua

y te daría la información sobre la versión instalada del paquete lua.

Cita:
Iniciado por Visions
Cada vez que intenta algo da un error de dependencias. Que significa ese (installed) entre parentesis?
Eso indica que tienes un paquete instalado y que necesita de otro paquete, por lo que no lo puede eliminar (o actualizar)
__________________
La carrera no siempre la ganan los más veloces, sino aquellos que siguen corriendo
"No importa cuanto sepas, sino las ganas que tengas de seguir aprendiendo"
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Como Instalar SuSe 9.2 Profesional??? Kensai Instalación y Actualizaciones 8 18-ago-2006 10:39
Problemas Al instalar suse 9.2 bernardo5 Instalación y Actualizaciones 11 25-abr-2005 03:23
Problemas al instalar SuSE 9.3 Pro (torrentes) iSVQ Instalación y Actualizaciones 9 21-abr-2005 14:11
¿Cómo instalar KDE 3.4 en SuSe 9.2? Goltnor FAQs, Manuales y Tutoriales 0 10-abr-2005 00:37
Aviso de seguridad Kunael Internet, Redes y Wireless 1 05-ago-2004 23:35



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 12:31.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba