Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

  #21  
Antiguo 22-may-2013, 20:49
feroSUSEANDO feroSUSEANDO está desconectado
Aforado
 
Fecha de Ingreso: 18-mayo-2013
Versión: Tumbleweed [x64]
Mensajes: 90
Agradecimientos: 38
Agradecido 6 Veces en 5 Mensajes
Poder de Credibilidad: 6
feroSUSEANDO está en el buen camino
hola,

estoy de acuerdo y lo entiendo, así hice la instalación desde YAST, eligiendo wine, pero sigo confuso, porque los dos paquetes que se instalan parecen ser el mismo:

wine versión 1.5.231.1.1-x86_64 y wine-32bit que curiosamente tiene la misma versión 1.5.231.1.1-x86_64, es decir no estoy seguro que sean dos paquetes distintos aunque el nombre de los paquetes sea distinto, wine y wine-32bits, porque la versión es idéntica. Además el paquete wine-32bit muestra una versión x86_64?

en cualquier caso con esos paquetes instalados funciona todo excepto alguna aplicacion que no dibuja bien en pantalla mostrando recuadros negros o incluso cuadros de dialogo que solo muestra un boton o partes, hasta que pulso tabulador.

Este fue el motivo por el que cambié la versión de uno de los paquetes dejándolo como sigue:

el paquete wine versión 1.5.23-1.1.1-i586 y el paquete wine-32bit versión 1.5.23-1.1.1-x86_64, (fíjaros que el paquete wine-32bit sigue mostrando ser una versión x86_64?

Con esta configuración es cuando me mostraba el error:
wine: '/home/.../.wine' is a 64-bit installation, it cannot be used with a 32-bit wineserver.

como no supe solucionarlo y así no me funcionaba ninguno de los programas regrese a la configuración inicial, la primera que comento y ahí me quedé.

lo único que se me ocurre:
1. eliminar todo salvando .wine, instalar de nuevo solo la versión i586, añadir la copia de seguridad a la carpeta .wine y ver si mejoran esos programas con fondos negros. (Alguien probó?)
2. sigo como estoy y paso de esos programas.
3. lo intento con VirtualBox

Saludos
Responder Citando
  #22  
Antiguo 23-may-2013, 22:03
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 17.062
Agradecimientos: 642
Agradecido 2.729 Veces en 1.863 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Mi paquetes de wine instalados y funcionando sin problemas:

Cita:
rpm -qa | grep wine
wine-1.5.30-247.1.x86_64
wine-mono-0.0.8-1.1.noarch
wine-gecko-1.9-36.1.noarch
wine-32bit-1.5.30-247.1.x86_64
wine-mp3-1.1.39-12.6.i586
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #23  
Antiguo 24-may-2013, 06:21
Avatar de julioeep
julioeep julioeep está desconectado
Miembro Junior
 
Fecha de Ingreso: 19-diciembre-2008
Ubicación: Villavicencio, Colombia
Versión: openSUSE LEAP 42.2
Mensajes: 693
Agradecimientos: 83
Agradecido 131 Veces en 115 Mensajes
Poder de Credibilidad: 10
julioeep está en el buen camino
Estas muy confundido en un tema relativamente básico, te recomiendo leas un poco en la wikipedia.

Wine es una tremenda capa de compatibilidad para que aplicaciones windows corran en GNU/Linux y otros, desde hace un tiempo para acá wine es capaz de "emular" Windows de 64 bits (hace un tiempo aunque Linux estuviera en 64 bits, el windows emulado era de 32 bits si o si) hoy en día lo lógico es que si tienes un sistema de 64 bits el wine también sea de 64 bits (wine-1.5.231.1.1-x86_64), sin embargo, wine te va a dar la opción de "emular" windows de 32 bits para ello necesita las librerías de 32 bits (wine-32bit-1.5.231.1.1-x86_64), por ejemplo necesitas crear un prefix de winMe el cual no te va a trabajar en 64 bits nunca, ergo hay que hacer una "emulación" a 32 bits...

Wine-32bits-x86-64 es diferente a wine-i586.

El problema que tuviste al cambiar la arquitectura de wine y no te dejaba ejecutar las aplicaciones era por el prefijo creado al momento de instalar los programas, es altamente recomendable separar los programas en prefijos diferentes y de acuerdo a las necesidades de cada programa, si se te hace complicado puedes probar playonlinux o el paquete de codeweavers el cual es muy bueno aunque sea de pago.

Última edición por julioeep; 24-may-2013 a las 06:24 Razón: ortografia
Responder Citando
  #24  
Antiguo 24-may-2013, 08:35
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.657
Agradecimientos: 74
Agradecido 403 Veces en 315 Mensajes
Poder de Credibilidad: 14
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Hola de nuevo¡¡¡.

instala desde los repos de la comunidad el repositorio de wine, tendrás las versiones mas actuales..

y como te dicen la versión wine-x-x-x-x-x86_64 es el de las librerías de 64bits y el wine-32-x-x-x-x86_64 es el wine de las librerías de 32 bits.
te pone los dos de 86_64 por que tu sistema es de 64bit, si fuese de 32 bits te instalaría con la arquitectura -i586.

así que si usas un sistema 64bit NO ISTALES EL
-i586.

instala el que te indica el sistema, aparte, no guardes el .wine de otra arquitectura, ya que los programas instalados no irán bien con las nuevas librerías..( te toca instalarlos con su configuración optima ).

edit2:
creo que los problemas mas comunes que tenemos son provocados por el mismo usuario, al no entender del todo la forma de manejo, y adelantarnos por oídas o por instinto a realizar cambios sin estar del todo documentado.

con solo poner wine en el buscador de programas te presenta el wine , lo seleccionas y la misma maquina instala los paquetes necesarios, si tienes un sistema de 64bits el -86_64 + el de wine-32-xxxx-86_64 y si tienes el sistema de 32 bit, solo te instala el -i586.

que es la arquitectura de 32bits.pero si tienes un sistema de 64bits el sistema te pondrá las librerías de wine de 64bits, wine a secas y el wine-32, especificando que son librerías de 32, pero ambos a con la arquitectura de 86_64, por que tu sistema es de 64bit y están copiladas a 86_64 tanto las librerías de 64 como las de 32 , para que trabajen perfectamente en 64bits.

si tienes un sistema de 32bits solo te instalara la compatibilidad de 32 bits, el -i586. ya que tu sistema esta optimizado a este.

es decir como tu sistema es de 64bits tanto las librerías de 64 como las d 32 bits, están optimizadas a 64bits,86_64, si tu sistema es de 32 bits , pondrá -i586.

espero aclarar mejor el caso, es decir que ponga wine-32-xxxxx-86_64 no significa que sea de 64bits, te dice que es de 32 bit las librerías, pero para trabajar en un sistema de 64bits....86_64...

un saludo.
__________________
Subir fotos: http://subefotos.com/

Última edición por LUKE10; 25-may-2013 a las 11:18
Responder Citando
Respuesta

Marcadores

Etiquetas
opensuse 12.3, qt4wine, wine


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Multimedia Pack portable para openSUSE 12.3 64 bit easgs Multimedia 2 13-oct-2014 13:23
¿porque ubuntu es mas popular q suse? goundzchecky El Contubernio 161 16-ago-2012 16:01
Después de instalar suse 11.2 no funciona red local amungar Internet, Redes y Wireless 15 21-nov-2009 09:52
Guía de Instalación de OpenSuSE 10.3 DiabloRojo Instalación y Actualizaciones 5 11-feb-2008 11:41
Bienvenido a GNU/Linux (y III) karlggest FAQs, Manuales y Tutoriales 0 13-ene-2008 18:26



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 12:42.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba