Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema con Gnucash luego de instalar OpenSUSE 12.1 [solucionado]
  #1  
Antiguo 14-feb-2012, 21:17
RaulEstela RaulEstela está desconectado
Aforado
 
Fecha de Ingreso: 27-septiembre-2010
Ubicación: Montevideo - Uruguay
Versión: 13.2
Mensajes: 14
Agradecimientos: 39
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
RaulEstela está en el buen camino
Problema con Gnucash luego de instalar OpenSUSE 12.1 [solucionado]

-- Al intentar correr Gnucash v. 2.4.7 me encontré que se tranca apenas arranca la pantalla de bienvenida. Buscando en el foro vi la solución dada por DiabloRojo de agregar un repositorio, lo hice quedando la v. 2.4.8, la corrí y abrió el programa. Agradecí la información brindada.
-- Al pretender correr Informes -> Resumen de cuentas e Informes -> Activos y pasivos -> Bitácora general salió un mensaje "Se ha producido un error al ejecutar el informe", si utilizo el menú contextual y doy Recargar aparece "URL cannot be shown".
-- Busqué en OpenSUSE 12.1 downloads encontré la v 2.4.9, la instalé y pasó lo mismo que la v. 2.4.7. Probé desinstalando Gnucash y Gnucash-lang para instalar la v.2.4.0 (11.4), no llegó a la pantalla de bienvenida. Desinstalé ambos archivos mas Guile v. 2.0.2 e instalé de nuevo ambos mas Guile v. 1.8.7 (11.4), funcionaron ambos informes. Queda la incompatibilidad de que si abro Herramientas -> Libro diario no puedo Recargar ambos informes pues aparecen los mensajes de error vistos, si cierro Libro diario sí Recarga bien.
-- Si bien puedo utilizar Gnucash con esa limitación (hasta ahora no apareció mas nada), pretendo instalar las actualizaciones. Pido que alguien me oriente para encontrar la solución, estuve buscando en el foro y vi que nadie tiene este problema, desde ya quedo muy agradecido.

Última edición por RaulEstela; 02-mar-2012 a las 20:46 Razón: Quedó solucionado el problema planteado instalé la versión 2.4.7 actualizada por el team OpenSUSE
Responder Citando
  #2  
Antiguo 15-feb-2012, 12:07
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.545
Agradecimientos: 566
Agradecido 2.446 Veces en 1.652 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Es que sin información detallada no se puede buscar la solución, así que te sugiero que lo preguntes en el forum de Gnucash: http://gnucash.1415818.n4.nabble.com/
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
RaulEstela (15-feb-2012)
Solucionado
  #3  
Antiguo 15-feb-2012, 21:41
RaulEstela RaulEstela está desconectado
Aforado
 
Fecha de Ingreso: 27-septiembre-2010
Ubicación: Montevideo - Uruguay
Versión: 13.2
Mensajes: 14
Agradecimientos: 39
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
RaulEstela está en el buen camino
Solucionado

Pude solucionar el problema, gracias:
-- Recorrí de nuevo el enlace dado por ti sobre el repositorio dimstar, fui mas allá hasta Bugzilla - Novel https://bugzilla.novell.com/show_bug.cgi?id=724917 abierto el 18/10/2011 - último 12/02/12 encontré:

"Bug 724917 - Can't start gnucash ("Unknown option name: maxdepth")

Stefan Kost 2012-01-02 16:07:31 UTC Comment 27

According to gnucash developers gnucash does not support guile-2. I have
downgraded guile-2.0.2 to guile-1.8.8
(http://download.opensuse.org/reposit.../openSUSE_12.1), but
neither gnucash-2.4.7 nor gnucash-2.4.8 (from dimstars repo) work. According to
the gnucash folks gnucash needs to be compiled against guile-1.8.8 to make it
work. Also according to the developers
"""
2.4.x will not support guile-2, and trunk (2.5/2.6) may, but only if people can
figure out how to tell guile-2 how to load libraries from a non-standard
location.
"""
So, can we please downgrade guile back to 1.8.8 and push an upgrade of
recompiled packages?

Steffen Tietsche 2012-01-06 09:39:17 UTC Comment 33

(In reply to comment #32)
> An update to gnucash just came through (to 2.4.7-28.1). The problem is NOT
> FIXED. The terminal output is unchanged.

Confirming comment #32.

I cannot do without gnucash, so for the time being I am using the workaround of
installing gnucash 2.4.0 and guile 1.8 from the openSUSE 11.4 repo. That works
nicely and doesn't seem to break anything else in my openSUSE 12.1
installation.

openSUSE team, please push the update requested by comment #27!"

veo que hice lo acertado al volver a la versión de OpenSUSE 11.4, la impresión que me deja haber visto todos los comentarios es que aún no existe una solución
única global.

-- Estuve en el enlace último oficial de Gnucash, encontré un comentario con fecha 06/02/12 de Christain Stimming-4 del team developers "GnuCash 2.4.10 released". Brinda un enlace para bajar Gnucash-2.4.10.tar.bz2 para compilarlo. Cuando dije que era un novato en Linux es porque hay áreas que todavía no manejo como ser la compilación de dichos archivos. Espero a que OpenSUSE brinde los rpm finales.

-- Respecto al 2do. párrafo de mi 1er. mensaje "Al pretender...", en las instaladas y desinstaladas de las versiones 2.4.7, 2.4.8 y 2.4.9 volví al final a la 2.4.0 (11.4), se solucionó no aparecen los mensajes de error al ejecutar los informes. ¡Gnucash 2.4.0está corriendo perfectamente!.

-- Por último agradezco la atención brindada a todos, dejo la lista de programas que hay que desinstalar de la 12.1 primero para luego instalar los de la 11.4:
aqbanking
aqbanking-lang
gnucash
gnucash-docs
gnucash-lang
guile
espero que les sirva a Uds.
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
problema con wifi opensuse 12.1 pedroyoli Portátiles y otros Dispositivos 15 01-oct-2012 22:16
Windows no inicia luego de instalar opensuse 11.4 soloesjesus Software 2 14-ago-2011 01:23
Instalar Opensuse 11.2 y Ubuntu 9, problema con el arranque. Grub suses Instalación y Actualizaciones 3 11-mar-2010 12:23
Problema con DVD-Rom al Instalar Opensuse 11.1 Saeglopur Hardware 5 25-dic-2008 17:12
Anuncio oficial openSUSE 11.0 (español) elpreto Portal de ForoSUSE 66 18-ago-2008 17:48



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 05:32.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba