Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

  #11  
Antiguo 10-nov-2015, 15:43
Avatar de Mazinger-Z
Mazinger-Z Mazinger-Z está desconectado
Habitual
 
Fecha de Ingreso: 06-agosto-2013
Ubicación: España
Versión: Tumbleweed
Mensajes: 207
Agradecimientos: 17
Agradecido 100 Veces en 70 Mensajes
Poder de Credibilidad: 4
Mazinger-Z está en el buen camino
Como curiosidad, añado la salida de "systemd-analyze blame" en mi aún no actualizado 13.2. Como observaréis, en mi caso en una barbaridad el tiempo que lleva el servicio dkms (que en este caso, no voy a necesitar y desactivaré). Habrá que contrastar cuando por fin actualice a la 42.1 este equipo.

Startup finished in 2.901s (kernel) + 2.994s (initrd) + 3min 7.603s (userspace) = 3min 13.500s


25.822s dkms.service
19.892s systemd-tmpfiles-clean.service
11.759s postfix.service
8.893s libvirtd.service
7.891s systemd-udev-settle.service
5.785s home.mount
5.251s ModemManager.service
4.744s winbind.service
4.078s NetworkManager.service
3.926s dev-mqueue.mount
3.925s dev-hugepages.mount
3.652s sys-kernel-debug.mount
3.466s systemd-remount-fs.service
3.398s rsyslog.service
3.183s display-manager.service
2.739s ntpd.service
....

Sin embargo, en otro de mis equipos, ya actualizado de 13.2 a 42.1 y con disco SSD, ésto es lo que tengo:
30.031s wicked.service
7.238s NetworkManager-wait-online.service
1.784s home.mount
764ms vboxdrv.service
490ms dev-sdc2.device
425ms tmp.mount
399ms vboxadd.service
319ms postfix.service
278ms SuSEfirewall2.service
255ms display-manager.service
240ms var-spool.mount
233ms var-log.mount
233ms var-opt.mount
232ms var-run-media-Juegos.mount
227ms var-lib-named.mount
227ms var-tmp.mount
224ms var-lib-mailman.mount
223ms var-crash.mount
223ms var-lib-pgsql.mount
222ms usr-local.mount
220ms srv.mount
215ms opt.mount
212ms boot-grub2-x86_64\x2defi.mount

y tan sólo .... ¡¡40 segundos de arranque!!!
Startup finished in 4.130s (kernel) + 1.176s (initrd) + 34.768s (userspace) = 40.075s
__________________
Yo sólo me limito a sugerir, no soy quién para dar consejos

Última edición por Mazinger-Z; 11-nov-2015 a las 00:10
Responder Citando
  #12  
Antiguo 10-nov-2015, 23:40
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.329
Agradecimientos: 1.819
Agradecido 1.299 Veces en 1.082 Mensajes
Poder de Credibilidad: 8
mikrios llegará a ser famoso muy pronto
Hola:

Creo haber comentado un par de veces que hay algunas versiones de systemd, que no está dando los tiempos de forma correcta y da unos tiempos que no corresponden con la realidad (excepto que que ejecutes systemctl list-jobs y la respuesta sea que lo intentes mas tarde, es decir cuando ya está ejecutado el sistema gráfico y dispones de la consola, eso indica o bien un fallo en alguna unidad o que hay algún trabajo sin terminar, mas claro no te deja ejecutar los comandos de analyze, mientras no termine el proceso de systemd.

Cierto que es exagerado el servicio de dkms, pero una vez arrancado el sistema, ya el equipo es estable y rápido, eso tienes que verlo tu si realmente tarda esos 3 minutos en aparecer el modo gráfico , si es que no tarda eso es que se dato no es correcto.

ES mas comprueba el estado de dkms, ya que el recopila en un directorio de la raíz los distintos módulos compatibles con el programa que lo usa, ya sea uno de virtualización, o unos drivers de la gráfica.

No hay nada como ver dkms -h y ver cuantos tienes y también comprobar su estado (bien quitas dkms del sistema, vale ganas tiempo, pero a lo mejor con ejecutar una orden de dkms, puede que se solucione el problema (es como a veces tener tres o 4 kernels en el sistema, no tiene sentido, el tener tantos si es que no los vas a usar, en cambio si puede influir un poco ya que están ocupando espacio y tienen que ser incluidos en el arranque (ya que estos no los has purgado o eliminado ) .

Bueno comprobar el estado de dkms, para ello se ejecuta dkms status

Código:
X79-PRO:~ # dkms status
vboxhost, 5.0.8, 4.2.0-7.g2d05727-desktop, x86_64: installed
Como ves solo tengo uno, pero he llegado a tener varios, pero para eso acudir a dkms -h y ejecutar el comando que corresponda .

Si ejecuto los drivers de nvidia los de su pagina web con el dkms, pues tendré otro directorio en la zona dkms para ellos, y así con algunos otros drivers .

No se si virtualbox, puede correr sin necesidad de activar en la bios, las configuraciones de virtualización, pero si esto fuese así , me supongo que la carga de módulos tendría que ser mayor para poder emular y hacer compatible eso, ademas de que tenga que venir en el kernel, cosa que dependiendo de el, el tiempo del sistema arranca, a veces a mas y otras veces a menos .

Otra cosa es comprobar la versión de systemd que usas, creo que TW está por la 224, pero en mi sistema lo tengo sin actualizar por la que tengo debe ser esta :

Código:
X79-PRO:~ # zypper se -si systemd
Loading repository data...
Reading installed packages...

S | Name                              | Type    | Version    | Arch   | Repository       
--+-----------------------------------+---------+------------+--------+------------------
i | systemd                           | package | 219-5.1    | x86_64 | (System Packages)
i | systemd-logger                    | package | 219-5.1    | x86_64 | (System Packages)
i | systemd-sysvinit                  | package | 219-5.1    | x86_64 | (System Packages)
i | util-linux-systemd                | package | 2.26.1-1.3 | x86_64 | (System Packages)
i | systemd-bash-completion           | package | 219-5.1    | noarch | (System Packages)
i | systemd-presets-branding-openSUSE | package | 0.3.0-18.1 | noarch | (System Packages)
i | systemd-rpm-macros                | package | 2-12.3     | noarch | (System Packages)
i | systemd-32bit                     | package | 219-5.1    | x86_64 | (System Packages)
Probé la actual, pero como no actualice el equipo, preferí seguir usando la que muestro en el log.

En el tema de systemd-analyze, hice una traducción al español y está disponible en el foro, eso complementado con la documentación de tunig de openSUSE o de SUSE, es de gran ayuda para comprobar errores y mejorar el sistema, ahora bien hay otros parámetros que influyen en el arranque, y pueden ser servicios que tienes desconetados, un systemd-analyze critical-chain puede dar una idea, pero no es lo bastante objetivo como para comprender el proceso, para eso está mejor el systemd-analyze plot > /home/user/Imágenes/arranque.svg.

Otros parámetros que pueden influir, y no dar constancia en journal o en systemd, puede ser un error en el sistema de ficheros, o bien el tener las particiones mal alineadas (lo que provoca que se hagan tres operaciones de I/O en vez de una (input/output) , cosa que también hay que comprobar.

También la velocidad del disco :hdparm -tT /dev/sda , idem lo mismo con sda1, sda2, etc.

Otra cosa que influye es la fragmentación del disco, en btrfs tiene su mantenimiento, y en linux también la tiene, actúa mucho menos que win, pero si la tiene (claro que en win creo que lo hace de forma secuencial y cada vez que el disco está mas lleno es mas lento) ; en cambio en ext4 no parte del principio , si no que creo que sitúa los lectores de los cabezales del disco a la mitad de su recorrido, bueno en eso no estoy muy al tanto .

Pero todas esas cosas influyen en el rendimiento del sistema operativo y deben ser comprobadas, lo mismo que tener bien programadas su ejecución de vez en cuando para que realice su mantenimiento, y si no hacerlo uno mismo de forma manual . (por ejemplo journal, los logs rotate de ambos , es decir de los que se mantienen de syslog y los de journal, las instantáneas, etc ) , eso también suele influir .

Solo hay que mirar lo que hay en systemd y ver a que corresponde cada cosa y si esa se puede mejorar desde alguna configuración del sistema .

En mi caso utilizo btrfs, tanto para raíz como para el /home (por defecto viene con una compresión determinada ) y los tiempos que me dan son estos :
Código:
X79-PRO:~ # systemd-analyze 
Startup finished in 2.091s (kernel) + 2.932s (initrd) + 43.924s (userspace) = 48.949s
El pc lleva dos años encendido y los discos están casi llenos, y ese tiempo, mas o menos se ha mantenido (variando un poco ha veces con los cambios o mejoras del kernel ) si veo que se pasa mas de eso y la diferencia es mucha, entonces si que me mosquearía (aunque el tiempo ha variado un poco, pero es por que el disco esta a tope y eso es lógico , por parte de smartctl , no hay errores, pero en el acceso al disco , si ha variado :hdparm -tT /dev/sda ) o sea 2,25 años de funcionamiento seguido (solo reinicio para el kernel y algún mantenimiento y cero errores) y al principio una tasa de 196Mb/seg y ahora ronda sobre los 138 a 140 y pico Mb/seg .

Pero el disco está a :
Código PHP:
X79-PRO:~ # inxi -P
PartitionID-1: / size41G used37G (94%) fsbtrfs dev: /dev/sda3
           ID
-2: /tmp size41G used37G (94%) fsbtrfs dev: /dev/sda3
           ID
-3: /home size890G used871G (99%) fsbtrfs dev: /dev/sda4
           ID
-4swap-1 size2.15GB used0.00GB (0%) fsswap dev: /dev/sda2 
Vamos casi a tope (raíz usado un 94% y el /home usado un 99%) .

Como ves todos esos parámetros al final influyen en el rendimiento y deben tenerse en cuenta (y eso me recuerda, que tengo que empezar hacerle algo de mantenimiento ) .

Saludos cordiales
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
Mazinger-Z (11-nov-2015)
Respuesta

Marcadores

Etiquetas
arranque, servicios


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Pequeño problema tras actualización a openSUSE 11.2 sruedat Instalación y Actualizaciones 2 16-mar-2010 18:57
Multiples cuestiones sobre opensuse por un usuario de ubuntu dudoso100 General OpenSUSE 18 27-ene-2009 22:16
Calendario del openSuSE 11.2 Dux Noticias 10 15-ene-2009 00:35
Guía de Instalación de OpenSuSE 10.3 DiabloRojo Instalación y Actualizaciones 5 11-feb-2008 11:41
lento pero muy lento al arrancar xakalito General OpenSUSE 7 04-may-2007 22:54



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 08:20.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba