Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

No se reconocen mis discos duros externos
  #1  
Antiguo 12-sep-2013, 00:19
jaimedc20 jaimedc20 está desconectado
Aforado
 
Fecha de Ingreso: 12-septiembre-2013
Versión: 11
Mensajes: 1
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
jaimedc20 está en el buen camino
No se reconocen mis discos duros externos

Tengo la version enterprise 11.3.22 y cuando conecto un pen drive me reconoce sin problemas pero cuando conecto un disco duro externo no lo hace, y ya he probado con tres marcas de discos duros.

Ayuda
Responder Citando
  #2  
Antiguo 12-sep-2013, 01:23
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.628
Agradecimientos: 1.954
Agradecido 1.445 Veces en 1.208 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Has actualizado a la versión de service pack 3 .

https://www.suse.com/promo/sle11sp3.html

Normalmente el comportamiento con los discos duros es un poco distinto a los pendrive , lo normal es que te lo reconozca , pero te pida pass ,para poder montarlo .

También es interesante saber si tienes instalado ntfs-3g , ya que un pendrive puede estar en fat32 y el disco en ntfs .

Mira en la info que te da del hardware si aparece ese dispositivo , o figura en el explorador de archivos que estés utilizando .

Creo que había algo al respeto , pero no me acuerdo donde ,era relacionado con usb ,había que cambiar una configuración para que lo reconociera como extraible , ya que si no aparece como tal , pero si abres el particionador , si lo ves .

También puedes mirar si aparece en lo que te muestra el comando dmesg .

Si tienes la identificación del disco o aparece en /dev/disk/by-id (ahí también puede aparecer) .

Después no se si seria correcto hacer un mount dev/sdx var/run/media o var/run/media/user (siendo sdx el disco que te detecte y user el nombre de tu usuario ) ; o bien añadir alguna configuración en fstab , sera cuestión de mirar por el foro , creo que había ejemplos de ello .

Pero para salir de la duda mejor mira por el foro que creo que eso ya se ha dado y puede que resuelva tu problema , ya que en estos temas soy un novato , pero si encuentro algo te lo pongo por aquí .

Saludos
Responder Citando
  #3  
Antiguo 12-sep-2013, 11:31
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Almazora
Versión: Leap 42.3 KDE
Mensajes: 3.451
Agradecimientos: 359
Agradecido 500 Veces en 412 Mensajes
Poder de Credibilidad: 14
jesusx está en el buen camino
Hola, que dice el comando desde consola?
lsusb
Salu2
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jesusx Por Este Mensaje:
mikrios (13-sep-2013)
  #4  
Antiguo 13-sep-2013, 01:19
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.628
Agradecimientos: 1.954
Agradecido 1.445 Veces en 1.208 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
no conocía o se me había olvidado ese comando gracias (lo añado a la chuleta de mi agenda )

Gracias jesusx por ello .

Saludos cordiales
Responder Citando
  #5  
Antiguo 13-sep-2013, 15:56
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Almazora
Versión: Leap 42.3 KDE
Mensajes: 3.451
Agradecimientos: 359
Agradecido 500 Veces en 412 Mensajes
Poder de Credibilidad: 14
jesusx está en el buen camino
Vaya!! Pues es uno de los pocos que me aprendí XD... No estoy muy puesto yo en comandos aunque tambien me hago alguna chuletilla de vez en cuando je, je...
Este como root arroja mas información: ls -l /dev/disk/by-id/*usb*
Salu2
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jesusx Por Este Mensaje:
mikrios (13-sep-2013)
  #6  
Antiguo 13-sep-2013, 17:07
Avatar de maniat1k
maniat1k maniat1k está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-abril-2011
Ubicación: Mdeo, Uy
Versión: Leap
Mensajes: 1.233
Agradecimientos: 171
Agradecido 254 Veces en 190 Mensajes
Poder de Credibilidad: 9
maniat1k está en el buen camino
Cita:
Iniciado por mikrios Ver Mensaje
no conocía o se me había olvidado ese comando gracias (lo añado a la chuleta de mi agenda )

Gracias jesusx por ello .

Saludos cordiales
Con este comentario aprovecho para recordar que existe este post para tomar como referencia para ayudar a quienes tienen problemas/dudas para mejorar sus preguntas... saludos!
__________________

Tips para dar mejor info sobre tu equipo | bbcode para el foro | @maniat1k -> en github | @maniat1k -> en twitter
Responder Citando
Los Siguientes 2 Usuarios Han Dado las Gracias a maniat1k Por Este Mensaje:
jesusx (13-sep-2013), mikrios (13-sep-2013)
  #7  
Antiguo 13-sep-2013, 21:04
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.628
Agradecimientos: 1.954
Agradecido 1.445 Veces en 1.208 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Gracias a los dos :

Este no me funciona :

mikrios-x79:~ # ls -l /dev/disk/by-id/*usb*
ls: cannot access /dev/disk/by-id/*usb*: No such file or directory



Si lo quito *usb* si va , pero hace un listado general .

Tenia un disco thoshiba de 1Tb usb 3.0

Me extraño que no funcionara , por lo que repetí la prueba con un pendrive normal :

mikrios-x79:~ # ls -l /dev/disk/by-id/*usb*
lrwxrwxrwx 1 root root 9 Sep 13 20:00 /dev/disk/by-id/usb-Lexar_JumpDrive_513199312-0:0 -> ../../sde
lrwxrwxrwx 1 root root 10 Sep 13 20:00 /dev/disk/by-id/usb-Lexar_JumpDrive_513199312-0:0-part1 -> ../../sde1

Y si va es correcto , pero para los discos usb , no los detecta con ese comando ( curiosidades ! ) .

Saludos
Edito
El disco usb lo ve como :

lrwxrwxrwx 1 root root 9 Sep 13 05:08 scsi-SToshiba_External_USB_3.0F79950020012102 -> ../../sdd
lrwxrwxrwx 1 root root 10 Sep 13 05:08 scsi-SToshiba_External_USB_3.0F79950020012102-part1 -> ../../sdd1

como un dispositivo scsi
Saludos

Última edición por mikrios; 13-sep-2013 a las 21:14 Razón: añadir
Responder Citando
  #8  
Antiguo 13-sep-2013, 21:41
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Cita:
Iniciado por mikrios Ver Mensaje
Este no me funciona :

mikrios-x79:~ # ls -l /dev/disk/by-id/*usb*
ls: cannot access /dev/disk/by-id/*usb*: No such file or directory
Con ese comando estás pidiendo que se listen todos los elementos del directorio /dev/disk/by-id/ que contengan "usb" en su nombre. Si no hay ninguno no muestra nada, que es lo que quiere decir No such file or directory.

Cita:
Iniciado por mikrios Ver Mensaje
Si lo quito *usb* si va , pero hace un listado general .

Tenia un disco thoshiba de 1Tb usb 3.0

Me extraño que no funcionara , por lo que repetí la prueba con un pendrive normal :

mikrios-x79:~ # ls -l /dev/disk/by-id/*usb*
lrwxrwxrwx 1 root root 9 Sep 13 20:00 /dev/disk/by-id/usb-Lexar_JumpDrive_513199312-0:0 -> ../../sde
lrwxrwxrwx 1 root root 10 Sep 13 20:00 /dev/disk/by-id/usb-Lexar_JumpDrive_513199312-0:0-part1 -> ../../sde1

Y si va es correcto , pero para los discos usb , no los detecta con ese comando ( curiosidades ! ) .
Creo que en esa ocasión funciona porque el id del dispositivo contiene la subcadena "usb". No sé cómo se genera el ID, pero igual tiene en cuenta la etiqueta del disco u otra cosa que en ese dispositivo en particular contiene "usb" aunque en otros pueda no ser así. Quizás solo se añada "usb" al ID si el dispositivo es un medio USB puro y no cuando es un disco duro conectado usando USB.

Cita:
Iniciado por mikrios Ver Mensaje
El disco usb lo ve como :

lrwxrwxrwx 1 root root 9 Sep 13 05:08 scsi-SToshiba_External_USB_3.0F79950020012102 -> ../../sdd
lrwxrwxrwx 1 root root 10 Sep 13 05:08 scsi-SToshiba_External_USB_3.0F79950020012102-part1 -> ../../sdd1

como un dispositivo scsi
Saludos
Me parece que hoy en día todos los discos se consideran o usan el subsistema SCSI, de ahí que los discos duros se llamen sdx en vez de como se hacía antes (hdx). De hecho, si compilas el kernel sin soporte para SCSI no funcionan los medios USB.

Un saludo.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jcsl Por Este Mensaje:
mikrios (13-sep-2013)
  #9  
Antiguo 14-sep-2013, 01:41
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.628
Agradecimientos: 1.954
Agradecido 1.445 Veces en 1.208 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Gracias jcsl , puede que esa sea una de las causas del problema de jaimedc20 .

Pero como no ha dado respuestas pues no estamos muy al tanto .

Por lo pronto dando palos de ciego , y como estoy interesado en el tema y sus posibles causas .
Me pongo a buscar y estudiar siempre saco algo bueno que me pueda beneficiarme y sirva de ayuda a otros .

Ejemplo que le podrían funcionar : actualizar al sp3, mirar si tiene ntfs-3g

Esto otro :
http://www.esdebian.org/wiki/montar-...fs-hal-ntfs-3g
Lo he mirado en mi pc y esta correcto (editando el archivo 21-storage-ntfs-3g.fdi ) coincide en lo mas común .
Y así de esta forma he buscado casi todos los casos que me he encontrado por la web ,mirando verificando archivos ,ejecutando comandos .
Comprobando paquetes :
/kernel/drivers/scsi_mod -- soporte scsi
/kernel/drivers/usb/storage/usb_storage -- soporte para dispositivos de almacenamiento masivo usb

Otro que tenía un fallo y no se lo reconocía (había conectado el disco en el hub usb ) , lo cambio a otro puerto y se lo reconoció .

Y así pasando el tiempo ,mirando las opciones de montaje , fstab etc.

Para haber empezado casi de cero en linux , los meses que he pasado aquí en el foro , no han sido una perdida de tiempo .

En algunos conceptos puede que aun este verde y meta la pata , pero si nadie me corrige , seguiré con lo mismo ( así que agradezco las posibles aclaraciones y correcciones que me podáis brindar )

Saludos cordiales
Responder Citando
  #10  
Antiguo 14-sep-2013, 03:01
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.322
Agradecimientos: 45
Agradecido 1.296 Veces en 958 Mensajes
Poder de Credibilidad: 20
karlggest está en el buen camino
Cita:
Iniciado por mikrios Ver Mensaje
(...)
Esto otro :
http://www.esdebian.org/wiki/montar-...fs-hal-ntfs-3g
Lo he mirado en mi pc y esta correcto (editando el archivo 21-storage-ntfs-3g.fdi ) coincide en lo mas común .
Y así de esta forma he buscado casi todos los casos que me he encontrado por la web ,mirando verificando archivos ,ejecutando comandos .
Comprobando paquetes :
/kernel/drivers/scsi_mod -- soporte scsi
/kernel/drivers/usb/storage/usb_storage -- soporte para dispositivos de almacenamiento masivo usb

(...)
Cuidado con la documentación de otras distribuciones. En este ejemplo, recordad que openSUSE no usa (o no debería) usar HAL (pero es posible que sled/sles sí, ya que cambiar el kernel a 3.0 ya fue un punto, como para ponerse a cambiar más cosas xd)

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a karlggest Por Este Mensaje:
mikrios (16-sep-2013)
Respuesta

Marcadores

Etiquetas
disco duro externo, montar, problemas, reconocer


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Después de actualizar el KERNEL, no puedo montar los discos duros externos manelleon Hardware 13 10-may-2011 14:54
Gran Problema con Discos Duros Externos defenomenos Hardware 1 03-may-2009 16:17
Discos duros hotplug Perilla Hardware 0 29-dic-2008 18:52
Mis discos duros han desaparecido! Rocio Paola Mor Hardware 8 29-ago-2008 15:58
Acelerando los discos duros en GNU/Linux DiabloRojo FAQs, Manuales y Tutoriales 0 31-oct-2006 20:42



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 06:05.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba