Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Error de sumas de verificación de paquetes
  #1  
Antiguo 27-jun-2018, 17:45
fabioonier fabioonier está desconectado
Aforado
 
Fecha de Ingreso: 22-octubre-2012
Versión: 12.2
Mensajes: 33
Agradecimientos: 0
Agradecido 4 Veces en 3 Mensajes
Poder de Credibilidad: 0
fabioonier está en el buen camino
Error de sumas de verificación de paquetes

Buenos días.
Tengo instalado Opensuse Leap 42.3 y se ha vuelto bastante frecuente que cuando deseo instalar un nuevo paquete o hago una actualización me sale uno o varios mensajes del tipo
"Advertencia: valor de verificación incorrecto para el archivo ..."

Es bastante molesto este mensaje porque me genera desconfianza en el sistema operativo y los repositorios debido a que en el mensaje se hace la advertencia de que "aceptar paquetes con sumas de verificación incorrectas puede provocar fallos en el sistema y, en casos extremos, incluso el sistema se vea comprometido". ¿No se supone que Opensuse ofrece estabilidad y seguridad?

¿Podría alguien explicarme, por favor, a qué se deben estos mensajes y qué debo (o puedo) hacer de manera segura cada vez que salgan?

Agradezco su colaboración.
Responder Citando
  #2  
Antiguo 28-jun-2018, 16:09
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.843
Agradecimientos: 2.038
Agradecido 1.535 Veces en 1.291 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola:

Mira si puedes ir adelantando algún dato como los que pide, ahí : "http://www.forosuse.org/forosuse/showthread.php?t=33135" .

También un zypper ve y otro comando (voy a ver el patch) : cat /var/log/zypp/history | tail -n 15


Saludos cordiales .

PD. mira si las firmas de los repositorios está caducada .
Responder Citando
  #3  
Antiguo 28-jun-2018, 22:50
fabioonier fabioonier está desconectado
Aforado
 
Fecha de Ingreso: 22-octubre-2012
Versión: 12.2
Mensajes: 33
Agradecimientos: 0
Agradecido 4 Veces en 3 Mensajes
Poder de Credibilidad: 0
fabioonier está en el buen camino
Hola, Mikrios. Gracias por responder.
Aquí va el resultado de zypper lr -upPE

Código:
#  | Alias                            | Nombre                            | Habilitado | Comprobación GPG | Actualizar | Prioridad | URI                                                               
---+----------------------------------+-----------------------------------+------------+------------------+------------+-----------+-------------------------------------------------------------------
 1 | NVIDIA                           | NVIDIA                            | Si         | (r ) Si          | Si         |   99      | http://http.download.nvidia.com/opensuse/leap/42.3                
 2 | VLC                              | VLC                               | Si         | (r ) Si          | Si         |   99      | http://download.videolan.org/pub/vlc/SuSE/Leap_42.3/              
 3 | http-opensuse-guide.org-9df706f3 | libdvdcss repository              | Si         | (r ) Si          | Si         |   99      | http://opensuse-guide.org/repo/openSUSE_Leap_42.3/                
 4 | packman                          | packman                           | Si         | (r ) Si          | Si         |   99      | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.3/
 9 | repo-non-oss                     | openSUSE-Leap-42.3-Non-Oss        | Si         | (r ) Si          | Si         |   99      | http://download.opensuse.org/distribution/leap/42.3/repo/non-oss/ 
10 | repo-oss                         | openSUSE-Leap-42.3-Oss            | Si         | (r ) Si          | Si         |   99      | http://download.opensuse.org/distribution/leap/42.3/repo/oss/     
13 | repo-update                      | openSUSE-Leap-42.3-Update         | Si         | (r ) Si          | Si         |   99      | http://download.opensuse.org/update/leap/42.3/oss/                
14 | repo-update-non-oss              | openSUSE-Leap-42.3-Update-Non-Oss | Si         | (r ) Si          | Si         |   99      | http://download.opensuse.org/update/leap/42.3/non-oss/
Aunque, como dije en mi post, uso opensuse Leap 42.3, no sobra mostrarte el resultado del comando cat /etc/os-release

Código:
NAME="openSUSE Leap"
VERSION="42.3"
ID=opensuse
ID_LIKE="suse"
VERSION_ID="42.3"
PRETTY_NAME="openSUSE Leap 42.3"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:leap:42.3"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
Si hay algo malo, agradezco que me lo hagas saber.

Adicionalmente, ahora me sale un mensaje de error cada que intento refrescar los repositorios. Este es el mensaje de error

Código:
Construyendo el caché del repositorio openSUSE-Leap-42.3-Update ...........................................................................[terminado]
Error al generar el caché:
[|] Error al añadir a caché el repositorio (4).
Se va a omitir el repositorio openSUSE-Leap-42.3-Update debido al error anterior.
Muchas gracias por tu ayuda.
Responder Citando
  #4  
Antiguo 28-jun-2018, 23:24
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 17.057
Agradecimientos: 641
Agradecido 2.726 Veces en 1.860 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Los repositorios 2 (VLC) y 4 (packman) son incompatibles.

Ejecuta un "zypper clean" y limpia el contenido de la carpeta /var/cache/zypp

Parece que el problema es solo con ese repositorio openSUSE-Leap-42.3-Update
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #5  
Antiguo 29-jun-2018, 02:53
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 15
Mensajes: 749
Agradecimientos: 310
Agradecido 183 Veces en 157 Mensajes
Poder de Credibilidad: 9
Krovikan está en el buen camino
Adicionalmente a lo dicho por DR, sube la prioridad de Packman a 70 y pasa las versiones de paquetes a dicho repositiorio (creo que es zypper dup 4 en tu caso).




Saludos
Responder Citando
  #6  
Antiguo 29-jun-2018, 07:09
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.843
Agradecimientos: 2.038
Agradecido 1.535 Veces en 1.291 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola:

Ya está todo dicho, tienes que borrar el repo 2 y añadir 70 al 4 (nº mas bajo en repositorio, indica que tiene prioridad mas alta) .

Después lo comentado ejecutar : zypper clean && zypper refs && zypper ref
y lo de las carpetas.

Y por último lo que dice el compañero @Krovican o bien en yast añadir las 2 opciones que faltan y actualizar ( lo de cambiar de proveedor) .

Con lo comentado @D.Rojo y @Krovican deberías tener todo resuelto.

Saludos cordiales .

PD. Aclaración ¿ lo de /var/cache/zypp/ ? se refiere a eliminar zypp o el contenido de los dos directorios, de los tres que hay (uno está vació ) ; es una duda.
Responder Citando
Respuesta

Marcadores

Etiquetas
paquetes, sumas de verificación


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Como resolver las dependencias de los paquetes pendientes de actualizar DiabloRojo General OpenSUSE 3 04-ene-2016 03:49
Yast abre pero no funciona enae General OpenSUSE 15 23-feb-2015 16:59
Tengo cuatrocientos Kernels!! fromhell Software 7 20-ene-2014 10:33
no puedo instalar manualmente paquetes en suse 11.0 corcobada Software 6 26-may-2009 23:09
como obtener los paquetes ordenados por Grupo de Paquetes roilo General OpenSUSE 0 14-abr-2009 17:17



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 07:29.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba