Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

raro despues de actualizar
  #1  
Antiguo 13-ago-2018, 19:05
Avatar de maniat1k
maniat1k maniat1k está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-abril-2011
Ubicación: Mdeo, Uy
Versión: Leap
Mensajes: 1.234
Agradecimientos: 172
Agradecido 254 Veces en 190 Mensajes
Poder de Credibilidad: 9
maniat1k está en el buen camino
raro despues de actualizar

Como están tanto tiempo!
OK quise hace r un "zypper up"

miren esto:
Código:
>$ ~ zypper ls
#  | Alias                               | Nombre                                  | Habilitado | Comprobación GPG | Actualizar | Tipo  
---+-------------------------------------+-----------------------------------------+------------+------------------+------------+-------
1  | google-chrome                       | google-chrome                           | Si         | (r ) Si          | Si         | rpm-md
2  | http-download.opensuse.org-50454381 | openSUSE:Leap:42.3                      | Si         | (r ) Si          | Si         | yast2 
3  | http-download.opensuse.org-71561773 | openSUSE:Factory                        | Si         | (r ) Si          | Si         | rpm-md
4  | http-download.opensuse.org-84520ff8 | isv:ownCloud:desktop                    | Si         | (r ) Si          | Si         | rpm-md
5  | http-download.opensuse.org-dab3bc2f | home:beyerle:IAC                        | Si         | (r ) Si          | Si         | rpm-md
6  | openSUSE-Leap-15.0-1                | openSUSE-Leap-15.0-1                    | No         | ----             | ----       | rpm-md
7  | packman-essentials                  | packman-essentials                      | Si         | (r ) Si          | Si         | rpm-md
8  | repo-debug                          | openSUSE-Leap-15.0-Debug                | No         | ----             | ----       | NONE  
9  | repo-debug-non-oss                  | openSUSE-Leap-15.0-Debug-Non-Oss        | No         | ----             | ----       | NONE  
10 | repo-debug-update                   | openSUSE-Leap-15.0-Update-Debug         | No         | ----             | ----       | NONE  
11 | repo-debug-update-non-oss           | openSUSE-Leap-15.0-Update-Debug-Non-Oss | No         | ----             | ----       | NONE  
12 | repo-non-oss                        | openSUSE-Leap-15.0-Non-Oss              | Si         | (r ) Si          | Si         | rpm-md
13 | repo-oss                            | openSUSE-Leap-15.0-Oss                  | Si         | (r ) Si          | Si         | rpm-md
14 | repo-source                         | openSUSE-Leap-15.0-Source               | No         | ----             | ----       | NONE  
15 | repo-source-non-oss                 | openSUSE-Leap-15.0-Source-Non-Oss       | No         | ----             | ----       | NONE  
16 | repo-update                         | openSUSE-Leap-15.0-Update               | Si         | (r ) Si          | Si         | rpm-md
17 | repo-update-non-oss                 | openSUSE-Leap-15.0-Update-Non-Oss       | Si         | (r ) Si          | Si         | rpm-md
18 | snappy                              | snappy                                  | Si         | (r ) Si          | Si         | rpm-md
19 | vpn                                 | vpn                                     | Si         | (r ) Si          | No         | rpm-md
>$ ~
ok hago el zypper up como siempre: no levanta me dio error! Ok entre en panico leap no deberia de tener estos errores no? en fin: monto en modo rescue y reparo el grub (me salio bien de primera cosa que ya de por si deberia de haber iniciado alguna clase de alarma en mi )

muy bien! inicio el systema:

Código:
>$ ~ cat /etc/os-release 
NAME="openSUSE Tumbleweed"
# VERSION="20180812"
ID="opensuse-tumbleweed"
ID_LIKE="opensuse suse"
VERSION_ID="20180812"
PRETTY_NAME="openSUSE Tumbleweed"
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:tumbleweed:20180812"
BUG_REPORT_URL="https://bugs.opensuse.org"
HOME_URL="https://www.opensuse.org/"
>$ ~ zypper ls

QUE PASO???? no entiendo que paso!!! alguien sabe como volver de tumbleweeda leap??? yo no puedo creer esto!

obviamente hay cosa que ya no me funcionan como el firefox por ejemplo (estoy escribiendo en chrome)...
se agradezce si alguien me puede dar una mano.

ok quice correr a mano tanto zypper como yast y se caen: este es el error que me sale cuando corro zypper:

Código:
>$ ~ sudo zypper up
[sudo] password for root: 
zypper: symbol lookup error: /usr/lib64/libproxy.so.1: undefined symbol: _ZN9libmodman14module_manager8load_dirENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb
acabo de descubir que el firefox le pasa lo mismo

Código:
>$ ~ firefox
/usr/lib64/firefox/firefox: symbol lookup error: /usr/lib64/libproxy.so.1: undefined symbol: _ZN9libmodman14module_manager8load_dirENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEb

como lo soluciono? alguien tiene idea???

Saludos,
Maniat1k
__________________

Tips para dar mejor info sobre tu equipo | bbcode para el foro | @maniat1k -> en github | @maniat1k -> en twitter

Última edición por maniat1k; 13-ago-2018 a las 20:00 Razón: detalles extras
Responder Citando
  #2  
Antiguo 14-ago-2018, 04:06
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.830
Agradecimientos: 2.033
Agradecido 1.525 Veces en 1.282 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola:

Tienes un repo de la 42.3 suelto, ademas tienes añadido factory (factory en Git Browse es distinto, pero si lo asocias a los repositorios, factory y TW, son lo mismo, con lo cual a
TW se le aplica dup y no up.

Si estas con btrfs, no hay problema, también arrancar con otro hacer dracut --force, para mantener ese arranque e imágenes iniciales; eso si la condición es eliminar 42.3 y factory, en caso de que lo hayas usado para algún programa en particular, y no quieras quitarlo, pues lo desactivas.

1º probar desde esa versión y si está en uefi, mira donde sitúo el boot efi o ir a yast y en cargador de arranque en 3ª pestaña elegir que arranque, con el otro sistema, si es que te lo ha mantenido.

2ªotra añadir repos de actualización (me supongo que sabes donde están todos, los añades y actualiza(hace un donwgrade) .

3ª actualizar lo mismo con un pendrive , en la actualización añade los repos.

4ºActualizar reescribiendo la raíz, pierdes programas, excepto que los anotes, mismo user, mismo tipo de fs y partición, misma clave etc, marcar instalación nueva ( añades repos si los anotastes, si no como tienes que añadir uno por uno ya que no te va a mostrar lista, pues no lo añade, reescribe ráiz, pierdes algunos programas instalados, pero conservas el /home (eso si no lo particionas y usas mismos datos que el anterior ) , pass, user, fs, etc) .

Saludos cordiales.

PD. y no vuelvas añadir factory, este es un espejo de TW "http://download.opensuse.org/tumbleweed/" este es el enlace de factory, te manda a TW, comprueba tu mismo : "http://download.opensuse.org/"

Y TW "http://download.opensuse.org/tumbleweed/" mismo enlace para los 2.



Saludos Cordiales
Responder Citando
  #3  
Antiguo 14-ago-2018, 11:27
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 17.019
Agradecimientos: 635
Agradecido 2.705 Veces en 1.840 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Ese listado de repos no me dice nada sin su respectivos enlaces. Según esto parece que has mezclado repos

https://forums.opensuse.org/showthre...defined-symbol

Dame la salida de este comando

zypper lr -upPE

Y desmarca la casilla "Convertir URLs automáticamente en enlaces" antes de enviar tu respuesta
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #4  
Antiguo 18-ago-2018, 04:13
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.830
Agradecimientos: 2.033
Agradecido 1.525 Veces en 1.282 Mensajes
Poder de Credibilidad: 10
mikrios llegará a ser famoso muy pronto
Hola :

Hace tiempo, el enlace era el mismo, lo volví a confirmar ahora y sigue igual (factory=TW) .

Te puedes hacer una idea por "http://fr2.rpmfind.net/linux/opensuse/tumbleweed/iso/Changes.20180812.txt"

En mi caso algunas de esas actualizaciones estaban en la 42.3 y ademas tenía el kernel estable estándar y paso a la 4.18. perdí snapshots, dependencia al no oder montar ningún sub volumen btrfs, e incluso la partción /home, que estaba btrfs . el directorio /boot en grb2 en EFI estaba vacío ( fallo al hacer dracut y no lo contemplo (no funcionaba las teclas sysreq ni las tty, arranque con supergrub2 y cogí una de las copias de seguridad de TW y las pase a leap 42.3, arranque en TW hice dracut --force, y en yast cargador de arranque puse que arrancase en 42.3, elimine en 42.3 la de microsoft (EFI estaba compartiendo la de win 500MB con openSUSE, y como sabía donde estaba cada cual , tenía repetido esa partición en este caso 156MB) falla al arrancar el 42.3, lo vuelvo hacer con supergrub2, pero está vez arranco con imagen del kernel, y una vez funcionando fuerzo dracut --force en 42.3 (tuve que actualizar con pendrive usb la 42.3, ya que boot dejo la mitad vacía, eso fue lo que me paso a mi ese día ( la 15.0 estoy esperando unos meses a que complete unos programas ) .

También el programa calamares creo que instala y monta el sistema, es otro instalador de openSUSE, incluido lo que tienes que poner en la partición efi.

Saludos cordiales .

PD. revisa lo que te dijo @D.Rojo y mira los enlaces de "http://download.opensuse.org"
Responder Citando
Respuesta

Marcadores

Etiquetas
leap, tumblebeed, update


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Pantalla negra despues de actualizar driver de la placa grafica Firebird Hardware 2 18-dic-2017 21:16
Sin entorno gráfico después de actualizar el kernel NestorAcevedo Instalación y Actualizaciones 12 05-dic-2017 17:42
Despues de actualizar Pantalla en NEGRO JuanJ Escritorios: KDE, Gnome, otros... 12 01-jun-2006 07:43
Problemas al actualizar... novato Software 4 10-jul-2005 12:55
Problemas despues de actualizar wilby Instalación y Actualizaciones 2 05-jul-2005 22:36



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 11:45.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba