Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Escritorios: KDE, Gnome, otros...


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Desastrosa actualizacion
  #1  
Antiguo 04-may-2016, 17:26
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.932
Agradecimientos: 626
Agradecido 2.673 Veces en 1.818 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Desastrosa actualizacion

Hola compañeros.

Quería comentaros la desastrosa actualización que he tenido esta mañana con el repositorio Update que acabo de solucionar, os cuento.

Cuando instale en su día nuestro Leap 42.1 me pase a Plasma 5 del repositorio Framework Plasma 5 (FK5) con las ultimas versiones hasta que empezó a pedirme que añadiera el nuevo repo QT 5, gracias a un comentario de karlggest no lo hice, me quede con el ultimo Plasma instalado, eliminando el repo FK5 y ya actualizaría al nuevo Plasma 5 cuando saliera las versiones mas nuevas del repo Update a lo instalado en mi PC.

Esta mañana me ha salido un montón de actualizaciones de Update que afectaba a Plasma 5, como tenia la mente espesa y tonta , hice sin darme cuenta un zypper dup desde repo Update. ¡Craso error!. Plasma 5 se va a carajo saliendome un revoltijo donde le falta todos los iconos. Y, sobre todo, NO podía recuperarlo de Snapper porque no había hecho un snapper rollback, equivalente a un punto de restauración.

No sabia como solucionarlo salvo volver a instalar y me he ido a comer. Comiendo he dado con una posible solución que explico a continuación.

Usando ese escritorio gris y vetusto ¿IceWM?. Me ido a Yast para añadir los repositorios FK5 y Qt5 y, primero actualizar el repo Qt5 para ir luego al instalador de paquetes en Patrones, he marcado las dos casillas de Plasma 5 Desktop y Entorno escritorio KDE. Problemas a la hora de actualizar un paquete plasma5-session porque estaban recuperando los paquetes en la cache, es decir, que no se los descargaba. He tenido que desmarcar la version anterior de ese paquete y volver a marcar la nueva version. Y ya he podido actualizarlo, ahora Plasma 5 luce muy bien y tiene mejores colores que antes. Y para terminar he actualizado Packman.

Ya es la segunda vez que arreglo un estropicio desde que instale Leap 42.1, a ver, si cuento desde 10 hasta 1 antes de volver hacer un zypper dup.

Os dejo mis repos y los paquetes que no se instalado:
Código:
zypper lr -upPE
#  | Alias                               | Nombre                            | Activado | Comprobación GPG | Refresco | Prioridad | URI                                                                                 
---+-------------------------------------+-----------------------------------+----------+------------------+----------+-----------+-------------------------------------------------------------------------------------
12 | packman.inode.at-suse               | Packman Repository                | Sí       | (r ) Sí          | Sí       |   70      | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Leap_42.1/                  
 1 | KDE_Frameworks_5                    | KDE Frameworks 5 Leap 42.1        | Sí       | (r ) Sí          | Sí       |   99      | http://download.opensuse.org/repositories/KDE:/Frameworks5/openSUSE_Leap_42.1/      
 2 | Pipelight_Leap_42.1                 | Pipelight Leap 42.1               | Sí       | (r ) Sí          | Sí       |   99      | http://download.opensuse.org/repositories/home:/ecsos:/pipelight/openSUSE_Leap_42.1/
 3 | Qt_5                                | Qt 5                              | Sí       | (r ) Sí          | Sí       |   99      | http://download.opensuse.org/repositories/KDE:/Qt5/openSUSE_Leap_42.1/              
 5 | google-chrome                       | google-chrome                     | Sí       | ( p) Sí          | Sí       |   99      | http://dl.google.com/linux/chrome/rpm/stable/x86_64                                 
 6 | http-download.opensuse.org-49e94bfd | server:messaging                  | Sí       | (r ) Sí          | Sí       |   99      | http://download.opensuse.org/repositories/server:/messaging/openSUSE_Leap_42.1/     
10 | opensuse-guide.org-repo             | Libdvdcss Repository              | Sí       | (r ) Sí          | Sí       |   99      | http://opensuse-guide.org/repo/openSUSE_Leap_42.1/                                  
11 | opera                               | Opera packages                    | Sí       | (r ) Sí          | Sí       |   99      | https://rpm.opera.com/rpm                                                           
17 | repo-non-oss                        | openSUSE-Leap-42.1-Non-Oss        | Sí       | (r ) Sí          | Sí       |   99      | http://download.opensuse.org/distribution/leap/42.1/repo/non-oss/                   
18 | repo-oss                            | openSUSE-Leap-42.1-Oss            | Sí       | (r ) Sí          | Sí       |   99      | http://download.opensuse.org/distribution/leap/42.1/repo/oss/                       
20 | repo-update                         | openSUSE-Leap-42.1-Update         | Sí       | (r ) Sí          | Sí       |   99      | http://download.opensuse.org/update/leap/42.1/oss/                                  
21 | repo-update-non-oss                 | openSUSE-Leap-42.1-Update-Non-Oss | Sí       | (r ) Sí          | Sí       |   99      | http://download.opensuse.org/update/leap/42.1/non-oss/                              
leches@linux-5cpg:~> 
zypper lu -a
Cargando datos del repositorio...
Leyendo los paquetes instalados...
S | Repositorio               | Nombre                 | Versión actual | Versión disponible | Arquitectura
--+---------------------------+------------------------+----------------+--------------------+-------------
v | openSUSE-Leap-42.1-Update | libKF5IconThemes5      | 5.21.0-2.1     | 5.21.0-12.1        | x86_64      
v | openSUSE-Leap-42.1-Update | libKF5IconThemes5-lang | 5.21.0-2.1     | 5.21.0-12.1        | noarch      
v | server:messaging          | libloudmouth-1-0       | 1.4.3-24.1     | 1.5.3-5.1          | x86_64      
v | openSUSE-Leap-42.1-Oss    | libmediastreamer_base4 | 2.11.2-4.2     | 2.11.2-6.2         | x86_64      
v | openSUSE-Leap-42.1-Oss    | libmediastreamer_voip4 | 2.11.2-4.2     | 2.11.2-6.2         | x86_64      
v | openSUSE-Leap-42.1-Oss    | susehelp               | 2009.10.06-4.1 | 2009.10.06-22.2    | noarch      
v | openSUSE-Leap-42.1-Oss    | susehelp_en            | 2009.10.06-4.1 | 2009.10.06-22.2    | noarch      
v | openSUSE-Leap-42.1-Oss    | susehelp_es            | 2009.10.06-4.1 | 2009.10.06-22.2    | noarch
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Los Siguientes 5 Usuarios Han Dado las Gracias a DiabloRojo Por Este Mensaje:
Germanlokura (08-may-2016), gvcastellon (05-may-2016), LUKE10 (04-may-2016), victorhck (05-may-2016)
  #2  
Antiguo 04-may-2016, 18:13
Avatar de SergioNN
SergioNN SergioNN está desconectado
Miembro Senior
 
Fecha de Ingreso: 11-junio-2011
Ubicación: Canarias
Versión: Leap15
Mensajes: 908
Agradecimientos: 197
Agradecido 25 Veces en 20 Mensajes
Poder de Credibilidad: 8
SergioNN está en el buen camino
¡¡¡Diablo Rojo haciendo un zypper dup!!!
Jaaaaaa
Responder Citando
  #3  
Antiguo 04-may-2016, 21:57
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.657
Agradecimientos: 74
Agradecido 403 Veces en 315 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Hola¡¡.

Yo hace unas semanas que uso el rep QT5, ya que no podía actualizar a QT 5.6.3 error de librerías, no conocía este repo y me volvía loco con mi dos repos de siempre, el current y KDE-Extra, y buscando un poco me di cuenta que todo cambio...
Ahora hay que poner el KDE de aplicaciones, el KDE-Extra de toda la vida de la comunidad y el novedoso KDE QT5.

Es decir ahora ya son 3 repos de KDE los que hacen falta para tener actualizado el escritorio Oo, creo que es demasiado, esta bien querer tener separadas las cosas para desarrollo, pero es que es demasiado que para usuario te lo tengan igual, yo lo metería todo en un current como estaba y el de Extras si la gente quería tener el mantenido por la comunidad...

No se lo veo así, por lo demás el escritorio se ve y se nota fantástico.

Un saludo.
__________________
Subir fotos: http://subefotos.com/
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a LUKE10 Por Este Mensaje:
  #4  
Antiguo 05-may-2016, 12:13
Avatar de gvcastellon
gvcastellon gvcastellon está desconectado
Miembro Senior
 
Fecha de Ingreso: 17-febrero-2012
Ubicación: Somewhere in the third planet of the Solar System ;)
Versión: Leap 42.1
Mensajes: 1.282
Agradecimientos: 1.080
Agradecido 611 Veces en 385 Mensajes
Poder de Credibilidad: 8
gvcastellon está en el buen camino
Vamos a ver como me va cuando intente hacer estos cambios, la ultima vez fue un desastre. ...Diablo veo que tienes Opera, hace unas semanas que lo estoy probando y su rendimiento y fluidez supera a todos los que e probado, lastima que no me funcione con NETFLIX, aunque creo que están trabajando en eso ...como te va a ti con Opera??? ...para que usas Pipelight???

...perdón por el off-topic.

Saludos.
__________________
The box said: 'Requires Windows 95 or better' ...SO I INSTALLED LINUX!


Kernel: 4.17.2-2.gddde22d-default x86_64
Distro: openSUSE Leap 15.0 / TW
KDE Plasma 5.12.5
Mobo: ASUSTeK ROG STRIX B350-F GAMING
CPU: AMD Ryzen 7 1700X 8-Core
RAM-16.0 GiB
Video-Radeon RX 460/560D
Responder Citando
  #5  
Antiguo 05-may-2016, 14:37
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.932
Agradecimientos: 626
Agradecido 2.673 Veces en 1.818 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por SergioN Ver Mensaje
¡¡¡Diablo Rojo haciendo un zypper dup!!!
El zypper dup siempre lo hago desde el repositorio a actualizar como Packman, es un comando que se puede usar pero con mucho cuidado.

Cita:
Iniciado por LUKE10 Ver Mensaje
Es decir ahora ya son 3 repos de KDE los que hacen falta para tener actualizado el escritorio Oo, creo que es demasiado, esta bien querer tener separadas las cosas para desarrollo, pero es que es demasiado que para usuario te lo tengan igual, yo lo metería todo en un current como estaba y el de Extras si la gente quería tener el mantenido por la comunidad...
openSUSE siempre ha tenido la política de separar las librerías de KDE, te en cuenta que son pesadas y no se actualiza tan a menudo como el escritorio, acuérdate de KDE 4. En este caso, ha ocurrido que las nuevas versiones de Plasma usan nuevas versiones de librerías, parece ser que Plasma 5 ira incorporando los avances de las librerías de Qt5.
Plasma 5.6 luce esplendido y se nota mas ágil que nunca.

Cita:
Iniciado por gvcastellon Ver Mensaje
Vamos a ver como me va cuando intente hacer estos cambios, la ultima vez fue un desastre. ...Diablo veo que tienes Opera, hace unas semanas que lo estoy probando y su rendimiento y fluidez supera a todos los que e probado, lastima que no me funcione con NETFLIX, aunque creo que están trabajando en eso ...como te va a ti con Opera??? ...para que usas Pipelight???
Opera lo uso de vez en cuando y no tengo queja de el.
Pipelight es la version libre de Silverlight pero para Linux, intentaba que Netflix y otras Web de streaming me funcione en Firefox. No funciona bien según que Website, en Netflix no va tal bien como en Chrome.

Saludos.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
gvcastellon (05-may-2016)
  #6  
Antiguo 05-may-2016, 16:23
Avatar de maniat1k
maniat1k maniat1k está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-abril-2011
Ubicación: Mdeo, Uy
Versión: Leap
Mensajes: 1.234
Agradecimientos: 172
Agradecido 254 Veces en 190 Mensajes
Poder de Credibilidad: 9
maniat1k está en el buen camino
Bueno a mi me paso con el snapshot 20160422 que me salio mal y no me funcionaba gnome-control-center ni tampoco gedit.

La solución fue directamente hacer zypper dup osea es como dice Diablo se puede hacer dup pero con responsabilidad...
__________________

Tips para dar mejor info sobre tu equipo | bbcode para el foro | @maniat1k -> en github | @maniat1k -> en twitter
Responder Citando
  #7  
Antiguo 05-may-2016, 17:46
Avatar de SergioNN
SergioNN SergioNN está desconectado
Miembro Senior
 
Fecha de Ingreso: 11-junio-2011
Ubicación: Canarias
Versión: Leap15
Mensajes: 908
Agradecimientos: 197
Agradecido 25 Veces en 20 Mensajes
Poder de Credibilidad: 8
SergioNN está en el buen camino
Código:
se puede hacer dup pero con responsabilidad...
Siempre tengo cachondeo con el dup, desde hace varios años. Ya es tradición.

Pero, ahora en serio, ¿ya se puede actualizar sin problemas?
Responder Citando
  #8  
Antiguo 05-may-2016, 21:31
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Almazora
Versión: Leap 42.3 KDE
Mensajes: 3.455
Agradecimientos: 359
Agradecido 502 Veces en 414 Mensajes
Poder de Credibilidad: 14
jesusx está en el buen camino
Joer!! Pensaba pasarme a KDE pronto (lo siento @maniat1k) pero me parece que aún voy a tardar, después de estos comentarios XD...
Salu2
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
  #9  
Antiguo 06-may-2016, 01:56
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.657
Agradecimientos: 74
Agradecido 403 Veces en 315 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
No tienes por que retrasarte, no hay ningún problema, por lo menos a mi no me los dio.
Para hacerlo fácil pon estos repos de aplicaciones:

Versión: 42.1


Aquí el KDE QT:
Versión: 42.1
Con esos repos no deberías tener problemas, yo el dup lo hago con yast2, en instalar le doy a ver por repos, y luego le digo cambiar archivos a este repo y se lo hago a los 4.

Durante el proceso te dirá que se cambiaran paquete desde el repo suse al que estamos cambiando, le decimos que si y listo.

El escritorio se ve estupendo y muy fluido, no le veo pega alguna, se ve muy estable, me puse discoveri para probar las actualizaciones e instalar gráficamente, pero para buscar programas esta verde un, pero para actualizar si funciona medianamente bien, aun así uso zypper up o yast2, no me fio mucho, pero lo estoy probando me es grato ver todo hay gráficamente y poder comentar en los paquetes xdd.

Fuente: https://es.opensuse.org/Repositorios_de_KDE

Editado para añadir el repositorio QT 5.
Lo curioso que cuando fuy a ponerlo en mis repos ya lo tenia jiji

Un saludo.
__________________
Subir fotos: http://subefotos.com/

Última edición por LUKE10; 08-may-2016 a las 13:03
Responder Citando
Los Siguientes 2 Usuarios Han Dado las Gracias a LUKE10 Por Este Mensaje:
jesusx (06-may-2016)
  #10  
Antiguo 06-may-2016, 08:32
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.932
Agradecimientos: 626
Agradecido 2.673 Veces en 1.818 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por LUKE10 Ver Mensaje
...
Aqui el KDE QT:
....
Fuente: https://es.opensuse.org/Repositorios_de_KDE
Un saludo.
He modificado la fuente para poner el Qt5 que faltaba.
http://download.opensuse.org/reposit...USE_Leap_42.1/

Total, son 4 repositorios si quieres tener las ultimas versiones del escritorio y sus aplicaciones.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Los Siguientes 3 Usuarios Han Dado las Gracias a DiabloRojo Por Este Mensaje:
jesusx (06-may-2016), LUKE10 (08-may-2016)
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Mensajes de error tras actualización de openSUSE12.3tumbleweedKde a openSUSEtumblewee feroSUSEANDO General OpenSUSE 1 16-dic-2014 20:33
Yast2 da error al arrancar Susefan1 Software 10 01-dic-2014 15:32
Multiseat [documento de trabajo] soyasi La cafetería 15 15-jul-2014 16:45
Actualización de múltiples paquetes para productos Suse Linux loquevenga Noticias 0 05-oct-2007 00:31
Sistema de actualización openSUSE 10.1 2ª Parte valentinux Instalación y Actualizaciones 0 24-sep-2006 19:41



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 15:56.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba