Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Vlc..pantalla en negro [SOLUCIONADO]
  #1  
Antiguo 02-ago-2017, 04:51
Avatar de Germanlokura
Germanlokura Germanlokura está desconectado
Habitual
 
Fecha de Ingreso: 06-febrero-2013
Ubicación: Buenos Aires - Argentina
Versión: Leap 42.3
Mensajes: 260
Agradecimientos: 323
Agradecido 16 Veces en 15 Mensajes
Poder de Credibilidad: 5
Germanlokura está en el buen camino
Vlc..pantalla en negro [SOLUCIONADO]

Que tal amigos, una consulta. He instalado vlc en opensuse 42.3 me llevado la desagradable sorpresa de ver que vlc tiene la pantalla en negro, se escucha el audio pero la pantalla solo se ve en negro. He instalado vlc-codecs incluso el multimedia 1clic install. Alguna idea que puede ser?


[SOLUCIONADO]

Prueba lo siguiente:
Herramientas----->Preferencias---->Video
Marca:Salida de video acelerada
Decoraciones de ventanas
En salida, en vez de automática, seleccionas Salida de video X11(XCB)
__________________
Un buen caminante no deja huella...

Última edición por Germanlokura; 08-ago-2017 a las 05:11
Responder Citando
  #2  
Antiguo 02-ago-2017, 12:40
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 479
Agradecimientos: 173
Agradecido 104 Veces en 89 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
¿Has comprobado que todo tu sistema coja paquetes de Packman?

¿Te pasa con sólo 1 tipo de archivo? Si es así qué extensión.
¿Has probado a abrir ese archivo con Xine?
¿Has probado varios archivos por si el tuyo estuviera corrupto?


Saludos
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Krovikan Por Este Mensaje:
Germanlokura (07-ago-2017)
  #3  
Antiguo 02-ago-2017, 16:52
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.550
Agradecimientos: 566
Agradecido 2.448 Veces en 1.654 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
A @soyasi y a mi nos dieron problemas utilizar vlc, hay un tema en el foro, y nos pasamos a vlc-beta de Packman. Estamos contentos con vlc-beta, yo a menos.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Germanlokura (07-ago-2017)
  #4  
Antiguo 02-ago-2017, 21:49
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 27-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 853
Agradecimientos: 190
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
Como dice DR nos dió bastantes problemas, pero a dia de hoy todos solucionados. Usas por casualidad driver propietario?? en caso afirmativo, pruebalo con los libres, por si te funciona mejor ..
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.3 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a soyasi Por Este Mensaje:
Germanlokura (07-ago-2017)
  #5  
Antiguo 04-ago-2017, 16:59
Avatar de caligulaelsanto
caligulaelsanto caligulaelsanto está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 14-febrero-2007
Ubicación: Buenos Aires
Versión: 42.3 kde
Mensajes: 2.060
Agradecimientos: 224
Agradecido 99 Veces en 87 Mensajes
Poder de Credibilidad: 13
caligulaelsanto está en el buen camino
me ha pasado algo parecido un par de veces
en general cuando uso mixxx para la radio , de pronto en un cambio de ventana
queda todo negro y las ventanas si se ven pero desaparece el entorno gráfico del escritorio

de momento saqué el cambio cubo de escritorio y dejé sin efectos y por ahora anda
__________________
en busca de la esencia

mi blog
seguime en twitter @caligulaelsanto
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a caligulaelsanto Por Este Mensaje:
Germanlokura (07-ago-2017)
  #6  
Antiguo 04-ago-2017, 19:40
Avatar de smrafa
smrafa smrafa está desconectado
Aforado
 
Fecha de Ingreso: 24-agosto-2005
Ubicación: Suramérica
Versión: 42.2 - Mate
Mensajes: 18
Agradecimientos: 0
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
smrafa está en el buen camino
Enviar un mensaje por MSN a smrafa Enviar un mensaje por Yahoo  a smrafa Enviar un mensaje por Skype™ a smrafa
Creo el problema de fondo viene siendo los Drivers pero bueno seria de seguir probando
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a smrafa Por Este Mensaje:
Germanlokura (07-ago-2017)
  #7  
Antiguo 05-ago-2017, 17:03
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.537
Agradecimientos: 1.913
Agradecido 1.410 Veces en 1.181 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

He observado que desde hace tiempo (mas o menos lo que comenta @D.Rojo), que vlc no se comportaba como siempre, así que cambie a rosa media player.

La versión que saca la pantalla en negro es la de Leap 42.3, en la 42.2 y en la versión 2.2.4 funciona bien, he ejecutado esa versión en 42.3, exceptuando los paquetes de qt y nox y el problema sigue siendo el mismo,creo que puede ser algo que influya a vlc, pero de la sesión de usuario de plasma (opengl, probé los dos y xrender idem y tampoco es).

Código:
Z-87-DELUXE:~ # zypper se -si vlc
Loading repository data...
Reading installed packages...

S  | Name                | Type        | Version      | Arch   | Repository                                 
---+---------------------+-------------+--------------+--------+--------------------------------------------
i+ | VLC Media player    | application |              | noarch | Repositorio principal (OSS)                
i+ | VLC Media player    | application |              | noarch | Repositorio Principal de Actualizaciones   
i+ | VLC Media player    | application |              | noarch | Repositorio de actualizaciones (depuración)
i+ | VLC Media player    | application |              | noarch | openSUSE:Leap:42.2                         
i+ | VLC Media player    | application |              | noarch | openSUSE:Leap:42.2                         
i+ | libvlc5             | package     | 2.2.4-32.4.2 | x86_64 | Packman Repository                         
i+ | libvlccore8         | package     | 2.2.4-32.4.2 | x86_64 | Packman Repository                         
i+ | vlc                 | package     | 2.2.4-32.4.2 | x86_64 | Packman Repository                         
i+ | vlc-codec-gstreamer | package     | 2.2.4-32.4.2 | x86_64 | Packman Repository                         
i+ | vlc-codecs          | package     | 2.2.4-32.4.2 | x86_64 | Packman Repository                         
i  | vlc-lang            | package     | 2.2.4-32.4.2 | noarch | Packman Repository                         
i+ | vlc-noX             | package     | 2.2.4-32.4.2 | x86_64 | Packman Repository                         
i+ | vlc-qt              | package     | 2.2.4-32.4.2 | x86_64 | Packman Repository


En la versión de 42.3 creo que hubo una actualización de code gstremer de vlc ,pero no ha solucionado el problema.
Tener cuidado ya que lo coge del proveedor de oss, en mi caso lo he cambiado a packman desde yast:
Código:
 
LEAP-42-3:~ # zypper se -si vlc
Loading repository data...
Reading installed packages...

S  | Name                | Type        | Version   | Arch   | Repository                 
---+---------------------+-------------+-----------+--------+----------------------------
i+ | VLC Media player    | application |           | noarch | Repositorio principal (OSS)
i+ | libvlc5             | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
i+ | libvlccore8         | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
i+ | vlc                 | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
i+ | vlc-codec-gstreamer | package     | 2.2.6-1.1 | x86_64 | Repositorio principal (OSS)
i+ | vlc-codecs          | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
i+ | vlc-lang            | package     | 2.2.6-4.1 | noarch | Packman Repository         
i+ | vlc-noX             | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
i+ | vlc-qt              | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
LEAP-42-3:~ # zypper se -si vlc
Loading repository data...
Reading installed packages...

S  | Name                | Type        | Version   | Arch   | Repository                 
---+---------------------+-------------+-----------+--------+----------------------------
i+ | VLC Media player    | application |           | noarch | Repositorio principal (OSS)                                                                                                    
i+ | libvlc5             | package     | 2.2.6-4.1 | x86_64 | Packman Repository                                                                                                             
i+ | libvlccore8         | package     | 2.2.6-4.1 | x86_64 | Packman Repository                                                                                                             
i+ | vlc                 | package     | 2.2.6-4.1 | x86_64 | Packman Repository                                                                                                             
i+ | vlc-codec-gstreamer | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
i+ | vlc-codecs          | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
i+ | vlc-lang            | package     | 2.2.6-4.1 | noarch | Packman Repository         
i+ | vlc-noX             | package     | 2.2.6-4.1 | x86_64 | Packman Repository         
i+ | vlc-qt              | package     | 2.2.6-4.1 | x86_64 | Packman Repository
Las pruebas hechas fueron en 42.3 con las versiones 2.2.4 y la 2.2.6, resultado audio con pantalla negra, solo probé en mp4 y mkv, no se si los demás formatos van bien .

Creo que el programa pueda tener algún problema con la decodificación de vídeo, solo me queda probarlo con un depurador, haber si veo algo ( y queda por probar también vlc qt y nox , lo demás está ok y casi coinciden los binarios con la versión anterior que si funciona, la 2.2.4) .

Edito:
He observado y no viene al caso, algún bloqueo en la 42.3 al finalizar plymouth y comenzar la sesión de usuario (el caso es que se quedo una vez viendo la pantalla de la sesión con una fusión de la imagen de la bombilla de plymouth, he tenido como 3 cuelgues, por lo que he cambiado a xrender (vlc se probó con la versión 2.x y la versión 3.x y con xrender, con las tres y el fallo no creo que vaya por ahí, aunque no puedo asegurarlo ) .
Saludos cordiales

Última edición por mikrios; 05-ago-2017 a las 17:09 Razón: corregir y añadir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
Germanlokura (07-ago-2017)
  #8  
Antiguo 05-ago-2017, 17:41
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 479
Agradecimientos: 173
Agradecido 104 Veces en 89 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
No acabo de entender a qué os refereis. Tengo desde siempre VLC y no me ha dado problemas ni en 42.1, ni 42.2 ni 42.3.

Mi vlc actual es el señalado por @mikrios, 2.2.6-4.1 (siempre todo, vlc-codec-gstreamer incluido, de Packman). Siempre con openGl 3.1 de renderizado.

Sea lo que sea que os pasa (que no lo entiendo), ¿es siempre con alguna extensión concreta de archivo?


EDIT: Por cierto, siempre uso drivers privativos de Nvidia.

Saludos

Última edición por Krovikan; 05-ago-2017 a las 17:44 Razón: más info
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Krovikan Por Este Mensaje:
Germanlokura (07-ago-2017)
  #9  
Antiguo 07-ago-2017, 07:10
Avatar de Germanlokura
Germanlokura Germanlokura está desconectado
Habitual
 
Fecha de Ingreso: 06-febrero-2013
Ubicación: Buenos Aires - Argentina
Versión: Leap 42.3
Mensajes: 260
Agradecimientos: 323
Agradecido 16 Veces en 15 Mensajes
Poder de Credibilidad: 5
Germanlokura está en el buen camino
Gracias por sus respuestas amigos, y disculpen la demora de la mia, estuve fuera de la ciudad y sin acceso a mi compu. A dia de doy y teniendo el so actualizado, sigue el mismo problema, sea con el formato de archivo que sea la pantalla queda en negro, solo se escucha el audio. Probare vlc beta como me recomiendas DiabloRojo. Primera vez que tengo problemas con vlc. De momento estoy usando smplayer que va de lujo también.


Edito: desinstale vlc y puse vlc beta..pero persiste el mismo error...en fin creo que seguiré usando smplayer hasta que solucionen el asunto.
__________________
Un buen caminante no deja huella...

Última edición por Germanlokura; 07-ago-2017 a las 08:27
Responder Citando
  #10  
Antiguo 07-ago-2017, 09:06
cuqui cuqui está desconectado
Habitual
 
Fecha de Ingreso: 26-octubre-2005
Mensajes: 120
Agradecimientos: 1
Agradecido 20 Veces en 18 Mensajes
Poder de Credibilidad: 13
cuqui está en el buen camino
Prueba lo siguiente:
Herramientas----->Preferencias---->Video
Marca:Salida de video acelerada
Decoraciones de ventanas
En salida, en vez de automática, seleccionas Salida de video X11(XCB)

Y lo comentas
Responder Citando
Los Siguientes 2 Usuarios Han Dado las Gracias a cuqui Por Este Mensaje:
DiabloRojo (08-ago-2017), Germanlokura (08-ago-2017)
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
pantalla en negro. falangista Instalación y Actualizaciones 18 13-mar-2011 11:22
Problema instalación pantalla en negro carpeta Instalación y Actualizaciones 6 01-nov-2010 20:10
Pantalla negro al iniciar con Desktop chusma Hardware 7 21-oct-2010 11:19
Pantalla en Negro steeldan Hardware 2 06-may-2007 23:16
Despues de actualizar Pantalla en NEGRO JuanJ Escritorios: KDE, Gnome, otros... 12 01-jun-2006 07:43



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 20:15.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba