Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Mensajes/Advertencias al instalar controlador Nvidia.
  #1  
Antiguo 19-abr-2018, 10:27
juanchusjuan juanchusjuan está desconectado
Aforado
 
Fecha de Ingreso: 04-abril-2014
Ubicación: Islas Canarias - España
Versión: Leap 42.3
Mensajes: 16
Agradecimientos: 5
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
juanchusjuan está en el buen camino
Question Mensajes/Advertencias al instalar controlador Nvidia.

Buenos Días.
En el enlace a la imagen que adjunto, se puede observar a qué me refiero con los mensajes de advertencia.
Al instalar Nvidia, la versión 390, mediante terminal. Por ejemplo con zypper inr, al finalizar la instalación en Opensuse Leap 42.3 aparecen esos mensajes de advertencia, que son muchos, uno por cada archivo:

"depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknow symbol __X86_indirect_"
La lista de archivos que necesitan ese "unknow symbol" es larga.

Luego, aparece otro dos mensaje:
"WARNING: /lib/modules/4.4.76-default is inconsistent"
"WARNING: weak updates symlinks might not be created"

Cabe destacar que el desempeño del driver es correcto, pero no deja de llamarme la atención la cantidad de advertencias. En Tumbleweed no sucede, así como tampoco en otras distros como Debian (usa la versión 375), Ubuntu y derivadas (usan la 396).

¿Alguna idea sobre qué puede causar esos "errores"?

Gracias de antemano.

https://i.imgur.com/pehmwwA.jpg
Responder Citando
  #2  
Antiguo 19-abr-2018, 11:18
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 567
Agradecimientos: 211
Agradecido 130 Veces en 112 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Yo siempre lo hago manual (hay muchos posts mios en el foro con los pasos y cosas previas a hacer) y 0 problemas.

Lo de los símbolos igual es que te falta uno de los paquetes de kernel.

Has de tener kernel-default, kernel-default-devel, kernel-devel y kernel-macros (este último tiene símbolos). Los 4 con la misma versión, en tu caso 4.4.76-1 (a día de hoy la versión de tu rama de kernel es la 4.4.128 por si lo quieres actualizar).
Respeta la numeración completa del kernel. En mi caso es 4.15.8-1.1 (acaba en 1.1, eso lo ves fácil en Yast).

No olvides de instalar siempre el kernel-firmware para estar actualizado de info sobre Hardware para manejar dispositivos.


Saludos
Responder Citando
Los Siguientes 2 Usuarios Han Dado las Gracias a Krovikan Por Este Mensaje:
juanchusjuan (19-abr-2018), victorhck (19-abr-2018)
  #3  
Antiguo 19-abr-2018, 15:40
juanchusjuan juanchusjuan está desconectado
Aforado
 
Fecha de Ingreso: 04-abril-2014
Ubicación: Islas Canarias - España
Versión: Leap 42.3
Mensajes: 16
Agradecimientos: 5
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
juanchusjuan está en el buen camino
Thumbs up

Cita:
Iniciado por Krovikan Ver Mensaje
Yo siempre lo hago manual (hay muchos posts mios en el foro con los pasos y cosas previas a hacer) y 0 problemas.

Lo de los símbolos igual es que te falta uno de los paquetes de kernel.

Has de tener kernel-default, kernel-default-devel, kernel-devel y kernel-macros (este último tiene símbolos). Los 4 con la misma versión, en tu caso 4.4.76-1 (a día de hoy la versión de tu rama de kernel es la 4.4.128 por si lo quieres actualizar).
Respeta la numeración completa del kernel. En mi caso es 4.15.8-1.1 (acaba en 1.1, eso lo ves fácil en Yast).

No olvides de instalar siempre el kernel-firmware para estar actualizado de info sobre Hardware para manejar dispositivos.


Saludos
Pues esta tarde te comento. Usualmente hago la instalación de los drivers vía terminal y zypper. Al poner zypper inr se instalan los programas recomendados así como también los drivers de nvidia. Voy a probar instalar previamente las dependencias que me indicas y lo comento por aquí.
En cuanto al kernel, previo iniciar las X, hago todas las actualizaciones que correspondan hasta esa fecha, en modo consola. Una vez actualizado todo y configurado el firewall, los grupos a los que quiero que mi usuario pertenezca, etc, reinicio, y ejecuto zypper inr y zypper dup --from packman... etc.
No inicio servidor gráfico alguno hasta que todo esté totalmente instalado y actualizado. Manías que uno coge luego de años de linux. jejejeje
Nuevamente Gracias.

Última edición por juanchusjuan; 19-abr-2018 a las 15:48
Responder Citando
  #4  
Antiguo 19-abr-2018, 20:47
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.803
Agradecimientos: 598
Agradecido 2.582 Veces en 1.748 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por juanchusjuan Ver Mensaje
Buenos Días.
En el enlace a la imagen que adjunto, se puede observar a qué me refiero con los mensajes de advertencia.
Al instalar Nvidia, la versión 390, mediante terminal. Por ejemplo con zypper inr, al finalizar la instalación en Opensuse Leap 42.3 aparecen esos mensajes de advertencia, que son muchos, uno por cada archivo:

"depmod: WARNING: /lib/modules/4.4.76-1-default/updates/nvidia-modeset.ko needs unknow symbol __X86_indirect_"
La lista de archivos que necesitan ese "unknow symbol" es larga.

Luego, aparece otro dos mensaje:
"WARNING: /lib/modules/4.4.76-default is inconsistent"
"WARNING: weak updates symlinks might not be created"

Cabe destacar que el desempeño del driver es correcto, pero no deja de llamarme la atención la cantidad de advertencias. En Tumbleweed no sucede, así como tampoco en otras distros como Debian (usa la versión 375), Ubuntu y derivadas (usan la 396).

¿Alguna idea sobre qué puede causar esos "errores"?

Gracias de antemano.

https://i.imgur.com/pehmwwA.jpg
Son Warning o Avisos, no implica que tenga un error. Más bien parece que no coincide el kernel con el paquete instalado de Nvidia.

Enviado desde mi m2 note mediante Tapatalk
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Instalar osx, windows 7 y opensuse 11.4 en un imac... y no morir en el intento oscarpoio FAQs, Manuales y Tutoriales 6 04-abr-2013 23:37
Instalar Skype en open Suse 11.3 64 bits. tranzorx FAQs, Manuales y Tutoriales 10 31-dic-2012 00:50
Que hacer después de Instalar Opensuse 12.2 Jonathan Miguel Instalación y Actualizaciones 10 23-oct-2012 15:40
Guia como instalar my paint arag Multimedia 8 13-mar-2011 17:28
conflicto al instalar beryl linuxsuse10.2 Software 6 24-abr-2007 06:45



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 01:23.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba