Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Escritorios: KDE, Gnome, otros...


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema con temas de usuario GNOME
  #1  
Antiguo 20-mar-2017, 18:25
Avatar de aldebaran
aldebaran aldebaran está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2013
Ubicación: Madrid
Versión: 13.2 GNOME
Mensajes: 38
Agradecimientos: 6
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
aldebaran está en el buen camino
Problema con temas de usuario GNOME

Hola a todos, parece que he metido la mano más de la cuenta y ahora ya no me aparecen las extensiones de mi Gnome. Además también sale una alerta en los temas de la shell de la herramienta de retoques.
También he podido comprobar que no puedo descargarme las extensiones desde la propia pagina puesto que no me reconoce el tener alguna y no me aparecen los botones de ON/OFF.

¿ Alguien sabe como puedo arreglarlo, es un tema que me gustaría poder arreglar para descargarme mis extensiones favoritas.?
__________________
Responder Citando
  #2  
Antiguo 20-mar-2017, 19:19
J_VM J_VM está desconectado
Habitual
 
Fecha de Ingreso: 22-septiembre-2013
Versión: Tumbleweed
Mensajes: 162
Agradecimientos: 19
Agradecido 11 Veces en 11 Mensajes
Poder de Credibilidad: 4
J_VM está en el buen camino
Bueno, te escribo sin tener mucha idea, pero una opción es que cojas la carpeta oculta de configuración de gnome (estará en tu carpeta personal, será .gnome o algo así, no sé como es porque yo uso KDE) y le cambies el nombre (por ejemplo .gnome_old) y cierres y abras sesión o reinicies. Entonces se pondrá la configuración por defecto y ya puedes volver a añadirlo todo.


A menos que hayas estropeado algo más importante de GNOME, pero por probar no pierdes nada. Siempre puedes restablecer a como lo tenías antes borrando la carpeta de configuración que se ha creado y cambiando el nombre de la antigua por el nombre que tenía originalmente, antes de que lo cambiases.


Saludos!
Responder Citando
  #3  
Antiguo 20-mar-2017, 22:19
Avatar de aldebaran
aldebaran aldebaran está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2013
Ubicación: Madrid
Versión: 13.2 GNOME
Mensajes: 38
Agradecimientos: 6
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
aldebaran está en el buen camino
Gracias por la contestación, pero ya he mirado por los ficheros de mi home y solamente he podido comprobar que en la ruta de mi home .local/share/gnome-shell/extensions no hay nada.

He probado de todo, eliminar el gnome y volver a instalar nuevamente el opensuse leap 42.1 todo sigue igual...¿ Alguien me puede ayudar ?
__________________
Responder Citando
  #4  
Antiguo 21-mar-2017, 01:28
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Dartmouth, Tumbleweed
Mensajes: 8.111
Agradecimientos: 39
Agradecido 1.209 Veces en 887 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

Bucea por la carpeta .config y busca la carpeta gnome o si hay una para la extensiones. Cámbiales el nombre, cierra el sistema gráfico y vuelve a entrar en GNOME; y reinstala las extensiones.

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
Problema con temas de usuario GNOME
  #5  
Antiguo 21-mar-2017, 11:13
Avatar de aldebaran
aldebaran aldebaran está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2013
Ubicación: Madrid
Versión: 13.2 GNOME
Mensajes: 38
Agradecimientos: 6
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
aldebaran está en el buen camino
Problema con temas de usuario GNOME

Muchas gracias a todos, al final he podido recuperar mis extensiones realizando un restore de mi deja-dup. Menos mal que me acorde que tengo un backup del home y con fecha anterior a los problemas.

Pero aún así veo que no me reconoce las extensiones que tengo y por supuesto sigo sin poder descargar nuevas extensiones desde la WEB.

https://extensions.gnome.org/
__________________
Responder Citando
  #6  
Antiguo 21-mar-2017, 16:04
Alienator Alienator está desconectado
Aforado
 
Fecha de Ingreso: 06-abril-2009
Ubicación: La Paz, Bolivia
Versión: Leap 42.2 Gnome
Mensajes: 52
Agradecimientos: 0
Agradecido 3 Veces en 3 Mensajes
Poder de Credibilidad: 9
Alienator está en el buen camino
Buenas, eso de no ver los botones on/off en la pagina web de las extensiones de gnome, lo resolví siguiendo las instrucciones de dicha pagina para instalar el plugin para chrome, hice todo el proceso como indica en la parte Cmake.

Parece ser que el plugin de gnome para los navegadores ha cambiado y no se han actualizado en las distros.

Ahora no recuerdo la uri de la documentacion de gnome shell, pero si no tienes el plugin instalado, deberia salirte un recuadro donde dice que lo instales o veas la documentacion. Debes ver la documetnacion primero y hacer el proceso de Cmake, luego instalas el plugin si no lo esta ya.

Saludos
Responder Citando
  #7  
Antiguo 22-mar-2017, 10:13
Avatar de aldebaran
aldebaran aldebaran está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2013
Ubicación: Madrid
Versión: 13.2 GNOME
Mensajes: 38
Agradecimientos: 6
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
aldebaran está en el buen camino
Gracias alienator, segui tus indicaciones y me he vuelto loco.. madre mia que lio de requrimientos e instalaciones para que pueda funcionar una extension..!!. Creo que son cosas que van en perjuicio de este gran escritorio, muchos dejaran de usarlo por no tener estas complicaciones que al final desesperan y de la cual todavía no he podido subsanar ni con indicaciones.

Me da un error en el ./compile al no encontrar las cabeceras de la libreria python, y eso que tengo más de una versión instalada 2.7 y 3 según he visto.

Voy a olvidarme del asunto espero que normalizen estos nuevos cambios desde los repositorios de las distribuciones que tengan Gnome como escritorio, por que me parece de verdad un infierno el solucionarlo como indican en la wiki.
__________________
Responder Citando
  #8  
Antiguo 22-mar-2017, 17:16
Alienator Alienator está desconectado
Aforado
 
Fecha de Ingreso: 06-abril-2009
Ubicación: La Paz, Bolivia
Versión: Leap 42.2 Gnome
Mensajes: 52
Agradecimientos: 0
Agradecido 3 Veces en 3 Mensajes
Poder de Credibilidad: 9
Alienator está en el buen camino
Hola, la verdad no estan complicado... solo hay que seguir la parte referente a Cmake

Cmake installation
First of all make sure following dependencies are installed:

Build time
Python 2.7+ or 3.x (also runtime dependency)
Cmake 2.8 (or newer)
Coreutils
jq

Runtime
GNOME Shell

PyGObject

Python Requests 2.x

DBus
Then clone source repository or download latest release tarball. To make git clone type:

$ git clone git://git.gnome.org/chrome-gnome-shell

Web extension sources located in "extension" folder. Refer Google Chrome documentation for information about installation of unpacked extension.

All commands must be issued from the root of cloned repository.

Create build folder and go to it:
$ mkdir build
$ cd build

Run cmake to create makefiles:
$ cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_EXTENSION=OFF ../

Install connector:
$ sudo make install

En una pc con gnome recien instalado y actualizado, desde la actualizacion ya no funciona el conector de firefox. Lo hice asi:

1. instale Cmake
2. coreutils ya esta instalado, sino lo instalas desde yast
3. instale jq
4. instale python-pygit2 --> PyGObject (esta libreria contiene los bindings para libgit2, necesarios, que pide la documentacion con PyObject)
5. instale git

Todo desde YAST

6. ejecute el comando git clone git://git.gnome.org/chrome-gnome-shell en una terminal como usuario normal
7. ejecute cd chrome-gnome-shell
8. mkdir build
9. cd build
10. cmake -DCMAKE_INSTALL_PREFIX=/usr -DBUILD_EXTENSION=OFF ../
11. su -c "make install"

Ningun problema, quizas te pasaste la libreria python-pygit2, me tomo unos minutos entender que era esta la que habia que instalar para satisfacer PyGObject
Responder Citando
  #9  
Antiguo 22-mar-2017, 17:28
Alienator Alienator está desconectado
Aforado
 
Fecha de Ingreso: 06-abril-2009
Ubicación: La Paz, Bolivia
Versión: Leap 42.2 Gnome
Mensajes: 52
Agradecimientos: 0
Agradecido 3 Veces en 3 Mensajes
Poder de Credibilidad: 9
Alienator está en el buen camino
PD. tambien instale python-requests

Pero no te dejara desactivar/quitar la extension desde chrome, para hacerlo ejecuta los comandos
rm /etc/opt/chrome/policies/managed/chrome-gnome-shell.json
rm /etc/chromium/policies/managed/chrome-gnome-shell.json


como root, esto quitara la extension de chrome solamente, la instalas desde chrome web store gnome-shell-integration y listo, funcionan los btones ON/OFF y la extension se la puede quitar/desactivar desde chrome
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Alienator Por Este Mensaje:
aldebaran (22-mar-2017)
Problemas con temas de usuario GNOME
  #10  
Antiguo 22-mar-2017, 23:10
Avatar de aldebaran
aldebaran aldebaran está desconectado
Aforado
 
Fecha de Ingreso: 04-junio-2013
Ubicación: Madrid
Versión: 13.2 GNOME
Mensajes: 38
Agradecimientos: 6
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 0
aldebaran está en el buen camino
Problemas con temas de usuario GNOME

Gracias alienator, consegui seguir tus pasos y no me dio error, pero con el chrome tampoco consigo que me salgan los botones de ON/OFF y tampoco me reconoce las extensiones instaladas.
Creo que me doy por vencido y seguiré con las que tengo y esperare nuevos desarrollos para firefox.
__________________
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Pasar a Framework 5 en Leap 42.1 Krovikan Escritorios: KDE, Gnome, otros... 23 20-sep-2016 20:52
Problema Gnome 3.10 y sus Extensiones. Caratulas en carpetas Maxstill Escritorios: KDE, Gnome, otros... 4 15-ene-2014 13:06
Problema con la actualización online algosuntos Instalación y Actualizaciones 6 10-abr-2013 03:19
Modificar temas en Gnome Azrael Escritorios: KDE, Gnome, otros... 3 21-oct-2011 18:08
un problema con gnome y opensuse 11.1 perrito Instalación y Actualizaciones 7 01-feb-2009 00:51



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 11:53.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba