Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Evitar una actualización de kernel (constante aviso de update)
  #1  
Antiguo 26-nov-2017, 12:12
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Evitar una actualización de kernel (constante aviso de update)

Tengo añadido el repo de kernel stable standard, sobre kernels, es el único repo que tengo añadido.
Anteriormente tuve el kernel de leap, pero ahora no.

Cada vez que tengo actualizaciones, me dice que tengo la de kernel-default 4.4.92-31.1

Es un kernel que no tengo instalado, por lo tanto, si digo de instalar, me dice que no un candidato para kernel-default 4.14.2 (que es el kernel que tengo).
Tengo 2 kernels instalados, ambos de 4.14.

Para que "desaparezca" ese update me toca ir a yast e instalar el kernel de 4.4.92-31.1

No obstante, una vez reiniciado el equipo desaparece ese update pero también la instalación del kernel 4.4.92-31.1

En el siguiente chequeo de update, vuelve a aparecerme este update.

Y de ese bucle no salgo...

No se si debería añadir el repo de leap para kernel, o hacer alguna otra cosa...

Saludos!
__________________
Responder Citando
  #2  
Antiguo 26-nov-2017, 15:18
DanielVE DanielVE está desconectado
Aforado
 
Fecha de Ingreso: 07-noviembre-2017
Versión: Leap
Mensajes: 63
Agradecimientos: 3
Agradecido 15 Veces en 15 Mensajes
Poder de Credibilidad: 0
DanielVE está en el buen camino
Porqué no lo marcas como tabú, o lock desde zypper, y así deja de marearte. :?
Responder Citando
  #3  
Antiguo 26-nov-2017, 16:11
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Lo intenté, marcarlo como tabú, pero, o no me deja o no se (creo que más bien esto último) marcar como tabú una versión de kernel-default.
Cuando hago la búsqueda de kernel-default, debo pinchar en versión, ahí veo la del update desmarcada, si la marco solo me deja instalarla o quitarla (si esta instalada) pero marcarla como tabú seria el kernel-default completo, no una única versión.
Y un loock desde zypper, eso si que no se, debo buscar sobre ello.

Saludos!
__________________
Responder Citando
  #4  
Antiguo 26-nov-2017, 16:30
DanielVE DanielVE está desconectado
Aforado
 
Fecha de Ingreso: 07-noviembre-2017
Versión: Leap
Mensajes: 63
Agradecimientos: 3
Agradecido 15 Veces en 15 Mensajes
Poder de Credibilidad: 0
DanielVE está en el buen camino
Disculpa tienes toda la razón, no lo pensé bien puesto que no sería bloquear un paquete, que por supuesto tienes instalado en otra versión, sino una actualización en sí misma y esto la verdad nunca lo hice, habría que investigarlo. ¿Podemos bloquear cierta versión ofrecida por un depósito en concreto?

Última edición por DanielVE; 26-nov-2017 a las 16:37 Razón: Aclaración.
Responder Citando
  #5  
Antiguo 26-nov-2017, 16:36
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Cita:
Iniciado por DanielVE Ver Mensaje
Disculpa tienes toda la razón, no lo pensé bien puesto que no sería bloquear un paquete, que por supuesto tienes instalado en otra versión, sino una actualización en sí misma y esto la verdad nunca lo hice, habría que investigarlo. Si te ofrece esa actualización es porque algún patrón o paquete esta pidiendo esa dependencia pero, ¿cuál, se podría eliminar? Busca por "requerido por".
No problem

Es el paquete instalado que tengo y debo tener claro, pero es una versión, la que "canta".

Es raro, ofrece actualización si...pero no esta ese kernel instalado...solo tengo 2, y son otras versiones, porque "canta" esa versión? Ni idea... Si, lo tuve instalado en su momento, pero ahora no...

Y le he dado a instalar, la he instalado, el kernel completo de esa versión, pero tras reinicio...bye bye...desaparece...
Intuyo que es por el drm-kmp-default, pero no lo tengo instalado (cuando instalo ese kernel, se instala automáticamente, y para kernels 4.1x.x o superior, no hace falta.

Es muy curioso, le doy a actualizar solo el paquete que canta en actualización e indica,
Que no es un candidato para el kernel 4.14.2 (que es el que tengo instalado).

Y cada día me aparece, ya he probado de todo (lo que yo conozco) y nada lo solventa, siempre "canta"...

Saludos!
__________________
Responder Citando
  #6  
Antiguo 26-nov-2017, 17:22
DanielVE DanielVE está desconectado
Aforado
 
Fecha de Ingreso: 07-noviembre-2017
Versión: Leap
Mensajes: 63
Agradecimientos: 3
Agradecido 15 Veces en 15 Mensajes
Poder de Credibilidad: 0
DanielVE está en el buen camino
Mira la edición, ¿se puede bloquear selectivamente escogiendo los paquetes desde un repo? No estoy en la compu ahora mismo pero creo que en el desplegable se puede seleccionar por repo y me pregunto si desde ahí, bloquear el paquete en cuestión.
Si entiendo bien, tienes instalado un núcleo diferente del repo principal y que te pida actualizar uno inferior, ¿del principal?, solo indica que el mantenedor de algún paquete del sistema no contempla versiones superiores.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DanielVE Por Este Mensaje:
Wonder (27-nov-2017)
  #7  
Antiguo 26-nov-2017, 17:55
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.882
Agradecimientos: 619
Agradecido 2.641 Veces en 1.788 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Porque no lo proteges y cuando salga una version superior lo desproteges.

Para bloquear una determinada version del kernel, haz lo indicado en este tema en ingles: https://forums.opensuse.org/showthre...kage-in-Zypper

Seria algo así:
zypper addlock "kernel-default == 4.4.92"
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
Los Siguientes 2 Usuarios Han Dado las Gracias a DiabloRojo Por Este Mensaje:
Krovikan (27-nov-2017), Wonder (27-nov-2017)
  #8  
Antiguo 27-nov-2017, 12:13
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Cita:
Iniciado por DanielVE Ver Mensaje
Mira la edición, ¿se puede bloquear selectivamente escogiendo los paquetes desde un repo? No estoy en la compu ahora mismo pero creo que en el desplegable se puede seleccionar por repo y me pregunto si desde ahí, bloquear el paquete en cuestión.
Si entiendo bien, tienes instalado un núcleo diferente del repo principal y que te pida actualizar uno inferior, ¿del principal?, solo indica que el mantenedor de algún paquete del sistema no contempla versiones superiores.
Disculpa, no acabé de coger la idea o el método.
Es correcto, tengo instalado un núcleo diferente del repo principal, y me pide actualizar uno inferior, y es del principal el que pide actualizar si.
Algo hay que hace ese "extraño".
Cita:
Iniciado por DiabloRojo Ver Mensaje
Porque no lo proteges y cuando salga una version superior lo desproteges.

Para bloquear una determinada version del kernel, haz lo indicado en este tema en ingles: https://forums.opensuse.org/showthre...kage-in-Zypper

Seria algo así:
zypper addlock "kernel-default == 4.4.92"
Han salido versiones superiores, de hecho, tengo instaladas versiones superiores y sigue saltando ese update...

No obstante, he seguido la guía que has indicado y efectivamente ha funcionado, pero de un modo extraño:
Bloquee el 4.4.92 y al momento me cantó el update de una inferior (justo la anterior) y bloqueé esa también, y cantó justo la anterior, al final ví que tuve que bloquear todas las que había anteriores a las 2 versiones que tengo instaladas, o todas las que pertenecen al repo principal...

Una vez bloqueados todos, ya no cantó ninguna más...pero tuve que bloquearlas todas ellas...extraño al menos...

Saludos!!
__________________
Responder Citando
  #9  
Antiguo 27-nov-2017, 13:58
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.882
Agradecimientos: 619
Agradecido 2.641 Veces en 1.788 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Cita:
Iniciado por Wonder Ver Mensaje
Bloquee el 4.4.92 y al momento me cantó el update de una inferior (justo la anterior) y bloqueé esa también, y cantó justo la anterior, al final ví que tuve que bloquear todas las que había anteriores a las 2 versiones que tengo instaladas, o todas las que pertenecen al repo principal...
Podias haber puesto el signo menor según el enlace que te puse

zypper addlock "kernel-default <= 4.4.92"
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Krovikan (27-nov-2017)
  #10  
Antiguo 27-nov-2017, 14:20
Wonder Wonder está desconectado
Habitual
 
Fecha de Ingreso: 07-agosto-2014
Versión: Leap 42.3
Mensajes: 149
Agradecimientos: 87
Agradecido 5 Veces en 5 Mensajes
Poder de Credibilidad: 4
Wonder está en el buen camino
Cita:
Iniciado por DiabloRojo Ver Mensaje
Podias haber puesto el signo menor según el enlace que te puse

zypper addlock "kernel-default <= 4.4.92"
Si, lo pensé a la segunda o tercera vez que me salió.
La primera, no pensé que luego "cantase" una versión inferior, pensé que solo se quedaba o el problema era con la 4.4.92, al salir una inferior, lo hice de nuevo y a la siguiente vez pensé en el signo menor, pero ya quedaban una o dos versiones...y quería ver que iba sucediendo...

Thanks!
__________________
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Microsoft debe pagar a un cliente $10.000 por la actualización de Windows 10 no dese gvcastellon La cafetería 0 28-jun-2016 16:41
Mensajes de error tras actualización de openSUSE12.3tumbleweedKde a openSUSEtumblewee feroSUSEANDO General OpenSUSE 1 16-dic-2014 20:33
Yast2 da error al arrancar Susefan1 Software 10 01-dic-2014 15:32
Multiseat [documento de trabajo] soyasi La cafetería 15 15-jul-2014 16:45
Actualización de múltiples paquetes para productos Suse Linux loquevenga Noticias 0 05-oct-2007 00:31



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 16:50.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba