Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Técnica > FAQs, Manuales y Tutoriales


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Beryl en Ati
  #1  
Antiguo 26-ago-2007, 22:24
Avatar de jncruces
jncruces jncruces está desconectado
Miembro Junior
 
Fecha de Ingreso: 03-agosto-2007
Ubicación: Sevilla (España)
Versión: openSUSE Leap 42.1
Mensajes: 460
Agradecimientos: 33
Agradecido 104 Veces en 87 Mensajes
Poder de Credibilidad: 11
jncruces está en el buen camino
Thumbs up Beryl en Ati

He conseguido, no creo que sea el unico espero, instalar Beryl en mi ordenador de sobremesa, voy ha explicar el procedimiento que lo he cogido de la siguiente dirección, solo voy ha traducir la página y ha dar mis impresiones sobre cómo se hace.

http://en.opensuse.org/ATI

Lo primero decir que tras reinstalar 3 veces mi openSuse 10.2 ya creía que sería imposible instalar el beryl en mi ordenador, el cual describo a continuación (si ha alguien no le funciona esta explicacion, tal vez sea por su hardware):

AMD Athlon 64 3400+ a 2400Mhz
Placa Asus K8V-X
Gráfica: Ati Radeon 9550 256MB Agp 8x
Kingston 1GB Ram

SO: OpenSuse 10.2 con KDE

Lo primero sera instalar la tarjeta gráfica, en esa página viene descrito de dos formas, la forma dificil y la fácil, yo explicaré la fácil porque entiendo que la dificil es dificil hasta para mi, jj, y la fácil le tiene que resultar facil ha todo el mundo.

La forma fácil de instalar los drivers ATI:

- Añadir el repositorio siguiente al yast

- Menu K -> Aplicaciones -> Sistema -> Yast

- En el yast ir al apartado Software y dentro del mismo cambiar fuente de instalacion.

- Pinchamos en Añadir -> Especificar URL, e introducimos la siguiente URL

http.//www2.ati.com/suse/10.2

- Abrimos una ventana de terminal e ingresamos como superusuario (comando su, nos pedira la contraseña de superusuario que indicamos en la instalacion)

-Ejecutamos el siguiente comando


Version:
openSuse 10.2
yast2 --install x11-video-fglrxG01 ati-fglrxG01-kmp-`uname -r | awk -F"-" '{print $NF}'`

Version:
openSuse 10.1
yast2 --install x11-video-fglrx ati-fglrx-kmp-`uname -r | awk -F"-" '{print $NF}'`

(Solo hay que ejecutar una de las dos, dependiendo del openSuse que uno tenga)

- Seguidamente Ejecutaremos en el mismo terminal y como superusuario el comando

sax2 -r

Nos saldra una ventana gráfica donde podemos configurar varios aspectos del sistema gráfico como resolucion, colores, posicion, frecuencia de actualización, etc. Simplemente Aceptamos y probamos la configuracion, donde también aceptaremos los cambios


- Lo siguiente sería reiniciar el sistema gráfico, yo recomiendo que que se Reinicie el ordenador por completo, pusto que el método más drástico como dice en el tutorial que he seguido, nos podemos quedar colgados sin entorno gráfico y sin poder volver, de todos modos para los aventureros decir que se hace con la combinacion de teclas Ctrl+Alt+Retroceso

-Cuando el ordenador reinicie, abrimos un terminal y ejecutamos el comando:

glxgears (Debe de salir una ventanita gráfica done hay unos engranajes de colores rotando)

Si hasta aqui seguimos viendo colores, jj podremos proceder ha instalar el beryl.

Instalar Beryl:

- Volvemos ha irnos al yast

Menu K -> Aplicaciones -> Sistema -> Yast

- Agregamos otra fuente de instalacion en el apartado Software -> Cambiar Fuente de Instalacion

- Pulsamos en Añadir -> Especificar URL -> Añadimos la siguiente URL

http://ftp.skynet.be/pub/software.op...openSUSE_10.2/

- Aceptamos y Finalizamos todo y sin salir del yast nos vamos ha Software -> Instalar/Desinstalar Software

- Instalaremos la siguiente lista de paquetes

aquamarine
beryl-core
beryl-manager
beryl-plugins
beryl-settins
beryl-vidcap
emerald
emerald-themes

Tengo que aclarar que en la página de done he tomado todo esto instalan los paquetes que terminan en snapshot, es decir todos los paquetes antes mencionados terminados en -snapshot, sin embargo yo no he instalado esos por que no son versiones finales, son de pruebas y pueden darnos problemas. Quien quiera probarlos e informar de los fallos seguro que los desarrolladores de beryl se alegran de que la gente colabore para mejorar su sistema.

- Desinstalaremos todos los paquetes que tengan en su nombre compiz

- El siguiente paso solo deben hacerlo aquellas personas que tengan más de una pantalla conctada en su ordenador y repito SOLO aquellos que tengan más de una pantalla, o pantalla+televisor, pantalla+proyector, etc

ir al directorio /etc/X11 y editad el fichero xorg.conf y cambiar la siguiente opcion

Section "ServerLayout"
...
Option "Xinerama" "on"
...
EndSection

(Por defecto esta en off hay que poner on)
Guardad los cambios y salid.

- Ejecutar en el terminal, como usuario normal, NO como superusuario

beryl-manager

- Nos saldra el ruby de beryl en la barra de tareas al lado del reloj, pincharemos con el boton derecho del raton y en la parte que pone "opciones avanzadas de beryl" cambiaremos lo siguiente:

Plataforma de Renderizado -> Forzar XGL
Enlazar -> Enlace XGL
Renderizado -> Renderizado XGL

(Si tras terminar, ha alguno le desaparecen los bordes de las ventanas, o cosas parecidas recomiendo cambiar las opciones de "Compuesto del recubrimiento de la ventana" y cambiamos entre Automático, Usar COW, No usar COW.)


- Tendremos que hacer el siguiente camino y desabilitar la Translucidez en las ventanas.

Menu K -> Configurar Escritorio -> Escritorio -> Comportamiento de la Ventana -> La ultima pestaña que se llama Translucidez desactivamos la casillita que pone "Usar Translucidez/Sombras" en la parte superior.

- Lo siguiente es hacer que el sistema Beryl arranque desde el inicio.

Para KDE
Abrimos terminal como usuario normal:
ln -s /usr/bin/beryl-manager ~/.kde/Autostart/beryl-manager
ln -s /usr/bin/beryl ~/.kde/Autostart/beryl

Para GNOME
Ir al Centro de Control de GNOME's -> Sesiones Ir a la ultima pestaña Programas de Inicio y añadir las dos siguientes lineas
beryl-manager
beryl

(Decir que no conozco bien GNOME y me puedo haber equivocado traduciendo, lo siento)

- Volvemos al Yast
yast-> Sistema -> Editor para los archivos /etc/sysconfig

Aqui modificaremos lo siguiente

Desktop -> Display manager -> DISPLAYMANAGER_XSERVER

Y donde pone Xorg ponemos Xgl


FIN (yo aki ya tenia ventanitas de goma, jj)


- Esto ultimo yo no lo he tenido que hacer pero supuestamente hay que hacerlo en el terminal:

rcxdm restart

o si tu estas usando gdm (yo no se que es gdm)

rcgdm restart



PD. A mi me ha funcionado, y espero que a todos vosotros también, solo he querido hacer un manual que este en castellano y he intentado que este bien escrito, también decir que estos son los pasos que yo he seguido parece muy largo pero al final se hace en 5 minutos. Si ha alguien no le funciona que se vaya ha la página que especifique al principio donde el manual esta más completito aunque en inglés.
__________________
En ocasiones, se pueden ajustar los tipos para permitir la operación.
Responder Citando
  #2  
Antiguo 27-ago-2007, 10:46
javilete javilete está desconectado
Habitual
 
Fecha de Ingreso: 23-diciembre-2005
Mensajes: 275
Agradecimientos: 0
Agradecido 11 Veces en 4 Mensajes
Poder de Credibilidad: 13
javilete está en el buen camino
Para empezar yo tengo el mismo procesador y la misma gráfica que tu.Te puedo decir que beryl ya es "arcaico" y con el mismo repositorio que cuentas puedes instalar compiz fusion que funciona mucho mejor e incluye muchos más efectos y más estables.

En cuanto a cambiar xorg por xgl en DISPLAYMANAGER_XSERVER hay una forma más facil que lo hace todo por tí. Solo tienes que escribir en una consola (como su) esto:

gnome-xgl-switch --enable-xgl

Tienes explicado como instalar compiz fusion aqui:
http://www.forosuse.org/forosuse/sho...75&postcount=8

Saludos.
Responder Citando
  #3  
Antiguo 27-ago-2007, 14:37
Avatar de jncruces
jncruces jncruces está desconectado
Miembro Junior
 
Fecha de Ingreso: 03-agosto-2007
Ubicación: Sevilla (España)
Versión: openSUSE Leap 42.1
Mensajes: 460
Agradecimientos: 33
Agradecido 104 Veces en 87 Mensajes
Poder de Credibilidad: 11
jncruces está en el buen camino
Gracias, he estado viendo el Compiz Fusion por el Youtube y me ha gustado lo que he visto, creo que el que esta arcaico soy yo, jj. Aunque lo de instalar beryl era por cabezonería porque en ningún sitio venia una buena forma de hacerlo, a excepcion de la página oficial que menciono, y pense que ha alguien le gustaría tenerlo en castellano, para guiarse.

También probare el compiz-fusion pero eso me temo que lo tendre que hacer tras hacer los examenes de septiembre, con esto de poner el opensuse en los dos ordenadores que tengo y solucionar todos los problemas que he tenido, más el beryl, creo que en el examen de la asignatura Compiladores en vez de explicar el analizador léxico explicare como compilar el núcleo del linux, jj
__________________
En ocasiones, se pueden ajustar los tipos para permitir la operación.
Responder Citando
  #4  
Antiguo 28-ago-2007, 21:09
Avatar de pedrogeek
pedrogeek pedrogeek está desconectado
Miembro Junior
 
Fecha de Ingreso: 10-septiembre-2006
Ubicación: Cartagena (Spain)
Versión: openSuSE 10.3 i586
Mensajes: 557
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 12
pedrogeek está en el buen camino
Yo a ver si monto el compiz fusion en la 10.3 y pongo una guia en cuanto pueda.
Lo unico que yo uso el driver libre, que con AIGLX me va de perlas en la 10.2.
PD: Mi ATI es una x600 Pro 128Mb Mobile
__________________
Guia ATI con Compiz Fusion:
http://www.forosuse.org/forosuse/showthread.php?t=15734
Responder Citando
  #5  
Antiguo 05-sep-2007, 05:45
Avatar de caligulaelsanto
caligulaelsanto caligulaelsanto está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 14-febrero-2007
Ubicación: Buenos Aires
Versión: 42.3 kde
Mensajes: 2.064
Agradecimientos: 237
Agradecido 101 Veces en 88 Mensajes
Poder de Credibilidad: 14
caligulaelsanto está en el buen camino
yo tengo una ati a9250 256mb y el 10.3 me deja 3d
algun problema con beryl?? puede haber?o debere poner los drivers que dice el tuto?
Responder Citando
  #6  
Antiguo 05-sep-2007, 11:35
Avatar de jncruces
jncruces jncruces está desconectado
Miembro Junior
 
Fecha de Ingreso: 03-agosto-2007
Ubicación: Sevilla (España)
Versión: openSUSE Leap 42.1
Mensajes: 460
Agradecimientos: 33
Agradecido 104 Veces en 87 Mensajes
Poder de Credibilidad: 11
jncruces está en el buen camino
Eso lo tendrás que probar, yo lo hice funcionar con el opensuse 10.2 que desde el principio no daba aceleración 3d. Creo que el 10.3 ya trae el driver libre incorporado por lo que no tendrías problemas, pero eso hay que confirmarlo y nos hace falta un conejillo de indias, jj.

Se supone que el requisito del beryl para poder hecharlo a andar es tener aceleración 3d y por eso es importante instalar los drivers de la tarjeta. Si tu ya tienes los drivers puedes probar ha poner solo el beryl. Si te funciona ya nos contarás, seguro que a mucha gente le interesará saber si se puede instalar directamente en el 10.3 sin tener que instalar los drivers.
__________________
En ocasiones, se pueden ajustar los tipos para permitir la operación.
Responder Citando
ERROR istalando driver ATI
  #7  
Antiguo 11-sep-2007, 22:34
anata
Invitado
 
Mensajes: n/a
ERROR istalando driver ATI

Hola, yo soy nuevo con el linux y he instalado el SUSE 10.2 la instalación perfecta sin problemas, pero cuando instale el DRIVER de mi tarjeta ATI, no se que ha pasado que cuando arranca el sistema se queda en modo de consola.

¿Que puedo hacer para volver al modo gráfico, que de consola no se nada?.

Para la instalacion de los DRIVER segui los pasos de: http://en.opensuse.org/ATI#The_Easy_Way

y llegue hasta el paso 4:

Step 4 - Restart X

Restart the X server by logging out of your desktop and logging back in; or, for the more adventurous, use the more drastic method: Ctrl+Alt+Backspace.

Reinicie el ordenador y cuando volvio a encender se queda en modo consola, pidiéndome login, pongo user y pass pero sigue en consola.
Responder Citando
  #8  
Antiguo 12-sep-2007, 15:04
Avatar de eduararley
eduararley eduararley está desconectado
Miembro Senior
 
Fecha de Ingreso: 21-abril-2007
Ubicación: Medellín, Colombia
Versión: 11.0 x86 GNOME
Mensajes: 1.193
Agradecimientos: 29
Agradecido 48 Veces en 43 Mensajes
Poder de Credibilidad: 13
eduararley está en el buen camino
Enviar un mensaje por Yahoo  a eduararley
Vuelve a correr el comando:
Código:
sax2 -r
Con eso, te debería volver a subir el entorno gráfico. Si nó, intenta la sección de "Troubleshotting" que hay más abajo en la página que diste.

Slds.
Responder Citando
  #9  
Antiguo 13-sep-2007, 22:55
anata
Invitado
 
Mensajes: n/a
Ejecute el SaX2 -r y me salio:

SaX: no X-server is running
SaX: will start own server if needed
SaX: prepare device [0] profile: Depth24
SaX: prepare device [0] profile: Radeon
SaX: prepare device [0] profile script: Radeon
SPP: including prepared profile(s)...
SaX: starup

---- Aqui se pone negro y vuelve a consola

XC: sorry could not start configuration server
XC: for datails refer to the log file: /var/log/SaX.log
XC: abort...

y ahi queda.

trate de ver el archivo SaX.log, pero no tengo ni idea de como verlo, fui a la ruta /var/log/SaX.log pero no puedo ejecutarlo...

Serian tan amables en ayudarme a abrir el log?
Responder Citando
  #10  
Antiguo 14-sep-2007, 14:20
Avatar de eduararley
eduararley eduararley está desconectado
Miembro Senior
 
Fecha de Ingreso: 21-abril-2007
Ubicación: Medellín, Colombia
Versión: 11.0 x86 GNOME
Mensajes: 1.193
Agradecimientos: 29
Agradecido 48 Veces en 43 Mensajes
Poder de Credibilidad: 13
eduararley está en el buen camino
Enviar un mensaje por Yahoo  a eduararley
Código:
vi /var/log/SaX.log
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
falla de instalación de beryl en Suse 10.2, no puedo ver nada Daniel V Escritorios: KDE, Gnome, otros... 9 02-jul-2007 03:05
Consumo de memoria en Beryl + XGL + nVidia Ragnarok Software 10 28-abr-2007 19:28
Xgl + Beryl maxim_o Escritorios: KDE, Gnome, otros... 0 24-abr-2007 22:20
Beryl falla al iniciar SuSE Vanhel Software 9 25-ene-2007 20:17
[FAQ] Beryl [IMCOMPLETO] noident FAQs, Manuales y Tutoriales 0 11-dic-2006 12:36



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 09:08.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba