Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

probllema con las librerías opengl
  #1  
Antiguo 22-ene-2018, 18:31
J_VM J_VM está desconectado
Habitual
 
Fecha de Ingreso: 22-septiembre-2013
Versión: Tumbleweed
Mensajes: 244
Agradecimientos: 32
Agradecido 23 Veces en 21 Mensajes
Poder de Credibilidad: 6
J_VM está en el buen camino
probllema con las librerías opengl

Hola a todos,

Estoy en openSuSE 42.3 y bueno, todo parece ir normal, pero tengo problemas en algunos programas. Playonlinux me dice:

Código:
 PlayOnLinux no es capaz de encontrar las bibliotecas OpenGL de 32bits.
Código:
 PlayOnLinux no es capaz de encontrar las bibliotecas OpenGL de 64bits.
Mendeley (para gestionar bibliografía) no me abre. Da este error:

Código:
static QPlatformTheme* QKdeTheme::createKdeTheme(): Unable to determine KDE dirs
Could not initialize GLX
Tengo una tarjeta NVIDIA con optimus. Casi siempre uso la intel, tengo bumblebee instalado y tal pero últimamente no he conseguido que funcione lo de activar la nvidia con optirun (quizá desde que actualicé 42.2 a 42.3, no sé). Por ejemplo

Código:
$ optirun glxspheres

Polygons in scene: 62464 (61 spheres * 1024 polys/spheres)
Visual ID of window: 0x21
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  154 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  22
  Current serial number in output stream:  23
El caso es que no sé qué instalar o desisntalar y tal...si alguien me puede echar un cable lo agradeciería.


EDITO: añado la salida de "zypper search opengl"

Código:
E  | Nombre                                    | Resumen                                                        | Tipo       
---+-------------------------------------------+----------------------------------------------------------------+------------
   | gambas3-gb-gtk-opengl                     | GTK-OpenGL component for Gambas                                | paquete    
   | gambas3-gb-opengl                         | The OpenGL component for Gambas                                | paquete    
   | gambas3-gb-opengl-glsl                    | High level shading language integration for Gambas             | paquete    
   | gambas3-gb-opengl-glu                     | OpenGL complementary routines for Gambas                       | paquete    
   | gambas3-gb-opengl-sge                     | The Gambas opengl-sge component                                | paquete    
   | gambas3-gb-qt4-opengl                     | Qt4-OpenGL component for Gambas                                | paquete    
   | gambas3-gb-qt5-opengl                     | Qt5-OpenGL component for Gambas                                | paquete    
   | ghc-OpenGL                                | A binding for the OpenGL graphics system                       | paquete    
   | ghc-OpenGL-devel                          | Haskell OpenGL library development files                       | paquete    
   | ghc-OpenGLRaw                             | A raw binding for the OpenGL graphics system                   | paquete    
   | ghc-OpenGLRaw-devel                       | Haskell OpenGLRaw library development files                    | paquete    
   | libG4OpenGL                               | Geant4 OpenGL library                                          | paquete    
i+ | libQt5OpenGL-devel                        | Qt 5 OpenGL Library - development files                        | paquete    
   | libQt5OpenGL-devel-32bit                  | Qt 5 OpenGL Library - development files                        | paquete    
   | libQt5OpenGL-private-headers-devel        | Qt 5 OpenGL Library - Non-ABI stable development files         | paquete    
i+ | libQt5OpenGL5                             | Qt 5 OpenGL Library                                            | paquete    
   | libQt5OpenGL5-32bit                       | Qt 5 OpenGL Library                                            | paquete    
   | libQt5OpenGLExtensions-devel-static       | Qt OpenGLExtensions module                                     | paquete    
   | libQt5OpenGLExtensions-devel-static-32bit | Qt OpenGLExtensions module                                     | paquete    
   | libfifechan_opengl0_1_4                   | OpenGL extension library of the Fifechan GUI toolkit           | paquete    
   | opengl-games-utils                        | Utilities to check proper 3d support before launching 3d games | paquete    
   | python-opengl                             | OpenGL bindings for Python                                     | paquete    
   | python-opengl                             | OpenGL bindings for Python                                     | paquete src
   | python-opengl-accelerate                  | Acceleration for python-opengl                                 | paquete src
   | python-opengl-accelerate                  | Acceleration for python-opengl                                 | paquete    
   | python3-opengl                            | OpenGL bindings for Python                                     | paquete    
   | python3-opengl-accelerate                 | Acceleration for python-opengl                                 | paquete

Última edición por J_VM; 24-ene-2018 a las 11:40 Razón: más información
Responder Citando
Respuesta

Marcadores

Etiquetas
glx, opengl


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Sin entorno gráfico después de actualizar el kernel NestorAcevedo Instalación y Actualizaciones 12 05-dic-2017 17:42
Muestra tu "glxgears" [FPS] + Tarjeta Gráfica 1antares1 La cafetería 20 19-sep-2017 10:31
No puedo ejecutar juegos en steam! jularaXD Juegos en Linux 6 07-sep-2013 09:24
librerias opengl LUKE10 Software 4 14-mar-2013 22:02
¿Qué sabéis de librerías vtk, itk, mitk...? Mdk Programación y Scripts 0 21-ene-2005 02:14



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 03:24.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba