Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Técnica > FAQs, Manuales y Tutoriales


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Instalación DNI-e en Opensuse 13.2 (solucionado)
  #1  
Antiguo 05-dic-2014, 01:42
lokopepe lokopepe está desconectado
Aforado
 
Fecha de Ingreso: 30-noviembre-2014
Versión: 13.2
Mensajes: 4
Agradecimientos: 4
Agradecido 5 Veces en 2 Mensajes
Poder de Credibilidad: 0
lokopepe está en el buen camino
Instalación DNI-e en Opensuse 13.2 (solucionado)

Hola.
Después de romperme la cabeza y de buscar por todos los sitios en el foro, en san google, etc he dado con el post de este foro que me ha ayudado a que al fin funcione. Vayan, pues, todos los méritos para el autor del post susodicho.

http://www.forosuse.org/forosuse/sho...d.php?p=178259

Os cuento lo que he hecho yo siguiendo las indicaciones de ese post
Aquí va.

1.-Siguiendo las indicaciones del post he añadido los dos repositorios que cita:
download.opensuse.org/repositories/home:/frispete:/chipcard/openSUSE_13.2/
download.opensuse.org/repositories/security:/chipcard/openSUSE_13.2/
Lógicamente he cambiado la versión de opensuse; de 13.1 he dejado 13.2

2.-He abierto una ventana de terminal en modo root y he copiado y pegado todo lo que viene en la cita.
A saber:

zypper in mozilla-nss-tools gcc gcc-c++ kernel-devel pkg-config autoconf automake docbook-xsl-stylesheets pcsc-lite pcsc-lite-devel pcsc-ccid perl-pcsc libreadline6 readline-devel openssl libopenssl0_9_8 libopenssl-devel pinentry pinentry-gtk2 pinentry-qt4 libtool libltdl7 openct openct-devel pcsc-openct libopenct1 libpth20 libpth-devel

Se ha empezado a ejecutar y me han salido varias veces unas opciones (1, 2, 3, 4, c). He elegido siempre la opción 1 y en la última he seleccionado la que viene por defecto (yes=y)

Ha terminado de ejecutarse todo en la terminal root y..

3.-Me he bajado de la página oficial del DNIe el archivo correspondiente a la versión de opensuse 13.1, en mi caso para 64bits.
Le he dado a guardar archivo ya que si lo ejecuto con apper desde ahí me salía un error.
He ido a descargas y he pinchado en él con el botón derecho/abrir con/instalador de apper.
le he dado a todo que sí y he reinciado el ordenador (si no no funcionará)

4.-He abierto Firefox (con el lector y el dni-e ya puestos)
Preferencias/Avanzado/Certificados/Dispositivos de seguridad/Cargar

He puesto un nombre en el primer cuadro de diálogo (No se puede dejar en blanco) y en el segundo he pinchado en examinar y he cargado el archivos libpkcs11-dnie.so de la carpeta usr/lib64. Luego he cerrado el navegador.

5.-He reiniciado Firefox
Preferencias/avanzado/certificados/ver cdertificados y aquí ya me ha solicitado la clave del DNI-e. La he puesto y he pinchado en importar. Y he seleccionado el archivo ac_raiz_dnie.crt de la carpeta usr/share/libpkcs-dnie. He marcado las tres casillas de verificación y he cerrado todo dándole a aceptar.
Luego me he ido a la pagina oficial del dni electronico para comprobar el certificado y me ha funcionado.
Os deseo suerte.

Última edición por lokopepe; 08-dic-2014 a las 12:07
Responder Citando
Los Siguientes 4 Usuarios Han Dado las Gracias a lokopepe Por Este Mensaje:
jesusx (08-dic-2014), Mazinger-Z (07-dic-2014), Megatorpe (11-jun-2015), oceano4 (25-feb-2015)
  #2  
Antiguo 07-dic-2014, 22:33
Avatar de Mazinger-Z
Mazinger-Z Mazinger-Z está desconectado
Habitual
 
Fecha de Ingreso: 06-agosto-2013
Ubicación: España
Versión: Tumbleweed
Mensajes: 224
Agradecimientos: 18
Agradecido 108 Veces en 75 Mensajes
Poder de Credibilidad: 5
Mazinger-Z está en el buen camino
Te falta una "e" al final del nombre del módulo a cargar:

libpkcs11-dnie.so

Me he vuelto loco hasta darme cuenta. Corrígelo por favor.

Por cierto, ¿has conseguido usar el programa de cambiar el PIN?

A mí se me lanza pero acaba diciendo

"No se tiene acceso a la librería 'jpcsc'
Vuelva a instalar el producto"
Y dicha liibrería está en la propia carpeta del programa que me descargué. Mi versión es 64 bits ... intuyo que por ahí van los tiros.

Un saludo
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Mazinger-Z Por Este Mensaje:
lokopepe (08-dic-2014)
  #3  
Antiguo 08-dic-2014, 17:17
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Castellón
Versión: Tumbleweed+Kde
Mensajes: 3.369
Agradecimientos: 325
Agradecido 482 Veces en 399 Mensajes
Poder de Credibilidad: 13
jesusx está en el buen camino
Graciassss!! Al fin!!
Funciona perfecto, salu2
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
  #4  
Antiguo 25-feb-2015, 12:14
Avatar de oceano4
oceano4 oceano4 está desconectado
Aforado
 
Fecha de Ingreso: 12-diciembre-2013
Ubicación: Santander, España
Versión: 42.2 Leap
Mensajes: 29
Agradecimientos: 22
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
oceano4 está en el buen camino
-Instalado siguiendo tu tutorial y funcionando a la perfeccion.

-GRACIAS.
__________________
Responder Citando
  #5  
Antiguo 15-mar-2016, 17:59
Manux Manux está desconectado
Aforado
 
Fecha de Ingreso: 04-julio-2013
Versión: 12.3
Mensajes: 6
Agradecimientos: 2
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
Manux está en el buen camino
Buenas tardes compañeros,

Me estaba preguntando si todo el tutorial sirve para opensuse leap.
Y pienso que desde entonces, ahora debe de ser todo más fácil.

Aparte en la web del DNI no hay paquetes para opensuse leap 64 bits.

Muchas gracias! y un saludo

Manuel
Responder Citando
  #6  
Antiguo 13-sep-2017, 14:38
Avatar de SergioNN
SergioNN SergioNN está desconectado
Miembro Senior
 
Fecha de Ingreso: 11-junio-2011
Ubicación: Canarias
Versión: Tumbleweed
Mensajes: 817
Agradecimientos: 30
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 7
SergioNN está en el buen camino
Hola.
Estoy en TW, y he intentado hacer tu guía (la de @Soyasi se me antoja muy enrevesada), y para empezar, este repo no existe para TW:
Código:
download.opensuse.org/repositories/home:/frispete:/chipcard/openSUSE_13.2/
de modo que le instalé este:
Código:
http://download.opensuse.org/repositories/home:/frispete:/chipcard/openSUSE_Leap_42.1/
El otro repo que apuntas:
Código:
download.opensuse.org/repositories/security:/chipcard/openSUSE_13.2/
viene para la versión TW, y lo instalé:
Código:
http://download.opensuse.org/repositories/security:/chipcard/openSUSE_Tumbleweed/
Después hice la instalación de todos los paquetes que anotas, con la Konsola, pero me da este error, si bien todos los demás paquetes sí se han instalado:
Código:
No provider of 'libopenssl0_9_8' found.
Con lo cual, a la hora de cargar el módulo pkz11, me dice que no se puede cargar el módulo y después ya no puedo seguir.
Mi lector de tarjetas es un Coolbox, y haciendo lsusb sí lo ve.
Por si alguien me aclara algo.
Gracias.
Responder Citando
  #7  
Antiguo 13-sep-2017, 15:51
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.469
Agradecimientos: 563
Agradecido 2.415 Veces en 1.626 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
@SergioNN, ¿no funciona la guía de soyasi?, ya esta solucionado el problema de las descargas.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
SergioNN (13-sep-2017)
  #8  
Antiguo 13-sep-2017, 17:52
Avatar de SergioNN
SergioNN SergioNN está desconectado
Miembro Senior
 
Fecha de Ingreso: 11-junio-2011
Ubicación: Canarias
Versión: Tumbleweed
Mensajes: 817
Agradecimientos: 30
Agradecido 2 Veces en 2 Mensajes
Poder de Credibilidad: 7
SergioNN está en el buen camino
Cita:
@SergioNN, ¿no funciona la guía de soyasi?, ya esta solucionado el problema de las descargas.
Lo intentaré esta semana. Dado que mezcla cosas de @ManoloBarea del año 2012, cuando hubo que compilar paquetes, con aportaciones suyas, me pareció más claro el aporte de @lokopepe. De todas formas, el peor problema que llevo es la falta de repo para TW que apunto y el dichoso paquete que tampoco se quiere bajar
Gracias.

Edito mi mensaje para contar que:
-Instalé un Sistema 42.2, limpio, y seguí los pasos que aquí se indican, con los repos para 42.2.
-Descargué el paquete que pone la Policía para esta versión.
-Lo fui a instalar con YaST y me dijo que el paquete está dañado.
-Lo instalé con Ark y se copió, en efecto, en USR/lib64, el paquete libpkcs11-dni.so.
-Fui a cargar el módulo de seguridad, lo fui a buscar y...
NO SE PUEDE AGREGAR EL MÓDULO
Ahí me quedé...

Última edición por SergioNN; 16-sep-2017 a las 17:18
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Como conseguir instalar opensuse 12.3 en un equipo con windows 8 y tener dual boot oscarpoio FAQs, Manuales y Tutoriales 13 14-dic-2013 11:50
Problema instalación en USB de opensuse 12.2 gnome Tolguin Instalación y Actualizaciones 2 22-oct-2012 22:39
Intalando agente NRPE en suseserver 10 64bits prubilar Seguridad y Servidores 4 27-abr-2012 18:40
Problema de Xorg tras la instalación de OpenSUSE 11.3 jldoreste Instalación y Actualizaciones 0 27-dic-2010 22:06
Review de openSUSE 11.0 y comparativa con Ubuntu. Dux El Contubernio 54 20-feb-2010 13:30



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 23:59.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba