Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Tras instalación driver nvidia no detecta pantalla [RESUELTO]
  #1  
Antiguo 10-dic-2016, 12:43
Eduardorl Eduardorl está desconectado
Aforado
 
Fecha de Ingreso: 25-diciembre-2015
Versión: 42.1
Mensajes: 23
Agradecimientos: 21
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Eduardorl está en el buen camino
Angry Tras instalación driver nvidia no detecta pantalla [RESUELTO]

Buenas a tod@s,

Todo ha comenzado tras una actualización del kernel (4.1.36-38), todo iba bien hasta ese momento. No puedo volver a la versión estable porque creo recordar que en GRUB tenía configurado que solo dejara las dos últimas y por olvido mío se han quedado las dos que me daban error al arrancar.

La información de mi sistema es:

https://drive.google.com/file/d/0B1y...ew?usp=sharing

en él se puede ver que tengo instalado el driver nvidia.

el error que obtengo es:

https://drive.google.com/file/d/0B1y...ew?usp=sharing

Según dice el error no me detecta la pantalla.

He realizado la instalación como otras veces. La siguiente imagen muestra el contenido del archivo: "var/log/nvidia-installer.log" en el mismo aparecen los pasos que he realizado en la instalación.

https://drive.google.com/file/d/0B1y...ew?usp=sharing

Creo que el error puede estar motivado al haber aceptado la actualización del "X configuration file" no recuerdo haber realizado ese paso en otras instalaciones.

¿Qué puedo hacer? cualquier ayuda o sugerencia es bienvenida, es la primera vez que me encuentro con este error.

Muchas gracias de antemano.

Última edición por Eduardorl; 10-dic-2016 a las 18:41 Razón: Resuelto
Responder Citando
  #2  
Antiguo 10-dic-2016, 14:24
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.585
Agradecimientos: 568
Agradecido 2.475 Veces en 1.673 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
¿Has mirado la guía de instalación de Nvidia en la Web de openSUSE en ingles y español?.

El error de screen es muy genérico y no dice nada. Prueba volver a reinstalar el driver sin aceptar "X configuration file" que dices.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
Eduardorl (10-dic-2016)
  #3  
Antiguo 10-dic-2016, 15:11
Eduardorl Eduardorl está desconectado
Aforado
 
Fecha de Ingreso: 25-diciembre-2015
Versión: 42.1
Mensajes: 23
Agradecimientos: 21
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Eduardorl está en el buen camino
Red face

He ido a reinstalar el driver como indicaba Diablorojo y me ha lanzado un error durante la instalación haciendo referencia a que estaban instalados los driver nouveau. He vuelto a comprobar que no están instalados los nouveau y entonces he reiniciado con el siguiente comando:

sudo /sbin/reboot

pensado que tendría el mismo efecto que un "sudo reboot" y al arrancar ha cargado opensuse sin problemas.

Creo que el problema estaba que para instalar el driver nvidia tienes que deshabilitar el entorno gráfico mediante el comando "sudo /sbin/init 3" lo hice e instalé el driver nvidia de forma correcta pero no ejecuté al final el "sudo /sbin/reboot" que restablecería el entorno gráfico, de ahí que al arrancar de nuevo siempre cargaba sin el entorno gráfico.

Podéis confirmarme si el error que me daba se ha podido deber a esto que he comentado, es para aprenderlo y dejar este post como resuelto en el foro.

Podéis poner algún enlace o comentario sobre la utilidad de "init x", a que hace referencia ?? para que se suele utilizar??

Yo lo he utilizado por que es uno de los pasos indicados por la guía de instalación del driver de nvidia (dejo el enlace por si es de utilidad para algún compañero del foro)
https://es.opensuse.org/SDB:C%C3%B3m...fico_de_NVIDIA

Un saludo y gracias de nuevo
Responder Citando
  #4  
Antiguo 10-dic-2016, 16:37
Avatar de Krovikan
Krovikan Krovikan está desconectado
Miembro Junior
 
Fecha de Ingreso: 16-noviembre-2010
Ubicación: Delante del ordenador
Versión: Leap 42.3
Mensajes: 491
Agradecimientos: 179
Agradecido 111 Veces en 95 Mensajes
Poder de Credibilidad: 8
Krovikan está en el buen camino
Tu error fue ese.

El driver de Nvidia siempre hay que reinstalarlo tras una actualización de kernel o Xorg.

Para ello hay que ir a una consola (Ctrl+Alt+F1), ingresar como root y:

Código:
init 3
(este número inicia el sistema con acceso a la red pero sin sistema grafico)

Instalar el driver de Nvidia:

Código:
sh NVIDIA-Linux-x_86_64-375.20.run -q
(en mi caso)

Una vez hecho teclear:

Código:
init 5
(este número inicia el sistema con acceso a la red y con sistema gráfico)

Y ya lo tienes todo listo.

init 6 es para hacer un reboot
init 0 es para apagar el ordenador
init 1 es modo administrador sin acceso a red ni a sistema gráfico
init 2 y 4 no se suelen usar salvo por pruebas que pueda hacer un usuario avanzado en estas lides.


Saludos
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Krovikan Por Este Mensaje:
Eduardorl (10-dic-2016)
  #5  
Antiguo 10-dic-2016, 18:40
Eduardorl Eduardorl está desconectado
Aforado
 
Fecha de Ingreso: 25-diciembre-2015
Versión: 42.1
Mensajes: 23
Agradecimientos: 21
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Eduardorl está en el buen camino
Muchas gracias por la respuesta Krovikan me ha sido de ayuda. Creo que después de tantos fallos una y otra vez ya he aprendido lo suficiente para que cada vez que haya una actualización del kernel no me entren los sudores fríos.



saludos
Responder Citando
Respuesta

Marcadores

Etiquetas
actualización kernel, driver nvidia, no detecta pantalla


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Gigabyte z77-ud5h y sonido ALC898 djdevil666bcn Hardware 10 17-feb-2016 12:35
Probando hardware X-99 y GTX-970 mikrios La cafetería 22 26-oct-2015 00:00
Problema tras actualizar el driver de NVIDIA Xnake Hardware 13 14-sep-2015 14:51
Instalacion driver nvidia Fisaulerod Hardware 4 22-dic-2008 03:49
Instalacion driver tarjeta gráfica Nvidia en modo fácil openSUSE 10.3 carlos-cv-907 Hardware 10 24-feb-2008 18:08



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 20:46.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba