Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Duda con zypper
  #1  
Antiguo 25-jun-2015, 16:17
Avatar de maniat1k
maniat1k maniat1k está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-abril-2011
Ubicación: Mdeo, Uy
Versión: Leap
Mensajes: 1.228
Agradecimientos: 170
Agradecido 253 Veces en 189 Mensajes
Poder de Credibilidad: 8
maniat1k está en el buen camino
Duda con zypper

Bueno quizás sea una tonteria pero no encontré como con zypper bajar de versión un paquete... http://www.forosuse.org/forosuse/showthread.php?t=22739

Que es lo que quiero... bajar la versión de kernel a una versión previa pero solo con zypper.

Por lo menos que me liste las versiones que tengo entre los repos y después hacer el downgrade.


¿Me explico?
Responder Citando
  #2  
Antiguo 26-jun-2015, 00:42
Avatar de julioeep
julioeep julioeep está desconectado
Miembro Junior
 
Fecha de Ingreso: 19-diciembre-2008
Ubicación: Villavicencio, Colombia
Versión: openSUSE LEAP 42.2
Mensajes: 678
Agradecimientos: 76
Agradecido 122 Veces en 110 Mensajes
Poder de Credibilidad: 9
julioeep está en el buen camino
Hola:

Puedes ver acá y encontrarás opciones como esta:

Cita:
zypper in "paquete.arquitectura=versión"
Edición:

También puedes realizar instalaciones con los operadores "< y >"

Cita:
zypper in "paquete<versión"
Para realizar búsquedas mas avanzadas puedes utilizar las opciones "-s --match-exact"

Cita:
zypper se -s --match-exact "paquete"
Por ejemplo:

Cita:
sudo zypper se -s --match-exact amarok
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

E | Nombre | Tipo | Versión | Arquitectura | Repositorio
--+--------+-------------+-------------+--------------+------------
| Amarok | aplicación | | noarch | oss
| Amarok | aplicación | | noarch | factory
i | amarok | paquete | 2.8.0-27.12 | x86_64 | packman
v | amarok | paquete | 2.8.0-27.12 | i586 | packman
v | amarok | paquete | 2.8.0-14.1 | x86_64 | oss
v | amarok | paquete | 2.8.0-14.1 | i586 | oss
v | amarok | paquete | 2.8.0-14.1 | x86_64 | factory
v | amarok | paquete | 2.8.0-14.1 | i586 | factory
| amarok | paquete src | 2.8.0-27.12 | noarch | packman

Última edición por julioeep; 26-jun-2015 a las 00:51
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a julioeep Por Este Mensaje:
maniat1k (26-jun-2015)
  #3  
Antiguo 26-jun-2015, 08:41
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.473
Agradecimientos: 563
Agradecido 2.415 Veces en 1.626 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
¿Por que no pruebas el maravilloso Yast?. Buscas el paquete, lo seleccionas y abajo tienes la pestaña Versiones para escoger.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #4  
Antiguo 26-jun-2015, 12:28
Avatar de maniat1k
maniat1k maniat1k está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-abril-2011
Ubicación: Mdeo, Uy
Versión: Leap
Mensajes: 1.228
Agradecimientos: 170
Agradecido 253 Veces en 189 Mensajes
Poder de Credibilidad: 8
maniat1k está en el buen camino
Cita:
Iniciado por DiabloRojo Ver Mensaje
¿Por que no pruebas el maravilloso Yast?. Buscas el paquete, lo seleccionas y abajo tienes la pestaña Versiones para escoger.
Si no eso si claro es el método Opensuse y ya sabemos que YaST es tu amigo fiel. jeje

Solo me entró la curiosidad de como hacerlo.

De todas formas aparte de la mano de julioeep (gracias de nuevo) en la rápida ayer a los minutos de postear esto me dio una mano jcsl en el chat de opensuse
Con eso digo tambien, densde una vuelta por el chat que esta muy bueno, estamos unos cuantos por ahí.

Saludos!
Responder Citando
  #5  
Antiguo 26-jun-2015, 13:51
Avatar de victorhck
victorhck victorhck está desconectado
Moderador
 
Fecha de Ingreso: 08-abril-2010
Ubicación: /HOME
Versión: Tumbleweed y Leap + KDE
Mensajes: 3.559
Agradecimientos: 307
Agradecido 1.127 Veces en 734 Mensajes
Poder de Credibilidad: 11
victorhck está en el buen camino
Cita:
Iniciado por maniat1k Ver Mensaje
De todas formas aparte de la mano de julioeep (gracias de nuevo) en la rápida ayer a los minutos de postear esto me dio una mano jcsl en el chat de opensuse
Con eso digo tambien, densde una vuelta por el chat que esta muy bueno, estamos unos cuantos por ahí.

Saludos!
Y ya de paso, podías poner por aqui la solución que te dió jcsl! Así sirve para otros!!
__________________


Guía básica de openSUSE Leap para recién llegados a GNU/Linux.
→ Mi blog sobre openSUSE, GNU/Linux, software libre ...y de todo un poco: Victorhck in the free world
→ Me puedes seguir en: Quitter - Diaspora*
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a victorhck Por Este Mensaje:
maniat1k (26-jun-2015)
  #6  
Antiguo 26-jun-2015, 21:29
Avatar de maniat1k
maniat1k maniat1k está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-abril-2011
Ubicación: Mdeo, Uy
Versión: Leap
Mensajes: 1.228
Agradecimientos: 170
Agradecido 253 Veces en 189 Mensajes
Poder de Credibilidad: 8
maniat1k está en el buen camino
Cita:
Iniciado por victorhck Ver Mensaje
Y ya de paso, podías poner por aqui la solución que te dió jcsl! Así sirve para otros!!
ah claro! jajajja mala mia:


Cita:
12:47:58 - jcsl: !tell maniat1k 1⁰ zypper se -s -t package kernel-variante; 2⁰ Mirar la versión que te interese en la columna "Versión"; 3⁰ zypper in --oldpackage kernel-versión → reiniciar
que pasado en limpio es asi:

Código:
fila:~ # uname -r
3.16.7-21-default
fila:~ # zypper se -s -t  package kernel-default
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...

E | Nombre               | Tipo     | Versión     | Arquitectura | Repositorio         
--+----------------------+----------+-------------+--------------+---------------------
i | kernel-default       | paquete  | 3.16.7-21.1 | x86_64       | openSUSE-13.2-Update
i | kernel-default       | paquete  | 3.16.7-7.1  | x86_64       | openSUSE-13.2-Update
v | kernel-default       | paquete  | 3.16.6-2.1  | x86_64       | openSUSE-13.2-Oss   
v | kernel-default       | paquete  | 3.16.7-21.1 | i586         | openSUSE-13.2-Update
v | kernel-default       | paquete  | 3.16.7-7.1  | i586         | openSUSE-13.2-Update
v | kernel-default       | paquete  | 3.16.6-2.1  | i586         | openSUSE-13.2-Oss   
  | kernel-default-base  | paquete  | 3.16.7-21.1 | x86_64       | openSUSE-13.2-Update
  | kernel-default-base  | paquete  | 3.16.7-7.1  | x86_64       | openSUSE-13.2-Update
  | kernel-default-base  | paquete  | 3.16.6-2.1  | x86_64       | openSUSE-13.2-Oss   
  | kernel-default-base  | paquete  | 3.16.7-21.1 | i586         | openSUSE-13.2-Update
  | kernel-default-base  | paquete  | 3.16.7-7.1  | i586         | openSUSE-13.2-Update
  | kernel-default-base  | paquete  | 3.16.6-2.1  | i586         | openSUSE-13.2-Oss   
  | kernel-default-devel | paquete  | 3.16.7-21.1 | x86_64       | openSUSE-13.2-Update
  | kernel-default-devel | paquete  | 3.16.7-7.1  | x86_64       | openSUSE-13.2-Update
  | kernel-default-devel | paquete  | 3.16.6-2.1  | x86_64       | openSUSE-13.2-Oss   
  | kernel-default-devel | paquete  | 3.16.7-21.1 | i586         | openSUSE-13.2-Update
  | kernel-default-devel | paquete  | 3.16.7-7.1  | i586         | openSUSE-13.2-Update
  | kernel-default-devel | paquete  | 3.16.6-2.1  | i586         | openSUSE-13.2-Oss   
fila:~ # zypper in --oldpackage kernel-desktop-3.16.6-2.1
Obteniendo los datos del repositorio...
Leyendo los paquetes instalados...
Resolviendo dependencias...

Los siguientes 3 paquetes NUEVOS van a ser instalados:
  kernel-desktop spl-kmp-desktop zfs-kmp-desktop 

3 nuevos paquetes a instalar.
Tamaño total de descarga: 48,1 MiB. Ya descargado: 0 B  Después de la operación, se utilizarán 255,3 MiB adicionales.
¿Desea continuar? [s/n/? mostrar todas las opciones] (s): s
Responder Citando
  #7  
Antiguo 27-jun-2015, 01:22
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.530
Agradecimientos: 1.911
Agradecido 1.402 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Es la opción de búsqueda de zypper (zypper search -s (source) y kernel-dsktop*) ; pero va a buscar lo que hay en ese momento de los repositorios que se tenga añadidos del kernel .

Pero no creo que sirva de mucho, ya que si vas a los servidores ftp (o sea los que están de los repositorios), no suelen guardar los antiguos, solo se mantienen los actuales ) .

De todas formas, no hay mas que mirar en : http://download.opensuse.org/repositories/Kernel:/ , para verlos.

Otra cosa sería que alguien hubiese bajado el seguimiento de los kernel que han ido pasando por los repositorios .

Creo que debo tener una copia de los repositorios, pero no recuerdo la fecha y si es que se llego a completar el mirror que hice en su momento del servidor .
( lo que si hay es el que he descargado de todas las isos de tumbleweed, creo que desde el 2014 hasta la fecha actual del 2015 ) .

Por chuletas de zypper buena está la de la wiki, y la última que se hizo es muy buena .
Bueno aquí va otra :

http://www.muylinux.com/2011/09/12/chuletas-para-zypper

Una pregunta cuando se hace un zypper se -s loque sea (suele aparecer la i que es lo que está instalado, pero también aparece otras sin ella y otras con una " v " , que significa eso? .

Haber si con elgún ejemplo muestro lo que quiero decir :
Cita:
X79-PRO:~ # zypper se -s kernel-desktop*
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+-------------------------------+------------+--------------------+--------+------------------------
i | kernel-desktop | package | 4.0.2-1.1.ga425d38 | x86_64 | (System Packages)
i | kernel-desktop | package | 4.0.1-1.1.ge3a374a | x86_64 | (System Packages)
i | kernel-desktop | package | 4.0.0-4.1.g27299c0 | x86_64 | (System Packages)
v | kernel-desktop | package | 4.1.0-2.1.ga2813fe | x86_64 | Kernel:/stable/standard
v | kernel-desktop | package | 4.1.0-2.1.ga2813fe | i686 | Kernel:/stable/standard
v | kernel-desktop | package | 4.0.5-1.1 | x86_64 | repo-oss
v | kernel-desktop | package | 4.0.5-1.1 | i686 | repo-oss
| kernel-desktop-base | package | 4.1.0-2.1.ga2813fe | x86_64 | Kernel:/stable/standard
| kernel-desktop-base | package | 4.1.0-2.1.ga2813fe | i686 | Kernel:/stable/standard
| kernel-desktop-base | package | 4.0.5-1.1 | x86_64 | repo-oss
| kernel-desktop-base | package | 4.0.5-1.1 | i686 | repo-oss
| kernel-desktop-base-debuginfo | package | 4.1.0-2.1.ga2813fe | x86_64 | Kernel:/stable/standard
| kernel-desktop-base-debuginfo | package | 4.1.0-2.1.ga2813fe | i686 | Kernel:/stable/standard
| kernel-desktop-base-debuginfo | package | 4.0.5-1.1 | x86_64 | repo-debug
| kernel-desktop-base-debuginfo | package | 4.0.5-1.1 | x86_64 | tumbleweed/repo/debug/
| kernel-desktop-base-debuginfo | package | 4.0.5-1.1 | i686 | repo-debug
| kernel-desktop-base-debuginfo | package | 4.0.5-1.1 | i686 | tumbleweed/repo/debug/
| kernel-desktop-debuginfo | package | 4.1.0-2.1.ga2813fe | x86_64 | Kernel:/stable/standard
| kernel-desktop-debuginfo | package | 4.1.0-2.1.ga2813fe | i686 | Kernel:/stable/standard
| kernel-desktop-debuginfo | package | 4.0.5-1.1 | x86_64 | repo-debug
| kernel-desktop-debuginfo | package | 4.0.5-1.1 | x86_64 | tumbleweed/repo/debug/
| kernel-desktop-debuginfo | package | 4.0.5-1.1 | i686 | repo-debug
| kernel-desktop-debuginfo | package | 4.0.5-1.1 | i686 | tumbleweed/repo/debug/
| kernel-desktop-debugsource | package | 4.1.0-2.1.ga2813fe | x86_64 | Kernel:/stable/standard
| kernel-desktop-debugsource | package | 4.1.0-2.1.ga2813fe | i686 | Kernel:/stable/standard
| kernel-desktop-debugsource | package | 4.0.5-1.1 | x86_64 | repo-debug
| kernel-desktop-debugsource | package | 4.0.5-1.1 | x86_64 | tumbleweed/repo/debug/
| kernel-desktop-debugsource | package | 4.0.5-1.1 | i686 | repo-debug
| kernel-desktop-debugsource | package | 4.0.5-1.1 | i686 | tumbleweed/repo/debug/
i | kernel-desktop-devel | package | 4.0.2-1.1.ga425d38 | x86_64 | (System Packages)
i | kernel-desktop-devel | package | 4.0.1-1.1.ge3a374a | x86_64 | (System Packages)
i | kernel-desktop-devel | package | 4.0.0-4.1.g27299c0 | x86_64 | (System Packages)
v | kernel-desktop-devel | package | 4.1.0-2.1.ga2813fe | x86_64 | Kernel:/stable/standard
v | kernel-desktop-devel | package | 4.1.0-2.1.ga2813fe | i686 | Kernel:/stable/standard
v | kernel-desktop-devel | package | 4.0.5-1.1 | x86_64 | repo-oss
v | kernel-desktop-devel | package | 4.0.5-1.1 | i686 | repo-oss
| kernel-desktop | srcpackage | 4.1.0-2.1.ga2813fe | noarch | Kernel:/stable/standard
Y para los que están instalados con zypper se -si kernel-desktop :

Cita:
X79-PRO:~ # zypper se -si kernel-desktop*
Loading repository data...
Reading installed packages...

S | Name | Type | Version | Arch | Repository
--+----------------------+---------+--------------------+--------+------------------
i | kernel-desktop | package | 4.0.2-1.1.ga425d38 | x86_64 | (System Packages)
i | kernel-desktop | package | 4.0.1-1.1.ge3a374a | x86_64 | (System Packages)
i | kernel-desktop | package | 4.0.0-4.1.g27299c0 | x86_64 | (System Packages)
i | kernel-desktop-devel | package | 4.0.2-1.1.ga425d38 | x86_64 | (System Packages)
i | kernel-desktop-devel | package | 4.0.1-1.1.ge3a374a | x86_64 | (System Packages)
i | kernel-desktop-devel | package | 4.0.0-4.1.g27299c0 | x86_64 | (System Packages)
Saludos cordiales

Última edición por mikrios; 27-jun-2015 a las 01:23 Razón: corregir
Responder Citando
Respuesta

Marcadores

Etiquetas
comandos, downgrade, zypper


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Comandos y mantenimiento de OpenSUSE Tumbleweed joakoej General OpenSUSE 54 10-abr-2015 21:12
No funciona Banshee maniat1k Software 8 08-may-2013 16:45
Duda con zypper y la reintalación de paquetes jony127 General OpenSUSE 9 30-nov-2010 22:20
Manual zypper para 11.1 (Traducción al español) tranzorx FAQs, Manuales y Tutoriales 11 21-ene-2010 23:21
duda sobre Zypper danhorris Software 5 11-nov-2008 01:29



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 03:44.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba