Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

  #31  
Antiguo 29-mar-2015, 13:55
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.530
Agradecimientos: 1.911
Agradecido 1.402 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

Creo que había una recomendación de no mantener, los repositorios de lo que añades de las paginas de descargas.

Creo que si se trata de repositorios de openSUSE, si se puede hacer, mas bien el experto es el que ha puesto el tuto y otros compañeros que saben mas de eso.

Para mi opinión, si es una aplicación la instalo (siempre procuro que sea de la versión de openSUSE, si no la hay y me funciona otra versión la instalo, siempre que no me rompa dependencias y que afecte, al sistema o partes del sistema que tengo instalado) .

De elegir elijo siempre la oficial , las otras no las mantengo( en la lista de repositorios) ; ademas busco siempre la posibilidad de que sea del servidor de openSUSE : http://tube.opensuse.org/repositories/

Y busco ahí si esta : http://tube.opensuse.org/repositorie...SE_Tumbleweed/

También miro las fechas y año de ese repositorio, si veo que no se mantiene y es atrasado no lo añado, ten en cuenta que no hablamos de una aplicación si no de algo del escritorio (como no se mucho de gnome, ya que no es mi escritorio habitual, pues para cosas así me ando con cuidado ) . y la prioridad dejo mas alta los oficiales, excepto algunos que son packman, kernel estable impresión y algún otro (pero por lo demás prevalece los oficiales ) .

De todas formas quien mejor te puede indicar es quien use gnome.

Por lo de actualización esta bien , no se si lo de interactivos ,no entiendo muy bien a que se refiere, pero por lo menos los parches necesarios que sean instalados (porque habrá otros que tu sistema no los necesite por no usar una determinada aplicación ) .

Ponerlo a diario (a mi me salen actualizaciones casi todos los días , aunque puede pegarse días que no salgan ninguna ) .

Saludos cordiales y feliz domingo
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
joakoej (30-mar-2015)
  #32  
Antiguo 30-mar-2015, 19:07
joakoej joakoej está desconectado
Aforado
 
Fecha de Ingreso: 25-marzo-2015
Versión: Tumbleweed
Mensajes: 19
Agradecimientos: 17
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joakoej está en el buen camino
Ah bueno te voy a hacer caso entonces. A los repositorios extra de aplicaciones que agregué les voy a poner una prioridad de 120 por si en algún momento las aplicaciones se incluyen en los repositorios oficiales.
Tampoco, por lo que dice DiabloRojo, que al final no me aclaró la pregunta, pero le voy a tomar la palabra, voy a poner ningún repositorio que diga Factory en el nombre, así que el repositorio de Cinnamon lo voy a eliminar. Además, funciona muy mal el Cinnamon de ese repositorio.

Y tampoco voy a incluir ningún repositorio que esté indicado para otra versión que no sea Tumbleweed. Por ejemplo, de Cinnamon hay otros repositorios que se pueden agregar, los cuales cuentan con la ultima versión (2.4), pero, según está página: http://software.opensuse.org/package/cinnamon
sólo están disponibles para OpenSUSE 13.2 y no para Tumbleweed.
¿Qué opinás vos de esto? ¿Conviene o no conviene incluir alguno de los repositorios esos en Tumbleweed? Yo prefiero abstenerme por lo que me dijeron, pero, a la vez, veo que está ese repositorio con Factory en el nombre que está indicado como compatible con Tumbleweed y 13.2, así que me pone a dudar un poco.

Con respecto a los parches, todavía no se me disipa del todo la duda, de hecho no sé si voy a correr las actualizaciones por consola o si voy a poner las actualizaciones automáticas.

Saludos
Responder Citando
  #33  
Antiguo 31-mar-2015, 08:45
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.654
Agradecimientos: 73
Agradecido 402 Veces en 314 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Hola¡¡

1º) No dejar los repositorios comunitarios después de instalar el programa ( * )
2ª) No incluir ningún repositorio que no sea del mismo estilo " Tumbleweed " ( * )
3º) Da igual que actualices por zypper, yast2 o packagekit (zypper es mas potente o igual que yast2 y packagekit menos que los anteriores, pero hacen el trabajo igual, ya son gustos como hacerlo ), yo lo hago por packagekit, y 1 vez cada 2 semanas hago un zypper up para ver lo que dice ( siempre dice nada que hacer, todo bien ), y miro por yast2 los reposistorios en instalar/desistalar programas.

Te aseguro que no veo forma mas fácil de hacer las cosas como en openSUSE, tiene mucha menos ciencia que en otras distros.

PD: yast2 es tu amigo, es muy pero muy potente y tiene todo lo que puedas necesitar, todo lo dicho en este hilo se hace con yast2, gráficamente y el sistema se configura solo como tu le digas en la ventanita.

PD2: No te gusta ninguno de los 6 escritorios que trae la distribución para ponerle cinnamon?

*) Problemas de compatibilidad de paquetes, peligro de inestabilidad del sistema o mal funcionamiento.

Un saludo.
__________________
Subir fotos: http://subefotos.com/
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a LUKE10 Por Este Mensaje:
joakoej (07-abr-2015)
  #34  
Antiguo 31-mar-2015, 10:21
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.175
Agradecimientos: 40
Agradecido 1.238 Veces en 910 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

En general, la regla es: no añadas más repositorios que los oficiales más packman, uses la versión regular o Tumbleweed. Al menos, hasta que te sientas cómodo con el tema de los repositorios, los paquetes, las dependencias y demás.

Por ejemplo, no añadir un repositorio implica no tener actualizaciones del paquete que te ha llevado a instalarlo, tanto añadan estas más funcionalidad como sean revisiones por problemasd e seguridad. Así que la idea es no instalarlos cuando son muchos o cuando pueden afectar a varios paquetes requeridos por el sistema.

Uno podría preguntar por qué Cinnamon está para Factory y no para la versión regular. Uno quizá debería preguntarle a sus mantenedores, y tal vez sea muy buena idea hacerlo. De hecho, incluso ponerles un bug.

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a karlggest Por Este Mensaje:
joakoej (07-abr-2015)
  #35  
Antiguo 31-mar-2015, 17:04
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.530
Agradecimientos: 1.911
Agradecido 1.402 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola:

El segundo enlace que puse, es para Cinnamon de tumbleweed (pero pone también factory) , hasta mayo están conviviendo factory y tumbleweed, a partir de ahí , eso va a cambiar (lo normal es ir pasando todos aquellos que estaban en factory a su homologo en tumbleweed) .

Si te fijas en las fechas de ese repositorio, veras que son actuales ( 30 de marzo del 2015) .

Cita:
El cuatro de noviembre de 2014, las versiones Factory rolling y Tumbleweed rolling de openSUSE se fusionaron en una sola llamada openSUSE Tumbleweed rolling.

Cualquiera que estuviera usando openSUSE Factory y openSUSE Tumbleweed antes del cuatro de mayo de 2015 debe seguir las instrucciones de esta página. Los usuarios de Tumbleweed deben hacerlo inmediatamente para seguir recibiendo actualizaciones. Los usuarios de Factory tienen hasta el cuatro de mayo de 2015 para hacerlo.
Lo puedes ver en la wiki de openSUSE : https://es.opensuse.org/SDB:Migraci%...leweed_rolling

Creo que a partir de esas fechas en adelante estén mejor definidos los repositorios, pero por ahora lo que te han comentado los compañeros es como un regla (de oro) a seguir, sobre todo para evitar problemas.

Saludos cordiales
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
joakoej (07-abr-2015)
  #36  
Antiguo 07-abr-2015, 08:12
joakoej joakoej está desconectado
Aforado
 
Fecha de Ingreso: 25-marzo-2015
Versión: Tumbleweed
Mensajes: 19
Agradecimientos: 17
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joakoej está en el buen camino
Ok, entonces voy a actualizar con zypper up y ya, tal vez mande de vez en cuano un zypper patch para ver si tira algo, aunque por lo que veo siempre dice "Nada que hacer". Las herramientas gráficas también parecen funcionar bien y te advierten si tenés parches disponibles al parecer, pero planeo desactivarlas para ahorrar recursos.

Con respecto a los repositorios extra, por ahora no voy a instalar ninguno, porque parece que es cierto lo que dice mikrios, todavía no terminaron de pasarlos de Factory a Tumbleweed.
De todas maneras, algo que no entiendo es que determina que un repositorio o paquete sea compatible con Tumbleweed o no. Es decir, yo vi paquetes que estaban disponibles tanto para OpenSUSE 13.2 y para Tumbleweed, pero otros paquetes, que ofrecían el mismo programa, por ahí sólo estaban disponibles para OpenSUSE 13.2.
¿Alguno sabe por qué pasa esto?

Saludos
Responder Citando
  #37  
Antiguo 07-abr-2015, 10:06
Avatar de karlggest
karlggest karlggest está desconectado
Moderador
 
Fecha de Ingreso: 07-febrero-2007
Ubicación: Ourense
Versión: Leap 42.3
Mensajes: 8.175
Agradecimientos: 40
Agradecido 1.238 Veces en 910 Mensajes
Poder de Credibilidad: 19
karlggest está en el buen camino
Hola.

Lo que esté en un repositorio para Tumbleweed es lo que es compatible con Tumbleweed; lo que esté en un repositorio 13.2 es lo que es compatible con la versión 13.2. Eso es que alguien se haya molestado en compilarlo y probarlo.

Salud!!
__________________
http://sementedotempo.blogspot.com/

-Si lo creen unos pocos, es un delirio; si son muchos los creyentes, es una religión
Responder Citando
  #38  
Antiguo 07-abr-2015, 13:20
jcsl jcsl está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 18-mayo-2008
Versión: Tumbleweed
Mensajes: 2.104
Agradecimientos: 0
Agradecido 973 Veces en 587 Mensajes
Poder de Credibilidad: 12
jcsl llegará a ser famoso muy pronto
Hola.

Cita:
Iniciado por joakoej Ver Mensaje
Ok, entonces voy a actualizar con zypper up y ya, tal vez mande de vez en cuano un zypper patch para ver si tira algo, aunque por lo que veo siempre dice "Nada que hacer". Las herramientas gráficas también parecen funcionar bien y te advierten si tenés parches disponibles al parecer, pero planeo desactivarlas para ahorrar recursos.

Con respecto a los repositorios extra, por ahora no voy a instalar ninguno, porque parece que es cierto lo que dice mikrios, todavía no terminaron de pasarlos de Factory a Tumbleweed.
De todas maneras, algo que no entiendo es que determina que un repositorio o paquete sea compatible con Tumbleweed o no. Es decir, yo vi paquetes que estaban disponibles tanto para OpenSUSE 13.2 y para Tumbleweed, pero otros paquetes, que ofrecían el mismo programa, por ahí sólo estaban disponibles para OpenSUSE 13.2.
¿Alguno sabe por qué pasa esto?

Saludos
  • Todos los programas necesitan una versión mínima de algún otro software (compilador, bibliotecas, programas externos, etc.) para poder compilarlos o para funcionar correctamente (muchos programas son simples interfaces gráficas de otros que son para la terminal).
  • Dicha versión puede depender a su vez de la versión del programa. Por ejemplo, la versión 5.1 del programa P necesita la versión 1.0 de la biblioteca B. Más tarde, el desarrollador del programa ve que ha aparecido la versión 3.0 de B que ofrece algo interesante que no incluia la versión 1.0, así que decide adaptar su programa para usar la nueva funcionalidad de B y lanza la versión 6.0. A partir de ese momento, P ya depende como mínimo de la versión 3.0 de B y no puede compilarse ni funcionar con versiones anteriores porque no incluyen la funcionalidad necesaria. Sin embargo, si el cambio en B hubiera sido menor ─una corrección de errores, por ejemplo─ y se hubiera lanzado la versión 1.1, por decir algo, el programa podría haber seguido funcionando tranquilamente. De forma un poco más precisa, un programa que usa una biblioteca espera que esta ofrezca una serie de elementos que forman lo que se llama la interfaz (básicamente una lista de nombres de constantes, funciones con sus parámetros, etc.) y que utiliza para comunicarse con ella y así poder hacer su tarea. Si la bibliteca cambia alguno de dichos elementos hay que actualizar todos los programas que la usen para que puedan seguir funcionando. Pasa lo si usa un programa externo y este cambia alguno de sus parámetros.
  • Cuando aparece una nueva publicación de openSUSE, el software incluido viene en unas versiones dadas que no se modifican durante su ciclo de vida, excepto para actualizaciones de seguridad o correcciones de fallos. No siempre es así, Firefox se actualiza cada vez que aparece una versión nueva, pero en la inmensa mayoría de casos funciona de esta forma.
  • En Tumbleweed, al ser una versión de desarrollo continuo, no es así. La versión de cualquier software puede cambiar en cada nueva actualización, pero siempre hay que procurar que eso no cause destrozos. No siempre es posible, por lo que, en ocasiones, un programa dado deja de funcionar porque haya habido un cambio en alguna de sus dependencias. En este caso el desarrollador del programa debe actualizarlo para que funcione con la nueva versión de la dependencia que produce el fallo.
  • Al crear un paquete se indican las dependencias y también se puede decir algo como "si la versión de openSUSE es la 13.1 usa la versión X de la biblioteca B, y si es la 13.2 usa la versión Y".

En resumen:
  • para la versión estable de openSUSE cada paquete es compatible con ella en la versión que se incluye. Otras versiones más recientes pueden funcionar, pero como no suelen actualizarse, salvo para correcciones, no importa mucho. Una excepción a la regla de los cambios de versión son los repositorios no oficiales. Estos suelen ofrecer versiones más recientes de programas, siempre y cuando puedan funcionar con lo que haya disponible en la versión estable o lo tengan incluido en el mismo repositorio y no provoquen fallos en el resto del sistema. Si el empaquetador lo hace mal es cuando aparecen los problemas por mezclar repositorios.
  • para Tumbleweed un paquete es compatible si se puede crear con la versión de sus dependencias en cada momento. Por ejemplo, en mi netbook utilizo Tilda, una terminal desplegable, que usa una biblioteca de GNOME llamada vte. La última versión de Tilda disponible en Tumbleweed es la 0.9.6, que depende de GTK2. Las versiones posteriores de Tilda necesitan GTK3, que incluye una versión de vte para la que no está preparado el programa (funcionaba al principio y pude crear el paquete con versiones hasta la 1.2.2, pero luego se actualizó vte y dejó de hacerlo). Así que, mientras el desarrollador no actualice Tilda para que funcione con la nueva versión de vte presente en GTK3 (esta en ello) no se puede actualizar (¡y la versión 0.9.6 es de 2008!).
Sobre lo de hacer zypper patch, no es necesario. Hasta donde yo sé, al hacer un zypper up se instalan también los parches. Fíjate en la ayuda (zypper up --help) y verás que si quieres puedes indicar lo que quieres actualizar (paquetes, parches, etc.). De lo que deduzco que, a menos que indiques lo contrario, se actualiza todo lo disponible, parches incluidos. Tampoco suele ser necesario hacer zypper ref antes de alguna otra operación como zypper up. En el fichero de configuración /etc/zypp/zypp.conf se incluye el intervalo de tiempo tras el cual zypper refresca los repositorios al hacer alguna operación (repo.refresh.delay). Eso no quiere decir que se actualice cada dicho intervalo todo el tiempo sino solo cuando se hace algo con zypper. Por defecto son 10 minutos, así que si ha pasado más tiempo el ref está implícito.

Un saludo.

Última edición por jcsl; 07-abr-2015 a las 13:24
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a jcsl Por Este Mensaje:
joakoej (07-abr-2015)
  #39  
Antiguo 07-abr-2015, 19:06
joakoej joakoej está desconectado
Aforado
 
Fecha de Ingreso: 25-marzo-2015
Versión: Tumbleweed
Mensajes: 19
Agradecimientos: 17
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
joakoej está en el buen camino
Tremenda respuesta, gracias. Me quedo bastante claro ahora. ¿Entonces un mismo repositorio puede tener dos versiones distintas para el mismo programa? ¿dependiendo si estoy en Tumbleweed o 13.2 me instala una versión o la otra?
Responder Citando
  #40  
Antiguo 07-abr-2015, 21:40
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.654
Agradecimientos: 73
Agradecido 402 Veces en 314 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Hola¡¡

Puede, pero no es eso lo que quiso decir " creo ", si no que cada repositorio ya te indica para que versión de S.O. esta compilado, si es factory, versión normal, o Tumbleweed, cada una esta compilada para cada sistema y sus librerías actuales.

Es decir si el repositorio es Tumbleweed no lo pongas en la versión normal o factory. (para algo lo pone explicito).

Un saludo.
__________________
Subir fotos: http://subefotos.com/
Responder Citando
Respuesta

Marcadores

Etiquetas
seguro, tumbleweed, upgrade, zypper dup, zypper up


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Yast abre pero no funciona enae General OpenSUSE 15 23-feb-2015 15:59
Instalar osx, windows 7 y opensuse 11.4 en un imac... y no morir en el intento oscarpoio FAQs, Manuales y Tutoriales 6 04-abr-2013 23:37
Mantenimiento en los servidores de openSUSE victorhck General OpenSUSE 4 02-dic-2012 18:58
¿porque ubuntu es mas popular q suse? goundzchecky El Contubernio 161 16-ago-2012 15:01
Propuesta de traduccion para el foro DiabloRojo El Contubernio 74 01-nov-2011 09:57



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 05:05.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba