Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > Software


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

YaST reinstala automáticamente paquetes desinstalados
  #1  
Antiguo 13-nov-2014, 09:54
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Thumbs down YaST reinstala automáticamente paquetes desinstalados

No es un problema nuevo ni mucho menos, pues llevo experimentando este comportamiento desde al menos la versión 11.4 de OpenSUSE, con la diferencia de que hasta ahora solamente me ocurría con Apper (y antes con KPackageKit), y desde que he instalado la versión 13.2 me lo hace el mismo YaST. El problema básicamente es que al desinstalar cualquier paquete de la instalación por defecto de OpenSUSE 13.2, en la siguiente instalación/actualización de paquetes que haga desde YaST, éste selecciona automáticamente los paquetes anteriormente eliminados para volverlos a instalar, obligándome a marcarlos uno por uno para que no se instalen nunca (la marca Tabú).

¿Alguien más está experimentando el mismo problema? porque resulta bastante molesto tener que andar constantemente vigilando que no se autoinstalen nuevamente paquetes que eliminé en su día, y lo peor es que es un problema que ya estaba presente en todas las versiones anteriores de la distribución y sigue sin resolverse. ¿A alguien se le ocurre alguna solución, que a ser posible no pase por cambiar de distro?

Actualización
Pido el favor de que al menos alguien me diga si le ocurre lo mismo, que desinstalando algún paquete, luego al intentar instalar otros, le vuelva a reinstalar los anteriormente desinstalados.

Última edición por VaryHeavy; 13-nov-2014 a las 12:40
Responder Citando
No sé si es a lo que te refieres
  #2  
Antiguo 13-nov-2014, 13:51
Avatar de Mazinger-Z
Mazinger-Z Mazinger-Z está desconectado
Habitual
 
Fecha de Ingreso: 06-agosto-2013
Ubicación: España
Versión: Tumbleweed
Mensajes: 224
Agradecimientos: 18
Agradecido 108 Veces en 75 Mensajes
Poder de Credibilidad: 5
Mazinger-Z está en el buen camino
No sé si es a lo que te refieres

Yo he instalado recientemente (la actualización desde la 13.1 falló) la 13.2 y en el proceso de instalación, le dije que NO instalara LibreOffice (ningún paquete ofimático, ya que es un HTPC lo que monto) ni Digikam, por ejemplo.
Pues bien, como tú dices, tras actualizar (o hacer un zypper up, que no recuerdo ahora) el solito, me los instala.

Yo supongo que es porque el patrón de instalación (pattern_desktop en mi caso) los tiene marcados para instalar, y alguna forma habrá de decirle que no siga el patrón. No lo sé.
Responder Citando
  #3  
Antiguo 13-nov-2014, 14:14
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Sí, efectivamente a ese comportamiento me refería, luego parece ser que no es un hecho aislado, y que a cualquiera que desinstale algún paquete, si como tú dices, está dentro de los patrones, YaST volverá a intentar instalárselos en cuanto tenga ocasión. Quizás una posible solución sea quitar los paquetes "patrón"... haré la prueba, intentaré desinstalar alguno, a ver si no me desmonta el sistema cuando lo haga.
Responder Citando
  #4  
Antiguo 13-nov-2014, 17:07
Avatar de Invisuu
Invisuu Invisuu está desconectado
Aforado
 
Fecha de Ingreso: 05-octubre-2012
Ubicación: Carmen, CAMP, Mexico
Versión: 42.3 GNOME
Mensajes: 76
Agradecimientos: 45
Agradecido 29 Veces en 22 Mensajes
Poder de Credibilidad: 6
Invisuu está en el buen camino
Que tal amigos.

Probaron a seleccionar la opción de "ignorar paquetes recomendados para paquetes ya instalados" dentro del menu opciones de YAST?

A mi eso me ha funcionado.
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Invisuu Por Este Mensaje:
VaryHeavy (13-nov-2014)
  #5  
Antiguo 13-nov-2014, 17:17
Avatar de VaryHeavy
VaryHeavy VaryHeavy está desconectado
Habitual
 
Fecha de Ingreso: 20-marzo-2011
Ubicación: Sevilla, España
Versión: La última estable
Mensajes: 235
Agradecimientos: 15
Agradecido 6 Veces en 6 Mensajes
Poder de Credibilidad: 7
VaryHeavy está en el buen camino
Enviar un mensaje por Skype™ a VaryHeavy
Parece ser que la cosa está relacionada con los paquetes "patrón", al menos en su mayoría, pues he desinstalado todos los paquetes "patterns" y ya no intenta la instalación de los paquetes desinstalados, excepto KMail, en cuyo caso sigue intentando instalarlo y me veo en la obligación de bloquearlo.

Al activar la opción que cita Invisuu, deja de intentar instalar KMail, por lo que entiendo que hemos dado con la solución. Lo malo es que esta opción debería venir activada por defecto, porque cualquiera que no esté conforme con la selección de aplicaciones por defecto se verá con la molestia de que no puede eliminar nada de la instalación original.

Última edición por VaryHeavy; 13-nov-2014 a las 17:21
Responder Citando
  #6  
Antiguo 14-nov-2014, 08:00
Avatar de Invisuu
Invisuu Invisuu está desconectado
Aforado
 
Fecha de Ingreso: 05-octubre-2012
Ubicación: Carmen, CAMP, Mexico
Versión: 42.3 GNOME
Mensajes: 76
Agradecimientos: 45
Agradecido 29 Veces en 22 Mensajes
Poder de Credibilidad: 6
Invisuu está en el buen camino
Cita:
Iniciado por VaryHeavy Ver Mensaje
Parece ser que la cosa está relacionada con los paquetes "patrón", al menos en su mayoría, pues he desinstalado todos los paquetes "patterns" y ya no intenta la instalación de los paquetes desinstalados, excepto KMail, en cuyo caso sigue intentando instalarlo y me veo en la obligación de bloquearlo.

Al activar la opción que cita Invisuu, deja de intentar instalar KMail, por lo que entiendo que hemos dado con la solución. Lo malo es que esta opción debería venir activada por defecto, porque cualquiera que no esté conforme con la selección de aplicaciones por defecto se verá con la molestia de que no puede eliminar nada de la instalación original.
Coincido contigo VaryHeavy, en cuanto a que es molesto que el sistema esté solicitando permanentemente la reinstalación de paquetes, y que llega a parecer hasta imposible "limpiar" el sistema debido a ésta opcion, pero no creo que la activación por defecto sea la mejor manera, ya que se pueden perder algunos paquetes importantes que el sistema ofrece recién instalado o después de instalar alguna aplicación.

A éste respecto me explico un poco más:

Si instalas oS en limpio, abres YAST, desactivas esa opción, lo cierras y lo vuelves a abrir, ya no se te ofrece la instalación de los paquetes de idiomas faltantes, de flash o del codec para los mp3. Lo mismo sucede si esta seleccionada esa opción de ignorar e instalas un programa; al volver a abrir yast, no te ofrecerá la opción de instalar el paquete de idioma, por ejemplo.

Así que aunque me da gusto haber podido ayudarte con el problema, creo que vale la pena dejar este aviso para evitar confusiones

Saludos!
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Invisuu Por Este Mensaje:
VaryHeavy (14-nov-2014)
  #7  
Antiguo 15-nov-2014, 16:45
Avatar de bxo
bxo bxo está desconectado
Aforado
 
Fecha de Ingreso: 01-junio-2013
Ubicación: Galicia
Versión: 13.1
Mensajes: 71
Agradecimientos: 23
Agradecido 20 Veces en 15 Mensajes
Poder de Credibilidad: 5
bxo está en el buen camino
Me ocurrio lo mismo, en mi caso al desinstalar pulse audio
Responder Citando
  #8  
Antiguo 13-ene-2015, 08:37
Avatar de jesusx
jesusx jesusx está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 06-enero-2008
Ubicación: Castellón
Versión: Tumbleweed+Kde
Mensajes: 3.383
Agradecimientos: 327
Agradecido 486 Veces en 402 Mensajes
Poder de Credibilidad: 13
jesusx está en el buen camino
Y a mi también me pasa, lo que hago es marcarlo como tabu... Salu2

Enviado desde mi u9501
__________________

Si tienes el vibrato de BB King, el tapping de Van Halen, la velocidad de Malmsteen y la guitarra de Vai... enhorabuena eres un gran imitador.
Responder Citando
Respuesta

Marcadores

Etiquetas
apper, instalacion de software, paquetes, yast


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
¿Por qué Apper reinstala paquetes que estaban desinstalados? VaryHeavy Software 1 30-may-2012 15:41
Una forma alternativa de instalar codecs multimedia zchronos FAQs, Manuales y Tutoriales 14 05-mar-2011 17:44
Opinion de OpenSuse 11.1 mukenio Encuestas 48 22-oct-2009 13:59
Multiples cuestiones sobre opensuse por un usuario de ubuntu dudoso100 General OpenSUSE 18 27-ene-2009 22:16
error en yast cuando intento cualquier cosa con paquetes... estoy perdido HashSolo General OpenSUSE 2 13-ene-2007 15:17



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 13:48.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba