Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona Software > General OpenSUSE


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

OpenSuse 13.2 y drivers de Nvidia
  #1  
Antiguo 13-nov-2014, 01:39
Avatar de Warrior
Warrior Warrior está desconectado
Aforado
 
Fecha de Ingreso: 22-septiembre-2013
Ubicación: internet
Versión: 13.2
Mensajes: 12
Agradecimientos: 3
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Warrior está en el buen camino
Smile OpenSuse 13.2 y drivers de Nvidia

Hola, quería compartir el problema que he tenido con la nueva versión de OpenSuse 13.2

Llevo varios años usando este sistema y nunca antes había tenido problema con la gráfica (uso nvidia), o por lo menos no como esta vez. La cuestión es que cuando instalé la versión 13.2, que es la última, al arrancar el sistema no me podía mover por el entorno gráfico. Un problema bastante curioso, veía todo con cuadrados grandes, algún momento al pasar el ratón por le escritorio iba "dibujando" lo que había detrás de los cuadrados... (lógicamente el propio escritorio, programas...)

Solución:

El problema reside en que un usuario no muy avanzado igual le resulta un poco lioso de arreglar, ya que no se puede usar la interfaz gráfica.
  • Una vez iniciado suse y ya en el escritorio pulsamos CNTRL +ALT + F1 para lanzar modo terminal.

Para usar el terminal tenemos que poner nuestro nombre de usuario y contraseña, con el que entramos en el sistema.
  • Averiguamos que tarjeta gráfica tenemos:
# lspci | grep VGA
  • Añadimos el repositorio de nvidia (importante: hay que dejar el espacio en blanco al final de la ruta, nvidia no va pegado porque es el alias (nombre) que le damos al repositorio para identificarlo nosotros, podríamos poner otro nombre):
# sudo zypper ar -f ftp://download.nvidia.com/opensuse/13.2/ nvidia
  • Dependiendo de la tarjeta gráfica ejecutamos:

GeForce 8xxx and newer:
# zypper install x11-video-nvidiaG03
GeForce 6xxx and 7xxx:
# zypper install x11-video-nvidiaG02
GeForce FX 5xxx:
# zypper install x11-video-nvidiaG01
GeForce 4xx/4xxx or older:
# zypper install x11-video-nvidia
  • Para finalizar, reiniciamos:
# reboot

*Nota: si alguno quiere realizar todo el proceso como root, recuerden tener siempre cuidado y que antes hay que activarlo:

#sudo passwd root


Fuente: https://en.opensuse.org/SDB:NVIDIA_drivers
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Warrior Por Este Mensaje:
Kalifa (25-nov-2014)
  #2  
Antiguo 13-nov-2014, 07:16
Avatar de LUKE10
LUKE10 LUKE10 está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 27-septiembre-2006
Ubicación: Epaña (murcia)
Versión: Leap 42.2 - KDE
Mensajes: 1.654
Agradecimientos: 73
Agradecido 402 Veces en 314 Mensajes
Poder de Credibilidad: 13
LUKE10 está en el buen camino
Enviar un mensaje por MSN a LUKE10
Hola¡¡

No hace falta entrar en modo terminal, con yast2 puedes agregar el repo de nvidia tanto en terminal como en modo gráfico, ya que yast2 se ejecuta en terminal también escribiendo.
yast2

Nos vamos a repositorios de yast2 y hay eliges añadir repo, de la lista elegimos repositorios de la comunidad, y hay tienes en la lista el repo de nvidia para marcar al igual que el de packman entre otros..

Creía que te referías a instalar el controlador .run que si pide instalarlo en terminal.
sh nvidia-linux_version.run. -q

Un saludo.
__________________
Subir fotos: http://subefotos.com/
Responder Citando
  #3  
Antiguo 13-nov-2014, 07:27
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.530
Agradecimientos: 1.912
Agradecido 1.402 Veces en 1.175 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Si tiene el modo gráfico como un mosaico, todo a cuadros, tendría dificultad, para ejecutar Yast y el terminal o consola (por que no lo veria bien) .

Pero desde el tty1 (Ctrl+Alt+F1) , como root, puede ejecutar yast y realizar el proceso, es similar que hacerlo desde el terminal o consola (lo he comprobado y funciona) .

Saludos cordiales
Responder Citando
  #4  
Antiguo 16-nov-2014, 01:14
Avatar de Warrior
Warrior Warrior está desconectado
Aforado
 
Fecha de Ingreso: 22-septiembre-2013
Ubicación: internet
Versión: 13.2
Mensajes: 12
Agradecimientos: 3
Agradecido 1 Vez en 1 Mensaje
Poder de Credibilidad: 0
Warrior está en el buen camino
Cita:
Iniciado por mikrios Ver Mensaje
Si tiene el modo gráfico como un mosaico, todo a cuadros, tendría dificultad, para ejecutar Yast y el terminal o consola (por que no lo veria bien) .

Pero desde el tty1 (Ctrl+Alt+F1) , como root, puede ejecutar yast y realizar el proceso, es similar que hacerlo desde el terminal o consola (lo he comprobado y funciona) .

Saludos cordiales
Correcto! No sabía lo del Yast, lo probaré!
Responder Citando
  #5  
Antiguo 25-nov-2014, 05:44
Avatar de Kalifa
Kalifa Kalifa está desconectado
Aforado
 
Fecha de Ingreso: 03-julio-2012
Ubicación: Bogotá D. C. Colombia
Versión: 13.2
Mensajes: 25
Agradecimientos: 43
Agradecido 5 Veces en 3 Mensajes
Poder de Credibilidad: 0
Kalifa está en el buen camino
Yast. Definitivamente la mejor herramienta para nosotros los novatos. Simplemente agregue el repositorio y lo demás lo hizo Yast automáticamente. Gracias.
__________________
Genuine Intel(R) 8 Core i7-4700MQ @ 3.40GHz
Linux 4.1.12-1 (x86_64)
openSUSE 42.1
KDE 5.4.2
Responder Citando
Respuesta

Marcadores

Etiquetas
13.2 opensuse, nvidia


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Activado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
problema con pci. LUKE10 Software 6 20-feb-2014 00:58
opensuse 13.1 cuelgue con drivers nvidia elreycastor Hardware 10 10-feb-2014 20:49
COMO compiz AIGLX + NVIDIA 5200 en openSUSE 10.3 chiquimouse FAQs, Manuales y Tutoriales 2 07-jun-2008 18:42
Mi OpenSuse 10.2 no reconoce mi Broadcom 802.11 a/b/g inalambrico Dejo caracteriztiks Abv_mx81 Hardware 2 28-oct-2007 13:12
Tarjeta de video korn_head Hardware 5 03-may-2007 20:24



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 10:17.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba