Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Instalación y Actualizaciones


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Problema OpenSuse y Windows 8.1
  #1  
Antiguo 16-mar-2014, 22:25
roker470 roker470 está desconectado
Aforado
 
Fecha de Ingreso: 20-febrero-2014
Versión: 13.1
Mensajes: 5
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
roker470 está en el buen camino
Unhappy Problema OpenSuse y Windows 8.1

Muy buenas
El caso es que no puedo instalar OpenSuse 13.1 ni 12.3 en mi pc con Windows 8.1 ya que no me deja bootear nada. No arranca nada en live desde que instale 8.1 (antes podia sin problemas) y con ello no puedo acceder a ninguna herramienta de particionamiento o siquiera instalar opensuse.

He buscado por google por si habia se habia activado la opcion de secure boot que windows 8.1 pide que venga activado en los equipos que se venden a partir de ahora con el pero creo que mi placa no trae esa funcionalidad directamente o al menos no soy capaz de encontrarla por mas que rebusco por la bios. Mi placa es una Asus p8h67.

Espero que me podais ayudar, gracias
Responder Citando
  #2  
Antiguo 17-mar-2014, 01:09
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Hola roker470 :

Todas las placas que actualmente tengo son Asus (menos una que es Acer) .

Win 8 viene instalado en uefi y en modo seguro , cuando intentas instalar , te abortara todas las intalaciones .

Para instalar Opensuse tienes que hacerlo en modo uefi (para ello en el disco debes tener espacio para hacerlo ) .
El disco debe estar dentro de la lectora en el momento que inicies el pc , y antes de que este arranque debes pulsar la tecla F8 (que es el gestor de arranque uefi ) , desde ahí debes buscar Opensuse en modo uefi y ese el el que tienes que elegir para que te lo instale (debe ser un opensuse 64Bit) , si eliges en modo legacy la instalación es abortada .

En la bios de la placa Asus tienes dos opciones en la zona de arranque , una se llama CSM (que es el modulo de compatibilidad entre el sistema uefi y el sistema antiguo o OpRom (legacy bios rom) , en dispositivos de almacenamiento debe estar como primer dispositivo uefi y el segundo OpRom (en este caso puede aparecer ambos , pero 1º uefi y 2 º OpRom

En el modo de arranque del pc , cuando pulsas F8 durante el post debes elegir opensuse Uefi (o Opensuse modo seguro) .

Los dos sistemas pueden convivir ya que se instalan en distintos sitios y las claves son validad para ambos sistema (en el caso que no quieras que ambos sistemas tengan el modo seguro habilitado puedes hacerlo .desde el modulo de arranque seguro cambiando las opciones (pero debe ser en modo uefi ya que ambos sistemas utilizan el sistema de particionado gpt ) .

Intente leer información que se ha puesto en la wiki de este foro , que te informara al respeto , las instalaciones que se han echo , son muy fáciles de hacer , lo único que hay que tener en cuenta son unos pocos parámetros de la bios .

Te recomiendo leer la parte de secure boot de la wiki de Opensuse , al mismo la parte de Uefi .

Saludos

Instalación en modo seguro UEFI y mode UEFI en placas Asus , fallos 0% , instalaciones correctas al 100% y todas funcionando (p8z77m.px79pro,x87deluxe y la futura black edition que viene en camino ) todo ok revisa bien tus configuraciones de la bios con la info dejada en la wiki , si quieres date un salto por ese apartado del foro que hay explicaciones claras como hacerlo , mas la info que exista en faq y manuales y todo , incluso las foros que se han subido , contienen info .

Saludos
Imágenes Adjuntas
Tipo de Archivo: jpg csm2.jpg (23,3 KB (Kilobytes), 46 visitas)
Tipo de Archivo: jpg DSCN0437.jpg (18,8 KB (Kilobytes), 46 visitas)
Tipo de Archivo: jpg modo_seguro.jpg (15,5 KB (Kilobytes), 45 visitas)

Última edición por mikrios; 19-mar-2014 a las 03:56 Razón: corregir
Responder Citando
  #3  
Antiguo 17-mar-2014, 02:11
roker470 roker470 está desconectado
Aforado
 
Fecha de Ingreso: 20-febrero-2014
Versión: 13.1
Mensajes: 5
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
roker470 está en el buen camino
Nada
La instalacion la estaba llevando a cabo desde un usb y seguia igual, probe con un dvd que me dieron hace unos dias en las oficinas de OpenSuse (Que casualidad que me lo instale ahora eh jeje, estuve alli de visita) y booteo, hice todo el tema de la instalacion pero al final daba error con la instalacion del grub2-efi y sin eso cuando termino la instalacion como si no tuviera nada instalado. Intente instalarlo en el directorio raiz pero nada. Solo tengo la particion de Windows y la de OpenSuse

Sigo teniendo un buen lio con todo el tema uefi asi que adjunto una imagen de la configuracion de boot de la bios por si hay algo no correcto.

https://drive.google.com/file/d/0B9h...it?usp=sharing
Responder Citando
  #4  
Antiguo 17-mar-2014, 06:34
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Bueno la foto solo las pueden ver los que tengan cuenta en google . la añado aquí para que te fijes en ella.
Aunque tuve que bajarle la resolución , Se debe cambiar Legacy Rom , por UEFI Rom o el otro parámetro que tenga (en el caso que admita varios pues debe estar en primer lugar UEFI .
Ademas debajo veo un SATA UEFI .

No importa que dispositivo UEFI sea el que uses , si ese dispositivo es reconocido como UEFI , ya sea un pendrive USB o un DVD , si están con UEFI ,sirven como dispositivos de arranque o de instalación (mis instalaciones las hice desde un usb en modo uefi sin ningún problema ) . (ademas la placa Asus tiene una utilidad que pulsando la tecla F12 te graba la imágen de la captura de la pantalla en usb , no hace falta usar cámara de fotos ) .

UEFI , reconoce cualquier dispositivo uefi , como dispositivo de arranque , ya sea un pendrive , dvd, disco, win en modo uefi , Opensuse en modo uefi , todos son dispositivos de arranque , si pulsas F8 puedes arrrancar con cualquiera de ellos .

Si no te finalizo la instalación es por que no elegiste por segunda vez arrancar con Opensuse en modo UEFI ,para que terminara la instalación .

Una vez que este finalizada , vas a la bios y en la opción de arranque puedes cambiar el orden de arranque , poniendo OpenSUSE en primer lugar ,el arrancara con grun-efi (y en la pantalla debe aparecer OpenSUSE y debajo opciones de openSUSE ( arranque modo seguro ) y debajo de este aparecerá winndows 8 ) .

Ten en cuenta que cuando openSUSE re reinicia por que ha terminado la instalación , ira a arrancar el pc y este en su configuración debe tener como primer arranque win , deberás pulsar por segunda vez F8 y elegir que arranque OpenSUSE (ya ahí puedes quitar el dvd o pendrive ) , entonces arranca Opensuse que esta en el disco terminando la instalación automática que no termino al reiniciar ; a partir de ahí ya tienes los dos sistemas .

Después vas a la bios y eliges en dispositivos de arranque que carge primero Opensuse en modo seguro , en su pantalla (grub-efi) deben aparecer los 2 sistemas , un opensuse normal , otro en modo seguro y un win 8 ) .

Otra forma de arrancarlos es usando lo que se conoce como gestor de arranque UEFI que es la famosa tecla F8 durante el post de arranque del pc .

Como ves el sistema es muy sencillo , también puedes arrancar OpenSUSE y Win 8 en modo no seguro , pero usando UEFI , ya que esta usa tablas de particiones gpt , que entre sus ventajas permite tener 128 particiones primarias y la posibilidad de usar discos de mas de dos terabytes (ademas que es un sistema mucho mejor que la vieja legacy rom ) .

con lo del tema de 128 particiones primarias , te da la posibilidad de instalar una tira de distros de linux o windows (en este caso solo win8 y linux soportan el modo seguro , pero si no lo vas a usar puedes usar varios win de 64bit como vista ,win 7, opensuse 64bit,fedrora 64bit etc...) .

Estudia un poco eso y acude a la info que se puso en el foro , veras que es muy sencillo y podrás disfrutar de ambos sistemas sin ningún tipo tipo de problema .

Hay un pequeño impedimento en cuanto OpenSUSE en cuanto el sistema de hibernación , que espero que solucionaran , pero por lo pronto goza de las ventajas de los dos sistemas .

Te dejo un enlace por si se te escapa algo :

http://www.forosuse.org/forosuse/showthread.php?t=31127

Saludos cordiales

PD . ojo ten cuidado que cuando finaliza la instalación de OpenSUSE y reinicia , lo hace con lo que tiene configurado en la bios , o sea que te arranca win , y hace que OpenSUSE , no termine de escribir los cambios automáticos , solo lo hace una vez que arranques de nuevo cuando lo haces con la tecla F8 o invalidas el arranque y arrancas con OpenSUSE , una vez hecho eso se puede decir que ya termino la instalación .
Ya después decides el orden de arranque en la bios para que arranque primero OpenSUSE en primer lugar , deberán aparecer los 2 arranques .

Ya comentaras como te va , y si quieres haces un pequeño tuto o proceso de como te fue , para que sirva de ayuda a otros .

Edito :
PCI ROM Priority :UEFI mode
Saludos
Imágenes Adjuntas
Tipo de Archivo: png instantánea45.png (87,5 KB (Kilobytes), 42 visitas)

Última edición por mikrios; 19-mar-2014 a las 03:51 Razón: añadir-corregir
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a mikrios Por Este Mensaje:
fonfonete (19-mar-2014)
  #5  
Antiguo 19-mar-2014, 14:56
roker470 roker470 está desconectado
Aforado
 
Fecha de Ingreso: 20-febrero-2014
Versión: 13.1
Mensajes: 5
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
roker470 está en el buen camino
La otra opción aparte de legacy ROM es uefi compatible ROM pero si lo pongo en esa no arranca nada, ni la BIOS, tengo que quitar la pila y volverla a poner para volver a la configuración por defecto

Enviado desde mi XT1032 mediante Tapatalk
Responder Citando
  #6  
Antiguo 19-mar-2014, 17:17
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Ese comportamiento no es correcto , deberías poder entrar en la bios .

De todas formas que modelo de placa es la que tienes m, i , pro , debes mirar el modelo exacto , después mirare en la faq de Asus por si hay algún error y tienen actualización de bios .

También di que versión de bios tienes .

Y una pregunta cuando cambias esa opción te abre alguna mas en la bios ? .

Me quedo en la duda que versión de win8 tienes , por que si este es un 32bit , no usa uefi ,por lo cual la instalación de Opensuse , podría ser en legacy rom (o sea con partición mbr ),tampoco tendría el arranque en modo seguro ; pero si te fijas en la foto que enviaste de google , tiene un uefi sata en el dispositivo 2 )

Pero todos esos datos podrías aportarlos , si ya te vino el pc , con win8 instalado , si es 64bit , si tiene arranque en modo seguro etc.

No se si podrías entrar con un dvd live de Opensuse , así podrías dar la salidas de los comandos dmidecode -t 0 , dmidecode -t1 , dmidecode -t 2 y dmidecode -t 3 (desde una consola o terminal ) .

Saludos

PD . cuando me des el modelo exacto de la placa , me voy a Asus y me bajo el manual de la placa , ahí podre ver todas sus configuraciones .
Responder Citando
  #7  
Antiguo 19-mar-2014, 17:25
roker470 roker470 está desconectado
Aforado
 
Fecha de Ingreso: 20-febrero-2014
Versión: 13.1
Mensajes: 5
Agradecimientos: 0
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
roker470 está en el buen camino
Windows 8.1, con placa Asus p8h67, no venia preinstalado, este pc tiene su tiempo y ha tenido ya varios SO booteando siempre sin problemas.

Al cambiar esa opcion no se despliega ninguna otra y no veo nada por el faq y es de 64 bits
Responder Citando
  #8  
Antiguo 19-mar-2014, 18:05
Avatar de mikrios
mikrios mikrios está desconectado
Miembro FOROSuSE
 
Fecha de Ingreso: 02-marzo-2013
Ubicación: Lat. 27.994547-Lon -15.405127-160m nivel del mar
Versión: 13.1-2,TW,Leap
Mensajes: 4.551
Agradecimientos: 1.916
Agradecido 1.417 Veces en 1.187 Mensajes
Poder de Credibilidad: 9
mikrios llegará a ser famoso muy pronto
Pues soporta uefi , no se que versión . según asus la bios ultima es 3706 y en el manual no aparece esa opciones que muestra la foto . pero claro de la p8h67 están las versiones de P8H67 a secas , la P8H67-M , P8H67-M PRO , P8H67-V , P8H67-I PRO ,P8H67-I DELUXE y la P8H67-M-LX .

http://www.asus.com/Motherboards/P8H67/#support

http://www.asus.com/support/Manual/1/39/P8H67/

En caso de actualizar bios tendría que ser el modelo exacto , porque como descarges una que no es , la placa base acaba en la basura , o sea no funcionaria nada .

Puede que sea una placa antigua , si esta en 64bit y con win 8 , no veo que tenga el soporte (según el manual ) para el arranque seguro ) ,como tiene uefi bios , no se hasta que punto puede dar soporte a uefi , pero según el manual tiene un shell de UEFI con lo cual puede cargar sistemas operativos efi .

La instalación de Opensuse se puede hacer en efi , sin la opción de arranque seguro ( y win 8 tambien no debe tenerlo , ya que la placa no tiene soporte para ello ) .

Por lo cual seria una instalación normal en efi gpt (siempre y cuando en el apartado Advance de la bios , donde pone Sata configuration este en modo AHCI ) .

Lo extraño es que te diese error en grub-efi (y si lo ha puesto es porque tiene tablas de partición gpt ) , con gpt no tiene mucho que ver con la partición raíz , ya que cada sistema tiene que tener una primaria de boot-efi , no es como en legacy rom que puedes ponerlo en la raíz o en el mbr ,si no que aparecen tantos boot-efi como sistemas tengas instalados ,voy haber si encuentro ejemplos de algunas de mis instalaciones para que lo veas :
Código PHP:
mikrios-ssd:~ # gdisk -l /dev/sdb
GPT fdisk (gdiskversion 0.8.5

Partition table scan
:
  
MBRprotective
  BSD
not present
  APM
not present
  GPT
present

Found valid GPT with protective MBR
using GPT.
Disk /dev/sdb3907029168 sectors1.8 TiB
Logical sector size
512 bytes
Disk identifier 
(GUID): 31E3A680-CBD9-46A6-B7CD-0112B4B19C7B
Partition table holds up to 128 entries
First usable sector is 34
last usable sector is 3907029134
Partitions will be aligned on 2048
-sector boundaries
Total free space is 2157 sectors 
(1.1 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          321535   156.0 MiB   EF00  primary
   2          321536        84211711   40.0 GiB    0700  primary
   3        84211712      3907028991   1.8 TiB     0700  primary
mikrios
-ssd:~ # gdisk -l /dev/sda
GPT fdisk (gdiskversion 0.8.5

Partition table scan
:
  
MBRprotective
  BSD
not present
  APM
not present
  GPT
present

Found valid GPT with protective MBR
using GPT.
Disk /dev/sda234441648 sectors111.8 GiB
Logical sector size
512 bytes
Disk identifier 
(GUID): A5B2E423-671C-4D66-AEDB-E0F9A28E6098
Partition table holds up to 128 entries
First usable sector is 34
last usable sector is 234441614
Partitions will be aligned on 2048
-sector boundaries
Total free space is 2925 sectors 
(1.4 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          321535   156.0 MiB   EF00  primary
   2          321536         4530175   2.0 GiB     0700  primary
   3         4530176        46475263   20.0 GiB    0700  primary
   4        46475264       234440703   89.6 GiB    0700  primary 
Es el mismo pc con 2 sistemas instalados cada EF00 es una partición de arranque de UEFI .

Y en este pc :
Código PHP:
X79PRO:~ # gdisk -l /dev/sda
GPT fdisk (gdiskversion 0.8.7

Partition table scan
:
  
MBRprotective
  BSD
not present
  APM
not present
  GPT
present

Found valid GPT with protective MBR
using GPT.
Disk /dev/sda1953525168 sectors931.5 GiB
Logical sector size
512 bytes
Disk identifier 
(GUID): 4D35FB2B-4BDA-4A8E-9DCA-C972F36C844B
Partition table holds up to 128 entries
First usable sector is 34
last usable sector is 1953525134
Partitions will be aligned on 2048
-sector boundaries
Total free space is 3437 sectors 
(1.7 MiB)

Number  Start (sector)    End (sector)  Size       Code  Name
   1            2048          321535   156.0 MiB   EF00  primary
   2          321536         4530175   2.0 GiB     8200  primary
   3         4530176        88422399   40.0 GiB    0700  primary
   4        88422400      1953523711   889.3 GiB   0700  primary 
¿ Tu crees que desde win 8 se podría mirar como tienes las particiones ?

Saludos

Edito :
La única cosa que he visto que diera fallo en la instalación de Opensuse en UEFI con particiones gpt , es que creara una partición gpt extendida y no primaria ( ahí es cuando falla , la instalación ) .
Todas las de arranque deben ser primarias (no se por que en una determinada configuración Opensuse con una placa Asus , creo una gpt extendida , cosa que corregí desde la bios cambiando el orden de dispositivos en la compatibilidad CSM , pero tu placa es mas sencilla ) .
De todas formas se puede verificar con un live cd y gparted y ver como monto las particiones , si primarias o extendidas ) .
Saludos

Última edición por mikrios; 19-mar-2014 a las 18:13 Razón: corregir-añadir
Responder Citando
Respuesta

Marcadores

Etiquetas
boot, opensuse 12.3, opensuse 13.1, windows 8


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Reinstalar el cargador de arranque GRUB sanjui Instalación y Actualizaciones 42 08-feb-2016 23:25
Problema con la actualización online algosuntos Instalación y Actualizaciones 6 10-abr-2013 04:19
Instalar osx, windows 7 y opensuse 11.4 en un imac... y no morir en el intento oscarpoio FAQs, Manuales y Tutoriales 6 05-abr-2013 00:37
Multiples cuestiones sobre opensuse por un usuario de ubuntu dudoso100 General OpenSUSE 18 27-ene-2009 22:16
Instalacion openSUSE 11, problema con particiones carlos-cv-907 Instalación y Actualizaciones 15 02-oct-2008 23:32



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 10:26.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba