Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Echar a andar intel pro wireless 5100 suse 12.1 [SOLUCIONADO]
  #1  
Antiguo 13-jun-2012, 22:26
eibrajam eibrajam está desconectado
Aforado
 
Fecha de Ingreso: 08-junio-2012
Versión: 12.2
Mensajes: 8
Agradecimientos: 7
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
eibrajam está en el buen camino
Echar a andar intel pro wireless 5100 suse 12.1 [SOLUCIONADO]

Hola, este es mi primer post de mi primer foro

hace mucho tiempo tenía suse y jalaba excelente, ahora quiero volver a retomarlo, la cosa es que no funca la red inalambrica, así instale gnome o kde (escritorio actual)

Conforme a lo que pide DiabloRojo en otros temas en este mismo foro, ahí va mi planteamiento:

el network manager tiene deshabilitada la pestalla de inalambrica y en la lista de interfaces solo aparece la red cableada, ya he hecho varios intentos, hago un resumen:

Lenovo Thinkpad T500, Intel Pro/Wireless 5100 AGN

-hice la actualización en linea en YaST2 de todos los parches y actualizaciones disponibles

-agregue el repo packman

-Instalé los paquetes
broadcom-wl
broadcom-wl-kmp-default
ipw-firmware <Firmware para tarjetas Intel PRO/Wireless WLAN>

-quise habilitar desde la terminal como usuario su con modprobe wl y me tira:

FATAL: Module wl not found.

Hago el intento segun el tema de DiabloRojo "Mi tarjeta inalambrica (wireless) no func..."

-En terminal como su, tecleo /sbin/lspci para saber el chipset y me tira:

03:00.0 Network controller: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

pero no sé exactamente cual es el chipset, disculpen por mi ignorancia :\

-En terminal como su, tecleo /sbin/lspci -nnk para saber si hay un driver cargado y me tira:

03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
Subsystem: Intel Corporation WiFi Link 5100 AGN [8086:1211]

no hay nada de Kernel driver in use: xxxxx como en los demás dispositivos

-reviso si no ocupo firmware externo con el comando dmesg | grep firmware y me tira:

[ 4.811926] r600_cp: Failed to load firmware "radeon/R600_rlc.bin"
[ 4.811937] [drm:r600_startup] *ERROR* Failed to load firmware!
[ 7.753059] IBM TrackPoint firmware: 0x0e, buttons: 3/3
[ 17.941607] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-5.ucode' failed.
[ 17.942922] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-4.ucode' failed.
[ 17.944211] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-3.ucode' failed.
[ 17.945489] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-2.ucode' failed.
[ 17.946761] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-1.ucode' failed.
[ 17.946768] iwlagn 0000:03:00.0: no suitable firmware found!

como explica DiabloRojo, busco por ahí y encuentro un paquete en la pag de intel que trae solo el archivo 'iwlwifi-5000-5.ucode'

quise pegarlo en la carpeta /lib/firmware, pero no me deja pegarlo, me dice "acceso denegado, no se puede escribir en..."

Hasta ahí me quedé, alguna idea? comentario? norte?

Se los agradecería mucho si me echaran una mano para levantar mi wifi

Saludos cordiales

Última edición por eibrajam; 15-jun-2012 a las 22:11 Razón: Tema solucionado
Responder Citando
  #2  
Antiguo 14-jun-2012, 08:27
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 13.943
Agradecimientos: 333
Agradecido 1.162 Veces en 747 Mensajes
Poder de Credibilidad: 10
DiabloRojo está en el buen camino
Bienvenido al foro, por favor, lee las normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar.... es como una guía para los novatos. Fíjate lo que dice resaltado la norma 5.

Para empezar lo estas haciendo mal.
1.- NO instales esos 2 paquetes para tarjetas wifi de Broadcom: broadcom-wl.... desinstalarlos
2.- openSUSE tiene su propio paquete de archivos firmware: kernel-firmware así que instalarlo
3.- El driver de las Intel son iwlwifi o iwlagn , este ultimo es el que te ha detectado.
4.- Solo el superusuario root tiene privilegios para copiar el firmware a esa ubicación /lib/firmware , pero si instalas el kernel-firmware no lo necesitaras copiarlo, míralo tu mismo.
Código:
rpm -ql kernel-firmware | grep -i iwlwifi-5000
/lib/firmware/iwlwifi-5000-1.ucode
/lib/firmware/iwlwifi-5000-2.ucode
/lib/firmware/iwlwifi-5000-5.ucode
Como eres nuevo, preséntate en la sección de Presentaciones y, por favor, lee las normas.

__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   SubirImagenes    SendSpace       TextSnip  Cl1p
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a DiabloRojo Por Este Mensaje:
eibrajam (15-jun-2012)
  #3  
Antiguo 15-jun-2012, 00:12
eibrajam eibrajam está desconectado
Aforado
 
Fecha de Ingreso: 08-junio-2012
Versión: 12.2
Mensajes: 8
Agradecimientos: 7
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
eibrajam está en el buen camino
Gracias DiabloRojo, ya leí las normas y procedí:

-Reinstalé suse 12.1 con gnome desde cero para ir paso a paso

-Actualicé casi todo en parches y updates disponibles en YaST

-Instalé el paquete kernel-firmware

-bajo el archivo de la red iwlwifi-5000-5.ucode

-lo copio como root en /lib/firmware

-tecleo cd /lib/firmware
-tecleo ls para ver los archivos y ahí está, (no creo necesario pegarte la lista de archivos contenidos a menos que me lo pidas, lo pego)

-le tecleo como root en terminal /sbin/lspci -nnk y me tira:

03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]
Subsystem: Intel Corporation WiFi Link 5100 AGN [8086:1211]

-le tecleo como root en terminal dmesg | grep firmware y me tira:

[ 4.651021] r600_cp: Failed to load firmware "radeon/R600_rlc.bin"
[ 4.651032] [drm:r600_startup] *ERROR* Failed to load firmware!
[ 7.661984] IBM TrackPoint firmware: 0x0e, buttons: 3/3
[ 18.354624] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-5.ucode' failed.
[ 18.355975] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-4.ucode' failed.
[ 18.357254] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-3.ucode' failed.
[ 18.358540] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-2.ucode' failed.
[ 18.359793] iwlagn 0000:03:00.0: request for firmware file 'iwlwifi-5000-1.ucode' failed.
[ 18.359799] iwlagn 0000:03:00.0: no suitable firmware found!

-y solo por repetir, tecleo rpm -ql kernel-firmware | grep -i iwlwifi-5000 y efectivamente me tira:

/lib/firmware/iwlwifi-5000-1.ucode
/lib/firmware/iwlwifi-5000-2.ucode
/lib/firmware/iwlwifi-5000-5.ucode

Cómo vez DiabloRojo? Qué crees que haga falta?

De antemano gracias por la valiosa ayuda
Responder Citando
  #4  
Antiguo 15-jun-2012, 01:35
Avatar de davmont
davmont davmont está desconectado
Moderador
 
Fecha de Ingreso: 13-diciembre-2007
Ubicación: ~/
Versión: 12.3 x86_64
Mensajes: 2.871
Agradecimientos: 78
Agradecido 138 Veces en 122 Mensajes
Poder de Credibilidad: 9
davmont está en el buen camino
siento no haber visto antes el hilo

instala el paquete ipw-firmware desde los repos, tengo la misma tarjeta y basta con ese firmware

EDITO: en teoría es ese paquete, no te lo puedo asegurar que funcione en la 12.1, ya que actualmente ando con la beta1 de la 12.2 :S (acabo de leer que ya lo tienes instalado)

un saludo
__________________
No atiendo consultas sobre Linux/openSUSE por privado, usad el foro que para algo está
Normas del foro, de lectura obligada


Responder Citando
El Siguiente Usuario Ha Dado las Gracias a davmont Por Este Mensaje:
eibrajam (15-jun-2012)
  #5  
Antiguo 15-jun-2012, 04:36
eibrajam eibrajam está desconectado
Aforado
 
Fecha de Ingreso: 08-junio-2012
Versión: 12.2
Mensajes: 8
Agradecimientos: 7
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
eibrajam está en el buen camino
Ya me cargó la tarjeta!!! solo faltaba reiniciar

ya tengo la red wireless en el Network Manager y me detecta las redes...

Ahora el problema es que no me acepta las claves correctas de ninguna red, me dice "Intentelo de nuevo"


No puedo instalar el dato que me da davmont, mañana a primera hora lo instalo, (Por el momento no tengo red cableada, solo wifi y estoy en win)

De cualquier modo, voy a estarle buscando haber que puede ser y si tienen un norte por ahí, ps les agradezco su interés

Al menos ya hoy fué un excelente avance y estoy aprendiendo un chingo

Gracias moderadores, saludos cordiales
Responder Citando
  #6  
Antiguo 15-jun-2012, 04:53
eibrajam eibrajam está desconectado
Aforado
 
Fecha de Ingreso: 08-junio-2012
Versión: 12.2
Mensajes: 8
Agradecimientos: 7
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
eibrajam está en el buen camino
listo!!!!

ya funcionó, ahora mismo estoy en wifi con mi suse 12.1

resulta que al seleccionar una red inalambrica, primero te pide el password de root y después la contraseña de la red y eso es todo!

Todo lo que hice en el msg #3 fue lo que funcionó, solo faltaba reiniciar

Gracias DiabloRojo, saludos!!!!
Responder Citando
  #7  
Antiguo 15-jun-2012, 16:25
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 13.943
Agradecimientos: 333
Agradecido 1.162 Veces en 747 Mensajes
Poder de Credibilidad: 10
DiabloRojo está en el buen camino
De nada, chavalin. Lee la norma nº 9 edita solo el titulo de tu 1er. post para añadir [SOLUCIONADO] al titulo
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   SubirImagenes    SendSpace       TextSnip  Cl1p
Responder Citando
Respuesta

Marcadores


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Ayuda con Wireless RT5390 en OpenSuse 12.1 CoreSplendor Internet, Redes y Wireless 3 30-ene-2012 13:44
Intel PRO Wireless 2200BG Joker Hardware 14 09-sep-2005 15:50
Ayuda de suse no sirvió tarjeta wireless naufrago Hardware 0 14-jul-2005 18:14
wireless para mi Suse 9.2 Juan Internet, Redes y Wireless 1 16-may-2005 18:56
Aviso de seguridad Kunael Internet, Redes y Wireless 1 05-ago-2004 22:35



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 08:57.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba