Registrarse
Home
Foros
Miembros
Calendario
Normas
Ayuda

Foros de usuarios de openSUSE
Retroceder   ForoSUSE > Zona OpenSUSE > Hardware


Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook

Respuesta
 
Herramientas Desplegado

Drivers correctos para Leap 42.2 AMD
  #1  
Antiguo 02-abr-2017, 19:54
Avatar de notf0und
notf0und notf0und está desconectado
Aforado
 
Fecha de Ingreso: 02-abril-2017
Versión: 42.2 Leap
Mensajes: 11
Agradecimientos: 8
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
notf0und está en el buen camino
Question Drivers correctos para Leap 42.2 AMD

Hola,

Que tal amigos del foro, he estado buscando por la red y no encuentro información referente a drivers que debo instalar en mi laptop con AMD.
Ya que estuve testeando como funcionaba mi instalación de opensuse Leap, noté que mi batería se consume muy rápido, no puedo bajar ni subir volumen, la tarjeta de red solo conecta en un radio de 3 metros a la redonda.

Todo esto siempre lo solucionaba instalando los Catalyst de AMD y listo! Pero ahora esto ya no existe, ahora se llama Crimson y al parecer no esta actualizado para Linux, al menos algo así entendí, Mi CPU es R5 y tengo una tarjeta dedicada R7, no se que driver elegir en la sección de drivers.

Por ahora estoy descargando el que es para R7 M260, a ver que tal funciona. Alguien sabe o alguien que haya instalado un Driver de AMD en Linux o especificamente en OpenSUSE Leap 42.2 como es que lo realizó, espero puedan ayudarme un poco, siempre tengo problema con los drivers en ADM
Responder Citando
  #2  
Antiguo 02-abr-2017, 20:52
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 851
Agradecimientos: 187
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
El Driver correcto.... uhmmm depende ...

Los "drivers propietarios" para tu tarjeta de AMD estan aqui



Con la versión 42.1 se terminó el soporte a los fglrx. Si quieres usar los fglrx tendrias que instalar la leap 42.1.

Los "Drivers libres" de amdgpu que son los que vienen actualmente, tienen algunas desventajas, ya que no se espera hasta la versión del kernel 4.12 La solución de algunos problemas , como el soporte de DC/DAL, que es el que permite la salida de audio atraves de hdmi/DP. De momento no cuentan con esta ventaja. En la lista de kernel puedes ver en lo que estan trabajando en la versión del kernel 4.11.


Asi que con los propietarios, puedes tener todas las ventaja, incluido el sonido, pero la desventaja que aunque vienen con dkms, a partir del kernel 4.XX (no me acuerdo de la versión) dejan de funcionar.

Con los Libres no tendrás sonido en las salidas HDMI/DP, pero si sonido a través de la placa y la ventaja de poder actualizar kernel, si tienes problemas de hardware.


Con el kernel original de leap 42.2 funciona perfectamente el privativo, pero no actualices a la última que deja de funcionar. Al menos cuando estuve haciendo pruebas.

No se si te vale la respuesta

P.D: Se me olvidó comentarte que el mejor software y el único que conozco para controlar la tarjeta gráfica amd es el Radeon-Profile


Edición: hay un nuevo driver privativo el 17.10

nota informativa
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.1 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)

Última edición por soyasi; 19-abr-2017 a las 04:04
Responder Citando
Los Siguientes 2 Usuarios Han Dado las Gracias a soyasi Por Este Mensaje:
gvcastellon (14-abr-2017), notf0und (11-abr-2017)
  #3  
Antiguo 03-abr-2017, 15:34
Avatar de DiabloRojo
DiabloRojo DiabloRojo está desconectado
Super Moderador
 
Fecha de Ingreso: 19-marzo-2005
Ubicación: En un lugar del planeta Tierra
Versión: La ultima estable
Mensajes: 16.481
Agradecimientos: 563
Agradecido 2.416 Veces en 1.627 Mensajes
Poder de Credibilidad: 10
DiabloRojo llegará a ser famoso muy pronto
Bienvenido al foro, por favor, lee las normas del foro donde aprenderás cosas útiles como aportar datos, hacer preguntas, como buscar....es como una guía para los novatos. Fíjate lo que dice resaltado y en negrita la norma 5 y sobre todo la norma 7 de escribir.

Sigue los consejos de soyasi que tiene una tarjeta gráfica Radeon.

Como eres nuevo, preséntate en la sección de Presentaciones y, por favor, lee las normas.
__________________
NORMAS A CUMPLIR EN LOS FOROS (Lectura obligatoria) Lo siento, no contesto privados sobre problemas con GNU/Linux.
Síguenos en TWITTER y en FACEBOOK
Código:
Buscador de   Alojamiento      Alojamiento     Otros
 paquetes:    de imágenes:     de ficheros:    buscadores:
Search        TinyPic          Ifile Wuala     Simple y Facil
Webpinstant   Paste Suse       SendSpace       TextSnip  Cl1p
Responder Citando
  #4  
Antiguo 09-abr-2017, 20:26
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 851
Agradecimientos: 187
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
Buenas noticias!! con la versión 17.10 de los drivers privativos para las Graficas AMD/ATI parece ser que han solucionado el famoso bug del kernel que hacia que no funcionasen a partir de la versión 4.XX (Sorry no me acuerdo cual era).

Lo estoy probando con el kernel 4.11.0-rc5-2.g8c4cd71-default y funciona sin problemas, tendré que mirarlo mas a fondo desde que tenga tiempo....

Saludos,
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.1 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)
Responder Citando
Los Siguientes 3 Usuarios Han Dado las Gracias a soyasi Por Este Mensaje:
gvcastellon (14-abr-2017), mikrios (09-abr-2017), notf0und (11-abr-2017)
Drivers Update
  #5  
Antiguo 11-abr-2017, 07:25
Avatar de notf0und
notf0und notf0und está desconectado
Aforado
 
Fecha de Ingreso: 02-abril-2017
Versión: 42.2 Leap
Mensajes: 11
Agradecimientos: 8
Agradecido 0 Veces en 0 Mensajes
Poder de Credibilidad: 0
notf0und está en el buen camino
Drivers Update

Cita:
Iniciado por soyasi Ver Mensaje
Buenas noticias!! con la versión 17.10 de los drivers privativos para las Graficas AMD/ATI parece ser que han solucionado el famoso bug del kernel que hacia que no funcionasen a partir de la versión 4.XX (Sorry no me acuerdo cual era).

Lo estoy probando con el kernel 4.11.0-rc5-2.g8c4cd71-default y funciona sin problemas, tendré que mirarlo mas a fondo desde que tenga tiempo....

Saludos,
Hola! De verdad te agradezco el soporte que me has brindado, estuve algo ocupado con la escuela y hasta hoy me puse al corriente, ahora te explico.

No me percaté que la versión de Opensuse que tenía era la 42.1 con KDE y bueno trate de instalar los drivers privativos (Versión 17.10) que mencionas y no me dejaba instalarlos, mencionaba un error de incompatibilidad.

Ahora tengo la 42.2 con gnome y el problema de audio y brillo están solucionados pero la tarjeta de red tiene problemas. Es como si no destinara la suficiente potencia a la tarjeta porque solo si estoy a menos de 3 metros del modem la detecta, si me alejo la señal desaparece. Igual he notado que la batería dura menos de lo normal. Me parece que el kernel es la 4.57 default... supongo que es la última.

Intentaré instalar los drivers privativos de nuevo.

Espero tu respuesta y de nuevo gracias. Seguiré buscando que puedo hacer
Responder Citando
  #6  
Antiguo 12-abr-2017, 12:38
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 851
Agradecimientos: 187
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
Me alegro hayas solventado el problema.

Antes de abrir un hilo busca si hay algún caso similar.

Si tienes problemas de wifi, abre otro hilo en el foro y explica exactamente cual es el problema. Pon datos, no somos adivinos.

Sobre todo sigue los consejos de DR [Diablo Rojo].

Si se te ha solucionado este problema edita el titulo y añade [Solucionado]

saludines,
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.1 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a soyasi Por Este Mensaje:
notf0und (13-abr-2017)
  #7  
Antiguo 14-abr-2017, 04:01
Avatar de gvcastellon
gvcastellon gvcastellon está desconectado
Miembro Senior
 
Fecha de Ingreso: 17-febrero-2012
Ubicación: Somewhere in the third planet of the Solar System ;)
Versión: Leap 42.1
Mensajes: 1.192
Agradecimientos: 960
Agradecido 545 Veces en 351 Mensajes
Poder de Credibilidad: 7
gvcastellon está en el buen camino
Cita:
Iniciado por soyasi Ver Mensaje
Buenas noticias!! con la versión 17.10 de los drivers privativos para las Graficas AMD/ATI parece ser que han solucionado el famoso bug del kernel que hacia que no funcionasen a partir de la versión 4.XX (Sorry no me acuerdo cual era).

Lo estoy probando con el kernel 4.11.0-rc5-2.g8c4cd71-default y funciona sin problemas, tendré que mirarlo mas a fondo desde que tenga tiempo....

Saludos,
Saludos...
@soyasi: ...estoy teniendo problemas con mi Gráfica,
Código:
inxi -G
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Juniper XT [Radeon HD 6770]
           Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD JUNIPER (DRM 2.43.0, LLVM 3.8.0) GLX Version: 3.0 Mesa 11.2.2
...como siempre trabajo con dual-screen, y con frecuencia empiezan el "flickering" (parpadeo), solo se soluciona temporalmente entrando en la configuración del sistema y cambiando el compositor de video de turno, por cualquiera otro hasta que vuelva la crisis, no importa si dejo uno u otro, esto incluye a "XRender" .

Tambien noto que esto sucede, con mas frecuencia con aplicaciones como "ThunderBird, Firefox, o sea (GTK),
Estoy por actualizar el Kernel y volver a los privativos, a ver como van los tiros, pero un consejo tuyo me vendría bien.

Código:
System:    Host: masterpc Kernel: 4.4.57-18.3-default x86_64 (64 bit) Desktop: KDE Plasma 5.8.6
           Distro: openSUSE Leap 42.2
Machine:   Device: desktop Mobo: ASUSTeK model: M4A78LT-M-LE v: Rev X.0x BIOS: American Megatrends v: 0803 date: 07/23/2012
CPU:       Triple core AMD Athlon II X3 450 (-MCP-) speed/max: 800/3200 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Juniper XT [Radeon HD 6770]
           Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD JUNIPER (DRM 2.43.0, LLVM 3.8.0) GLX Version: 3.0 Mesa 11.2.2
Network:   Card: Qualcomm Atheros AR8131 Gigabit Ethernet driver: atl1c
Drives:    HDD Total Size: 2500.5GB (32.1% used)
Info:      Processes: 237 Uptime: 2 days  3:50 Memory: 2154.2/7981.5MB Client: Shell (bash) inxi: 2.3.8
Salud y suerte.
__________________
The box said: 'Requires Windows 95 or better' SO I INSTALLED LINUX


Kernel: 4.4.76-1-default x86_64
Distro: openSUSE Leap 42.3 /TW
KDE Plasma 5.8.7
Motherboard-ASUS M4A78LT-M LE
Quad core AMD Phenom II X4 B50Processor- 3.2 GHz
RAM-8.0 GiB
Video-AMD Radeon HD-6770
Responder Citando
  #8  
Antiguo 15-abr-2017, 11:23
Avatar de soyasi
soyasi soyasi está desconectado
Miembro Senior
 
Fecha de Ingreso: 26-julio-2005
Ubicación: Atlántida
Versión: leap 42.1
Mensajes: 851
Agradecimientos: 187
Agradecido 323 Veces en 221 Mensajes
Poder de Credibilidad: 13
soyasi está en el buen camino
@gvcastellon Así empezaron mis HD6850 y terminaron de pisapapeles, prueba los privativos, a lo mejor se te soluciona ¡suerte!!
__________________
--
hkp://subkeys.pgp.net
GNU/Linux Opensuse leap 42.1 x86_64
Linux Registered User #391410



(http://linuxcounter.net/)
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a soyasi Por Este Mensaje:
gvcastellon (15-abr-2017)
  #9  
Antiguo 19-abr-2017, 00:20
Avatar de Invisuu
Invisuu Invisuu está desconectado
Aforado
 
Fecha de Ingreso: 05-octubre-2012
Ubicación: Carmen, CAMP, Mexico
Versión: 42.3 GNOME
Mensajes: 76
Agradecimientos: 45
Agradecido 29 Veces en 22 Mensajes
Poder de Credibilidad: 6
Invisuu está en el buen camino
Cita:
Iniciado por gvcastellon Ver Mensaje
Saludos...
@soyasi: ...estoy teniendo problemas con mi Gráfica,
Código:
inxi -G
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Juniper XT [Radeon HD 6770]
           Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD JUNIPER (DRM 2.43.0, LLVM 3.8.0) GLX Version: 3.0 Mesa 11.2.2
...como siempre trabajo con dual-screen, y con frecuencia empiezan el "flickering" (parpadeo), solo se soluciona temporalmente entrando en la configuración del sistema y cambiando el compositor de video de turno, por cualquiera otro hasta que vuelva la crisis, no importa si dejo uno u otro, esto incluye a "XRender" .

Tambien noto que esto sucede, con mas frecuencia con aplicaciones como "ThunderBird, Firefox, o sea (GTK),
Estoy por actualizar el Kernel y volver a los privativos, a ver como van los tiros, pero un consejo tuyo me vendría bien.

Código:
System:    Host: masterpc Kernel: 4.4.57-18.3-default x86_64 (64 bit) Desktop: KDE Plasma 5.8.6
           Distro: openSUSE Leap 42.2
Machine:   Device: desktop Mobo: ASUSTeK model: M4A78LT-M-LE v: Rev X.0x BIOS: American Megatrends v: 0803 date: 07/23/2012
CPU:       Triple core AMD Athlon II X3 450 (-MCP-) speed/max: 800/3200 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Juniper XT [Radeon HD 6770]
           Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: modesetting,fbdev,vesa)
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           GLX Renderer: Gallium 0.4 on AMD JUNIPER (DRM 2.43.0, LLVM 3.8.0) GLX Version: 3.0 Mesa 11.2.2
Network:   Card: Qualcomm Atheros AR8131 Gigabit Ethernet driver: atl1c
Drives:    HDD Total Size: 2500.5GB (32.1% used)
Info:      Processes: 237 Uptime: 2 days  3:50 Memory: 2154.2/7981.5MB Client: Shell (bash) inxi: 2.3.8
Salud y suerte.
El problema que indicas también lo padezco cuando utilizo KDE. En algún lado leí que poniendo a "nunca" la opción de "prevención del efecto bandera (vsync)" en Preferencias del sistema> Pantalla y monitor> Compositor se soluciona el parpadeo (o flickering) y, en efecto, en mi sistema se corrige dicho problema. Hoy mismo me instalé KDE y hice dicho ajuste, con lo que no se ha presentado el problema.

Mi equipo tiene el siguiente hardware:

Cita:
00:00.0 Host bridge: Advanced Micro Devices, Inc. [AMD] Family 12h Processor Root Complex
00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Sumo [Radeon HD 6480G]
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] BeaverCreek HDMI Audio [Radeon HD 6500D and 6400G-6600G series]
Todo me funciona bien con los controladores libres y no tengo problema para reproducir el audo a través del cable HDMI, pero para ello necesito ajustar la salida desde el panel de control de pulseaudio (pavucontrol).
Responder Citando
El Siguiente Usuario Ha Dado las Gracias a Invisuu Por Este Mensaje:
gvcastellon (19-abr-2017)
Respuesta

Marcadores

Etiquetas
amd, driver, hardware, leap, suse


(0 miembros y 1 visitantes)
 
Herramientas
Desplegado

Normas de Publicación
No puedes crear nuevos temas
No puedes responder mensajes
No puedes subir archivos adjuntos
No puedes editar tus mensajes

Los Códigos BB están Activado
Las Caritas están Activado
[IMG] está Activado
El Código HTML está Desactivado

Ir al Foro

Temas Similares
Tema Autor Foro Respuestas Último mensaje
Pasar a Framework 5 en Leap 42.1 Krovikan Escritorios: KDE, Gnome, otros... 23 20-sep-2016 20:52
Yast2 da error al arrancar Susefan1 Software 10 01-dic-2014 15:32
Manual para configurar un Servidor FTP con Vsftpd gabrielkfr FAQs, Manuales y Tutoriales 33 09-jun-2014 22:47
Instalación de Java(JDK,JRE), MySQL, Apache(Httpd, Tomcat), JPS, PHP, para MOODLE joseluisbz Software 7 06-nov-2012 23:53
Bienvenido a GNU/Linux (y III) karlggest FAQs, Manuales y Tutoriales 0 13-ene-2008 17:26



Síguenos en Twitter Suscríbete a nuestras noticias Acompáñanos en Facebook


La franja horaria es GMT +2. Ahora son las 10:07.
Powered by vBulletin™
Copyright © vBulletin Solutions, Inc. All rights reserved.

Esta página está bajo una licencia de Creative Commons, salvo que no se indique lo contrario.
Creative Commons License

Valid CSS!

Diseño por:Designed by: vbdesigns.devbdesigns.de 
Contáctenos - ForoSUSE - Archivo - Declaración de Privacidad - Arriba